Register for your free account! | Forgot your password?

You last visited: Today at 03:56

  • Please register to post and access all features, it's quick, easy and FREE!


[Release] World Conquer Source v2

Reply
 
Old 12/11/2017, 11:25   #76
 
elite*gold: 0
Join Date: Nov 2014
Posts: 9
Received Thanks: 0
Quote:
Originally Posted by pintinho12 View Post
1. Exp calculation is right. cq_levexp table on mysql... and the exp is leveling after 25% because it's 4x lower than the one configured in the levexp.dat file in the client.
2. The status screen shows the damage without SDG/SPG, tho it's correct. TQ does the same way. You can find it in Character.cs file btw
3. The hitchance formula is doing ok, but good luck, it's on Battle System.cs
Thanks



gordonbay is offline  
Old 12/17/2017, 21:36   #77
 
elite*gold: 0
Join Date: Sep 2011
Posts: 16
Received Thanks: 0
ok i have hit and error when trying to login. it seems like the database syntax is wrong. ( my database is wrong ) but where are those syntaxes stored? cant seem to locate them?


jesper54321 is offline  
Old 12/18/2017, 13:53   #78
 
elite*gold: 0
Join Date: Nov 2014
Posts: 9
Received Thanks: 0
Quote:
Originally Posted by jesper54321 View Post
ok i have hit and error when trying to login. it seems like the database syntax is wrong. ( my database is wrong ) but where are those syntaxes stored? cant seem to locate them?
The only thing i had to do to work was this:

PHP Code:
-- phpMyAdmin SQL Dump
-- version 4.6.4
-- https://www.phpmyadmin.net/
--
-- 
Hostlocalhost
-- Generation TimeDec 182017 at 12:50 PM
-- Server version5.6.32
-- PHP Version7.0.9

SET SQL_MODE 
"NO_AUTO_VALUE_ON_ZERO";
SET time_zone "+00:00";


/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_CLIENT */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_RESULTS */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;

--
-- 
Database: `accountzf`
--

-- --------------------------------------------------------

--
-- 
Table structure for table `login_rcd`
--

CREATE TABLE `login_rcd` (
  `
account_idint(4NOT NULL,
  `
login_timeint(8NOT NULL,
  `
online_secondint(8NOT NULL,
  `
mac_adrvarchar(16NOT NULL,
  `
ip_adrvarchar(16NOT NULL,
  `
res_srcint(4NOT NULL
ENGINE=InnoDB DEFAULT CHARSET=utf8;

/*!40101 SET CHARACTER_SET_CLIENT [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION [MENTION=5761278]Old_[/MENTION]COLLATION_CONNECTION */
Insert it on accountzf database.
But as you did not post the error...
gordonbay is offline  
Old 12/18/2017, 16:20   #79
 
elite*gold: 0
Join Date: Sep 2011
Posts: 16
Received Thanks: 0
Quote:
Originally Posted by gordonbay View Post
The only thing i had to do to work was this:

PHP Code:
-- phpMyAdmin SQL Dump
-- version 4.6.4
-- https://www.phpmyadmin.net/
--
-- 
Hostlocalhost
-- Generation TimeDec 182017 at 12:50 PM
-- Server version5.6.32
-- PHP Version7.0.9

SET SQL_MODE 
"NO_AUTO_VALUE_ON_ZERO";
SET time_zone "+00:00";


/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_CLIENT */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_RESULTS */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;

--
-- 
Database: `accountzf`
--

-- --------------------------------------------------------

--
-- 
Table structure for table `login_rcd`
--

CREATE TABLE `login_rcd` (
  `
account_idint(4NOT NULL,
  `
login_timeint(8NOT NULL,
  `
online_secondint(8NOT NULL,
  `
mac_adrvarchar(16NOT NULL,
  `
ip_adrvarchar(16NOT NULL,
  `
res_srcint(4NOT NULL
ENGINE=InnoDB DEFAULT CHARSET=utf8;

/*!40101 SET CHARACTER_SET_CLIENT [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION [MENTION=5761278]Old_[/MENTION]COLLATION_CONNECTION */
Insert it on accountzf database.
But as you did not post the error...
Sry forgot that :P







those images is in a line from which is first :P


jesper54321 is offline  
Old 12/18/2017, 16:45   #80
 
elite*gold: 0
Join Date: Nov 2014
Posts: 9
Received Thanks: 0
Quote:
Originally Posted by jesper54321 View Post
Sry forgot that :P







those images is in a line from which is first :P
Its trying to query your account table but can't because something is not as its suppose to be. Import this and create another account:

PHP Code:
-- phpMyAdmin SQL Dump
-- version 4.6.4
-- https://www.phpmyadmin.net/
--
-- 
Hostlocalhost
-- Generation TimeDec 182017 at 03:41 PM
-- Server version5.6.32
-- PHP Version7.0.9

SET SQL_MODE 
"NO_AUTO_VALUE_ON_ZERO";
SET time_zone "+00:00";


/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_CLIENT */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_RESULTS */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;

--
-- 
Database: `accountzf`
--

-- --------------------------------------------------------

--
-- 
Table structure for table `account`
--
DROP TABLE IF EXISTS `account`;
CREATE TABLE `account` (
  `
idbigint(12NOT NULL,
  `
namevarchar(20NOT NULL DEFAULT '',
  `
passwordvarchar(128NOT NULL DEFAULT '',
  `
netbar_ipvarchar(15NOT NULL DEFAULT '',
  `
create_dateint(4UNSIGNED NOT NULL DEFAULT '0',
  `
first_loginint(4UNSIGNED NOT NULL DEFAULT '0',
  `
account_idint(4UNSIGNED NOT NULL DEFAULT '0',
  `
last_loginint(4NOT NULL DEFAULT '0',
  `
locktinyint(1NOT NULL DEFAULT '0',
  `
vipint(4UNSIGNED NOT NULL DEFAULT '1',
  `
typeint(4NOT NULL DEFAULT '2',
  `
referrerint(4UNSIGNED NOT NULL DEFAULT '0',
  `
vip_activeint(4UNSIGNED NOT NULL DEFAULT '0',
  `
saltvarchar(128NOT NULL DEFAULT '',
  `
mac_addrvarchar(16NOT NULL DEFAULT '000000000000',
  `
lock_expireint(4UNSIGNED NOT NULL DEFAULT '0'
ENGINE=InnoDB DEFAULT CHARSET=utf8;


--
-- 
Indexes for table `account`
--
ALTER TABLE `account`
  
ADD PRIMARY KEY (`id`);

--
-- 
AUTO_INCREMENT for dumped tables
--

--
-- 
AUTO_INCREMENT for table `account`
--
ALTER TABLE `account`
  
MODIFY `idbigint(12NOT NULL AUTO_INCREMENTAUTO_INCREMENT=8;
/*!40101 SET CHARACTER_SET_CLIENT [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION [MENTION=5761278]Old_[/MENTION]COLLATION_CONNECTION */
gordonbay is offline  
Old 12/19/2017, 14:12   #81
 
elite*gold: 0
Join Date: Sep 2011
Posts: 16
Received Thanks: 0
Quote:
Originally Posted by gordonbay View Post
Its trying to query your account table but can't because something is not as its suppose to be. Import this and create another account:

PHP Code:
-- phpMyAdmin SQL Dump
-- version 4.6.4
-- https://www.phpmyadmin.net/
--
-- 
Hostlocalhost
-- Generation TimeDec 182017 at 03:41 PM
-- Server version5.6.32
-- PHP Version7.0.9

SET SQL_MODE 
"NO_AUTO_VALUE_ON_ZERO";
SET time_zone "+00:00";


/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_CLIENT */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@CHARACTER_SET_RESULTS */;
/*!40101 SET [MENTION=5761278]Old_[/MENTION][email protected]@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8mb4 */;

--
-- 
Database: `accountzf`
--

-- --------------------------------------------------------

--
-- 
Table structure for table `account`
--
DROP TABLE IF EXISTS `account`;
CREATE TABLE `account` (
  `
idbigint(12NOT NULL,
  `
namevarchar(20NOT NULL DEFAULT '',
  `
passwordvarchar(128NOT NULL DEFAULT '',
  `
netbar_ipvarchar(15NOT NULL DEFAULT '',
  `
create_dateint(4UNSIGNED NOT NULL DEFAULT '0',
  `
first_loginint(4UNSIGNED NOT NULL DEFAULT '0',
  `
account_idint(4UNSIGNED NOT NULL DEFAULT '0',
  `
last_loginint(4NOT NULL DEFAULT '0',
  `
locktinyint(1NOT NULL DEFAULT '0',
  `
vipint(4UNSIGNED NOT NULL DEFAULT '1',
  `
typeint(4NOT NULL DEFAULT '2',
  `
referrerint(4UNSIGNED NOT NULL DEFAULT '0',
  `
vip_activeint(4UNSIGNED NOT NULL DEFAULT '0',
  `
saltvarchar(128NOT NULL DEFAULT '',
  `
mac_addrvarchar(16NOT NULL DEFAULT '000000000000',
  `
lock_expireint(4UNSIGNED NOT NULL DEFAULT '0'
ENGINE=InnoDB DEFAULT CHARSET=utf8;


--
-- 
Indexes for table `account`
--
ALTER TABLE `account`
  
ADD PRIMARY KEY (`id`);

--
-- 
AUTO_INCREMENT for dumped tables
--

--
-- 
AUTO_INCREMENT for table `account`
--
ALTER TABLE `account`
  
MODIFY `idbigint(12NOT NULL AUTO_INCREMENTAUTO_INCREMENT=8;
/*!40101 SET CHARACTER_SET_CLIENT [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS [MENTION=5761278]Old_[/MENTION]CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION [MENTION=5761278]Old_[/MENTION]COLLATION_CONNECTION */
still gets same error
jesper54321 is offline  
Old 12/20/2017, 03:32   #82
 
elite*gold: 0
Join Date: Jul 2009
Posts: 487
Received Thanks: 178
Code:
/// <summary>
        /// Configure NHibernate. This method returns an ISessionFactory instance that is
        /// populated with mappings created by Fluent NHibernate.
        /// </summary>
        /// <returns>The SessionFactory so you can use it to Mappings and w/e.</returns>
        internal ISessionFactory CreateSessionFactory()
        {
            var session = Fluently
                .Configure()
                .Database(MySQLConfiguration.Standard.ConnectionString(x => x
                    .Server(_hostname)
                    .Username(_username)
                    .Password(_password)
                    .Database(_database)))
                .Mappings(m => m.FluentMappings.AddFromAssemblyOf<SessionFactory>());
            session.ExposeConfiguration(x => x.SetProperty("hbm2ddl.keywords", "auto-quote"));
            return session.BuildSessionFactory();
        }

        internal ISessionFactory CreateLoginFactory()
        {
            string szString = string.Format("Server={0};Port={1};Database={2};Uid={3};Password={4};charset=utf8;"
                , _hostname, _port, _database, _username, _password);
            var session = Fluently
                .Configure()
                .Database(MySQLConfiguration.Standard.ConnectionString(szString))
                .Mappings(m => m.FluentMappings.AddFromAssemblyOf<SessionFactory>());
            session.ExposeConfiguration(x => x.SetProperty("hbm2ddl.keywords", "auto-quote"));
            return session.BuildSessionFactory();
        }
It's your job to figure out where you must replace this...
since it's hard to see that there are some columns with reserved names like "lock"... this will help you with not getting into troubles again.

good luck
pintinho12 is offline  
Old 01/04/2018, 06:40   #83
 
elite*gold: 0
Join Date: Nov 2012
Posts: 21
Received Thanks: 0
can u tell me how to solve the Shuriken Vortex Problem
alimosad20 is offline  
Old 01/05/2018, 02:53   #84
 
elite*gold: 0
Join Date: Jul 2009
Posts: 487
Received Thanks: 178
Debug the Battle System.cs file with ShurikenVortex on
pintinho12 is offline  
Old 01/05/2018, 20:33   #85
 
elite*gold: 0
Join Date: Nov 2012
Posts: 21
Received Thanks: 0
i did but not solved
alimosad20 is offline  
Old 01/06/2018, 03:20   #86
 
elite*gold: 12
Join Date: Jul 2011
Posts: 7,005
Received Thanks: 3,358
Quote:
Originally Posted by alimosad20 View Post
i did but not solved
And then fix it, I'm presuming.
Spirited is offline  
Old 03/24/2018, 17:40   #87
 
elite*gold: 0
Join Date: Mar 2010
Posts: 7
Received Thanks: 0
Hello people!

Sorry to bother you, ive been away for a long while!
Im just playing around with the source at the moment, just to get back on my skill level.

The only problem i just have(a.k.a. questions i have);

I have the source running, perfectly!
i have the client, downloaded Installed & patched.

Question 1:
can i just use 127.0.0.1 in the msgserver/loginservre CFG /Shell.ini?
&&
And in the Client Loaderset.ini?

Because server is running, and the entire client says "maintenance".

So im missing something...
as ive said'i was away for the last 2 years from CO p-server section (A)
i dont remember if u COULd or COULDNT use 127.0.0.1 or did i havw to change my Dynamic IP to a static ip and use that?

Or what serevr do i have to connect to(in client)
Elements > Dark Seemed obvious xD
(i tried all of them tho !! :/)

Thanks

--edit--

Checked client page
+ conquer loader on 5517 client, still maintenance.
I think im missing something..
Keep on trying!

(its not that i downloaded this patch, and instantly aasked for help..
I downloaded the source yesterday afternoon, and been trying untill now..
AND STILL AM xD!!


--edit2--

Found the issue -.- Port problem ofcourse.. im a nuub..
pff it has been to long :/


----Edit 3 Here i am again!-------
Set everything up, now i get "failed to login, wrong User id/password"

I added the new Tables, i added a accounts / login_rcd Table.
uhm ive tried the old database World Conquer (V1)
(Then it does login, but stucks loading & debug console shows errors & gets stuck on other items.)

i know, im asking for alot maybe.. but ive been on this for 12H, if not more!
Any "Advice/Help" to let me get in the server atleast. <3




---Edit 4---------

Okaii, found out:
It reads the user, since console says, user "test" entered wrong password
And if i put in a random account(not in Database) it says: user "BlaBla" doesnt Exist.

So its probably the password wich im failing to write/encrypt/decrypt??
uhmm just loudly thinking...

okaii so i converted my pass into a whirlpool hash.

I went to an online converter and i have converted:

123 (pass)
To:
344907e89b981caf221d05f597eb57a6af408f15f4dd7895bb d1b96a2938ec24a7dcf23acb94ece0b6d7b0640358bc56bdb4 48194b9305311aff038a834a079f

and now we login!!!

Jeej!

---edit 5---
New fail:

http://epvpimg.com/ACfFcab
Raven18 is offline  
Old 03/25/2018, 00:44   #88
 
elite*gold: 0
Join Date: Jul 2009
Posts: 487
Received Thanks: 178
Quote:
Originally Posted by Raven18 View Post
Hello people!

Sorry to bother you, ive been away for a long while!
Im just playing around with the source at the moment, just to get back on my skill level.

The only problem i just have(a.k.a. questions i have);

I have the source running, perfectly!
i have the client, downloaded Installed & patched.

Question 1:
can i just use 127.0.0.1 in the msgserver/loginservre CFG /Shell.ini?
&&
And in the Client Loaderset.ini?

Because server is running, and the entire client says "maintenance".

So im missing something...
as ive said'i was away for the last 2 years from CO p-server section (A)
i dont remember if u COULd or COULDNT use 127.0.0.1 or did i havw to change my Dynamic IP to a static ip and use that?

Or what serevr do i have to connect to(in client)
Elements > Dark Seemed obvious xD
(i tried all of them tho !! :/)

Thanks

--edit--

Checked client page
+ conquer loader on 5517 client, still maintenance.
I think im missing something..
Keep on trying!

(its not that i downloaded this patch, and instantly aasked for help..
I downloaded the source yesterday afternoon, and been trying untill now..
AND STILL AM xD!!


--edit2--

Found the issue -.- Port problem ofcourse.. im a nuub..
pff it has been to long :/


----Edit 3 Here i am again!-------
Set everything up, now i get "failed to login, wrong User id/password"

I added the new Tables, i added a accounts / login_rcd Table.
uhm ive tried the old database World Conquer (V1)
(Then it does login, but stucks loading & debug console shows errors & gets stuck on other items.)

i know, im asking for alot maybe.. but ive been on this for 12H, if not more!
Any "Advice/Help" to let me get in the server atleast. <3




---Edit 4---------

Okaii, found out:
It reads the user, since console says, user "test" entered wrong password
And if i put in a random account(not in Database) it says: user "BlaBla" doesnt Exist.

So its probably the password wich im failing to write/encrypt/decrypt??
uhmm just loudly thinking...

okaii so i converted my pass into a whirlpool hash.

I went to an online converter and i have converted:

123 (pass)
To:
344907e89b981caf221d05f597eb57a6af408f15f4dd7895bb d1b96a2938ec24a7dcf23acb94ece0b6d7b0640358bc56bdb4 48194b9305311aff038a834a079f

and now we login!!!

Jeej!

---edit 5---
New fail:

error - epvpImg
https://www.elitepvpers.com/forum/co...l#post36552915
pintinho12 is offline  
Old 04/02/2018, 07:56   #89
 
elite*gold: 0
Join Date: Jan 2016
Posts: 4
Received Thanks: 0
Hello, I was trying out this project trying to figure out the locking of the threads as you quoted, Find out that whenever I leave an account in the boxer training skill and the account takes disconnect it locks the battle threads and User, I'm trying to fix more I do not know where I've already tried everything I do not know much about C #, I'm learning a lot with this project, could someone tell me where I'm going wrong or indicate where I should start to fix this error?
Triton15789 is offline  
Old 04/04/2018, 12:33   #90
 
elite*gold: 0
Join Date: May 2015
Posts: 8
Received Thanks: 0
hello if i update this source 3d

how i can update it this please ?


mohanad2001 is offline  
Reply



« TinyMap Scene Coordinates Fix | Comet, Open Source Server (5017) »

Similar Threads
[RELEASE]Conquer Emulator Source 5165
11/22/2010 - CO2 PServer Guides & Releases - 29 Replies
Latest Version: v1.0.0 Last Updated: 07:37AM 29/07 2010 This is a small project in NewestCOServer. Why this? To make a better NewestCOServer source. Ive deleted alot things so far and started building things up. I will work on this time...
[RELEASE] Conquer v5065 Source
10/20/2009 - CO2 PServer Guides & Releases - 2 Replies
Edited
[Release] Conquer Source
08/23/2009 - CO2 PServer Guides & Releases - 1 Replies
Heya. Since wrong people got ahold of this (immature kids, ofcourse) I decided to release it. It's a source which base was made by Tanel, and was rewritten and continued by me. I will not say that the coding in this source is great, because...



All times are GMT +2. The time now is 03:56.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.