Register for your free account! | Forgot your password?

Go Back   elitepvpers > Star Wars: The Old Republic > SWTOR Hacks, Bots, Cheats & Exploits
You last visited: Today at 10:57

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Beta] UntzBot (Space Missions Bot, recorder+player)

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
[Release] UntzBot (Space Missions Bot, recorder+player)

UNTZBOT

CURRENT VERSION 5.0x3
5.0x3 RELEASE DATE 2012-05-03

4 youtube instruction videos for untzbot:
How to Use + Debugger :
Making Timer Sync Image Files :
Making Event Sync Image Files :
How to run 5.0 with 1.2 :

READ THE TEXT FILE INCLUDED

donation link :

IMPORTANT
- BE CAREFUL OR DO NOT TRY TO USE SCRIPTS ACROSS DIFFERENT LANGUAGES
- Each language may have different timer files, meaning they DO NOT SYNC WITH EACH OTHER
- If you want to do so, then make sure both timer files ARE OF THE SAME TIME (00 and 00, not 00 and 59)
- When trading scripts, make sure timer files are the same or else it is pointless (or just annoying to sync)


SPACE MISSION GUIDE (i did not make this)
https://docs.google.com/spreadsheet/...Vh6ZzRoalkyYmc

please note that i do not speak german or french at all, but still added support for both languages. so it is up to you guys to help each other out. or write up a guide that i can stick up somewhere, or similar. thanks.

[current releases]
v5.0x3
- Fixed Timer sync crashing on mission start
- Added standalone UntzCrewBot

v5.0x2
- Timer sync will now move to bottom left corner
- Timer sync will now have a 40 second maximum time
- Event sync will now have a 40 second maximum time
- Main Module will now show the 'bails'
- Increase the 'sleep before looking for loading screen' time from 4 to 9 seconds
- New recordings for the 'quick level summary' below

v5.0x
- Added new EVENT SYNC IMAGES
- Republic all missions complete
- Imperial 'quick level summary' missions complete
- Pack updates will be available occasionally when I have time, check the thead occasionally
- Added new TIMER SYNC IMAGES
- Should work for all versions
- If not, then just make new ones, like usual
- NO RECORDINGS INCLUDED. Watch the thread if you want, will upload 'quick route' missions later
- Debugger fixed, added warning to change to default interface
- Added login4.bmp to FR/DE (fixed DeathCheck errors)
- Dropped the crappy webhost

v5.0
- Patch 1.2 released, this version just fixes it up to match the UI a bit
- No new features, this is just for 1.2
- IF WORLD MAP CANNOT BE FOUND, CHANGE INTERFACE TO DEFAULT - ESPECIALLY AFTER RESIZING
- Changed some CrewBot logic to make it 'get stuck' less
- Changed SOME graphics
- Moved some coordinates around
- Due to changes in Fleet Commendations, Missions 34+ may fail due to not having
the powerboost/shield/EMP. You will probably need to record your own missions
until the default missions are modified to not use shield/EMP
- Added log.txt, that shows .. well, a log. Yeah.
- Not fully tested, just a rush release to make it work for 1.2, post problems in forums
- Relogger is kind of dodgy now. Will attempt to fix later.

V4.1
- Added CrewBot
- Added Save/Load settings (must be inactive to press)
- Added DoubleClick for 44+
- Added 'click accept multiple times just in case'
- Fixed Imperial48Ascendancy

V4.0x
- fixed the bug where 4.0 was stuck on event sync
- added Debugger.exe
- made it so if you pressed E after pressing Q it ACTUALLY STOPPED

V4.0
- adds the new event sync method
- as this is a huge new addition, if this causes problems, you can still use timer sync, or just stick with a lower version

V3.3 adds everything from V2.0X to 3.2 (left/right click now functional)
- added auto-relogin (experimental)
- removed some settings.txt, hopefully does not cause any problems
- hotkeys changed back to 3.X keys

V2.0X drops down to a modified version of a 'more stable' release (hopefully the new additions keep it still stable)
- added french support, classic/aero support, login support, removed left/right recording (must use 'a' for missiles for now). also threw in a little readme for a bit of help on how to use this thing. in english of course.

V3.2 adds a german language option (the menus are not translated, i will need a translator of sorts for that later), and galaxy map 'fix'

V3.1d fixes up 59xx for real this time

V3.1c fixes up 59xx bugs left over from the hotkey changes

V3.1b just fixes up ship positions, thats all

V3.1 fixes log in credentials (i think), download that for now.
also, i added in more 'debug' messages for when you start a mission/end a mission, so that you can provide WHEN exactly the bot 'screws up', such as if it gets stuck when the status is 'looking for galaxy map'

V2.0 stable version if all else fails

currently, the email that is supposed to be sent to you with credentials is not being sent (my web host is being annoying), so please email me if you do not get your email within 24 hours. thank you.

UntzBot v3.1, space mission bot, made in autoit
Videos/screenshots available on website/this thread

NOTE!! KEYBINDS HAVE ALL CHANGED.

Levels 1-34 free
Levels 35+ one time donation only

To donate, press the 'register' button on the bot during login or go to :

features :
- recording
- playback
- autolooping

ALL MISSIONS ARE NOW SUPPORTED.
levels 1-34 free
levels 35+ donation only

NOTES
- you CANNOT record WADS
- you CAN record leftclick,rightclick, 'z' (rapid fire missiles) and 1234 button presses

Quote:
Originally Posted by BlodyWarior
How to Use - by BlodyWarior
1. launch swtor
2. go sit in the captain's chair and leave the Galaxy map
3. Launch "UntzBotv14.exe" as administrator (rightclick and select "run as admin")
4. Also run DeathCheck.exe as well
//
resize with q
change to DEFAULT interface
//
5. once the bot is launched press "r" to change the mode to "record"
6. select the mission you want to play from the dropdown menu
7. press "q" to start the bot

if all goes correct the bot should now open the galaxy map and go to the mission

8.1. once the mission is loaded just do the mission as normal, but dont press any buttons or click the mouse. The bot will spam the "barrel roll" and autofires.
8.2. if you want to launch a missile just press "z" and it will shoot a missile
8.3 once the mission is almost over and you are sure there wont be any fighters anymore incoming press "e" to stop recording and wait untill the mission is over. The bot will automaticly select the reward and leave the mission.
9. once the mission is over and you are back in your ship press "e" to stop the bot
10. press "r" again to change the mode back to "play"
11. when the mode has been set back to "play" you can now press "q" to start the mission.

If everything went correct it will now run the mission properly and kill the ships.
Quote:
Originally Posted by thephilz
How to Use - by thephilz
- sit in captains chair, open galaxy map
- get out of galaxy map
- open the .exe

//
resize with q
change to DEFAULT interface
//

to play :
- select the correct mission
- change the delay if needed
- press q
- sit around and watch it go

to record :
- change to recording mode (press r)
- press q
- just wait, and when the mission starts, it will automatically start shooting down left click
- press e when the mission is finished
virus scan :
[url]https://www.virustotal.com/file/d9bf12db8d594e80baba1b9376fed660e08c8f878415f7afd6 18a2976
i tried frapsing it, but the lag ruined the script and everything kept going off (my comp sucks, sorry)

- thephilz

thank you.

//

donate links
http://untz.comuf.com/paypal.php
Attached Files
File Type: zip UntzBot50x.zip (1.99 MB, 1207 views)
File Type: zip UntzBot50x3.zip (2.36 MB, 2154 views)



thephilz is offline  
Thanks
72 Users
Old   #2
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
seeing how i couldnt fraps, i did the other thing i could do - take a video with my phone!


blurry as ****, but hey, thats how it works


thephilz is offline  
Thanks
1 User
Old   #3
 
elite*gold: 0
Join Date: Jan 2008
Posts: 52
Received Thanks: 17
Doesn't work for me!

Win 7 64bit

Line 5179 Error
Moto600 is offline  
Old   #4
 
elite*gold: 0
Join Date: Jul 2011
Posts: 35
Received Thanks: 0
yeah in my case its the same problem


Keksefresser is offline  
Old   #5
 
elite*gold: 0
Join Date: Aug 2011
Posts: 79
Received Thanks: 2
Hallo,

engl.
I get an error on Win XP and Win 7 64 bit.
the question is why or. what's wrong?
the exe is run as admin ...
thank you for the help

germ.
ich bekomme leider auch einen Fehler unter Win XP und Win 7 64 bit.
Die Frage ist nur warum? Bzw. was stimmt nicht?
Die Exe wird als Admin ausgeführt...
Danke schonmal für die Hilfe

lg
Sani

//Edit:
Hey
i testet it on Win 7 32 Bit but i got the error too...

//Edit 2:
Hey again
I found the following out
When I move the files from the folder "includes" into the main directory and start the bot then it selects the Galaxy Map and the Mission, but it is not start hunting, it is do nothing more...
Why is that so? has it something to do with the other problem else? or is it my Win 7 64 bit edition?



You must register and activate your account in order to view images.
sahnibar is offline  
Old   #6
 
elite*gold: 0
Join Date: Jul 2005
Posts: 57
Received Thanks: 2
works great for me, went from lvl 12 to 18 so far, but I imagine after 20 the xp will be close to nothing.

I imagine this will be great when you can include more missions. After upgrading the ship I was able to, while recording, get all the bonuses and extra xp I could squeeze out of the mission. It only failed once or twice but that was because I run off a wireless network and it lagged out.
Looking forward to any updates
kakaman is offline  
Old   #7
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
so ive been doing a LOOOOT of work on the bot (im surprised that it even worked without the optimizations i did just then) and now its v1.3 and have successfully done ascendancy (endgame level 48 imperial mission) overnight with 41wins and 3fails, so i can safely say it works.

however i still cant get rid of that stupid line 5179 error that many people are experiencing. it works perfectly fine on mine and another computer i have tested, but i believe that is because i set up imagesearch there myself

can someone who has 'somehow' got it working post any fixes they think they did earlier, perhaps the /includes/ folder or putting the .dll somewhere?

theres no point updating the bot with new missions if half the people cant get it working
thephilz is offline  
Old   #8
 
elite*gold: 0
Join Date: Jul 2005
Posts: 57
Received Thanks: 2
I'm using win 7 ultimate 64 bit, I also downloaded .net runtimes/c+ 2010 x86 prior to running this. Runs fine for me.
I also run the bot directly from the default unzipped folder on the desktop, not from another folder.


Also did a google search for this error:
kakaman is offline  
Old   #9
 
elite*gold: 0
Join Date: Aug 2010
Posts: 70
Received Thanks: 19
Same here, getting the "line 5179" error.
Jinxz is offline  
Old   #10
 
elite*gold: 0
Join Date: Jul 2005
Posts: 57
Received Thanks: 2
unzip directly to desktop, run from there and see if it works
kakaman is offline  
Old   #11
 
elite*gold: 0
Join Date: Jan 2012
Posts: 8
Received Thanks: 0
Nope, I have tried unzipping the full thing to desktop. Tried on two computers. No luck. Lin 5179.

I would be happy to help debug it if your interested.
gthm is offline  
Old   #12
 
elite*gold: 0
Join Date: Aug 2010
Posts: 70
Received Thanks: 19
unzipped it directly to the desktop, same error, also tried to start it off the unzipped folder, didnt change anything. i'll try the .net runtimes stuff when im back from the dentist, will report then if it works.
Jinxz is offline  
Old   #13
 
elite*gold: 0
Join Date: Jul 2005
Posts: 57
Received Thanks: 2
try to "run as administrator" and see if that fixes it
kakaman is offline  
Old   #14
 
elite*gold: 0
Join Date: Jan 2012
Posts: 8
Received Thanks: 0
I tried moving all of the file sin the sub folders to the directory which contains the executable, and it seems ot have solved the line 5179 issue. However, the bot does not seem to function.

Steps to reproduce:
1.) Sit down in captains chair (star map appears)
2.) I open Untzbot
3.) Select ImprialJambiim, and press Q
Results:
Bot shows
"Stating Bot!
Make sure your in the captains chair"
After that nothing happens

Things I have tried:
*running as admin (never know, maybe it needed to call win system dlls)
*I have the all the files in the folders copied(not moved) to the main dir where the script runs
*I tried starting it over, and changing the mode to record, then do th emission, and finally switch to play mode, hit q.... results were thesame as above

If the script is capable of what your video shows, its well worth the effort of debuging so everyone can use it.

Great job!
gthm is offline  
Old   #15
 
elite*gold: 0
Join Date: Jul 2005
Posts: 57
Received Thanks: 2
are you running in windowed mode? It should re-size the window very small (mine does anyway)


kakaman is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Beta player gesucht!!!
Hey, ich suche ein paar beta spieler für meinen minecraft root server 1.1 soweit steht schon ein großteil an gebäuden jedoch suche ich noch 4 beta...
1 Replies - Minecraft Server Advertising
Minecraft 1.7.3 Beta: Not enough space
Hallo! Also, ich habe Minecraft Beta 1.7.3, und benutze den Mod ,,Millionaire´´. In dem Mod bauen ja andere was für dich. Auf dem Schild steht was...
2 Replies - elite*gold Trading
Do The TP Missions And get 2000 TP/Missions
Free File Hosting & Video Downloads, Free File Sharing, Online Friends Network - Ziddu OK. i know all of you is understand using fiddler2.. no...
6 Replies - Facebook



All times are GMT +1. The time now is 10:57.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.