Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 13:21

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Help Thread] Please post your questions here.

Reply
 
Old   #2701
 
elite*gold: 0
Join Date: Oct 2011
Posts: 118
Received Thanks: 4
In my Local server on a few things out'' Empty string'' and other (???????), How can I solve?



ciccioxd is offline  
Old   #2702
 
elite*gold: 0
Join Date: May 2011
Posts: 3
Received Thanks: 0
Bot trap pet!

Hello everyone,
I've started to take a deeper look into Rappelz again and came across a challenge when viewing good ol' screenshots, and there was this Equulus (purple/brown horse thing) bot trap once, but got removed again.
Finding it and spawning it was a no-brainer.
So I've decided to try to implement it as a pet. Ive started editing the MonsterResource to make it possible to kill it for later taming purpose.
But I failed miserably, changing the fight type and f_response attack didnt help

So I decided to add it to SummonResource and itemResource, to see if it will show up at all. I edited the database, hashed the files, put them in the Resource folder.

(EDIT) Got it to show up now after I summon

You must register and activate your account in order to view images.

Still need help on making the bot trap to act as a normal mob, what are my mistakes in my MonsterResource?

(EDIT) After changing the face_file_name and illust_file_name in SummonRsource and editing 02_item(ascii).spr, the new pet icon doesnt show up :3
I hashed the jpgs and put them into resources, the new illust_file_name is working, so I guess it's something in the .spr....
My hashed 02_item(ascii).spr is MmYsif4lPD.F8Xa䖙& <- is that correct??


Code:
MonsterResource
[TABLE]id	monster_group	name_id	location_id	model	motion_file_id	transform_level	walk_type	slant_type	size	scale	target_fx_size	camera_x	camera_y	camera_z	target_x	target_y	target_z	level	grp	magic_type	race	visible_range	chase_range	f_fisrt_attack	f_group_first_attack	f_response_casting	f_response_race	f_response_battle	monster_type	stat_id	fight_type	monster_skill_link_id	material	weapon_type	attack_motion_speed	ability	standard_walk_spped	standard_run_spped	walk_speed	run_speed	attack_range	hidesense_range	hp	mp	attack_point	magic_point	defence	magic_defence	attack_speed	magic_speed	accuracy	avoid	magic_accuracy	magic_avoid	taming_id	taming_percentage	taming_exp_mod	exp	jp	gold_drop_percentage	gold_min	gold_max	chaos_drop_percentage	chaos_min	chaos_max	exp_2	jp_2	gold_min_2	gold_max_2	chaos_min_2	chaos_max_2	drop_table_link_id	texture_group	local_flag	script_on_dead
1000030	105004	1030030	121000030	beast_Equulus_01	10001	1	5	0	3.30	1.00	12.00	-2	-24	7	-0.30	-0.06	14.86	12	1	5	105004	10	100	0	0	0	0	1	5	11000	1	0	1	101	3	0	40	80	20	150	0.20	1.00	538	269	50	50	22	24	-58	0	0	0	0	0	10000	1.0000	3.00	82	14	60	44	73	10	4	7	82	14	44	73	4	7	7053006	-1	0	 
[/TABLE]


kaize123 is offline  
Old   #2703
 
elite*gold: 0
Join Date: Oct 2011
Posts: 118
Received Thanks: 4
Quote:
Originally Posted by kaize123 View Post
Hello everyone,
I've started to take a deeper look into Rappelz again and came across a challenge when viewing good ol' screenshots, and there was this Equulus (purple/brown horse thing) bot trap once, but got removed again.
Finding it and spawning it was a no-brainer.
So I've decided to try to implement it as a pet. Ive started editing the MonsterResource to make it possible to kill it for later taming purpose.
But I failed miserably, changing the fight type and f_response attack didnt help

So I decided to add it to SummonResource and itemResource, to see if it will show up at all. I edited the database, hashed the files, put them in the Resource folder.

(EDIT) Got it to show up now after I summon

You must register and activate your account in order to view images.

Still need help on making the bot trap to act as a normal mob, what are my mistakes in my MonsterResource?

Code:
MonsterResource
[TABLE]id	monster_group	name_id	location_id	model	motion_file_id	transform_level	walk_type	slant_type	size	scale	target_fx_size	camera_x	camera_y	camera_z	target_x	target_y	target_z	level	grp	magic_type	race	visible_range	chase_range	f_fisrt_attack	f_group_first_attack	f_response_casting	f_response_race	f_response_battle	monster_type	stat_id	fight_type	monster_skill_link_id	material	weapon_type	attack_motion_speed	ability	standard_walk_spped	standard_run_spped	walk_speed	run_speed	attack_range	hidesense_range	hp	mp	attack_point	magic_point	defence	magic_defence	attack_speed	magic_speed	accuracy	avoid	magic_accuracy	magic_avoid	taming_id	taming_percentage	taming_exp_mod	exp	jp	gold_drop_percentage	gold_min	gold_max	chaos_drop_percentage	chaos_min	chaos_max	exp_2	jp_2	gold_min_2	gold_max_2	chaos_min_2	chaos_max_2	drop_table_link_id	texture_group	local_flag	script_on_dead
1000030	105004	1030030	121000030	beast_Equulus_01	10001	1	5	0	3.30	1.00	12.00	-2	-24	7	-0.30	-0.06	14.86	12	1	5	105004	10	100	0	0	0	0	1	5	11000	1	0	1	101	3	0	40	80	20	150	0.20	1.00	538	269	50	50	22	24	-58	0	0	0	0	0	10000	1.0000	3.00	82	14	60	44	73	10	4	7	82	14	44	73	4	7	7053006	-1	0	 
[/TABLE]
Hello,
In my Local server on a few things out'' Empty string'' and other (???????), How can I solve?
ciccioxd is offline  
Old   #2704
 
elite*gold: 0
Join Date: May 2011
Posts: 3
Received Thanks: 0
ciccioxd, this tutorial explains it all:


UPDATE: Edited the strings, added evo2 and evo3, but I have a new problem:
Icons still not showing, meh, mob is still a bot trap like thing, so not tameable....

When I go to the breeder, I can "evolve" it, but only the appearance and name changes, the level stays 60+10 and it can't lvl up. Also the evolve menu stays active at the breeder. I copied the Unicorn skills (with my pets IDs but Unicorn skillIDs), only the basic skill tab in the skill menu is available, when I evolve it, the evo1 skills in the basic skill tree get replaced by the evo2 skills, no new skill tab, so I cant access evo1 skills anymore.
Also when I right click the creature card it shows the evo1 image.


kaize123 is offline  
Old   #2705
 
elite*gold: 0
Join Date: Oct 2013
Posts: 36
Received Thanks: 1
what tool is used to edit resource files
kodiaktommy616 is offline  
Old   #2706
 
elite*gold: 0
Join Date: May 2011
Posts: 3
Received Thanks: 0
RDB manager 2013 by raskim,
the server files are from slayer's repack plus shiva's client, tried another 8.1 too with the same results
kaize123 is offline  
Old   #2707
 
elite*gold: 0
Join Date: Sep 2013
Posts: 36
Received Thanks: 3
Unhappy Hilfe

Hallo liebe ePvPler

Ich habe da ein problem, ich möchte gern mit einer Schriftrolle auf meinem Buff-NPC zu greifen. Alles gut und schön, es klappt ja auch.

Ich klicke auf die Schriftrolle in meinem Inventar, der NPC öffnet sich, dann wähle ich --> Starke Buffs und nun schließt sich das Fenster O.o


Das habe ich unter der schriftrolle in die DB unter script_text eingetragen : NPC_Foreign_Secroute_mage_contact()


Code:
function NPC_Foreign_Secroute_mage_contact()

dlg_title( "Buff NPC 2011" )
dlg_text( "Hallo, Buffs? Kein Thema!" )	
	
dlg_menu( "<#80BF80><b><u>Kleine Buffs" , "Kleine_Buffs()" )
dlg_menu( "<#80BF80><b><u>Starke Buffs" , "Starke_Buffs()" )

dlg_menu( "Auf Wiedersehn", '' )
dlg_show()	
	
end

Währe toll wenn mir wer helfen könnte!
DrMaRe is offline  
Old   #2708
 
elite*gold: 0
Join Date: Oct 2011
Posts: 118
Received Thanks: 4
Hello,

I have a problem with the setup of SQL,
In practice, Installing SQL, I went on, and I accept the terms of use, and license.

Once you get to the Install Setup Files, after which almost all are complete, suddenly closes the Setup, you return to the page

SQL Installation Center.

I hope someone can help me, I have to re-create the server.
ciccioxd is offline  
Old   #2709
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,002
Received Thanks: 957
You removed all of the previous installations of SQL server first?
ThunderNikk is offline  
Old   #2710
 
elite*gold: 0
Join Date: Oct 2011
Posts: 118
Received Thanks: 4
I formatted the PC, I installed all the drivers on my computer.

I try to open SQL, and tells me that the requirements of my computer are not good for SQL, but I had created before formatting the server, solutions?
ciccioxd is offline  
Old   #2711
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,002
Received Thanks: 957
Did you install Service pack 1 for Windows 7 yet?

It is required for MSSQL Server 2012.
ThunderNikk is offline  
Old   #2712
 
elite*gold: 0
Join Date: Nov 2013
Posts: 12
Received Thanks: 0
Hallo an alle

Ich brauch Hilfe beim Starten des Gameservers.


Gestern habe ich mit Hilfe von Google dieses Portal gefunden und bin froh das es möglich ist einen privaten Server für Rappelz zu erstellen.

Der Guide hier im Forum ist sehr gut dargelegt, daher habe ich mich entschlossen, Schritt für Schritt danach vorzugehen.

Alle angegebenen Dateien habe ich herunterladen können.

Der SQL-Server hat sich klaglos installiert und noch eine Menge Updates gezogen.

Die Konfiguration des SQL-Servers ist gut bebildert so das man alles leicht nachvollziehen kann.

Leider startet nur der Auth-Server fehlerfrei, der Game-Server meldet das die Telecaster-Datenbank nicht geöffnet werden kann, da bei der Anmeldung ein Fehler auftritt.

Ich weiß, diese Fehlermeldung wurde bereits auf S. 161 dieses Threads behandelt, aber die Ausgangslage war dort leider eine andere, so das ich mit der Lösung nicht viel anfangen kann.

Ich habe die im Guide angegebenen Beispiele der opt-Dateien unverändert übernommen und in der GameServer.opt sind für die Arcadia und die Telecaster Datenbank die selben Anmeldedaten eingetragen:
Account: sa | passwort: leer.

AuthServer.opt
Code:
S db.auth.server:127.0.0.1
S db.auth.name:Auth
S db.auth.account:sa
S db.auth._password:
S app.name:Auth Server
S log.ip:127.0.0.1
S db.auth.port:1433
S io.auth.port:8841
N db.auth.use_webauth:0
N db.auth.use_md5:1
N db.auth.debug_md5:1
N db.auth.md5_key:2011


gameserver.opt
Code:
S app.name:Game Server
S auth.server_idx:1
S auth.server_name:Player95Server

S db.user.work_total:
S db.user.work_pending:
S db.user.work_active:
S db.user.thread_active:
S db.user.thread_total:

S console.port:4515
S console._password:

S db.game.ip:127.0.0.1

S db.c.name:Arcadia
S db.c.server:127.0.0.1
S db.c.account:sa
S db.c._password:

S db.user.name:Telecaster
S db.user.server:127.0.0.1
S db.user.account:sa
S db.user._password:

S io.auth.ip:127.0.0.1
S io.ip_address:127.0.0.1
S io.port:4504

S game.server_screenshot_url:

S io.upload.port:4617
S io.upload.ip:your_website/external_ip
S game.guild_icon_base_url:http://your_website/external_ip/icons/
S game.url_list:guild_icon_upload.ip|your_website/external_ip|guild_icon_upload.port|4615

S game.use_auto_jail:0
S game.pvp_damage_rate_for_summon:.03
S game.pvp_damage_rate_for_player:.03
S game.use_storage_security:0
S game.check_storage_security_always:0
S game.use_delete_security:0
S game.mem_usage_info_save_interval:6000
S game.base_ethereal_durability_consumption:.35
S game.play_point_accumulate_term:6000
S game.play_point_accumulate_amount:10
S game.premium_pcbang_play_point_bonus_rate:2.5
S game.exp_rate:10
S game.item_drop_rate:12
S game.gold_drop_rate:12
S game.chaos_drop_rate:12
S game.party_drop_rate:2.5
S game.party_exp_rate:1.25
S game.apply_stamina_bonus_in_premium_pcb:.50
S game.premium_pcbang_bonus_rate:1.25
S game.premium_pcbang_chaos_bonus_rate:2
S game.premium_pcbang_gold_bonus_drop_rate:2.5
S game.premium_pcbang_item_bonus_drop_rate:2.5
S game.premium_pcbang_chaos_bonus_drop_rate:2.5
S game.ally_pcbang_bonus_rate:1.75
S game.ally_pcbang_chaos_bonus_rate:1.75

T game.pcbang_bonus_server:1
T game.use_play_point:0
T game.use_guild_donation_point:1
T game.use_login_logout_debug:1
T game.max_level:180
T game.use_auto_trap:0
T game.cash_usable_server:1
T game.no_collision_check:0
T game.no_skill_cooltime:0
T game.disable_huntaholic:0
S game.disable_huntaholic_timer:0
S game.huntaholic_timer:1
T game.disable_dungeon_raid_siege:0
N game.UseHackShield:0
N game.UseGameGuard:0
N game.skip_loading_attribute:1
N game.logout_timer:1
S log.disable:1
S log.working:0
S game.AdultServer:0
S game.PKServer:0
S game.disable_pk_on:0
S game.auction_process_request_min_interval:100
S game.auction_search_request_min_interval:100
S game.force_unregister_account_on_kick_fail:1
S game.min_global_chat_usable_level:20
S game.item_hold_time:11000


S memory.player_heap_size:1000
T game.max_storage_item_count:1000
T set_user_limit:50





Ich habe die Opt-Dateien, wie angegeben, mit RappelzCompress_v2.exe gepackt.

Auf die Arcadia-Datenbank kann zugegriffen werden, auf die Telecaster leider nicht.

Auch das Kopieren aller Datenbanken nach C: und neu wiederherstellen brachte keine Änderung.

In einem anderen Youtube-Guide habe ich gesehen wie dort die Telecaster und Arcadia Datenbank ebenso wiederhergestellt wurden wie die Auth. Wenn ich das selbe tue gibt der Gameserver zwar keine Fehlermeldung von sich schließt sich aber nach oder während dem Laden der Itemliste wortlos.


Um Fehler auszumerzen habe ich 2x den SQL-Server neuinstalliert, den Guide mehrmals Punkt für Punkt abgearbeitet und auch mehrmals die Dateien entpackt, aber nun weiß ich nicht weiter.

Hat die Telecaster Datenbank andere Anmeldedaten?
Auch habe ich im EigenschaftenMenü sehen können das die Telcaster-Datenbank von allen die Jüngste ist.


Ich hoffe jemand kann mir weiterhelfen.

Meine englisch-Schreibkentniss erspare ich uns allen lieber, englische Antworten sind für mich aber ok.
Attached Images
File Type: jpg gameserver_error.jpg (12.2 KB, 19 views)
File Type: jpg Eigenschaftenmenüs.jpg (24.9 KB, 20 views)
File Type: jpg Datenbaqnkbesitzer.jpg (14.2 KB, 19 views)
File Type: jpg sql_port.jpg (14.8 KB, 18 views)
Xedike is offline  
Old   #2713
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,002
Received Thanks: 957
Sorry I have to ask in English.

What is the name of your Arcadia database in the SQL database list?

If it is restored as "Arcadia8_1" then you need to rename it to "Arcadia" or Telecaster crashes looking for the missing database.

I will spare you the messy Google translated version.
ThunderNikk is offline  
Thanks
1 User
Old   #2714
 
elite*gold: 0
Join Date: Sep 2008
Posts: 1,570
Received Thanks: 1,154
In deinem dritten Screenshot sieht man deinen SQL Server...Ich sehe da NUR die Auth Datenbank...Eventuell ist der Screenshot ja bissel älter. Wenn bei dir aber wirklich nur die Auth-Datenbank aufgeführt wird, dann würde ich mal schleunigst die Telecaster und die Arcadia wiederherstellen. Geht genauso wie bei der Auth DB.

Wenn der PrincessAurora (Auth) Server geht, dann steht die Verbindung zur DB und dein sa benutzer bezieht sich auf den gesamten SQL Server und nicht auf eine Datenbank. Sprich der User sa hat bei jeder DB das gleiche Passwort, etwas anderes wäre unmöglich. Sieht also alles danach aus:
-dass die telecaster wirklich fehlt
-dass die telecaster anders heißt, als in der .opt
-dass die telecaster schrott is (würdest du aber im SQL Management Studio sehen)
c1ph3r is offline  
Thanks
1 User
Old   #2715
 
elite*gold: 0
Join Date: Nov 2013
Posts: 12
Received Thanks: 0
Vielen Dank an thndr und c1ph3r


Ich habe die beiden Datenbanken eingeunden und im Studio die Arcadia8_1 in Arcadia umbenannt.


Der Server startet jetzt fehlerfrei.


Xedike is offline  
Reply

Tags
7.4, client, rappelz



« Previous Thread | Next Thread »

Similar Threads
[Helping Topic] 24/7 Helping Services!
stucked on anything while setuping your server? post your problem here and you will get answer as fast as possible better than spamming with posts...
31 Replies - EO PServer Hosting



All times are GMT +2. The time now is 13:21.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.