Register for your free account! | Forgot your password?


You last visited: Today at 06:51

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



GW Working Bots 2020

Discussion on GW Working Bots 2020 within the GW Exploits, Hacks, Bots, Tools & Macros forum part of the Guild Wars category.

Reply
 
Old 08/10/2020, 23:27   #766
 
elite*gold: 0
Join Date: Mar 2018
Posts: 19
Received Thanks: 12
Anyone any idea what it could mean when your character loses connection to the server?

I tried to integrate PackMan into a Kilroy bot and on the second selling procedure i keep losing connection and it sends me back on char selection screen.

Every other bot works fine, there are no network issues, the issue is bot related.
TheGringott is offline  
Old 08/11/2020, 00:24   #767
 
elite*gold: 0
Join Date: May 2008
Posts: 248
Received Thanks: 23
Quote:
Originally Posted by TheGringott View Post
Anyone any idea what it could mean when your character loses connection to the server?

I tried to integrate PackMan into a Kilroy bot and on the second selling procedure i keep losing connection and it sends me back on char selection screen.

Every other bot works fine, there are no network issues, the issue is bot related.
You will have the same problem if you try to buy and sell really quickly
kendor is offline  
Old 08/11/2020, 11:36   #768
 
elite*gold: 0
Join Date: Oct 2012
Posts: 10
Received Thanks: 1
Hello, is it possible to do the Dragonmoss farm for Ranger / Faction only account please ? ty
azerty8585 is offline  
Old 08/11/2020, 14:00   #769
 
elite*gold: 0
Join Date: Mar 2018
Posts: 19
Received Thanks: 12
Quote:
Originally Posted by kendor View Post
You will have the same problem if you try to buy and sell really quickly
It seems like the PackMan bot beeing unstable during the salvaging process. Couldn't identify the exact issue yet.
TheGringott is offline  
Old 08/11/2020, 15:55   #770
 
elite*gold: 0
Join Date: May 2008
Posts: 248
Received Thanks: 23
Quote:
Originally Posted by TheGringott View Post
It seems like the PackMan bot beeing unstable during the salvaging process. Couldn't identify the exact issue yet.
I actually meant salvaging too quickly. Sorry. see if there is a way to slow it down
kendor is offline  
Old 08/11/2020, 16:49   #771
 
elite*gold: 0
Join Date: Aug 2019
Posts: 25
Received Thanks: 43
Quote:
Originally Posted by TheGringott View Post
It seems like the PackMan bot beeing unstable during the salvaging process. Couldn't identify the exact issue yet.
I've noticed it as well. There is a function RndPingSleep(). Make sure you use one of the latest GWA2's where GetPing() is fixed. The one packed with PackMan 1.5 will work.

Code:
Func RndPingSleep()
	While GetPing() == 0
		Sleep(50)
	WEnd
	RndSleep(GetPing() * 6)
EndFunc
The line where is kicks you is RndSleep(GetPing() * 6). For me a multiplier of * 3 is usually quite stable, but I set to * 6 to try account for slower connections. If you increase that value to 8, 10, 12, 14... you should eventually reach a state where it doesn't kick you, but obviously each time you slow your script down a bit. If using with a bot though then that extra few seconds wont hurt

If people who test this can post which values are stable for them, that would be helpful, thanks!
Air.Fox is offline  
Thanks
1 User
Old 08/11/2020, 21:48   #772
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 336
Quote:
Originally Posted by Pheliepee View Post
pic "gw018" is the stuck point

and

pic "gw019" is the spawn point
Ok thanks, working on it.
RiflemanX is offline  
Thanks
1 User
Old 08/12/2020, 00:56   #773
 
elite*gold: 0
Join Date: Jul 2019
Posts: 103
Received Thanks: 82
Quote:
Originally Posted by Air.Fox View Post
I've noticed it as well. There is a function RndPingSleep(). Make sure you use one of the latest GWA2's where GetPing() is fixed. The one packed with PackMan 1.5 will work.

Code:
Func RndPingSleep()
	While GetPing() == 0
		Sleep(50)
	WEnd
	RndSleep(GetPing() * 6)
EndFunc
The line where is kicks you is RndSleep(GetPing() * 6). For me a multiplier of * 3 is usually quite stable, but I set to * 6 to try account for slower connections. If you increase that value to 8, 10, 12, 14... you should eventually reach a state where it doesn't kick you, but obviously each time you slow your script down a bit. If using with a bot though then that extra few seconds wont hurt

If people who test this can post which values are stable for them, that would be helpful, thanks!
Yep, this is the best way to fix it in the current gwa2 available to the public. The 100% bullet proof way would be to hook the GameServer -> Client Decryption function to only move on when the client receives back the finished salvage packets like gwca does.
list comprehension is offline  
Thanks
1 User
Old 08/12/2020, 01:45   #774
 
elite*gold: 0
Join Date: Sep 2014
Posts: 351
Received Thanks: 119
Cool

Quote:
Originally Posted by list comprehension View Post
Yep, this is the best way to fix it in the current gwa2 available to the public. The 100% bullet proof way would be to hook the GameServer -> Client Decryption function to only move on when the client receives back the finished salvage packets like gwca does.
...or an even easier way to fix this is to wait till your salvage kit value drops (meaning a salvage use has been used out of the salvage kit), this happens at the end of the salvage kit being used and signifies that the salvage is also finished. You can use already defined functions in gwa2 to fix it this way as well...
phat34 is offline  
Thanks
1 User
Old 08/12/2020, 02:45   #775
 
elite*gold: 0
Join Date: Jul 2019
Posts: 103
Received Thanks: 82
Quote:
Originally Posted by phat34 View Post
...or an even easier way to fix this is to wait till your salvage kit value drops (meaning a salvage use has been used out of the salvage kit), this happens at the end of the salvage kit being used and signifies that the salvage is also finished. You can use already defined functions in gwa2 to fix it this way as well...
Nice, that is a clever way to tell the transaction is finished. One of the funnest parts of game hacking is finding creative ways to relay information to the API.
list comprehension is offline  
Old 08/12/2020, 07:40   #776
 
elite*gold: 0
Join Date: Jun 2020
Posts: 13
Received Thanks: 0
Quote:
Originally Posted by Aimcorp View Post
Kilroy bot,

updated, fixed some ****,
added some **** nobody asked for
Hard mode, theoretically works, but dont use it, the bot wont be able to complete it 90% of the time.
picks up golds, stone summit emblems and gold now,
uses lightbringer/serker/whatever scrolls (not my doing)

have fun

Hey All,


when I try to run this bot, it says to me: Error: GWA2 not included
I did start GWA2 before, and i tried many different downloaded versions of GWA2. Someone has any idea what could be wrong here? I really would like to try this Kilroy bot.


Thanks in advance
riceprot94 is offline  
Old 08/12/2020, 12:17   #777
 
elite*gold: 0
Join Date: Sep 2011
Posts: 8
Received Thanks: 5
Hi this Kilroy bot, Works
Attached Files
File Type: rar Kilroy_Stoneskin_Bot_V1.4.rar (125.3 KB, 105 views)
guiposs is offline  
Thanks
2 Users
Old 08/12/2020, 15:22   #778
 
elite*gold: 0
Join Date: Aug 2019
Posts: 25
Received Thanks: 43
Quote:
Originally Posted by list comprehension View Post
Yep, this is the best way to fix it in the current gwa2 available to the public. The 100% bullet proof way would be to hook the GameServer -> Client Decryption function to only move on when the client receives back the finished salvage packets like gwca does.
I think this would be ideal. Any ideas on how to create the hook?

Quote:
Originally Posted by phat34 View Post
...or an even easier way to fix this is to wait till your salvage kit value drops (meaning a salvage use has been used out of the salvage kit), this happens at the end of the salvage kit being used and signifies that the salvage is also finished. You can use already defined functions in gwa2 to fix it this way as well...
In my tests waiting for salvage-kit uses to decrement was unfortunately not enough to prevent disconnect if starting another salvage immediately after.

But even if we have a long enough pause inbetween salvage items, it will also disconnect if there is not a long enough pause inbetween StartSalvage() -> Salvage(). Not sure why this is the case since TraderRequestSell() -> TraderSell() has similar process but does not have this issue Nevermind, TraderRequestSell() waits for TraderQuoteId before continuing
Air.Fox is offline  
Old 08/12/2020, 18:50   #779
 
elite*gold: 0
Join Date: Jan 2010
Posts: 16
Received Thanks: 5
Still looking for a working Follower Bot :S





there are 2 on the 2019 bots tread
Attached Files
File Type: rar FollowUpdated2020.rar (3.19 MB, 17 views)
Kn!ckl3s is offline  
Thanks
1 User
Old 08/13/2020, 05:50   #780
 
elite*gold: 0
Join Date: Dec 2017
Posts: 46
Received Thanks: 24
Quote:
Originally Posted by Kn!ckl3s View Post
Still looking for a working Follower Bot :S





there are 2 on the 2019 bots tread
Plain Jane follower for you fam
Attached Files
File Type: zip FollowKnicklesOnTwitterAndInstagram.zip (2.9 KB, 42 views)
ayyy_lmao is offline  
Thanks
2 Users
Reply


Similar Threads Similar Threads
[WTT] UPlay Anno 2020 Complete Key gegen Anno 1404/Anno 2020 Complete STEAM
08/12/2015 - Steam Trading - 0 Replies
Want to Trade UPlay Anno 2020 Complete Key gegen Anno 1404 oder Anno 2020 Complete STEAM only with Middleman



All times are GMT +2. The time now is 06:51.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2021 elitepvpers All Rights Reserved.