Register for your free account! | Forgot your password?

Go Back   elitepvpers > New Arrivals > Black Desert
You last visited: Today at 17:01

  • Please register to post and access all features, it's quick, easy and FREE!

 

[AutoIt] CrayonCode Bot Project (OpenSource & Free)

Reply
 
Old   #496
 
elite*gold: 0
Join Date: Nov 2007
Posts: 3
Received Thanks: 0
Is it possible to use this to bid on multiple different pets? It seems like I have to pick a pet and use the program and hope someone lists only that specific one.



Llght is offline  
Old   #497
 
elite*gold: 0
Join Date: Apr 2017
Posts: 108
Received Thanks: 189
Quote:
Originally Posted by Llght View Post
Is it possible to use this to bid on multiple different pets? It seems like I have to pick a pet and use the program and hope someone lists only that specific one.
At the moment functionality is limited to that.


CrayonCode is offline  
Old   #498
 
elite*gold: 0
Join Date: Apr 2017
Posts: 33
Received Thanks: 3
Need more Sleep time ! and the prosses count dont working i have donne in 23s and i wait 130s for next prosses!

i think the Game FPS alter the bot function no? in Haidel i go 17-20 fps

Fullscreen detected (1920x1080) - No Offsets
--> Chauffage minerai_fer 10/0 with
Trying to open Warehouse
StorageAnchor: not found
Clicking Transport Button
Clicking WarehouseButton
Returning items to storage
StorageAnchor: 904, 284
Scanning for current order: [minerai_fer, 10]
minerai_fer on page 0 is absent
minerai_fer on page 1 is PRESENT
FindResourceCustom: 1, 2 - All Required Ingredients PRESENT
Processing open: False
Processing open: True
Waiting for Processing to end.
Processing stopped after 130s.
Processing time longer than 1 seconds. Repeat the same item.
--> Chauffage minerai_fer 10/0 with Successful
--> Chauffage minerai_fer 10/0 with
Trying to open Warehouse
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: 420, 975
Escaping from Storage
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
Wrong NPC? Escape and turn
StorageAnchor: not found
OCInventory Timeout
StorageAnchor: not found
Skipping Queue: 0 Reason: Atleast One Ingredient absent
Skipping Queue: 1 Reason: No Processing Method selected
Skipping Queue: 2 Reason: No Processing Method selected
Skipping Queue: 3 Reason: No Processing Method selected
Skipping Queue: 4 Reason: No Processing Method selected
Skipping Queue: 5 Reason: No Processing Method selected
Skipping Queue: 6 Reason: No Processing Method selected
Skipping Queue: 7 Reason: No Processing Method selected
Skipping Queue: 8 Reason: No Processing Method selected
Skipping Queue: 9 Reason: No Processing Method selected
Skipping Queue: 10 Reason: No Processing Method selected
Skipping Queue: 11 Reason: No Processing Method selected
Skipping Queue: 12 Reason: No Processing Method selected
Skipping Queue: 13 Reason: No Processing Method selected
ProcessCustom finished

Edit: Lol sorry it for my Fr traduction i put new log in eng
imedbox is offline  
Old   #499
 
elite*gold: 0
Join Date: Apr 2017
Posts: 108
Received Thanks: 189
Seems like slow machine take longer for the basic actions.

You have no count set. You have only set the BatchSize (The amount you take out the storage for each processing attempt)
The actual counting is done by the Max value.
So BatchSize 10 and Max 100 would repeat 10 times.
But you have Max 0 which means process until it fails.

Doesn't the bot detect when the Production window pops up after the processing is done?
Or why would 10 iron ore take more than 2 minutes? Is it just doing nothing for all that time?
I'm polling the GUI pretty often while it's processing so the buttons actually respond.
Maybe that takes more time on your system. I'll need to take a look.

PS: Too bad that the transparency doesn't work with the imagesearch.dlls. It would make a lot of things easier and more reliable. I might need to learn some autohotkey since it is a base function that is extracted from there.
If anyone knows how to make the transparency working let me know


CrayonCode is offline  
Thanks
1 User
Old   #500
 
elite*gold: 0
Join Date: Apr 2017
Posts: 33
Received Thanks: 3
Quote:
Originally Posted by CrayonCode View Post
Seems like slow machine take longer for the basic actions.

You have no count set. You have only set the BatchSize (The amount you take out the storage for each processing attempt)
The actual counting is done by the Max value.
So BatchSize 10 and Max 100 would repeat 10 times.
But you have Max 0 which means process until it fails.

Doesn't the bot detect when the Production window pops up after the processing is done?
Or why would 10 iron ore take more than 2 minutes? Is it just doing nothing for all that time?
I'm polling the GUI pretty often while it's processing so the buttons actually respond.
Maybe that takes more time on your system. I'll need to take a look.

PS: Too bad that the transparency doesn't work with the imagesearch.dlls. It would make a lot of things easier and more reliable. I might need to learn some autohotkey since it is a base function that is extracted from there.
If anyone knows how to make the transparency working let me know
1- Doesn't the bot detect when the Production window pops up after the processing is done? yes
2- Or why would 10 iron ore take more than 2 minutes? Is it just doing nothing for all that time? yes

i have AMD 4G 8core 16 go ram ddr3 GTX970 ssd 240go
imedbox is offline  
Old   #501
 
elite*gold: 0
Join Date: Apr 2017
Posts: 108
Received Thanks: 189
Quote:
Originally Posted by imedbox View Post
1- Doesn't the bot detect when the Production window pops up after the processing is done? yes
2- Or why would 10 iron ore take more than 2 minutes? Is it just doing nothing for all that time? yes

i have AMD 4G 8core 16 go ram ddr3 GTX970 ssd 240go
There must be some kind of leak or performance drag, since there is no timeout to waiting for processing to end yet.
Please manually check Func ProductionActivityCheck() and replace GSleep(5000) with Sleep(5000).
Let me know if that fixed it.
CrayonCode is offline  
Old   #502
 
elite*gold: 0
Join Date: Apr 2017
Posts: 33
Received Thanks: 3
Quote:
Originally Posted by CrayonCode View Post
There must be some kind of leak or performance drag, since there is no timeout to waiting for processing to end yet.
Please manually check Func ProductionActivityCheck() and replace GSleep(5000) with Sleep(5000).
Let me know if that fixed it.
Edit: Work perfect just change GSleep(5000) to Sleep(1000) ty, i put 10 iron ore lanch the bot..., mini problem, the count time freeze at the second successes transformation 50% and continue the count at 100%
imedbox is offline  
Old   #503
 
elite*gold: 0
Join Date: Apr 2017
Posts: 108
Received Thanks: 189
Quote:
Originally Posted by imedbox View Post
Edit: Work perfect just change GSleep(5000) to Sleep(1000) ty, i put 10 iron ore lanch the bot..., mini problem, the count time freeze at the second successes transformation 50% and continue the count at 100%
If you are talking about the timer on the lower left of the Status Log, that is actually the timer for the alchemy stone and it was also getting updated via GSleep(). So it's not frozen but it will just not update the GUI (That's also the reason why the buttons won't work now, but the hotkeys still do)

I plan to add some more timers as visual guide, so you can see when sidefunctions like alchystone, workerfeed and buffood will happen.



Quote:
Originally Posted by CrayonCode
After trying to comprehend the fucking util.cpp from the link I posted for hours, I finally figured out where the fuck the stupid fucking autoit wrapper went wrong.

Code:
			else if (!_strnicmp(cp, "Trans", 5))
			{
				cp += 5;  // Now it's the character after the word.
				// Isolate the color name/number for ColorNameToBGR():
The wrapper didn't add the 'Trans' to the string, so when reading the filename string it would read "*HEX filepath" instead of correctly reading "*TransHEX filepath". So the transparency would be handled as shadevariation instead.

And they used $transparency <> 0 instead of <> "" so a string would always result in FALSE for some reason. So my manual attempts to test $transparency = "TransHEX" instead of $transparency = "HEX" failed, because of that.
Also autoit shows HEX like 0x0000FF as decimals (255) so even with adding Trans the color would be misinterpreted.

I fixed it by changing

Code:
	If $transparency <> 0 Then $findImage = "*" & $transparency & " " & $findImage
to

Code:
	If $transparency <> "" Then $findImage = "*Trans" & $transparency & " " & $findImage
Thanks man you made me look harder at the problem. All those different Imagesearch.au3 out there have that damn bug and no one even noticed.

There are also some more default colors mentioned in the that can be called with "ColorName" instead of "0xHEX":
Thanks to ahmedwork for making me waste half a night
CrayonCode is offline  
Thanks
4 Users
Old   #504
 
elite*gold: 0
Join Date: Mar 2012
Posts: 55
Received Thanks: 2
For me the marketplace is not working, sais purplebags not found, how do I fix it? playing english EU

Edit: Fixed it by creating a new higher resolution bitmap icon of the purple bags in the marketplace with paint, just screenshot the market and you can create it yourself, just don't make it too low res or it won't recognize the icon for some reason.
Mardoo is offline  
Old   #505
 
elite*gold: 0
Join Date: Mar 2011
Posts: 97
Received Thanks: 4
@CrayonCode is there anything about Relogg to change it i got Launcherside fail "Wrong Password or Email" i think its to fast how do i change the delays?
s3anlike is offline  
Old   #506
 
elite*gold: 0
Join Date: Apr 2017
Posts: 108
Received Thanks: 189
@Mardoo are you using optimization mode? Because it's searching those purple bags with zero tolerance and I already had people report that optimization mode ***** around with the textures.

@s3anlike did it work before or might the update have changed that? Just increase the Sleep() in the relevant function.

@Everyone did the worker window get moved since the last patch? It looks like it got moved up for every resolution. Could someone confirm this?
CrayonCode is offline  
Old   #507
 
elite*gold: 0
Join Date: Feb 2009
Posts: 63
Received Thanks: 2
Yes. i read that they changed the location in the patchnotes.
limital is offline  
Old   #508
 
elite*gold: 0
Join Date: Mar 2012
Posts: 55
Received Thanks: 2
@CrayonCode I just use the 0.21 I downloaded, changed nothing with any settings, but it works now with my new bitmap, totally fine, thanks anyway
Mardoo is offline  
Old   #509
 
elite*gold: 0
Join Date: May 2017
Posts: 1
Received Thanks: 0
Been using this for the past few days and it is great. Wanted to say thanks for the work done on it. The worker window was moved upwards with the patch. Using 1920x1080
astraykat is offline  
Old   #510
 
elite*gold: 0
Join Date: Mar 2006
Posts: 1,564
Received Thanks: 314
Quote:
Originally Posted by CrayonCode View Post
@Mardoo are you using optimization mode? Because it's searching those purple bags with zero tolerance and I already had people report that optimization mode ***** around with the textures.

@s3anlike did it work before or might the update have changed that? Just increase the Sleep() in the relevant function.

@Everyone did the worker window get moved since the last patch? It looks like it got moved up for every resolution. Could someone confirm this?
The UI updates now supports multiple presets as well as 100% ui scale even if its low resolution. And yes, it does seems to be moved in new location.


killzone is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
[Opensource] PokeMMO Autoit bots
DON'T USE THIS UNTIL WE FIND A WAY TO WORK AROUND THE CAPTCHA!!! Gnomepy's PokeMMO bot V6.1 *31 january 2013* Functions: -Heals when hp/pp...
117 Replies - Pokemon
[OPENSOURCE PROJECT] BROWSERGAME
HEYHO Leute :D , Ich suche Leute die Lust hätten mit mir ein eigenes Browsergame zu erstellen. Also ich bräuchte ein ganzes Team so wie Sponsoren...
8 Replies - Web Development
[OpenSource Project] C++ CoCore
Alright, I think I'm done with the lurking for now.. The main reason of me starting this project is to get some people to use C++ instead of C#....
59 Replies - CO2 PServer - Discussions / Questions
Farmville Automatizer OPENSOURCE free bot [AutoIT]
Farmville Automatizer released! Open Source >>> Download <<<
2 Replies - Facebook



All times are GMT +1. The time now is 17:01.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.