Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 08:57

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Help Thread] Please post your questions here.

Reply
 
Old   #2941
 
elite*gold: 0
Join Date: Jan 2014
Posts: 65
Received Thanks: 15
Quote:
Originally Posted by mmno View Post
-----
function on_server_init()
roaming()
rare_mob()
guardian_spawn()
random_respawn()
server_buffs()
end

function server_buffs()
add_state(1011, 20, 259200000)
add_state(1101, 20, 259200000)
add_state(1013, 20, 259200000)
add_state(9004, 20, 259200000)
add_cstate(1101, 20, 259200000)
add_cstate(1011, 20, 259200000)
add_cstate(1013, 20, 259200000)
add_cstate(9004, 20, 259200000)
end

this is what i have alrady.... and not working for me
Hmm...

You might want to try this:

Add this to the on_login script (92aaf4ae4ee42eb41693728da93f301a)

Code:
	
        add_state(1011, 20, 259200000)
	add_state(1101, 20, 259200000)
	add_state(1013, 20, 259200000)
	add_state(9004, 20, 259200000)
	add_cstate(1101, 20, 259200000)
	add_cstate(1011, 20, 259200000)
	add_cstate(1013, 20, 259200000)
	add_cstate(9004, 20, 259200000)
Add it right after this line:
Code:
function on_login( name )
P.S. I might be mistaken and this is completely hypothetical, but I think that the server init only takes on the event_states, because the event_states work for me, but the states don't. Maybe just me.



Prentis is offline  
Thanks
1 User
Old   #2942
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
Quote:
Originally Posted by Prentis View Post
P.S. I might be mistaken and this is completely hypothetical, but I think that the server init only takes on the event_states, because the event_states work for me, but the states don't. Maybe just me.
I am pretty sure you are correct on this.

On server init you are setting up the server to have event buffs that will affect everyone who logs on.

I think normal add states can only be directed toward a player logging in and not to the server starting.

@L3y5on

Post what you had before you opened the server for your friend to help you and what you had after you opened your server for your friends help and it might be easier for us to help you pinpoint the error.

That screen with that Korean message is a port issue though and your ports look right in your .opts

But if you are now trying to route through your external IP, where you may not have been before, and those ports are not set up properly in your router that may be why you are seeing that Korean message.

They need to be set up for both inbound and outbound rules (but not 1433 unless you are remotely managing the server, then if you are you better make sure your user is stronger than "sa" and that it has stronger than a blank password.)


ThunderNikk is offline  
Old   #2943
 
elite*gold: 0
Join Date: Sep 2009
Posts: 103
Received Thanks: 0
so it will be like this
function on_server_init()
roaming()
rare_mob()
guardian_spawn()
random_respawn()
server_buffs()
end

function server_buffs()
add_state(1011, 20, 259200000)
add_state(1101, 20, 259200000)
add_state(1013, 20, 259200000)
add_state(9004, 20, 259200000)
add_cstate(1101, 20, 259200000)
add_cstate(1011, 20, 259200000)
add_cstate(1013, 20, 259200000)
add_cstate(9004, 20, 259200000)
function on_login( name )
end


right?
mmno is offline  
Old   #2944
 
elite*gold: 0
Join Date: Jan 2014
Posts: 65
Received Thanks: 15
Quote:
Originally Posted by mmno View Post
so it will be like this
function on_server_init()
roaming()
rare_mob()
guardian_spawn()
random_respawn()
server_buffs()
end

function server_buffs()
add_state(1011, 20, 259200000)
add_state(1101, 20, 259200000)
add_state(1013, 20, 259200000)
add_state(9004, 20, 259200000)
add_cstate(1101, 20, 259200000)
add_cstate(1011, 20, 259200000)
add_cstate(1013, 20, 259200000)
add_cstate(9004, 20, 259200000)
function on_login( name )
end


right?

No... That won't work. You need to delete that part in the server init and put the line on the 92aaf4ae4ee42eb41693728da93f301a script... As I said here

Quote:
Originally Posted by Prentis View Post
Hmm...

You might want to try this:

Add this to the on_login script (92aaf4ae4ee42eb41693728da93f301a)

Code:
	
        add_state(1011, 20, 259200000)
	add_state(1101, 20, 259200000)
	add_state(1013, 20, 259200000)
	add_state(9004, 20, 259200000)
	add_cstate(1101, 20, 259200000)
	add_cstate(1011, 20, 259200000)
	add_cstate(1013, 20, 259200000)
	add_cstate(9004, 20, 259200000)
Add it right after this line:
Code:
function on_login( name )
P.S. I might be mistaken and this is completely hypothetical, but I think that the server init only takes on the event_states, because the event_states work for me, but the states don't. Maybe just me.


Prentis is offline  
Thanks
1 User
Old   #2945
 
elite*gold: 0
Join Date: Aug 2011
Posts: 48
Received Thanks: 1
Unhappy

Quote:
Originally Posted by thndr View Post
I am pretty sure you are correct on this.

On server init you are setting up the server to have event buffs that will affect everyone who logs on.

I think normal add states can only be directed toward a player logging in and not to the server starting.

@L3y5on

Post what you had before you opened the server for your friend to help you and what you had after you opened your server for your friends help and it might be easier for us to help you pinpoint the error.

That screen with that Korean message is a port issue though and your ports look right in your .opts

But if you are now trying to route through your external IP, where you may not have been before, and those ports are not set up properly in your router that may be why you are seeing that Korean message.

They need to be set up for both inbound and outbound rules (but not 1433 unless you are remotely managing the server, then if you are you better make sure your user is stronger than "sa" and that it has stronger than a blank password.)
Hello Friend,

Excuse the delay in responding, but I formatted my computer and before I used the original files and repack comes in, only thing that changed was open the ports in the modem and Firewall, al put my internal ip where it was 127.0.01 and external ip where requested, after that they can go and gives me that error message image I posted.
L3y5on is offline  
Old   #2946
 
elite*gold: 78
Join Date: Jul 2012
Posts: 254
Received Thanks: 131
Why dosn't become an answer? Or nobody can php to help me, lol, and i have thinked this is a help thread for help all! But not for me^^
Cyborg2009 is offline  
Old   #2947
 
elite*gold: 0
Join Date: Sep 2012
Posts: 62
Received Thanks: 3
Buff Toon

Hi all

I have created a buffing toon in Horizon, I would like to add altered pieces to the buffs list but I can't get the buffs to work, I am using this command
and have tried these variations,
/run add_state(9910,0,0)
/run add_state(9910,0)
/run add_state(9910)
Thanks
Domesday Brock is offline  
Old   #2948
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
/run add_state(9910,0,0)

Don't you need a buff level and duration in this?

like (9910,10,60)

Sorry Cyborg but I myself am not a PHP coder.
ThunderNikk is offline  
Thanks
1 User
Old   #2949
 
elite*gold: 0
Join Date: Sep 2012
Posts: 62
Received Thanks: 3
Quote:
Originally Posted by thndr View Post
/run add_state(9910,0,0)
Don't you need a buff level and duration in this?
like (9910,10,60)
Sorry Cyborg but I myself am not a PHP coder.
Thanks mate, life saver once again lol, I didn't think that I needed a level value as the item has a set buff value
Domesday Brock is offline  
Old   #2950
 
elite*gold: 0
Join Date: Aug 2011
Posts: 48
Received Thanks: 1
Unhappy

Hello to all ,

Well to start I'm having some problems , I will spend here the more urgent to be solved, if they can help me .

1 - My connection error , I can put my server online trough my external fixed ip , everyone can connect , but I can not connect to localhost alert , it only happens when I put the server online , I've set everything right , open the doors correctly in my moden and firewall , even more so I can not connect on localhost , told me the port problems , most did not tell me how I can solve this problem, I already searched everywhere in the forum and google , found nothing more about it

2 - I have problems with the image of former pets , eslas not appear , or take the form of a pet soul , how do I fix this? I found a guy with the same problem and managed to fix it , however he did not comment as he did .

3 - About the skill of the soul pets when I capture one and use command to raise them , the skill stay with " ? " I then relogo and skill appear , but many others are not raised with " ? " if I put points to raise when relogo they continue it , how do I resolve this ?

4 - On the issue of placing an icon in the guild , I followed a step by step tutorial here forum , most did not work at all , I can not save the icon in the game , any solution for this?

5 - My npc teleport to teleport HV not even standing with the passport, it's not the option to teleport to HV, how can I be more resolving this problem?

6 - Had to edit the rates of taming the old pets? As the cooling time of the skill?

For now these are my errors on the server that have more urgency, appreciate everyone's help right now, pending any solution, thank you!
L3y5on is offline  
Old   #2951
 
elite*gold: 0
Join Date: Sep 2012
Posts: 62
Received Thanks: 3
Quote:
Originally Posted by thndr View Post
/run add_state(9910,0,0)
Don't you need a buff level and duration in this?
like (9910,10,60)
Sorry Cyborg but I myself am not a PHP coder.
I am trying these altered pieces

/run add_state(910164,10,60) and get Dc'd from the server
tried
/run add_state(930000,10,60) and get Dc'd from the server

I don't know if the code for the buff is different from the code of the actual piece or if the level of the buff or time is the problem
Domesday Brock is offline  
Old   #2952
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
Altered pieces are a target-able buff, I tested it and it works with a target specified.

/run add_state(9910, 10 , 600000, "CHARACTERNAME")

(This one ran for about 1.5 hours)

Changing the second number did not seem to matter much.

So in the lua for the NPC you need to pull the variable for the character name that is using the NPC and put the variable into the buff command line for the buff they choose.

EDIT: Maybe you don't need the name for lua but you do for the chat window command. I just know that is the chat command that worked for me.
ThunderNikk is offline  
Thanks
1 User
Old   #2953
 
elite*gold: 0
Join Date: Aug 2011
Posts: 48
Received Thanks: 1
Unhappy

Hello to all ,

Well to start I'm having some problems , I will spend here the more urgent to be solved, if they can help me .

1 - My connection error , I can put my server online trough my external fixed ip , everyone can connect , but I can not connect to localhost alert , it only happens when I put the server online , I've set everything right , open the doors correctly in my moden and firewall , even more so I can not connect on localhost , told me the port problems , most did not tell me how I can solve this problem, I already searched everywhere in the forum and google , found nothing more about it

2 - I have problems with the image of former pets , eslas not appear , or take the form of a pet soul , how do I fix this? I found a guy with the same problem and managed to fix it , however he did not comment as he did .

3 - About the skill of the soul pets when I capture one and use command to raise them , the skill stay with " ? " I then relogo and skill appear , but many others are not raised with " ? " if I put points to raise when relogo they continue it , how do I resolve this ?

4 - On the issue of placing an icon in the guild , I followed a step by step tutorial here forum , most did not work at all , I can not save the icon in the game , any solution for this?

5 - My npc teleport to teleport HV not even standing with the passport, it's not the option to teleport to HV, how can I be more resolving this problem?

6 - Had to edit the rates of taming the old pets? As the cooling time of the skill?

For now these are my errors on the server that have more urgency, appreciate everyone's help right now, pending any solution, thank you!
L3y5on is offline  
Old   #2954
 
elite*gold: 0
Join Date: Oct 2010
Posts: 2,557
Received Thanks: 2,412
Quote:
Originally Posted by L3y5on View Post
Hello to all ,

Well to start I'm having some problems , I will spend here the more urgent to be solved, if they can help me .

1 - My connection error , I can put my server online trough my external fixed ip , everyone can connect , but I can not connect to localhost alert , it only happens when I put the server online , I've set everything right , open the doors correctly in my moden and firewall , even more so I can not connect on localhost , told me the port problems , most did not tell me how I can solve this problem, I already searched everywhere in the forum and google , found nothing more about it

I don't help with connection issues, wait for Thndr on this.

2 - I have problems with the image of former pets , eslas not appear , or take the form of a pet soul , how do I fix this? I found a guy with the same problem and managed to fix it , however he did not comment as he did .

I don't support over 7.1, again prolly just wait for Thndr on this.

3 - About the skill of the soul pets when I capture one and use command to raise them , the skill stay with " ? " I then relogo and skill appear , but many others are not raised with " ? " if I put points to raise when relogo they continue it , how do I resolve this ?

I don't support over 7.1, again prolly just wait for Thndr on this.

4 - On the issue of placing an icon in the guild , I followed a step by step tutorial here forum , most did not work at all , I can not save the icon in the game , any solution for this?

Are you sure it's not saving or it's not showing, to verify if the icon is being uploaded you should check dbo.Guild [icon] column after your upload. If there is something like game001_332_0034 then the icon is uploading but you're having problems with displaying it. (Post if you are seeing icon in dbo.Guild and I will help you from there)

5 - My npc teleport to teleport HV not even standing with the passport, it's not the option to teleport to HV, how can I be more resolving this problem?

//item 910023 1 <--- HV Teleport Pass and furthermore if your HV NPC are stock then they are searching for buff 9004 and item id 910000, you can chance this in ETC_Functions.lua @ function is_premium() (ALL Stock HV NPC use this check to see if you have bought HV)

6 - Had to edit the rates of taming the old pets? As the cooling time of the skill?

Pretty easy, go to dbo.SkillResource of Arcadia and adjust delay_cooltime field

For now these are my errors on the server that have more urgency, appreciate everyone's help right now, pending any solution, thank you!
There ya go
ismokedrow is offline  
Thanks
1 User
Old   #2955
 
elite*gold: 0
Join Date: Aug 2011
Posts: 48
Received Thanks: 1
Unhappy

Smokdrow Thanks for the reply, I resolved some of the problems

Now I have this problem that I am trying to solve.

In the settings server.opt game, if I put all ips on localhost, and only one as an external, everyone can put on and everything works fine, however if I put all the ips in local host, and two outside as it should be, I I have this image error, how to solve this?

You must register and activate your account in order to view images.

my opt files:

Auth:

Game Server:


I appreciate the help already


L3y5on is offline  
Reply

Tags
7.4, client, rappelz



« Previous Thread | Next Thread »

Similar Threads
[Helping Topic] 24/7 Helping Services!
stucked on anything while setuping your server? post your problem here and you will get answer as fast as possible better than spamming with posts...
31 Replies - EO PServer Hosting



All times are GMT +2. The time now is 08:57.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.