Register for your free account! | Forgot your password?

Go Back   elitepvpers > Aion > Aion Hacks, Bots, Cheats & Exploits
You last visited: Today at 00:23

  • Please register to post and access all features, it's quick, easy and FREE!

 

Aion AutoIt Bot Beta [Open Source]

Reply
 
Old   #226
 
elite*gold: 0
Join Date: May 2008
Posts: 33
Received Thanks: 3
meinst du mit castzeit+daley von wegen wie lang er ncoh warten soll bis er die nächste attake machen soll ? also z.b wenn ich nur 100 eingebe macht er die nächste attake in 100 sek ... iwie unlogisch

Naja zu den Wegpunkten ... ja man müsste irgendwas machen das er nicht einfacg ne klippe runter rennt und naja .... wenn er zurück will gegen die wand rennt jeder der es sieht denk sich " JA BOT". xD
Andererseits wenn erimmer weiter tab kommt du nachher in einem ganz anderen Mobgebiet raus =)

edit://

Ist den schon was bekannt wann ie nächste version rauskommt und was diese dann kann? =)



Calcifer is offline  
Old   #227
 
elite*gold: 0
Join Date: Feb 2009
Posts: 198
Received Thanks: 5
Quote:
Originally Posted by Posthardcore View Post
Danke erstmal für die Tipps,
Leider kann ich mir das HowTo Video nicht angucken, da ich leider keine Zahlen und co. drauf erkenne. Habe das jetzt aber so eingestellt wie ich es verstanden habe.

You must register and activate your account in order to view images.

Funktioniert leider trotzdem nicht, Ich habe mir auch für den 2ten Slot ein Dolch + Schwert gekauft, führt er den Waffenwechsel automatisch durch?
Jedenfalls habe ich es nun so eingestellt...

Habe WP.TXT eingeben und auf ADD WP gedrückt, dass habe ich etwa 10 mal an verschiedenen Stellen gemacht, anschließend auf Save gedrückt. Dann auf Open WP WP.TXT eingegeben und Run Bot - Passiert leider nichts!

War noch sie mein Ding ein Bot zu Konfigurieren
Würde doch noch mal gerne auf das Problem zurückkommen,


Posthardcore is offline  
Old   #228
 
elite*gold: 0
Join Date: Oct 2009
Posts: 7
Received Thanks: 0
Ohne .txt eingeben, einfach nur Sprigg oder lvl5 oder sowas.
Denke mal der Bot ist verwirrt wenn er ne wp.txt.txt laden soll.
Und denk dran, erst die Attacken konfigurieren, dann Save drücken, dann die WPs erstellen.

Bin mal gespannt ob der Bot gleich noch läuft, Server wurden ja gerade auf x.x.x.11 geupdatet.
hlx is offline  
Old   #229
 
elite*gold: 0
Join Date: Oct 2009
Posts: 6
Received Thanks: 1
Quote:
Originally Posted by unknown661 View Post
das habe ich deshalb so gemacht da er ansonsten zu weit vom wegpunkt abkommen kann und somit leichter hängen bleiben/den wegpunkt verfehlen kann.
Vorschlag:
Die Distanz zum Mob kannst du ja auslesen.

Mobkill -> Tab -> falls distanz <5 -> dann attack sonst zurück Wegpunkt.
und dass auch nur max 2-3 mal damit er nicht zu weit abkommt.
Somit könnten auch Adds beseitigt werden.


dawn4000 is offline  
Old   #230
 
elite*gold: 0
Join Date: Oct 2008
Posts: 314
Received Thanks: 160
ja alles mit seiner zeit ;-)

beschäftige mich gerade wie schon erwähnt mit ghostwaypoints und background mode

edit: kanns sein dass der login server von aion down ist?
unknown661 is offline  
Old   #231
 
elite*gold: 0
Join Date: Oct 2009
Posts: 7
Received Thanks: 0
Na sicher, ist doch Wartung
hlx is offline  
Old   #232
 
elite*gold: 0
Join Date: Feb 2009
Posts: 198
Received Thanks: 5
edit:

So es sieht immoment so bei mir aus,
Ich starte meine Waypoints als test hatte ich 1 - 3... Ich schreibe 1 bei Open WP hin und drücke Run bot. Er dreht sich erstmal im Kreis und läuft dann zum Waypoint 1, angekommen wechselt er die Waffe und der Bot sagt Start Attack 3, 4 , 5 obwohl kein Monster dort ist und auf meinen Screen tut die Figur nichts - Sie hat ebent nur die Waffen gewechselt - Danach tut der Bot nichts mehr!
Posthardcore is offline  
Old   #233
 
elite*gold: 0
Join Date: Jan 2009
Posts: 249
Received Thanks: 501
Quote:
Originally Posted by Posthardcore View Post
Würde doch noch mal gerne auf das Problem zurückkommen,
ich seh schon anhand des bots was du falsch gemacht hast


ALSO! ... zuerst gibst du ein namen ein "wp" zb dann läufst du ina gegend rum und drückst so alle 10m nochmal den addwp knopf (optional kannst du auch auf dein numpad die plus taste drücken (musst du nicht immer ausn spiel switchen!)) DANN! und hier liegt dein fehler

gibst du wie in mein beispiel wp in das rechte einhabefeld ein
DANN DRÜCKST DU "OPEN WP" ...dann sagt er dir wieviele waypoints in deiner datei vorhanden sind dann erst RUN BOT

der plany btw hab atm extrem viel at work zu tun heißt 12 stunden tag is standart arbeite wochenende wieder bissel mehr dran
plany123 is offline  
Old   #234
 
elite*gold: 0
Join Date: Feb 2009
Posts: 198
Received Thanks: 5
Quote:
Originally Posted by plany123 View Post
ich seh schon anhand des bots was du falsch gemacht hast


ALSO! ... zuerst gibst du ein namen ein "wp" zb dann läufst du ina gegend rum und drückst so alle 10m nochmal den addwp knopf (optional kannst du auch auf dein numpad die plus taste drücken (musst du nicht immer ausn spiel switchen!)) DANN! und hier liegt dein fehler

gibst du wie in mein beispiel wp in das rechte einhabefeld ein
DANN DRÜCKST DU "OPEN WP" ...dann sagt er dir wieviele waypoints in deiner datei vorhanden sind dann erst RUN BOT

der plany btw hab atm extrem viel at work zu tun heißt 12 stunden tag is standart arbeite wochenende wieder bissel mehr dran
Ok Danke,
Das Laufproblem wäre geklärt, aber nun läuft er die Waypoints ab ohne irgendwelche Mobs anzugreifen.
Posthardcore is offline  
Old   #235
 
elite*gold: 0
Join Date: Jan 2009
Posts: 249
Received Thanks: 501
Quote:
Originally Posted by Posthardcore View Post
Ok Danke,
Das Laufproblem wäre geklärt, aber nun läuft er die Waypoints ab ohne irgendwelche Mobs anzugreifen.
hast du standart einstellungen ?! tab usw auf default gesetzt?

überprüfe mal bitte deine aion options tastenbelegung ... ich teste ob der patch was damit zutun haben könnte!

EDIT: oke der patch hatte keinerlei auswirkung auf das verhalten des bottes ... was ich mir nicht erklären kann ist das tab problem von posthardcore ... ich überlege weiter ...!
plany123 is offline  
Old   #236
 
elite*gold: 0
Join Date: Jan 2009
Posts: 249
Received Thanks: 501
Quote:
Originally Posted by dawn4000 View Post
Vorschlag:
Die Distanz zum Mob kannst du ja auslesen.

Mobkill -> Tab -> falls distanz <5 -> dann attack sonst zurück Wegpunkt.
und dass auch nur max 2-3 mal damit er nicht zu weit abkommt.
Somit könnten auch Adds beseitigt werden.
die methode ist leider zu "schwammig" wir suchen weiter nach einer guten variante aber werden deine im hinterkopf behalten
plany123 is offline  
Old   #237
 
elite*gold: 0
Join Date: Feb 2009
Posts: 198
Received Thanks: 5
Quote:
Originally Posted by plany123 View Post
hast du standart einstellungen ?! tab usw auf default gesetzt?

überprüfe mal bitte deine aion options tastenbelegung ... ich teste ob der patch was damit zutun haben könnte!

EDIT: oke der patch hatte keinerlei auswirkung auf das verhalten des bottes ... was ich mir nicht erklären kann ist das tab problem von posthardcore ... ich überlege weiter ...!
Habe ebent alle Einstellungen auf Standart gesetzt und Ich spiele im Windowsfenster, wiegesagt: Er läuft zwar die einzelnen Waypoints ab, aber killt nichts :P
Posthardcore is offline  
Old   #238
 
elite*gold: 0
Join Date: Jan 2009
Posts: 249
Received Thanks: 501
Quote:
Originally Posted by Posthardcore View Post
Habe ebent alle Einstellungen auf Standart gesetzt und Ich spiele im Windowsfenster, wiegesagt: Er läuft zwar die einzelnen Waypoints ab, aber killt nichts :P

ich glaube ich das das problem gefunden es gab ein fehler in sourcecode .. das könnte die unregelmäßigkeit bei einigen erklären ich werde gleich mal eine fixed version hochladen vorher bau ich noch den F5 stopper ein programm killen is doch nervig ^^
plany123 is offline  
Thanks
1 User
Old   #239
 
elite*gold: 0
Join Date: Jul 2008
Posts: 31
Received Thanks: 9
Was noch ganz fehlt, ist ein Methode, falls der Bot hängen bleibt, beim laufen zu einem mob nacheiner gewissen Zeitspanne den Mobwechselt oder 180 Grad Wende macht.
dabudai is offline  
Old   #240
 
elite*gold: 0
Join Date: Oct 2008
Posts: 314
Received Thanks: 160
Also ich hab Neuigkeiten zum Background Mode, gute und schlechte ;-)

Hab mich genauer erkundigt und es gibt folgendes Problem:
-Controlsend unterstützt kein {wasd down} bzw. {wasd up}

Ich habs mit der user32.dll versucht über Postmessage jedoch blockt Aion diese Inputs da es nicht als Direct Input gesehen wird.

Jetzt gibt es vorerst folgende Möglichkeiten:

-Aions Check ob es sich um DirectInput/Postmessage handelt ausschalten bzw. verändern
-einige andere Bots(closed source) laufen schon mit Background Mode. Daher könnte man diese decompilieren und versuchen was aus der der Source zu bekommen.
-warten bis wer den Source für den bg mode released^^


unknown661 is offline  
Reply



« Previous Thread | Next Thread »



All times are GMT +2. The time now is 00:23.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.