Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Shaiya > Shaiya Private Server > Shaiya PServer Development
You last visited: Today at 19:52

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



Shaiya Private Server - Instructions - English

Discussion on Shaiya Private Server - Instructions - English within the Shaiya PServer Development forum part of the Shaiya Private Server category.

Closed Thread
 
Old 03/27/2011, 20:06   #976
 
elite*gold: 0
Join Date: Oct 2010
Posts: 14
Received Thanks: 1
Quote:
Originally Posted by menio0s View Post
can any1 tell me why i have this errors
ty
Same at by me -.-
Rif4T is offline  
Old 04/04/2011, 10:51   #977
 
elite*gold: 0
Join Date: Jul 2009
Posts: 10
Received Thanks: 34
I cant start session, it just start 5 sec then pause. How to fix it?
mickosor is offline  
Old 04/07/2011, 12:42   #978
 
SrShaden's Avatar
 
elite*gold: 0
Join Date: Feb 2009
Posts: 118
Received Thanks: 429
@ menio0s & Rif4zT

Try running it as Administrator, Right click/Run as Administrator... you can also shut off the UAC witch is really annoying and causes problems...

@ mickosor

When I started making pservers I must of read these pages 50 times from first to last... back then there was only 65 pages... anyways my point is in those pages the is about 100 of your question... read buddy... but for this once I'm gonna give you a small boost... 1 of many things, it can be a server file error or one that does not match your database, make sure you are using the first page files, second thing... I must of said this 5 times in previous pages... READ YOUR LOG !
SHAIYA_SERVER/Sever/PSM_Client/bin/log
Delete all the files there then try to restart the server... when it fails go there, new log files will be created and they will contain your error. If you can't figure it out post the one with the error here.
SrShaden is offline  
Old 04/10/2011, 17:45   #979
 
elite*gold: 0
Join Date: Jul 2009
Posts: 10
Received Thanks: 34
This is my log file error
PS_DBAGENT

Quote:
2011-04-10 22:38:53 PS_DBAGENT__system log start (DBAgent01)

2011-04-10 22:39:09 DB gamedata connect error

2011-04-10 22:39:09 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:39:09 DBKillCountSave db alloc failed

2011-04-10 22:39:09 SAVE kill count ERROR

2011-04-10 22:39:09 CKeepObeliskMgr:BSave db alloc failed

2011-04-10 22:39:09 SAVE g_KeepObeliskMgr ERROR

2011-04-10 22:39:09 GuildMgrSave:BSave db alloc failed

2011-04-10 22:39:09 SAVE g_GuildMgrSave ERROR

2011-04-10 22:39:09 PS_DBAGENT__system log end (DBAgent01)


2011-04-10 22:39:09 3 1 SService::ServiceCtrlDispatcher(): service shutdown
PS_GAME

Quote:
2011-04-10 22:38:54 PS_GAME__system log start (Game01)

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/sorp1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/croco1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/croco2

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/Troll1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/Spink1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/GoldenPig

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/Sorp3

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/SorpNamed1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/SorpNamed2

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/Sorp2

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/CrocoNamed1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/CrocoNamed2

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/CrocoNamed3

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/OrcNamed1

2011-04-10 22:38:54 Loaded Behavior In Factory : data/ai/OrcNamed2

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/OrcNamed3

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/TrollNamed1

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/HellTouthNamed1

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/Deinos

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/Parridalis

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/Alcarian

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/ZinAlcaria

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/Belizabeth

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/Kirhiross

2011-04-10 22:38:55 Loaded Behavior In Factory : data/ai/CrypticOne

2011-04-10 22:39:04 <Console input> .nprotectoff

2011-04-10 22:39:04 <Console output> error cmd not found

2011-04-10 22:39:10 DB gamedef connect error

2011-04-10 22:39:10 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:39:10 Call save all waiting...

2011-04-10 22:39:10 Call save all failed dbagent disconnected(user count = 0)...

2011-04-10 22:39:10 server shutdown Connection INFO : T=000:00:00:000, NumC=0,CMin=0,CMax=0,CAvg=0.00, CAva=0,CReq=0,CCnt=0,DCCnt=0, CTimeT=000:00:00:000,CTimeAvg=000:00:00:000, RBT=0,RBS=0,RBSC=0,SBT=0,SBS=0,SBSC=0

2011-04-10 22:39:10 Save MobID=1963109

2011-04-10 22:39:10 PS_GAME__system log end (Game01)

2011-04-10 22:39:10 3 1 SService::ServiceCtrlDispatcher(): service shutdown
PS_GAMELOG
Quote:
2011-04-10 22:38:53 PS_GAMELOG__system log start (GameLog01)

2011-04-10 22:39:09 DB gamelog connect error

2011-04-10 22:39:09 init db error

2011-04-10 22:39:09 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:39:09 PS_GAMELOG__system log end (GameLog01)

2011-04-10 22:39:09 3 1 SService::ServiceCtrlDispatcher(): service shutdown
PS_LOGIN
Quote:
2011-04-10 22:38:55 PS_LOGIN__system log start (Login01)

2011-04-10 22:39:10 DB userdata connect error, id=Shaiya, pass=Shaiya123

2011-04-10 22:39:10 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:39:10 PS_LOGIN__system log end (Login01)

2011-04-10 22:39:10 3 1 SService::ServiceCtrlDispatcher(): service shutdown
PS_SESSION
Quote:
2011-04-10 22:38:53 PS_SESSION__system log start (Session)

2011-04-10 22:38:54 userlog connect failed

2011-04-10 22:38:54 initserver() failed

2011-04-10 22:38:54 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:38:54 PS_SESSION__system log end (Session)

2011-04-10 22:38:54 3 1 SService::ServiceCtrlDispatcher(): service shutdown
PS_USERLOG
Quote:
2011-04-10 22:38:53 PS_USERLOG__system log start (UserLog)

2011-04-10 22:39:11 DB userlog connect error, Server=127.0.0.1, DBName=PS_UserData, User=Shaiya, Pass=Shaiya123

2011-04-10 22:39:11 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2011-04-10 22:39:11 PS_USERLOG__system log end (UserLog)

2011-04-10 22:39:11 3 1 SService::ServiceCtrlDispatcher(): service shutdown
Pls, help me
mickosor is offline  
Old 04/10/2011, 22:49   #980
 
elite*gold: 0
Join Date: Apr 2011
Posts: 3
Received Thanks: 0
IP

ok guys server work but just for me .... when other ppl try to enter in shaiya they get an error ... i must change ip i tink can u tell me how can i do that ? plsss
versace2012 is offline  
Old 04/12/2011, 00:03   #981
 
elite*gold: 0
Join Date: Apr 2011
Posts: 2
Received Thanks: 1
@ Mikosor

In the batch folder of your Shaiya Server there is a file named config.sql... its query you need to run for the server to work try that and give me feed back if it still fails
Sr.King is offline  
Thanks
1 User
Old 04/12/2011, 13:33   #982
 
elite*gold: 0
Join Date: Jul 2009
Posts: 10
Received Thanks: 34
error again...
[IMG] Uploaded with [/IMG]
mickosor is offline  
Thanks
1 User
Old 04/13/2011, 01:38   #983
 
elite*gold: 0
Join Date: Jan 2010
Posts: 4
Received Thanks: 0
Restore Database
The system cannot find the file batch\shaiya_db_restore.
The system cannot find the file batch\config_database.bat.
Start MSTDC and set to auto.
[SC] ChangeServiceConfig SUCCESS
[SC] StartService FAILED 1056:

An instance of the service is already running.

Shaiya Services
The system cannot find the file batch\shaiya_svc_register.bat.
Agent Install
The system cannot find the file PSM_Server\PSMServer_Mgr.exe.
This will now restart Windows.
Press any key to continue . . .

When i try to open Install_Server.bat the server just has red X's so i looked at other posts and looked it said run as administrator and this is what i got.

Any ideas on what i should do? Any advice would be much appreciated(:
dbenderboy is offline  
Old 04/13/2011, 05:25   #984
 
elite*gold: 0
Join Date: Apr 2011
Posts: 1
Received Thanks: 0
im having trouble with it and it wont let me download the sql email me the whole thing and info at
trickshot18 is offline  
Old 04/13/2011, 17:08   #985
 
Seblax3's Avatar
 
elite*gold: 0
Join Date: Mar 2011
Posts: 96
Received Thanks: 50
Cool Habe ein einfacherin Trick . ;)

Es ist ganz einfach das habe ich in 10min Fertig.

Braucht höchstens 2 sachen Downloaden mehr nichts.

Habe alles.Über Skype kann ich es euch schicken dazu müsst ihr mich adden

HOFFE HABE GEHOLFEN !
Seblax3 is offline  
Old 04/15/2011, 12:46   #986
 
elite*gold: 0
Join Date: Apr 2011
Posts: 2
Received Thanks: 1
Mikisor if the error is Invalid object name "PS_UserData...blah blah... it meens your database isn't there... You need to have you files in "D:\SHAIYA_SERVER" if you are using the files from here that is...this goes for dbenderboy too...

If they are then right click database in SMSE and Attach Database then browse too "D:\SHAIYA_SERVER\Database" and add those.
Sr.King is offline  
Old 04/17/2011, 00:55   #987
 
elite*gold: 0
Join Date: Jun 2010
Posts: 5
Received Thanks: 0
hhh

When i do "Start All Server Service" it start ,, than few secs after is pause ? what i need to do ??
benoli104 is offline  
Old 04/17/2011, 16:55   #988
 
adamkoolkid23's Avatar
 
elite*gold: 0
Join Date: Jun 2009
Posts: 255
Received Thanks: 143
@dbenderboy

make sure you have the specified files in your dir. In other words check you have the batch folder and check that you have the restore_db.bat and restore_db.bat. If you dont redownload the server files.

@benoli104

Check you have linked servers in your MSSQL. To do this go to Server Objects>Linked Servers...you should have about 6 (sorry cant remember names now lol). If you dont you need to add these in. You should find an SQL script with the server files you downloaded. You can either drag and drop it into SQL or you can click New Query and copy the information in (depending on wether its in a text file or an SQL file).
adamkoolkid23 is offline  
Old 04/17/2011, 17:59   #989
 
elite*gold: 0
Join Date: Mar 2010
Posts: 7
Received Thanks: 0
start all services log

Quote:
serverlog Move PSMSERVER_AGENT__system.log__20110417_154201.log
serverlog Copy __history_PSMServer_Patch.ini
start download 127.0.0.1:40900 AgentLog
down fileall AgentLog
LogGather\20110417_173849\psm_client\main\PSM_AGEN T__system.log__20110417_154136.log
download 1 completed....
Disconnected...
start download 127.0.0.1:40900 ServerLog
down fileall ServerLog
download 1 completed....
Disconnected...
download all completed....
Its the same like above it starts an few minutes later it paused


i dont know what to do


Can it be that this failure comes cause of no remoteconection to mssql ...because if i started the server installation ther comes a failure of my remote


sry for my english i try to give my best
TakeOver82 is offline  
Old 04/18/2011, 11:19   #990
 
cirustus's Avatar
 
elite*gold: 0
Join Date: Apr 2011
Posts: 9
Received Thanks: 0
Quote:
Originally Posted by letmein1234 View Post
I am using windows 7 64 bit, disable uac, run as admin but still get this error, help please. Thanks

1> 2> 3> 4> 5> 6> 7> 8> 9> 10> 11> 12> 13> 14> 15> 16> 17> 18> 19> 20> Msg 3201,
Level 16, State 2, Server TPRZ-PC, Line 2
Cannot open backup device 'D:\PSM_Data\PS_Billing'. Operating system error
3(The system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 2
RESTORE DATABASE is terminating abnormally.
Msg 3201, Level 16, State 2, Server TPRZ-PC, Line 5
Cannot open backup device 'D:\PSM_Data\PS_GameData'. Operating system error
3(The system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 5
RESTORE DATABASE is terminating abnormally.
Msg 3201, Level 16, State 2, Server TPRZ-PC, Line 8
Cannot open backup device 'D:\PSM_Data\PS_GameLog'. Operating system error
3(The system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 8
RESTORE DATABASE is terminating abnormally.
Msg 3201, Level 16, State 2, Server TPRZ-PC, Line 11
Cannot open backup device 'D:\PSM_Data\PS_GMTool'. Operating system error 3(The
system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 11
RESTORE DATABASE is terminating abnormally.
Msg 3201, Level 16, State 2, Server TPRZ-PC, Line 14
Cannot open backup device 'D:\PSM_Data\PS_GameDefs'. Operating system error
3(The system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 14
RESTORE DATABASE is terminating abnormally.
Msg 3201, Level 16, State 2, Server TPRZ-PC, Line 17
Cannot open backup device 'D:\PSM_Data\PS_UserData'. Operating system error
3(The system cannot find the path specified.).
Msg 3013, Level 16, State 1, Server TPRZ-PC, Line 17
RESTORE DATABASE is terminating abnormally.
Press any key to continue . . .

ok i had the same problem but my work around for it was to open server management studio and login as my default loging and leave it open (minimise it) then i went to the batch folder and ran the db restore batch it worked i got my db and i just followed the sequence of batch files running them as administrator hope this helps
cirustus is offline  
Closed Thread




All times are GMT +2. The time now is 19:52.


Powered by vBulletin®
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2024 elitepvpers All Rights Reserved.