Register for your free account! | Forgot your password?

You last visited: Today at 16:44

  • Please register to post and access all features, it's quick, easy and FREE!

 

prblem with map

Reply
 
Old   #16
 
elite*gold: 0
Join Date: Apr 2012
Posts: 453
Received Thanks: 781
Actually the auth filter try to parse packet as GS packets, this why there are errors.
But this does not have any effect beside writing errors to log (the auth part works fine, the filter just pass through raw packets between the client and server)

About your invisible models, its probably a rdb issue, I don't have any custom stuff on my server and everything was ok (mobs and summon pet were displayed and the character too)



glandu2 is offline  
Old   #17
 
elite*gold: 0
Join Date: Apr 2012
Posts: 208
Received Thanks: 23
its interesting by me no error in filters. but rdbs make problems i try to use orginal rdb from 9.4 but all ids and icons are changed with them need 9.4 structure in database for test them. my 9.3/9.1 will complete not work and make crash or graphic bugs but its the right way


[GA]Sharingan is offline  
Old   #18
 
elite*gold: 65
Join Date: Sep 2015
Posts: 312
Received Thanks: 468
Quote:
Originally Posted by glandu2 View Post
Actually the auth filter try to parse packet as GS packets, this why there are errors.
But this does not have any effect beside writing errors to log (the auth part works fine, the filter just pass through raw packets between the client and server)

About your invisible models, its probably a rdb issue, I don't have any custom stuff on my server and everything was ok (mobs and summon pet were displayed and the character too)
Maybe the fact that this character existed before using the 9.4 sFrame also kills the character-display.
If I would create a new character, I guess it would be rather fluid than this one.
My pet is invisible because Astaroth's motion_id is missing in original MonsterMotionSet...
So to sum this up, 9.4 sFrame is partially nice (more Icons for soulstones, better Minimap), but the fact you need 9.4-structured-rdbs destroys the dream...
LamiaCore is offline  
Old   #19
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
Quote:
Originally Posted by LamiaCore View Post
Hmmm, okay....thanks.

Now I got some errors for you xD

Client is 9.4, Server 9.1.
Now I have some troubles with my body and some other things.


I guess it's because of the different rdbs?
Can I use the 9.1 item.rdb in any way?
Monsterresource, Monstermotionset etc should be useable without problems, but I doubt the item.rdb will be that easy too :s
To fix your items problems , just take 9.4 item and load it to your db

-

i have this problem when i login my character : " it dont change "

You must register and activate your account in order to view images.


the herlock say :

You must register and activate your account in order to view images.

can someone help to fix it plz


MohcenMaher is offline  
Old   #20
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,147
Received Thanks: 1,032
Did you change the port as mentioned here...

https://www.elitepvpers.com/forum/ra...l#post35747291
ThunderNikk is offline  
Old   #21
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
no

i also have this problem when i use glandu2 epic emu
MohcenMaher is offline  
Old   #22
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,147
Received Thanks: 1,032
I would suggest changing the auth port as suggested it sounds like the filter uses a fixed port.

You error is exactly the same as LamiaCore was experiencing and changing the port was the solution.
ThunderNikk is offline  
Old   #23
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
change it from 14500 ?

i change it .. the same problem every time
MohcenMaher is offline  
Old   #24
 
elite*gold: 0
Join Date: Apr 2012
Posts: 453
Received Thanks: 781
you need to add /auth_port:14500 to sframe command line.
The filter need a different port than 4500 because only one server can listen on a port at anytime.

If you don't use /auth_port:14500, sframe will connect directly to the GS without using the filter.

You can change "client.listen.port:14500" to another port so the filter listen on that port.
But if the GS and auth are on the same computer as the filter, then you can't use the same port.

Put "core.log.level:debug" in rzfilter-game-version.opt and you should see log line with packets name if sframe correctly use the filter.
glandu2 is offline  
Old   #25
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
ok

9.4 sframe have problems with game guard , after 5m from opening the game , it send " game hack detected" message
MohcenMaher is offline  
Old   #26
 
elite*gold: 0
Join Date: Oct 2013
Posts: 410
Received Thanks: 29
Quote:
Originally Posted by glandu2 View Post
I successfully ran the 8.3 client on current 9.4 servers. Obviously, new 9.x items were not recognized by the 8.3 client.

The downside of this man in the middle is that you won't be able to have more than 65000 players because of ports limitation, but I guess no one will ever get to this number lol

You will have the stuff in attachment.
/!\ This filter was not tested specifically with all server/client combinations and thus may fail.

You need to change the "client.gamefilter.ip:EXTERNAL_PUBLIC_IP" line in the rzfilter-auth.opt file to the IP the client need to connect on (typically your public internet IP or 127.0.0.1 if you have the client on the same PC as the server)

To start the filters, launch the start_filter_version.bat file (it start both auth and game filters, the auth filter is needed to redirect the client to the game filter).

The following configs in rzfilter-game-version.opt set the client and server version.
Code:
client.epic:0x090400
server.epic:0x090100
So here the client is set to 9.4 and the GS server to 9.1.

Some packets might be wrongly implemented, in this case errors will appear in the logs so if you have issue with weird behavior, post the logs.

For the ones who want to use large version gaps (like epic 2 client on 9.4 server), it won't work because of the big changes in the auth system around epic 8.1.
My packets structure implementation might be obscure but its here for those interrested:
thank you for shearing this ...
will it work on 7.2 GS and using client 9.4 ?
Sherock is offline  
Old   #27
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,147
Received Thanks: 1,032
Quote:
Originally Posted by MohcenMaher View Post
ok

9.4 sframe have problems with game guard , after 5m from opening the game , it send " game hack detected" message
Do you run on a Windows 10 preview version?
ThunderNikk is offline  
Old   #28
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
no .. in windows 10 enterprise
MohcenMaher is offline  
Old   #29
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,147
Received Thanks: 1,032
Could you post the version number if you don't mind.

If you do mind I will help a little bit right now...

Version 1607 Build 14965.1001 Insider Preview build has conflicts with game guard.
ThunderNikk is offline  
Old   #30
 
elite*gold: 0
Join Date: Dec 2015
Posts: 89
Received Thanks: 6
You must register and activate your account in order to view images.

this is version num


MohcenMaher is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Ostermetins Prblem...
Hey, Kann jemand einen Tut machen wie man die Oster Metins in der db einfügen kann im Client hab ich schon alles erledigt... falls ein Tut gibts...
0 Replies - Metin2 PServer - Discussions / Questions
i have prblem plz help me
i have prblem plz help me http://desmond.imageshack.us/Himg827/scaled.php?server=827&filename=59423492.jpg&res=medium
2 Replies - CO2 PServer - Discussions / Questions
prblem mit dem clienten
hi ich habe ien probem und zwar hat die 80 ninja king bei mir das icon von der sura ninja king wieso und ich wollte noch fragen ob einer ein...
1 Replies - Metin2 PServer - Discussions / Questions
warrock prblem^
es öffnet sich nichnt da kommt bei update setup immer wenn ich auf start drück error : cannot find execute file ! ps hab keine hacks und auch...
2 Replies - WarRock
My prblem with sa ( VIDEO )
Hii this is my problém again :'( please watch the video and help me YouTube - ‪Rappelz Privat Server : My Problem !!!‬‏ :mofo:
7 Replies - Rappelz



All times are GMT +1. The time now is 16:44.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.