Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 14:57

  • Please register to post and access all features, it's quick, easy and FREE!

 

[HELP]NPC Merchant doesn't work.

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Jul 2012
Posts: 37
Received Thanks: 0
[HELP]NPC Merchant doesn't work.

All of NPC merchants don't work after I changed Client and Server languages.
They don't have any items in the shop list. Does anyone know how to fix it?

Could you give me an advice, please? Thank you very much.



hiderian is offline  
Old   #2
 
elite*gold: 0
Join Date: Sep 2008
Posts: 1,570
Received Thanks: 1,154
What SFrame do you use?


c1ph3r is offline  
Old   #3
 
elite*gold: 0
Join Date: Jul 2012
Posts: 147
Received Thanks: 196
He's probably using an 8.1 client.
TheChinStrap is offline  
Old   #4
 
elite*gold: 0
Join Date: Jul 2012
Posts: 37
Received Thanks: 0
Quote:
Originally Posted by c1ph3r View Post
What SFrame do you use?
I'm using 7.4 which is same as Rappelz Shiva's Client.


hiderian is offline  
Old   #5
 
elite*gold: 0
Join Date: Jul 2012
Posts: 147
Received Thanks: 196
Quote:
Originally Posted by hiderian View Post
I'm using 7.4 which is same as Rappelz Shiva's Client.
Try this.
Attached Files
File Type: zip SFrame.zip (5.17 MB, 29 views)
TheChinStrap is offline  
Old   #6
 
elite*gold: 0
Join Date: Jul 2012
Posts: 37
Received Thanks: 0
Quote:
Originally Posted by TheChinStrap View Post
Try this.
Sorry but it's not work...

Should I change MarketResource_TB for fix it? Or need to fix something on lua files?
I can buy items at the shops but item list doen't display.
hiderian is offline  
Old   #7
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 2,999
Received Thanks: 955
What files did you update in your client resource folder to change your language, other than db_string.rdb for your language locale?

This seems to happen when something in the client resources does not match with the server database tables, I am curious myself to find out exactly what the mismatch is.

I know from your other posts that your game was working fine before you changed languages. So it should not be a sframe issue or client version issue as those were matched before the error.
ThunderNikk is online now  
Old   #8
 
elite*gold: 0
Join Date: Sep 2008
Posts: 1,570
Received Thanks: 1,154
Quote:
Originally Posted by hiderian View Post
I'm using 7.4 which is same as Rappelz Shiva's Client.
It's your own server you are playing on?

@thndr i'm pretty sure it's a nui or sframe issue
c1ph3r is offline  
Old   #9
 
elite*gold: 0
Join Date: Jul 2012
Posts: 147
Received Thanks: 196
Quote:
Originally Posted by c1ph3r View Post
It's your own server you are playing on?

@thndr i'm pretty sure it's a nui or sframe issue
I second that. I think he's using 8.1 resources (Or an 8.1 client) with a 7.4 sframe. This is the only condition under which I've seen this error.
TheChinStrap is offline  
Old   #10
 
elite*gold: 0
Join Date: Jul 2012
Posts: 37
Received Thanks: 0
Well, I am using 7.4 Client as I said before, and the server file which I'm using is "Server 7.4 with 8.1 Features" that I got from Rappelz Download Center. Then, I've fixed something on lua and tried to replaced resource files from 8.1 to the 7.4 Client.

I tried to replace all resource files from 8.1 Client for the test when I got that error.
Why I tried replaced all resource files is because don't start, if I only replaced db_string.rdb and font files. "empty string : 828" has shown.

However, even if I replace all resource files from 8.1 official US Client to 7.4 Client, there is no problem.

EDIT
All US resource files are "ASCII" but my files which replaced are "****-jis", and I found some errors when I add only db_string.rdb and fontfile.

When I do this(the following)
1. Change locale:ASCII to ****-jis and Country:US to JP--> empty string : 828
2. Keep locale:ASCII and Change Country:US to JP --> It works but all NPC don't work and no informations display on the chat area, but system language has changed.

When I replaced all resources(the following)
3. Replaced all resources(****-jis) which are from 8.1 --> The merchant error.(I said as above)

Do you know what I'm mistake and how to fix?
hiderian is offline  
Old   #11
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 2,999
Received Thanks: 955
Just a little more history on his issue guys...

ThunderNikk is online now  
Old   #12
 
elite*gold: 0
Join Date: Jul 2012
Posts: 147
Received Thanks: 196
Quote:
Originally Posted by hiderian View Post
tried to replaced resource files from 8.1 to the 7.4 Client.
Quote:
Originally Posted by TheChinStrap View Post
I think he's using 8.1 resources
What the fuck did I say?

Quote:
Originally Posted by hiderian View Post
When I do this(the following)
1. Change locale:ASCII to Shit-jis and Country:US to JP--> empty string : 828
2. Keep locale:ASCII and Change Country:US to JP --> It works but all NPC don't work and no informations display on the chat area, but system language has changed.

When I replaced all resources(the following)
3. Replaced all resources(Shit-jis) which are from 8.1 --> The merchant error.(I said as above)

Do you know what I'm mistake and how to fix?
I told you, the 8.1 client resources will not work with the 7.4 sframe! Get a 7.4 client, with no 8.1 resources, and use Ciph3r's 8.1 client resource or, if you need another language, dump the stuff from another client. Jesus fucking christ, all the work has already been done for you!

I'm done. I'm out. Helping retards, as it seems, is not a healthy hobby for me.
TheChinStrap is offline  
Old   #13
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 2,999
Received Thanks: 955
Yet there has to be certain 8.1 resources which cause it.

I have the same set up and I have run into it myself before and started over with my client build to fix it, but it has to be easier than that.

I have still loaded 8.1 resources back into my client...

db_string(ascii).rbd, for US item names and to fix some empty string errors.

New pets, db_monster(ascii).rdb, db_creature(ascii).rdb, db_skilltree(ascii).rdb, db_skill(ascii).rdb, db_tenacity(ascii).rdb, db_monstermotionset(ascii).rdb, db_effectresource(ascii).rdb, 8.1 PET .COB/.NX3/.DDS/.NAF

Since the cards were already in the 7.4-8.1 DB I skipped db_item(ascii).rdb and that is dumped directly from my DB with a few of my own edits.

So maybe the issue just lies in the 8.1 db_item(ascii).rdb and db_marketresource(ascii).rdb

In the case of the OP try replacing the 8.1 db_item(****-jis).rdb and db_marketresource(****-jis).rdb with the 7.4 file db_marketresource(****-jis).rdb

In order to keep 8.1 content you should try dumping the 7.4 dbo.itemresource directly from your data base.
ThunderNikk is online now  
Thanks
1 User
Old   #14
 
elite*gold: 0
Join Date: Jul 2012
Posts: 37
Received Thanks: 0
Quote:
Originally Posted by TheChinStrap View Post
What the fuck did I say?



I told you, the 8.1 client resources will not work with the 7.4 sframe! Get a 7.4 client, with no 8.1 resources, and use Ciph3r's 8.1 client resource or, if you need another language, dump the stuff from another client. Jesus fucking christ, all the work has already been done for you!

I'm done. I'm out. Helping retards, as it seems, is not a healthy hobby for me.
I know what do I have to. First, to be honest, I have replaced only two of db_string(shift-jis).rdb(remaned to "!PWS)3rDAd3O'`dU+O}deN") and fontfile (remaned with hasher) from 7.4 to 7.4 US resource folder with 7.4 SFrame.exe which I'm using currently in order to change language, but it doesn't start with "empty string : 828".

Therefore, I just tried to replaced all 8.1 resource to 7.4 after the starting error displayed. Then it works actually but the merchant doesn't work.

It because resource and client don't match as you said.

At the time, I believe that I can use 8.1 resource with 7.4 client but now I understood so I will stop to try that way anyway.

Thank you for your help.

Quote:
Originally Posted by thndr View Post
Yet there has to be certain 8.1 resources which cause it.

I have the same set up and I have run into it myself before and started over with my client build to fix it, but it has to be easier than that.

I have still loaded 8.1 resources back into my client...

db_string(ascii).rbd, for US item names and to fix some empty string errors.

New pets, db_monster(ascii).rdb, db_creature(ascii).rdb, db_skilltree(ascii).rdb, db_skill(ascii).rdb, db_tenacity(ascii).rdb, db_monstermotionset(ascii).rdb, db_effectresource(ascii).rdb, 8.1 PET .COB/.NX3/.DDS/.NAF

Since the cards were already in the 7.4-8.1 DB I skipped db_item(ascii).rdb and that is dumped directly from my DB with a few of my own edits.

So maybe the issue just lies in the 8.1 db_item(ascii).rdb and db_marketresource(ascii).rdb

In the case of the OP try replacing the 8.1 db_item(Shit-jis).rdb and db_marketresource(Shit-jis).rdb with the 7.4 file db_marketresource(Shit-jis).rdb

In order to keep 8.1 content you should try dumping the 7.4 dbo.itemresource directly from your data base.
I'm also using 8.1 items and pets with 8.1 resources with 7.4 Client. In fact, I want to try replacing db_marketresource(Shit-jis).rdb from 7.4 as soon as possible but I don't have it right now... So I will try it later!!

Thank you for your help, anyway.

For all.
Finally, I solved the problem!! I appreciate your help very much


hiderian is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
[Help] KTS merchant dont work
hello i have added KTS merchant's to my server and when i click on merchant and click Use Shop nothing happens. any idea what could be wrong ? ...
3 Replies - Rappelz
DB bot doesn't work?
Hello guys.. everything was going great till yesterday morning :S the dbbot doesnt work for me i think.. when i log in the bot doesnt recognize my...
0 Replies - SRO PServer - Discussions / Questions
rPE doesn't work !! help me T_T
hi everybody !! i have a problem when using rPE. I can open the game with rPE, but when i click Start, it didnt capture any packets, everything is...
1 Replies - RO Guides & Templates
So why doesn't this work?
Ok, I dunno if this has been done before cuz I didn't find it on search. I edited shop.dat so that the pharmacist would sell dbs instead of...
4 Replies - CO2 Main - Discussions / Questions



All times are GMT +2. The time now is 14:57.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.