Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 06:32

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Help Thread] Please post your questions here.

Reply
 
Old   #5776
 
elite*gold: 0
Join Date: Nov 2011
Posts: 19
Received Thanks: 5
All My heros have: Traval Pass to Hidden village
It also tps my hero away from the starting area. I went though the files and found on_first_login.lua
And commented out the part of the code that said to TP to the city. But where is the default scripts.
and default settings. I really dont want to have to mess these scripts.

How to turn this off?
I also start with devas blessing item. Where are these settings? I would prefer it be just like the real game. not some crazy settings.



rover2341 is offline  
Old   #5777
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
The buffs are in the server init lua. They are a world buff when the server is started that you can comment out or just reduce the level of.

The devas blessing thing is probably in on_first_login.

Travel pass could be in on_log_in or in etc functions if they made it permanent. Not sure I always leave travel pass active on characters.

I see in the other topic you may have already fixed your start point issue.


ThunderNikk is offline  
Old   #5778
 
elite*gold: 0
Join Date: Feb 2014
Posts: 28
Received Thanks: 0
i neeb npc a great npc
thewitcher007 is offline  
Old   #5779
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
Quote:
Originally Posted by thewitcher007 View Post
i neeb npc a great npc
There used to be an old thread around about creating custom NPCs where we would direct people to go in order for them to learn about creating custom NPCs but I can't seem to find it any more.

Seems the forum got pruned.

Epic 7.3 release came with an NPC created by Stars Online.

I still use it although I have made a lot of my own edits to the original script in order to add the newer epic items.

Maybe you can start there.


ThunderNikk is offline  
Old   #5780
 
elite*gold: 0
Join Date: May 2013
Posts: 129
Received Thanks: 12
anyone can u help me about this ?


Quote:
Originally Posted by thund22222 View Post
have a question about modifying permissions in v9.1 and i did a test on permission 80

Then i empty AllowedCommandsForPermission in both telecaster and arcadia and still the permissions work?!

I try to customize new permission again but the same problem!

Also if you give char permissions 101+ the char can't join any team or sit .
thund22222 is offline  
Old   #5781
 
elite*gold: 0
Join Date: Jul 2016
Posts: 3
Received Thanks: 2
do epic5 files still exist? checked the downloadcenter but the link is dead
klopepin is offline  
Old   #5782
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
Quote:
Originally Posted by klopepin View Post
do epic5 files still exist? checked the downloadcenter but the link is dead
I have them buried away somewhere on an external drive, if I can find time to upload them I will post a link if someone does not already have them uploaded and beats me to it.
ThunderNikk is offline  
Thanks
1 User
Old   #5783
 
elite*gold: 0
Join Date: Jul 2013
Posts: 18
Received Thanks: 1
Alright so.. i've made a working server, i tested it on my secondary computer and it works fine, i can log in and stuff. but when i try to enter Rappelz from my main computer, where the server runs on, using the exact same files that i use to enter the game from my secondary computer, the game won't open.
i run Start.bat, it launches RappelzCmdLauncher.exe and nothing else happens.
.bat command:
keep in mind that on the second computer it works with the same command and the same files.
Any clue on what could be wrong?
TheSonicIQ is offline  
Old   #5784
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
Quote:
Originally Posted by TheSonicIQ View Post
Alright so.. i've made a working server, i tested it on my secondary computer and it works fine, i can log in and stuff. but when i try to enter Rappelz from my main computer, where the server runs on, using the exact same files that i use to enter the game from my secondary computer, the game won't open.
i run Start.bat, it launches RappelzCmdLauncher.exe and nothing else happens.
.bat command:
keep in mind that on the second computer it works with the same command and the same files.
Any clue on what could be wrong?
127.0.0.1 will only work on the computer that is running the server. It is a local host loopback address that reverts all traffic back to the same computer.

So if you are using the same .bat file on two computers I think you must have it backwards.

The one that should be working is the PC that is running the servers and the one that isnt working would need to be routed to the computers LAN address.
ThunderNikk is offline  
Old   #5785
 
elite*gold: 0
Join Date: Jul 2013
Posts: 18
Received Thanks: 1
No no no, I didn't mean i can't login into the actual server after opening the game, I meant that i can't open the actual game (i changed the ip here for security reasons). the .bat file runs RappelzCMD.exe and it doesn't seem to run sframe.exe next.
So what happens is i launch the .bat file -> it launches RappelzCMD.exe -> nothing else happens next.
While on my other computer,I launch it with the same files and code and it works fine and i can login and play.


EDIT:

I'm using Windows 8.1 on the computer with the issue and Windows 10 on the other one
TheSonicIQ is offline  
Old   #5786
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
So you want us to troubleshoot why sframe does not seem to run on your windows 8.1 computer for you?

Have you tried the basics yet so we don't go down the same path more than once.

Running as admin?

Conflicts with antivirus software?

Conflicts with other software?

Start the game after performing a clean start?

90% of the time sframe or game guard conflicts with your antivirus software and it has been particularly crappy about AVG lately if you do not set the correct exceptions.
ThunderNikk is offline  
Old   #5787
 
elite*gold: 0
Join Date: Jul 2013
Posts: 18
Received Thanks: 1
I've tried everything you listed above, yet nothing seemed to help..
I've also tried using different clients and different SFrame's.

Most of the Private Server clients i used had the same issue as i have now, while some other clients fixed the issue BUT a new issue had accured related to the Resources:
TheSonicIQ is offline  
Old   #5788
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,058
Received Thanks: 987
That happens when your sframe or client does not match the server file version.

The latest release here is 9.1 and uses a 9.1 client you can not use a newer client without repairing the resources of the client.
ThunderNikk is offline  
Thanks
1 User
Old   #5789
 
elite*gold: 0
Join Date: Jul 2013
Posts: 18
Received Thanks: 1
Ah.. okay. figured it out eventually Thanks!
TheSonicIQ is offline  
Old   #5790
 
elite*gold: 0
Join Date: Jul 2016
Posts: 2
Received Thanks: 0
Looking for older serverfiles aswell, preferably epic 6 files, if someone wants to share them, hit me up, would be great.


Nerf this! is offline  
Reply

Tags
7.4, client, rappelz



« Previous Thread | Next Thread »

Similar Threads
[Helping Topic] 24/7 Helping Services!
stucked on anything while setuping your server? post your problem here and you will get answer as fast as possible better than spamming with posts...
31 Replies - EO PServer Hosting



All times are GMT +2. The time now is 06:32.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.