secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using passwor
Discussion on secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using passwor within the Metin2 Private Server forum part of the Metin2 category.
secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using passwor
Quote:
YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsSuccess PLAYER
mysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsSuccess ACCOUNT
mysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsSuccess COMMON
mysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'm2user'@'localhost' (using password: YES)
failed, retrying in 5 secondsSuccess HOTBACKUP
So sieht bei mir CONFIG aus und alle andere auch so(auth, channel1, db, game99) benutze daroo SF
ja, mysql--tabelle--user alles da... mt2 als localhost
es sein könnte ich auf mein root was falsch gemacht habe...
ich hab von mein instalierte Hamachi server complette "game" in "usr/home" ordner hochgeladen und in "mysql" ordners: player, log, hotbackup, common, account..
einfach so mit Filezilla aus hamachi raus in root rein, ist richtig so ???
Quote:
Originally Posted by .Nizami
in deinem letzten thread sagte ich auch
PLAYER_SQL: localhost mt2 daroo@# player
COMMON_SQL: localhost mt2 daroo@# common
LOG_SQL: localhost mt2 daroo@# log
zu
PLAYER_SQL: localhost mt2user daroo@# player
COMMON_SQL: localhost mt2user daroo@# common
LOG_SQL: localhost mt2user daroo@# log
da der "NUTZER" bzw. "USER" FALSCH ist
guck, so wie ich jetzt verstehe soll das etwa so aussehen:
PLAYER_SQL: localhost m2mt2 daroo@# player
COMMON_SQL: localhost m2mt2 daroo@# common
LOG_SQL: localhost m2mt2 daroo@# log
weil so
PLAYER_SQL: localhost mt2user daroo@# player
COMMON_SQL: localhost mt2user daroo@# common
LOG_SQL: localhost mt2user daroo@# log
ich scho versucht habe...
Quote:
Originally Posted by Mischa.png
User ist eingetragen?
Guck mal bei navicat
mysql User eingetragen, und PW ist von mysql (genua wie ich mich einlogge bei Navikat)
mt2user mt2!@# (*1DA96A411E1563FF227A913C4E3161211DD564F4) ich hab jetzt so gemacht wie installiert.....
gleiche fehler meldung
Quote:
mysql_real_connect: Access danied for user 'mt2user'@'localhost' (using password "YES")
cannot open direct sql connection to host: localhost user: mt2user db: common cannot start server while no common sql connected
mysql_real_connect: Access danied for user 'mt2user'@'localhost' (using password "YES")
Nein, der Fehler kommt daher, dass etwas mit der Datei forkedmapindex.txt nicht stimmt (vlt. nicht vorhanden oder fehlerhaft).
Der Pfad zu der Datei ist locale/DEINE_LOCALE/forkedmapindex.txt.
Bei der Standard-Struktur wäre es also /usr/home/game/share/locale/DEINE_LOCALE/forkedmapindex.txt.
#/bin/sh
ORIGCHANNELS=$(cat ./daroo/channels.txt)
if [ "$1" != '' ] && [ "$1" = "quickstart" ] && [ "$2" != '' ];then
if [ "$2" -le $ORIGCHANNELS ];then
CHANNELS="$2"
else
exit
fi
else
echo -e "\033[31m Wie viele Channels möchtest du starten?\033[0m"
read CHANNELS
fi
if [ "$CHANNELS" -gt $ORIGCHANNELS ];then
echo -e "\033[31m Zu viele Channels(maximal $ORIGCHANNELS !)\033[0m"
exit
fi
echo -e "\033[31m Starte DB-Server...\033[0m"
cd /usr/home/game/db
./db &
cd ..
echo -e "\033[31m Starte Auth-Server...\033[0m"
cd /usr/home/game/auth
./auth &
cd ..
while [ $CHANNELS -ge 1 ]
do
echo -e "\033[31m Starte Channel "$CHANNELS" ...\033[0m"
sleep 1
cd /usr/home/game/channel1
./game &
sleep 1
cd ..
CHANNELS=$(( $CHANNELS-1 ))
sleep 1
done
echo -e "\033[31m Starte Channel 99...\033[0m"
cd /usr/home/game/game99
./game &
cd ..
sleep 4
echo -e "\033[31m Server erfolgreich gestartet!\033[0m"
kann hier fehler liegen ?
Quote:
Originally Posted by DaJuBi
Nein, der Fehler kommt daher, dass etwas mit der Datei forkedmapindex.txt nicht stimmt (vlt. nicht vorhanden oder fehlerhaft).
Der Pfad zu der Datei ist locale/DEINE_LOCALE/forkedmapindex.txt.
Bei der Standard-Struktur wäre es also /usr/home/game/share/locale/DEINE_LOCALE/forkedmapindex.txt.
MfG
so sieht bei mir forkedmapindex.txt. aus:was soll hier ändern ?
SYSERR: Aug 19 17:51:31 :: Start: TABLE_POSTFIX not configured use default
SYSERR: Aug 19 17:51:32 :: DirectQuery: AsyncSQL: DirectQuery : mysql_query error: Column 'name' in field list is ambiguous
query: SELECT pid, name, date FROM monarch_candidacy a, player b where a.pid = b.id
SYSERR: Aug 19 17:51:32 :: socket_bind: bind: Address already in use
access denied for user m2user - Rootserver 07/08/2012 - Metin2 Private Server - 13 Replies Haii Leute...
ich habe die 1678er Files von Daroo und habe diese jetzt auf einen Root installiert...
Soweit läuft auch alles, habe MySQL installiert und wollte dann den User für die Files anlegen, sprich m2user...
So habe dann den Befehl folgendermaßen benutzt:
mysql -uroot -p {ENTER}
grant all on *.* to m2user@"localhost" identified by "m2pass@";
Access denied for user 'localuser'@'localhost' 03/06/2012 - Metin2 Private Server - 9 Replies http://s1.directupload.net/images/120305/9w4ew3nw. png
So sieht das aus.
Ich benutze die Files von .Kay
Ftp geht, jedoch nicht Navicat sprich Datenbank
Ich habe ganz MySQL neu aufgesetzt und dann die Files nochmal drüberinstalliert und immernoch der gleiche Fehler.
Egal was ich mache, es geht nicht. Ich kann das PW vom MySQL auch nicht ändern, da der gleiche Fehler kommt.
Rechte kann ich auch nicht geben, same ^^