Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Archlord
You last visited: Today at 12:32

  • Please register to post and access all features, it's quick, easy and FREE!


WebzenBot

Reply
 
Old 11/07/2009, 23:37   #151
 
elite*gold: 20
Join Date: Feb 2009
Posts: 723
Received Thanks: 264
Quote:
Originally Posted by Newbb View Post
hey infin, im having a problem, i tried to run the bot(set up like the readme described),

but when i am in game and press home, it justn't do annything, even when i alt tab and click pause script off in the toolbar..

what am i doing wrong?
do i need to place the gate.dll somewhere?
had this problem too, but i could get it to work sometimes if i played around with the view a little bit, then sometimes it wouldnt.

First off i thought it was cus it was a lvl 1 toon and there was no buffs etc (but that shouldnt matter as none were ticked) and only the auto attack was in bar 3 slot 1 (which was ticked)



Faintedcombat is offline  
Old 11/08/2009, 02:27   #152
 
elite*gold: 0
Join Date: Jun 2009
Posts: 648
Received Thanks: 230
Glad to see your playing al Fainted. I hope you play on brumhart ( where I play )


Shadow Krunx is offline  
Old 11/08/2009, 03:56   #153
 
elite*gold: 0
Join Date: Oct 2007
Posts: 431
Received Thanks: 1,572
Quote:
Originally Posted by InfinityBoT View Post
regarding the pixel get color function and my reply to it..

i booted up my 2nd pc and tested the game and function (your test script)
on the pc and it worked fully

attachched is the results of the test
i hope this helped
Ok...i think i havent explained well what i am talking about ... i will try to be more specific... First of all you used the code i gave you for a normal window ,not on a running Archlord window... the point is to use it on the Archlord window. I forgot to mention that autoit has also an inside tool(Au3Info.exe) to pick coordinates and colors from whatever window you want.
That tool uses the Getpixel function.If that tool works that means you can get pixels, if you put your mouse on one place and returns 0x000000 it means that you cant get colors... I uploaded a picture to see exactly what i mean...
Use that tool on a running Archlord window(not fullsreen) and see what it returns... I tested it on vista and xp... same result 0x000000... Also any message box that i made and gave coordinates from inside the Archlord window returns "0"... So my point is , please check it again or the 3 pcs on which i tested have big problems :P .
I am waiting for your feedback
Greez
Attached Images
File Type: jpg autoit info tool.jpg (246.5 KB, 29 views)
avati is offline  
Old 11/08/2009, 12:53   #154
 
elite*gold: 0
Join Date: Dec 2007
Posts: 44
Received Thanks: 4
I have to say that the death detection is not working for me, im triyng with low textures and graphics in 1024/768 and nothing... i tried in windowed mode too and... nothing, its only for feedback im not complaining, really i think that is a good work and a good bot.
Thank you for your time and cya.


TSG is offline  
Old 11/08/2009, 13:12   #155
 
elite*gold: 0
Join Date: Jan 2009
Posts: 72
Received Thanks: 7
i have trx bot for collecting and work very fine.. kill mob (low lvl ) collect and go next mob
but i try for xp buff work fine, but attack make 3 4 5 wait a lot 3 4 5 wait a lot
is very slow xp so
aiaalm is offline  
Old 11/08/2009, 21:32   #156
 
elite*gold: 0
Join Date: Aug 2009
Posts: 1
Received Thanks: 0
First and foremost I want to thank you for making this bot and making it public, i've been using it now since you released it and its working great for a work in progress, and ransacking is an easy workaround for now until you get death detection working perfectly. The only problems i've had so far is nothing botwise, being trees pulling the view down, and pk'rs killing my bot. Good work on the bot and hope to see great progress from you as we have so far, and thanks again.
Relyk is offline  
Old 11/08/2009, 21:42   #157
 
elite*gold: 0
Join Date: Apr 2009
Posts: 279
Received Thanks: 214
Quote:
Originally Posted by Newbb View Post
hey infin, im having a problem, i tried to run the bot(set up like the readme described),

but when i am in game and press home, it justn't do annything, even when i alt tab and click pause script off in the toolbar..

what am i doing wrong?
do i need to place the gate.dll somewhere?
the Dll must be placed in the same location of the bot.exe for it to work.. regarding the start problems i am confused however i will look into the script and try and fix it the more infomation on the matter the better i can fix it
thankyou


Quote:
Originally Posted by Faintedcombat View Post
had this problem too, but i could get it to work sometimes if i played around with the view a little bit, then sometimes it wouldnt.

First off i thought it was cus it was a lvl 1 toon and there was no buffs etc (but that shouldnt matter as none were ticked) and only the auto attack was in bar 3 slot 1 (which was ticked)
hmm ..
again il have a little look around see if i can find a mess in the code

Quote:
Originally Posted by avati View Post
Ok...i think i havent explained well what i am talking about ... i will try to be more specific... First of all you used the code i gave you for a normal window ,not on a running Archlord window... the point is to use it on the Archlord window. I forgot to mention that autoit has also an inside tool(Au3Info.exe) to pick coordinates and colors from whatever window you want.
That tool uses the Getpixel function.If that tool works that means you can get pixels, if you put your mouse on one place and returns 0x000000 it means that you cant get colors... I uploaded a picture to see exactly what i mean...
Use that tool on a running Archlord window(not fullsreen) and see what it returns... I tested it on vista and xp... same result 0x000000... Also any message box that i made and gave coordinates from inside the Archlord window returns "0"... So my point is , please check it again or the 3 pcs on which i tested have big problems :P .
I am waiting for your feedback
Greez
thankyou for the eedback. and i understand where you came from with the au3info tool however all can beforgotten since i have a new dll toy to play with that has the get pixel bypass working so i will pause work on the 4th bag while i impliment the new dll ect and function calls
thankyou for the feedback and patience
Quote:
Originally Posted by TSG View Post
I have to say that the death detection is not working for me, im triyng with low textures and graphics in 1024/768 and nothing... i tried in windowed mode too and... nothing, its only for feedback im not complaining, really i think that is a good work and a good bot.
Thank you for your time and cya.
ok with the new Dll it should fix the get pixel error look out for the next update later tonight
Quote:
Originally Posted by Relyk View Post
First and foremost I want to thank you for making this bot and making it public, i've been using it now since you released it and its working great for a work in progress, and ransacking is an easy workaround for now until you get death detection working perfectly. The only problems i've had so far is nothing botwise, being trees pulling the view down, and pk'rs killing my bot. Good work on the bot and hope to see great progress from you as we have so far, and thanks again.
thankyou for the reply regarding tree's and pkers it is a awkuard subject since they are random. however.. i will try make a function for moving if no mob is selected .. if you have another idea how to fix this please post and i will try my hardest to get it to work..
regarding pkers.. it is hard to make a bot pk proof.. however.. i wioll be making a option that revives you (rev orb) if you die weather it be pk or mob death however it will be in the future updates .


Coming Later tonight Get pixel fix

thankyou
infB
InfinityBoT is offline  
Thanks
1 User
Old 11/08/2009, 22:01   #158
 
elite*gold: 20
Join Date: Oct 2008
Posts: 2,384
Received Thanks: 371
Quote:
Originally Posted by InfinityBoT View Post
the Dll must be placed in the same location of the bot.exe for it to work.. regarding the start problems i am confused however i will look into the script and try and fix it the more infomation on the matter the better i can fix it
thankyou
well, i have both places on desktop in a map.
Well, i cant give u more info, all i can do i make a screenshot of the set-up and in game, or i can make a movie with my phone, so u see what i do.
Newbb is offline  
Old 11/08/2009, 22:39   #159
 
elite*gold: 0
Join Date: Oct 2007
Posts: 431
Received Thanks: 1,572
InfinityBOT, the new dll now works ... tested ... everything ok
If you need help tell me ...
avati is offline  
Old 11/09/2009, 00:26   #160
 
elite*gold: 0
Join Date: Apr 2009
Posts: 279
Received Thanks: 214
ver 0.0.2.7

NEDS TESTING.. hopefully pixel get fix
InfinityBoT is offline  
Thanks
2 Users
Old 11/09/2009, 00:46   #161
 
elite*gold: 0
Join Date: Jan 2008
Posts: 446
Received Thanks: 31
i just tested 2.7 and mob death worked for me.
iamabot is offline  
Old 11/09/2009, 00:49   #162
 
elite*gold: 0
Join Date: Apr 2009
Posts: 279
Received Thanks: 214
ok gonna get to work with the 4th bag ect ect
InfinityBoT is offline  
Old 11/09/2009, 01:07   #163
 
elite*gold: 0
Join Date: Jan 2009
Posts: 72
Received Thanks: 7
death mod recognition work fine for me.
i put only 3 attack. bot lauch 3,4,5 but after wait 10 sec for launch attack again is normal?
aiaalm is offline  
Old 11/09/2009, 01:09   #164
 
elite*gold: 0
Join Date: Apr 2009
Posts: 279
Received Thanks: 214
10 second wait .. is this after the mob is dead ?
InfinityBoT is offline  
Old 11/09/2009, 01:35   #165
 
elite*gold: 0
Join Date: Jan 2009
Posts: 72
Received Thanks: 7
no cast 3,4,5 mob is at 30% life, and bot wait 10 sec.
but dunno if im alone with this problem or if is same for all


aiaalm is offline  
Reply



« Another Bot.. | tuto how to make blode empty »



All times are GMT +1. The time now is 12:32.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.