Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 19:57

  • Please register to post and access all features, it's quick, easy and FREE!

 

Error when trying to make NON HAMACHI Server

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Jul 2011
Posts: 16
Received Thanks: 0
Error when trying to make NON HAMACHI Server

Hey guys,

I tried everything to make my server public, but it just seems to not work, I always get "Cannot connect to login server" when trying to connect.

I followed this guide:

First, I made a DynDNS adress "rappelzserver.dyndns.info, which covers my IP which is 188.22.54.21. Then I forwarded these ports: 8129, 8093, 3724, 3727, 80, both: TCP and UDP. (These ports are forwarded for sure)

After that, I went to this path C:/windows/system32/drivers/etc/hosts and added this line to the "hosts" file: 188.22.54.21 rappelzserver.dyndns.info

Lastly, I went into the game_bin folder, and edited the GameServer.opt like this:

Quote:
S app.name:game001
S auth.server_idx:1
S auth.server_name:Server Name
S io.port:8129
S io.ip_address:rappelzserver.dyndns.info
T game.use_login_logout_debug:1
T game.max_level:170
T game.use_auto_trap:0
T game.no_skill_cooltime:1
S log.working:0
S game.item_drop_rate: 50
S game.exp_rate: 150
I did not edit the Authserver.opt:
Quote:
S db.auth.server:127.0.0.1
S db.auth.name:Auth
S db.auth.account:sa
S db.auth._password:
S app.name:TestServer
S log.ip:127.0.0.1
S db.auth.port:1433
N db.auth.use_webauth:0
N db.auth.use_md5:1
N db.auth.debug_md5:1
N db.auth.md5_key:2011
However, I'm still getting cannot connect to the game server, when trying to connect from the computer running the server, and with the computer which is testing if the server is really public.

I would really be grateful, if anyone could notice what I've done wrong. :/

Edit: I used this .bat to connect to the server, maybe that's the problem? (dunno)
Quote:
Start SFrame.exe /auth_ip:rappelzserver.dyndns.info /locale:ASCII /country:US /cash /commercial_shop



xIME1st is offline  
Old   #2
 
elite*gold: 0
Join Date: Jun 2011
Posts: 669
Received Thanks: 309
Hm, weird, I just checked the guide, it seems like you followed it correctly. Are you sure the ports are forwarded?


s0ul37 is online now  
Old   #3
 
elite*gold: 0
Join Date: Jul 2011
Posts: 16
Received Thanks: 0
Quote:
Originally Posted by s0ul37 View Post
Hm, weird, I just checked the guide, it seems like you followed it correctly. Are you sure the ports are forwarded?
Yeh, all ports are forwarded for sure. That's why I do not get the problem. I'm not sure but maybe I've to use an other port in the GameServer.opt, and/or edit the Authserver.opt? If yes, I do not know what I've to change there. Anyone knows a solution, please ?
xIME1st is offline  
Old   #4
 
elite*gold: 0
Join Date: Dec 2010
Posts: 257
Received Thanks: 14
i have the same issue if you find a fix message me =D


piratehat2 is offline  
Old   #5
 
elite*gold: 0
Join Date: Jul 2011
Posts: 31
Received Thanks: 1
#1 this is for woW lol which you need to go find the ports Rappelz Uses as they are not the same even if works your hostfile should be

127.0.0.1 & DNS
DNS Name
IP+DNS Name atleast how it should be don't forget the part so it doesent try to connect to Gala
Tiffany87 is offline  
Thanks
1 User
Old   #6
 
elite*gold: 0
Join Date: Jul 2011
Posts: 16
Received Thanks: 0
Quote:
Originally Posted by Tiffany87 View Post
#1 this is for woW lol which you need to go find the ports Rappelz Uses as they are not the same even if works your hostfile should be

127.0.0.1 & DNS
DNS Name
IP+DNS Name atleast how it should be don't forget the part so it doesent try to connect to Gala
Oh, this would explain the whole thing. Thanks. EDIT: Could anyone tell me which ports I have to forward?
xIME1st is offline  
Old   #7
 
elite*gold: 0
Join Date: Dec 2010
Posts: 257
Received Thanks: 14
Quote:
Originally Posted by wisp66
dedicated? ill be nice and let the cat out of the bag... since 6.1 is coming out and say all you need to do is port forward these ports
1433
80
4514
3516
4500
4518
4080
make sure all is set to tcp not tcp & udp
then go here use this ip as your io.ip_address

also disable windows firewall *if u have a router it has a built in firewall so winfirewall isnt really 100% needed* or add exceptions for these ports,and gameserver.exe,auth.exe

problem solved
now you dont need hamachi and can use your actual wan ip to allow connections
same as hamachi tho only thing u change is io.ip_address:
rest stay 127.0.0.1
the extra ports if u noticed on that are mostly cashshop which isnt added but its for future installments if the ports we use are a reflect of galanets ports. so just add them and your preset
there you go its on page 33 of current dev status
piratehat2 is offline  
Old   #8
 
elite*gold: 0
Join Date: Dec 2010
Posts: 257
Received Thanks: 14
Quote:
Originally Posted by Tiffany87 View Post

127.0.0.1 & DNS
DNS Name
IP+DNS Name atleast how it should be don't forget the part so it doesent try to connect to Gala
thanks for the help but i dont understand this here
piratehat2 is offline  
Old   #9
 
elite*gold: 0
Join Date: Jun 2011
Posts: 669
Received Thanks: 309
Quote:
Originally Posted by piratehat2 View Post
there you go its on page 33 of current dev status
Would you mind if I tell you, that I LOVE YOU. It worked, thanks mate.
s0ul37 is online now  
Old   #10
 
elite*gold: 0
Join Date: Dec 2010
Posts: 257
Received Thanks: 14
Quote:
Originally Posted by s0ul37 View Post
Would you mind if I tell you, that I LOVE YOU. It worked, thanks mate.
hugz n kisses [full of ****] also can you help me with that part the person i quoted above?
piratehat2 is offline  
Old   #11
 
elite*gold: 0
Join Date: Jul 2011
Posts: 16
Received Thanks: 0
Thanks, problem were wrong ports, but now I can connect to login server, but when selecting server I get a weird symbol text error.

Anyone knows why?
You must register and activate your account in order to view images.

My GameServer.opt:
Quote:
S app.name:game001
S auth.server_idx:1
S auth.server_name:Server Name
S db.game.ip:rappelzserver.dyndns.info
S db.c._password:
S db.c.account:sa
S db.c.name:Arcadia
S db.c.server:127.0.0.1
S db.user._password:
S db.user.account:sa
S db.user.name:Telecaster
S db.user.server:127.0.0.1
S io.port:4514
S io.ip_address:rappelzserver.dyndns.info
S game.server_screenshot_url:
S log.working:0
S game.exp_rate:150
S game.item_drop_rate:50
S game.gold_drop_rate:10
S game.chaos_drop_rate:10
T game.use_login_logout_debug:0
T game.max_level:170
T game.use_auto_trap:0
T game.cash_usable_server:0
T game.no_collision_check:1
T game.no_skill_cooltime:0
xIME1st is offline  
Old   #12
 
elite*gold: 0
Join Date: Jun 2011
Posts: 669
Received Thanks: 309
Quote:
Originally Posted by piratehat2 View Post
thanks for the help but i dont understand this here
Just means, that you go into the path C:/windows/system32/drivers/etc/hosts and open Hosts file with editor and add this line. 127.0.0.1 your_dyndns_adress

xIME1st's mistake was that he inserted his dynamic ip instead of his local ip.
s0ul37 is online now  
Old   #13
 
elite*gold: 0
Join Date: Jul 2011
Posts: 16
Received Thanks: 0
I cannot go into the server, when I select the server I get the error, which i posted above using this GameServer.opt: (logging in works, but as soon as I select server the error comes up)

S app.name:game001
S auth.server_idx:1
S auth.server_name:Server Name
S db.game.ip:93.82.56.143 <--- my ip from
S db.c._password:
S db.c.account:sa
S db.c.name:Arcadia
S db.c.server:127.0.0.1
S db.user._password:
S db.user.account:sa
S db.user.name:Telecaster
S db.user.server:127.0.0.1
S io.port:4514
S io.ip_address:rappelzserver.dyndns.info
S game.server_screenshot_url:
S log.working:0
S game.exp_rate:150
S game.item_drop_rate:50
S game.gold_drop_rate:10
S game.chaos_drop_rate:10
T game.use_login_logout_debug:0
T game.max_level:170
T game.use_auto_trap:0
T game.cash_usable_server:0
T game.no_collision_check:1
T game.no_skill_cooltime:0

What did I do wrong :O?
xIME1st is offline  
Old   #14
 
elite*gold: 0
Join Date: Jun 2011
Posts: 669
Received Thanks: 309
That's actually what I'm getting too. I tried using DynDNS adress/my IP/Localhost for game.ip did not work.
s0ul37 is online now  
Old   #15
 
elite*gold: 0
Join Date: Dec 2010
Posts: 257
Received Thanks: 14
if you guys find a fix message me


piratehat2 is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
How to make your server non-hamachi!
PartOne: 1. Open your Internet Browser. (Firefox. Internet Explorer.) 2. Go to DynDNS.Com and create and account if you don't already have one....
111 Replies - EO PServer Hosting
can someone tell me how make server with hamachi :(
please help me !!! how make server eudemons online with hamachi !!! give me pictures how to make a server with hamachi?
6 Replies - EO PServer Guides & Releases
[ERROR] Trying put server non-hamachi.
Hellp i need put my server non-hamachi .. and have very days i just try but don't connect.. PLz hellp me what my erro ? The MSG server don't...
4 Replies - CO2 PServer - Discussions / Questions
[HELP]How To make my server without hamachi
hey all i know this sounds nooby but can anyone tell me how to make my server without hamachi +k to the 1 that helps me
3 Replies - CO2 PServer - Discussions / Questions
[Help] to make my server non hamachi
i need help to make my server non hamachi i open all ports on my router and still dont work and this is apic to ports...
0 Replies - EO PServer Hosting



All times are GMT +2. The time now is 19:57.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.