Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 20:44

  • Please register to post and access all features, it's quick, easy and FREE!

 

Rappelz server files

Closed Thread
 
Old   #1
 
elite*gold: 0
Join Date: Aug 2010
Posts: 2
Received Thanks: 10
Rappelz server files

Hi, I got the server files a few weeks back and was following the main thread on how it worked. I experimented as much as I could and managed to get the Authentication and Game Server to work. The localhost workaround helped alot thanks to Tetris. I didn't use his program but simply just used a hex editor and changed the root url to localhost.

So far the server seems to run fine. It kinda lags when I attack monsters because of my poor system setup. The server is supposed to run on three server racks and I put it all on just a crappy quad core pc.

Configuration is good, defaults work fine, the drop rate is kinda lame, even setting it very high.

My Microsoft SQL server seems to work fine with the databases I got, but I am still working out the kinks on some stuff.

Anyway I hope to contribute these to you guys in the future. I'll inform you of my process next week.



tessybing123 is offline  
Thanks
9 Users
Old   #2
 
elite*gold: 0
Join Date: Dec 2010
Posts: 664
Received Thanks: 189
Congratulations Tessybing! Great job.


RoflcopterGoesSoiSoiSoi is offline  
Old   #3
 
elite*gold: 0
Join Date: May 2008
Posts: 80
Received Thanks: 92
Congrats, could you release your on_server_startup procedure? Mine seems to be broken...
Link404 is offline  
Thanks
1 User
Old   #4
 
elite*gold: 0
Join Date: Feb 2009
Posts: 57
Received Thanks: 21
Our login server and game server now can successfully connect to mssql server. Now just need to get DB.



demonroro is offline  
Old   #5
 
elite*gold: 0
Join Date: Mar 2009
Posts: 115
Received Thanks: 154
Take a look at this thread.
harmbasi is offline  
Old   #6
 
elite*gold: 0
Join Date: May 2008
Posts: 80
Received Thanks: 92
Quote:
Originally Posted by demonroro View Post
Our login server and game server now can successfully connect to mssql server. Now just need to get DB.

Hey, could you share your procedure "on_server_startup" with me please? This one seems to stuck while loading the game server... Where it says "Loading max item" or whatever, I get an error message.
Link404 is offline  
Old   #7
 
elite*gold: 0
Join Date: Feb 2009
Posts: 57
Received Thanks: 21
Got this error too. I just updated database with DBUpdater i'm launching right now.. i will see if this stored procedure has been fixed.
demonroro is offline  
Old   #8
 
elite*gold: 0
Join Date: Feb 2009
Posts: 57
Received Thanks: 21
This telecaster db got the good "on_server_startup" anyway it seems

Log File :
2011-04-01 22:18:08 Network initialize... ok

2011-04-01 22:18:08 IOCP initialize... ok

2011-04-01 22:18:08 Starting IOCP thread pool... ok

2011-04-01 22:18:08 LUA initialize... ok

2011-04-01 22:18:08 Launching ARCADIA... ok

2011-04-01 22:18:08 Start loading...


2011-04-01 22:55:25 Network initialize... ok

2011-04-01 22:55:25 IOCP initialize... ok

2011-04-01 22:55:25 Starting IOCP thread pool... ok

2011-04-01 22:55:25 LUA initialize... ok

2011-04-01 22:55:26 Launching ARCADIA... ok

2011-04-01 22:55:26 Start loading...


2011-04-01 22:55:28 Loading max Item index... (1) ok


2011-04-01 22:55:28 Loading Complete.
demonroro is offline  
Old   #9
 
elite*gold: 0
Join Date: May 2008
Posts: 80
Received Thanks: 92
Awesome, thanks alot!
Now I have another problem... Absolutely no idea why, but since I've rebooted my server, the both .exe-files seem to be unable to connect anymore.... meeeeeeh
Link404 is offline  
Old   #10
 
elite*gold: 0
Join Date: Feb 2009
Posts: 57
Received Thanks: 21


Did some progress with Link404.
demonroro is offline  
Old   #11
 
elite*gold: 0
Join Date: May 2008
Posts: 80
Received Thanks: 92
We managed to get it working half-way... As you can see, the game server loads some things. So far so good. But after a while, the game server crashes.. Currently, we have absolutely no idea why this is happening, but I'm sure, we'll figure it out. Keep waiting.

EDIT: Added the log files. Maybe you guys could help us...

Log #1

Log #2


Log #3
Link404 is offline  
Old   #12
 
elite*gold: 0
Join Date: Oct 2010
Posts: 296
Received Thanks: 432
Try copying the .pdb file into the same folder as the server exe. It will add more information to the log files (names of functions during crash).

Based on the screenshot,you're missing the tables ItemLocalResource and/or StringLocalResource. I basically copied the columns from the ItemResource and StringResource tables.

If you trace the sql stuff with SQL Server Profile it is real easy to see what you're missing since it will be one of the last commands sent, if not the very last.

You're going to run into quite a few more tables as well as a few stored procedures that don't exist.

Oh yeah, the Script and NewMap folders must be in a Resource subfolder.

Here's my log so far, minus a bunch of mob spawn errors.

Pyrok is offline  
Thanks
2 Users
Old   #13
 
elite*gold: 0
Join Date: May 2008
Posts: 80
Received Thanks: 92
Quote:
Originally Posted by Pyrok View Post
Try copying the .pdb file into the same folder as the server exe. It will add more information to the log files (names of functions during crash).

Based on the screenshot,you're missing the tables ItemLocalResource and/or StringLocalResource. I basically copied the columns from the ItemResource and StringResource tables.

If you trace the sql stuff with SQL Server Profile it is real easy to see what you're missing since it will be one of the last commands sent, if not the very last.

You're going to run into quite a few more tables as well as a few stored procedures that don't exist.

Oh yeah, the Script and NewMap folders must be in a Resource subfolder.
Thanks for your helpful post, mate.
I see, my database is incomplete yet. Yours seem to be quite full. And this one is very strange:

Code:
[1]   2011-04-01 20:20:59 Total 0 Summon Level Bonus info loaded...

[2]   2011-04-01 20:21:00 Total 1481 DropGroup info loaded...

[3]   2011-04-01 20:21:00 Total 0 DropGroup(local) info loaded...

[4]   2011-04-01 20:21:00 Total 0 Summon Default Name loaded...

[5]   2011-04-01 20:21:00 Total 0 Summon Unique Name loaded...

[6]   2011-04-01 20:21:00 Total 7808 Item loaded...

[7]   2011-04-01 20:21:00 Total 0 Item(local) info loaded...
Line 1: Loads
Line 2: Doesn't load
Line 3: Doesn't load
Line 4: Doesn't load
Line 5: Doesn't load
Line 6: Loads (not complete)
Line 7: Doesn't load

Hmm... I just don't get it.. Blergh :/
Could you share your database with me? Or at least send it by PM?
Link404 is offline  
Old   #14
 
elite*gold: 0
Join Date: Feb 2011
Posts: 496
Received Thanks: 107
any one can give me aserver files full
lilnani is offline  
Old   #15
 
elite*gold: 0
Join Date: Feb 2009
Posts: 57
Received Thanks: 21
Quote:
Originally Posted by Pyrok View Post
Try copying the .pdb file into the same folder as the server exe. It will add more information to the log files (names of functions during crash).

Based on the screenshot,you're missing the tables ItemLocalResource and/or StringLocalResource. I basically copied the columns from the ItemResource and StringResource tables.

If you trace the sql stuff with SQL Server Profile it is real easy to see what you're missing since it will be one of the last commands sent, if not the very last.

You're going to run into quite a few more tables as well as a few stored procedures that don't exist.

Oh yeah, the Script and NewMap folders must be in a Resource subfolder.

Here's my log so far, minus a bunch of mob spawn errors.

To which table did you copied those column ? items ?
The pdb file is in the same folder as server program, but we still have no informations about the crash.


demonroro is offline  
Closed Thread



« Previous Thread | Next Thread »

Similar Threads
Rappelz Server-Files
Hy, Here the Server-Files From Rappelz. The Files are From Gpotato and the Language is german. This Downloads has all Information witch i...
10 Replies - Rappelz
Is there anyone there has the Rappelz server files?
Is there anyone there has the Rappelz server files? I just wanna know becouse I relly need them.. If nobody have them cant we just "grab" the...
4 Replies - Rappelz



All times are GMT +2. The time now is 20:44.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.