Register for your free account! | Forgot your password?

Go Back   elitepvpers > Other Online Games > Need for Speed World
You last visited: Today at 10:42

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



[Bug] "Couldn't find registry entry for NFS:W."

Discussion on [Bug] "Couldn't find registry entry for NFS:W." within the Need for Speed World forum part of the Other Online Games category.

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Apr 2013
Posts: 23
Received Thanks: 4
Question [Bug] "Couldn't find registry entry for NFS:W."

Hello, I approach you with a recurring issue with the OfflineServer for Need for Speed: World.

It seems like every day I use the OfflineServer, I have had to reinstall it any time that I restart my PC.
This error "Couldn't find registry entry for NFS:W." appears any time I try to get on NFS:W after turning on my computer.

I have tried to troubleshoot it and also attempt to run the program as an administrator, but to no avail.
Plus, I never touch anything else except what is present on the OfflineServer interface. I touch no registry entry, and I don't touch the File Editor.

This aggravates me because I have had to reset my profile(s) three times since.

Is there any way that this can be resolved? I call this a [Bug] because it seems to happen under this specific circumstance (at the event of turning off/on my computer).

I appreciate it if I can get any support with this, as I'd like to keep my profiles and my cars, instead of being forced to restart my profiles every single day.

CodyP2000



CodyP2000 is offline  
Old 05/11/2016, 11:57   #2
 
elite*gold: 0
Join Date: Feb 2014
Posts: 30
Received Thanks: 1
i have the same problem with the 1,8 and i have install 3.0 automatik instaler and have no more problem


malakas78 is offline  
Old 05/11/2016, 23:53   #3
 
elite*gold: 0
Join Date: Apr 2013
Posts: 23
Received Thanks: 4
Quote:
Originally Posted by malakas78 View Post
i have the same problem with the 1,8 and i have install 3.0 automatik instaler and have no more problem
What Automatic Installer..?
CodyP2000 is offline  
Old 05/12/2016, 14:54   #4
 
elite*gold: 15
Join Date: Aug 2012
Posts: 3,041
Received Thanks: 6,370
Do you know where your nfsw.exe is located? If so, you can fix this easily. Open the settings.ini and change the NFS: World executable path with the correct value, including the driver name and the .exe file extension. (e.g., "C:\ProgramData\Electronic Arts\Need For Speed World\Data\nfsw.exe")


berkay2578 is offline  
Thanks
1 User
Old 05/12/2016, 21:33   #5
 
elite*gold: 0
Join Date: Apr 2013
Posts: 23
Received Thanks: 4
Quote:
Originally Posted by berkay2578 View Post
Do you know where your nfsw.exe is located? If so, you can fix this easily. Open the settings.ini and change the NFS: World executable path with the correct value, including the driver name and the .exe file extension. (e.g., "C:\ProgramData\Electronic Arts\Need For Speed World\Data\nfsw.exe")
Even though I select the correct file upon the "first time," it seems to produce that error. I'm guessing that the path seems to change by itself, even though I never change the location of nfsw.exe. I'll see what I can do when I get home.

Quote:
Originally Posted by berkay2578 View Post
Do you know where your nfsw.exe is located? If so, you can fix this easily. Open the settings.ini and change the NFS: World executable path with the correct value, including the driver name and the .exe file extension. (e.g., "C:\ProgramData\Electronic Arts\Need For Speed World\Data\nfsw.exe")
Okay, I managed to fix the problem that you suggested above. Thank you!
CodyP2000 is offline  
Old 05/13/2016, 01:07   #6
 
elite*gold: 15
Join Date: Aug 2012
Posts: 3,041
Received Thanks: 6,370
Yeah, the OfflineServer launcher is prone to so many bugs because I had to get it out fast. Nice to hear that you got it fixed though!
berkay2578 is offline  
Old 05/15/2016, 01:55   #7
 
elite*gold: 0
Join Date: Apr 2013
Posts: 23
Received Thanks: 4
Yep, so far I haven't gotten that error yet!
CodyP2000 is offline  
Old 06/13/2016, 01:46   #8
 
elite*gold: 0
Join Date: Jun 2016
Posts: 7
Received Thanks: 1
Question

Sorry if I'm necroing this thread, but I feel like it's better than making a new thread for something that might be an easy fix.
I have version 1.8 and things have gone smoothly after some initial bugs and confusion. However, I'm suddenly having difficulties.
I was playing it on my laptop and never got a low battery warning, and as such, it shut down while the server and game were running. This could have corrupted something, I dunno.
Upon opening OfflineServer.exe, I get the "Couldn't find registry entry for NFS:W" message. Clicking 'okay' just causes it to crash. I've also noticed that the prompt that opens whenever a program crashes (stating that "*** has stopped working") lasts only about a second and a half before just closing. So I deleted settings.ini and tried again. I'm able to import the drivers from the 1.7 version without crashing, until it's done. Then it just crashes again when I press "ok" on the "Old drivers have been imported successfully!" prompt. If I decline to import the drivers it crashes. The executable path was empty in the settings.ini, so I fixed that and guess what? No registry entry error! It just crashes immediately. Excellent. Not really sure where to go from here. Suggestions are welcome. This is kind of frustrating, even if it is just over some wonky abandonware. I'd rather not reinstall everything but if that's what it comes to at least I have somewhat recent persona backups. Thanks if you took the time to read this.
Cheers
Gedda206 is offline  
Old 06/13/2016, 10:36   #9
 
elite*gold: 15
Join Date: Aug 2012
Posts: 3,041
Received Thanks: 6,370
I can upload the source if anyone is interested to fix it, it is an abandonware since 2 months and no fixes are to come.
berkay2578 is offline  
Old 06/13/2016, 18:51   #10
 
elite*gold: 0
Join Date: Mar 2016
Posts: 174
Received Thanks: 262
@ Would be interesting to see that.
leorblx is offline  
Old 06/16/2016, 02:38   #11
 
elite*gold: 0
Join Date: Dec 2013
Posts: 2
Received Thanks: 0
Registry error can be fixed by installing EA's old launcher for the game
RamRawR is offline  
Old 06/17/2016, 17:11   #12
 
elite*gold: 0
Join Date: Feb 2014
Posts: 83
Received Thanks: 31
jesus jesus
ANC57 is offline  
Old 08/25/2016, 14:12   #13
 
elite*gold: 0
Join Date: Aug 2016
Posts: 1
Received Thanks: 0
Quote:
Originally Posted by RamRawR View Post
Registry error can be fixed by installing EA's old launcher for the game
yes, but where are you supposed to find that? the game shut down almost 2 years ago now, that's the problem.
if you know where I can find it, let me know, bearing in mind I don't actually have NFSW Online because I got a new PC.
sykopathic is offline  
Old 05/21/2017, 16:59   #14
 
elite*gold: 0
Join Date: May 2017
Posts: 1
Received Thanks: 0
Quote:
Originally Posted by berkay2578 View Post
Do you know where your nfsw.exe is located? If so, you can fix this easily. Open the settings.ini and change the NFS: World executable path with the correct value, including the driver name and the .exe file extension. (e.g., "C:\ProgramData\Electronic Arts\Need For Speed World\Data\nfsw.exe")
Change to what? Can you give me an example? I'm no programmer so I have no clue what to write. By the way my settings.ini is in the offline server folder, not the game folder.
AlexTheMatrixx is offline  
Old 02/13/2020, 15:42   #15
 
elite*gold: 0
Join Date: Feb 2020
Posts: 2
Received Thanks: 0
hey got setting.ini and but i coundn't get the problem fix and i saw in ini file that EVN Developer is you


ArsGamer is offline  
Reply

Tags
bug, cars, nfsw, profiles, registry



« NSFW Launcher Error | CarChanger by Vityacv (Permanently) »

Similar Threads
ERROR SRO ""Recording Registry failed!""
02/23/2011 - Silkroad Online - 1 Replies
Hello everyone: I need your help ... to execute the Silkroad launcher said: ""Recording Registry failed!"" GameCam had installed but the uninstall some time. From time to time I started to launch this mistake http://s1.subirimagenes.com/otros/previo/thump_48 6290wtf.jpg



All times are GMT +1. The time now is 10:42.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

BTC: 33E6kMtxYa7dApCFzrS3Jb7U3NrVvo8nsK
ETH: 0xc6ec801B7563A4376751F33b0573308aDa611E05

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2020 elitepvpers All Rights Reserved.