Register for your free account! | Forgot your password?

You last visited: Today at 03:17

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement


GW Working Bots 2020

Discussion on GW Working Bots 2020 within the GW Exploits, Hacks, Bots, Tools & Macros forum part of the Guild Wars category.

Reply
 
Old 04/02/2021, 00:05   #1726

 
elite*gold: 0
Join Date: Jul 2016
Posts: 11
Received Thanks: 12
you can also check for the instance time with usually a function named GetInstanceUptime() or GetInstanceTime() in the API's

So if you believe that if you're in the map for more than x seconds/minutes, something is wrong, it can help as well
jukia is offline  
Thanks
2 Users
Old 04/02/2021, 00:27   #1727
 
elite*gold: 0
Join Date: Apr 2016
Posts: 248
Received Thanks: 146
Quote:
Originally Posted by jukia View Post
you can also check for the instance time with usually a function named GetInstanceUptime() or GetInstanceTime() in the API's

So if you believe that if you're in the map for more than x seconds/minutes, something is wrong, it can help as well
Works but is kinda scuffed for longer farms since if the farm run is like an hour long and you already stuck after 5min that is a lot of wasted time - works never the less doe
Restia Ashdoll is offline  
Old 04/02/2021, 08:40   #1728
 
elite*gold: 0
Join Date: Jan 2021
Posts: 7
Received Thanks: 2
Quote:
Originally Posted by Scythe_Farmer View Post
.
perfect, running all the night whitout problem
jacques52 is offline  
Old 04/07/2021, 08:07   #1729
 
elite*gold: 0
Join Date: Mar 2021
Posts: 7
Received Thanks: 5
Sigh. I'm guessing the update changed something. The pre Omnifarmer doesn't recognize my primary profession and the Ascalon trade chat doesn't update anymore. Any way for me to check what changed and how to fix it, or do we have to wait for an updated G2A?
EDIT: And my chat spammer straight up crashes the game now.
john3636 is offline  
Old 04/07/2021, 08:19   #1730
 
elite*gold: 0
Join Date: Sep 2015
Posts: 5
Received Thanks: 1
good morning all, someone got the new headers?
greetings
B u l l a is offline  
Old 04/07/2021, 13:42   #1731
 
elite*gold: 0
Join Date: Dec 2010
Posts: 18
Received Thanks: 56
New Headers

New Headers.
But that wasn't all the update has changed. Even with the new headers you won't be able to successfully run a bot.

source for headers:
Attached Files
File Type: zip GWA2_Headers.zip (2.1 KB, 94 views)
tixxesdan is offline  
Thanks
2 Users
Old 04/07/2021, 13:57   #1732
 
elite*gold: 0
Join Date: Mar 2021
Posts: 7
Received Thanks: 5
Quote:
Originally Posted by tixxesdan View Post
New Headers.
But that wasn't all the update has changed. Even with the new headers you won't be able to successfully run a bot.

source for headers:
Yep, that's a RIP on my end. Twas easy enough to follow the AutoIt Header errors and fix them but I still get profession issues which aren't in the headers as far as I can tell.
john3636 is offline  
Old 04/07/2021, 15:22   #1733
 
elite*gold: 0
Join Date: Oct 2020
Posts: 6
Received Thanks: 2
Also updated my headers and it doesn't work, memory offsets are ******?
hellokok is offline  
Old 04/07/2021, 15:43   #1734
 
elite*gold: 26
Join Date: Apr 2019
Posts: 56
Received Thanks: 24
Quote:
Originally Posted by hellokok View Post
Also updated my headers and it doesn't work, memory offsets are ******?
It seems yes.

Call to GetAgentExists(-2) always return False which implies that every call to SendPacket function doing nothing but returning False as well...

75%+ of GWA2 api is using SendPacket function so here is why bot are doing nothing atm.
Yoshikawa91 is offline  
Old 04/07/2021, 16:19   #1735
 
elite*gold: 0
Join Date: Feb 2018
Posts: 11
Received Thanks: 1
Quote:
Originally Posted by Yoshikawa91 View Post
It seems yes.

Call to GetAgentExists(-2) always return False which implies that every call to SendPacket function doing nothing but returning False as well...

75%+ of GWA2 api is using SendPacket function so here is why bot are doing nothing atm.
Looks like the AddPattern has changed for ScanAgentBase
glechene is offline  
Old 04/07/2021, 16:43   #1736
 
elite*gold: 26
Join Date: Apr 2019
Posts: 56
Received Thanks: 24
Quote:
Originally Posted by glechene View Post
Looks like the AddPattern has changed for ScanAgentBase
Yes it has but changing the pattern and the offset does not seem to be enough though. :'(
Yoshikawa91 is offline  
Old 04/07/2021, 17:20   #1737
 
elite*gold: 0
Join Date: Aug 2016
Posts: 33
Received Thanks: 6
Cue influx of comments for working bots after the update xD

P.S thanks for the headers update ��
uK Cooki3 is offline  
Old 04/07/2021, 19:49   #1738
 
elite*gold: 0
Join Date: Jul 2009
Posts: 7
Received Thanks: 0
hey,
as a non-programmer:
is it right now fixible or we just have to wait?
Sizzlar is offline  
Old 04/07/2021, 20:05   #1739
 
elite*gold: 0
Join Date: Nov 2017
Posts: 11
Received Thanks: 1
Someone has a working JQ Bot ?
TKeyy is offline  
Old 04/07/2021, 23:56   #1740
 
elite*gold: 0
Join Date: Mar 2017
Posts: 24
Received Thanks: 7
GWA2 update

Hi everyone

I'm not sure I understand everything about the GWA2 update.
Is it specific to each bot or is the same one used for all bots?

Thanks in advance!
Balti Bblast is offline  
Reply


Similar Threads Similar Threads
[WTT] UPlay Anno 2020 Complete Key gegen Anno 1404/Anno 2020 Complete STEAM
08/12/2015 - Steam Trading - 0 Replies
Want to Trade UPlay Anno 2020 Complete Key gegen Anno 1404 oder Anno 2020 Complete STEAM only with Middleman



All times are GMT +2. The time now is 03:17.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2021 elitepvpers All Rights Reserved.