Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Guild Wars > GW Bots
You last visited: Today at 04:41

  • Please register to post and access all features, it's quick, easy and FREE!


Troubles with the SalvageItem function

Discussion on Troubles with the SalvageItem function within the GW Bots forum part of the Guild Wars category.

Old   #1
elite*gold: 0
Join Date: Oct 2005
Posts: 2,485
Received Thanks: 218
Troubles with the SalvageItem function


I am having some troubles with the salvage item function. I did some amateur reversing in olly and actually managed to successfully call the salvage item function but then without changing anything, the function began to crash the game. I was not able to recreate the in-game scenario in which my function worked and in which it crashed the game. Did not change much in-game either. Just restarted the game once.

If you look at the attached picture:
I suspected the salvage item function to be @ 0x800820, so I loaded the registers with the assumed necessary values and did some trial and error tryouts and actually got it working - until it began to crash the game (I could not identify a possible reason for this, I suspect a game restart).

EAX always has a pointer to a 0 - I do not know the purpose.
ECX always seems to be 9, I do not know why.
EDX and EBX contain the itemId of the salvageKit
EDI contains the itemId of the item that is about to be salvaged

I also went up in the call tree but I could not get the function to work again.
Can anyone give me some insight on why I am failing to get this particular function to work? Identing, Selling, Moving, Casting, Targeting - it all works fine, but this salvage thing with its random functionality is driving me nuts.

Yours sincerely
Attached Images
File Type: png SalvageItem.PNG (101.8 KB, 23 views)
Term!nX is offline  
Old 03/13/2019, 20:08   #2
elite*gold: 0
Join Date: Oct 2005
Posts: 2,485
Received Thanks: 218

So I figured that EAX would be some pointer to something, I do not know really. I managed to find a pointer which would be @ baseAdress A52230 + 0x158 + 0xB8, so it seems to be somewhat related to item management (+0x158 indicates this to me).
It makes the function work, but the weird thing is, I have to manually salvage an item once beforehand, otherwise it will make the game crash.

1) does anyone know the destination of the pointer in EAX? Its purpose?
2) why do I have to manually salvage an item once, before I can call the salvage function from my script engine without crashing the game?

Thank you very much in advance for any insight
Term!nX is offline  
Old 03/19/2019, 07:18   #3
elite*gold: 0
Join Date: Sep 2014
Posts: 349
Received Thanks: 118
What your looking for is already in the asm of the gwa2... look closer... and even better follow closely to a good script that is salvaging things and you will see the missing values you are looking for.
phat34 is offline  

Similar Threads Similar Threads
std::function of a function returning an std::function
11/11/2013 - C/C++ - 19 Replies
Nun muss ich nach langer Zeit auch mal wieder einen Thread erstellen, weil mir Google nicht mehr weiterhelfen kann. Ich verzweifle an Folgendem Vorhaben: #include <Windows.h> #include <string> #include <iostream> using namespace std;
Running Function 2 after Function 1 finished
09/15/2013 - AutoIt - 3 Replies
Hey, its me again. Im stuck on a problem since yesterday and as much as i hate to ask for help, i really dont know what else to try. I want Function 2 to run after Function 1 has finished. I tried GuiCtrlSetOnEvent and MsgLoop, but i dont really understand it. I tried to read tutorials but they didnt help at all. The line that are underline is what im talking about. I want gamestart() to run first and when its finished, i want iniviteteam() to run. #AutoIt3Wrapper_UseX64=n...
[VIP-function] ToxicSYS [VIP-function]
08/14/2010 - WarRock Hacks, Bots, Cheats & Exploits - 1 Replies
heeeey E-pvpers :pimp: this is a new hack by TSYS Status : UNDETECTED Functions (VIDEO) : YouTube - WarRock - Bikini event VIP hack
sv troubles
03/08/2007 - Conquer Online 2 - 4 Replies
i get an error msg saying i need to update the game and press f11 but i think i did everything using agentking.exe and i have host files in drivers/etc having troubles loading the pic to the site the image is here...
Having troubles here
02/07/2006 - Conquer Online 2 - 2 Replies
ever since patch 4295 came out i havnt been able to open more than 2 clients.....i have tried all the pinned topics and i even searched for a way..... did they finally fix it or what?

All times are GMT +2. The time now is 04:41.

Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

BTC: 33E6kMtxYa7dApCFzrS3Jb7U3NrVvo8nsK
ETH: 0xc6ec801B7563A4376751F33b0573308aDa611E05

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2021 elitepvpers All Rights Reserved.