Problem mit Starten des Servers.. MYSQL Acces ...

11/04/2011 19:45 Smackthat218#1
Hallo Elitepvpers,
ich habe seit ich in der MYSQL DB die Passwörter des Benutzers mt2 und root geändert habe Probleme den Server zu starten.

Folgende Meldung:
Quote:
Real Server
Log Offlog_file_delete_old: stat: No such file or directory
mysql_real_connect: Access denied for user 'mt2'@'localhost' (using password: YES)
failed, retrying in 5 secondsPUBLIC_IP: xxx.xxx.xx.xx interface re0
HOSTNAME: auth
mysql_real_connect: Access denied for user 'mt2'@'localhost' (using password: YES)
cannot open direct sql connection to host: localhost user: mt2 db: common
cannot start server while no common sql connected
PUBLIC_IP: xxx.xxx.xx.xx interface re0
HOSTNAME: channel1
mysql_real_connect: Access denied for user 'mt2'@'localhost' (using password: YES)
cannot open direct sql connection to host: localhost user: mt2 db: common
cannot start server while no common sql connected
PUBLIC_IP: xxx.xxx.xx.xx interface re0
HOSTNAME: channel2
mysql_real_connect: Access denied for user 'mt2'@'localhost' (using password: YES)
//EDIT xxx.xxx.xx.xx ist meine Ip aus sicherheitsgründen rausgeschrieben

Ich dneke ich muss nur wieder ein anderes PW in die DB eintragen bzw ein Hash Code bei dem das PW ausgeschlatet ist..... benötige bitte dringend hilfe

LG
11/04/2011 20:10 lolor2#2
hast du den mt2 benützer erstellt? o_0
11/04/2011 20:23 Smackthat218#3
Den hab ich ja schon in der Db geändert also das pw.

Weil der ja schon bestand.

aber seit ich das PW in der DB des Users MT2 geändert habe kommt er nicht mehr drauf. Also müsste ich dies zurückändern oder woanders in den cfgs des servers ändern nur wo. bzw wie.
11/04/2011 20:37 Finezt#4
Du gehst in dein Serverfiles Verzeichnis unter : Game99 , Channel1 (wenn du 2 Channel auf deinem Server hast , auch unter Channel2) , Auth & DB und guckst halt in den Configs welches PW dort eingetragen ist. Sagen wir dort steht "metin2" überall , dann gehst du in deine Konsole (Putty) gibst ein "mysql -p" ohne " und dann musst du dein PW eingeben , und gibst dann dein PW ein. Danach bist du in Mysql eingeloggt und gibst ein :
GRANT ALL PRIVILEGES ON *.* TO 'mt2'@'localhost' [ENTER]
IDENTIFIED BY 'metin2' WITH GRANT OPTION; [ENTER]
und gibst dann einfach ein "quit" ohne "

Dort oben wo metin2 steht ersetzt du halt dadurch was in deinen Configs steht!
Das kannst du aber auch beliebig ändern , aber musst es dann überall ändern!

Finezt
11/04/2011 20:39 xFreeshy#5
^this wollt ich gerade auch schreiben :>
Den Fehler hatte ich auch mal, finde ich Dumm, bis mir eingefallen ist in die Configs zu schauen :D
11/04/2011 21:24 Smackthat218#6
Hab nur folgendes da stehen:

Quote:
HOSTNAME: channel99
CHANNEL: 99
PORT: 13099
P2P_PORT: 14099
DB_PORT: 15000
DB_ADDR: localhost
MAP_ALLOW: 181 182 183 184 185 186 187 188 189 200 220
TABLE_POSTFIX:
PASSES_PER_SEC: 25
SAVE_EVENT_SECOND_CYCLE: 180
PING_EVENT_SECOND_CYCLE: 180
PLAYER_SQL: localhost mt2 mt2!@# player
COMMON_SQL: localhost mt2 mt2!@# common
LOG_SQL: localhost mt2 mt2!@# log
TEST_SERVER: 1
NO_PK: 1
VIEW_RANGE: 8000
CHECK_MULTIHACK: 1
LOCALE_SERVICE: GERMANY
Eine Auth $ Db Config habe ichdort nciht gefundne lediglich diese CONFIG File
11/04/2011 22:32 almobd3#7
in your freebsd type

mysql -p

your mysql password!

GRANT ALL PRIVILEGES ON *.* TO 'mt2'@'localhost'
IDENTIFIED BY 'mt2!@#' WITH GRANT OPTION;

quit;

start metin2 server.

best regards :)
11/05/2011 00:06 Smackthat218#8
Irgendwie komm ich nicht mehr in mein mysql rein

Quote:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
Hm.....



//EDIT GELÖST
11/05/2011 00:12 Finezt#9
Adde mich in Skype : arthurx333
Ich mach es dir ist'n bisschen kompliziert für dich..


Finezt