Register for your free account! | Forgot your password?

You last visited: Today at 08:08

  • Please register to post and access all features, it's quick, easy and FREE!

 

CMake Boost Error

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Aug 2015
Posts: 4
Received Thanks: 0
CMake Boost Error

Hey zusammen,
ich versuche jetzt schon eine Weile mein Problem zu lösen, aber irgendwie will es nicht so wirklich vorangehen.
Ich möchte eine Core von Trinity kompilieren, bekomme allerdings folgenden Fehler, wenn ich in Cmake auf Configure klicke:

Code:
CMake Error at cmake/macros/FindBoost.cmake:1184 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.58.0

  Boost include path: C:/local/boost_1_58_0

  Could not find the following static Boost libraries:

          boost_system
          boost_filesystem
          boost_thread
          boost_program_options
          boost_iostreams

  No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.
Ich habe jetzt auch schon ein bisschen gesucht zu dem Fehler und habe auch soweit schon die Anleitung von Trinity befolgt und eben noch die Systemvariable BOOST_ROOT hinzugefügt und seitdem erkennt er ja zumindestens schonmal die Boost Version, aber weiter komme ich jetzt auch nicht mehr, hätte jemand eventuell noch einen Hinweis für mich?



blubreloaded is offline  
Old   #2
 
elite*gold: 110
Join Date: Mar 2008
Posts: 827
Received Thanks: 361
Sowohl Boost in der 32-Bit- als auch in der 64-Bit-Version installieren hilft oft. Beides in den gleichen Ordner.
Eventuell solltest du auch die Systemvariable BOOST_LIBRARYDIR setzen. Kann dir gerade nicht sagen, auf welchen Ordner die genau zeigen muss, aber das sollte sich schnell per Google finden lassen.
Nach jedem Ändern von Systemvariablen CMake unbedingt neu starten und evtl. sogar den CMake Cache löschen und nochmal neu generieren.


Kaev <3 is offline  
Old   #3
 
elite*gold: 0
Join Date: Aug 2015
Posts: 4
Received Thanks: 0
Hatte schon die 32- und 64-Bit Version installiert und auch im gleichen Ordner.
Die Systemvariable BOOST_LIBRARYDIR setzen war leider auch nicht erfolgreich, habe jetzt beim googeln nichts eindeutiges gefunden, da dort nur stand, dass man den auf Boost/lib setzen soll, allerdings habe ich entweder nur boost\libs oder boost\lib32-msvc-12.0 und dann eben noch den Ordner mit der 64 Bit Version, ich habe jetzt mal alle 3 Ordner versucht aber geholfen hat es leider nichts.

Allerdings hat es funktioniert als ich in cmake direkt die Adresse von den einzelnen Boost Libraries angeben habe, nur ist das halt auf Dauer dann immer etwas mühsam.
Hätte daher eventuell noch jemand einen weiteren Tipp?
blubreloaded is offline  
Old   #4
 
elite*gold: 110
Join Date: Mar 2008
Posts: 827
Received Thanks: 361
Probier's mal mit Boost 1.57, wenn ich mich recht erinner, hatte ich mit 1.58 auch Probleme..
Und wenn das auch nicht hilft: Füg die Boost-Systemvariablen auch mal zu den Uservariablen hinzu, hilft auch ab und zu.

EDIT: Und ruf nochmal das Repository ab, in den letzten 5 Tagen kamen Commits hinzu, die Probleme bezüglich Boost behoben wurden.
Commit:
Problem:


Kaev <3 is offline  
Old   #5
 
elite*gold: 0
Join Date: Aug 2015
Posts: 4
Received Thanks: 0
Habs jetzt auch mal mit der Boost 1.57 und dann noch mit der Boost 1.59 versucht, beides mal der gleiche Fehler wie bei der Bost 1.58.
Die Boost-Systemvariablen habe ich auch schon zu den Uservariablen hinzugefügt, hilft auch nichts.
Habe heute auch nochmal die Core neu heruntergeladen, ebenfalls keine Veränderung.
Gibts noch weitere Vorschläge?


blubreloaded is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
CMake Error
Guten Abend! Habe beim compilieren von der TrinityCore einen CMake Error: CMake Error: The following variables are used in this project, but they...
3 Replies - WoW Private Server
Cmake problem suche jemand für cmake to vcproj
Hallo, da ich das problem habe das cmake bei mir immer fehler anzeigt wollte ich fragen ob mir jemand die cmake dateien in vcproj 10 datein...
2 Replies - WoW Main - Discussions / Questions
Cmake Error (OpenSSL)
Versuche gerade Trinity zu Installieren im mom hängt es beim Compilen System CentOS Linux 6.4 Kernel Linux 2.6.32-358.6.1.el6.x86_64 on x86_64...
0 Replies - WoW Private Server
[Cmake] Error!!!
Hallo Epvpers, Ich habe ein kleines Problem, (siehe Bild) Woran kann das liegen? http://62.141.42.240/img/epvper/epvper.png MFG:...
3 Replies - WoW Private Server
Mangos cmake Problem / Error
ich hab anhand der Befehlsreihe versucht einen 3.3.5a Server auf zu setzen. mkdir mangos335 && cd mangos335 && git clone...
2 Replies - WoW PServer Hosting



All times are GMT +1. The time now is 08:08.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.