Register for your free account! | Forgot your password?

Go Back   elitepvpers > World of Warcraft > WoW Private Server
You last visited: Today at 02:58

  • Please register to post and access all features, it's quick, easy and FREE!

 

Keine Verbindung zur db möglich

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
Keine Verbindung zur db möglich

Ein Wunderschönen Guten Tag,

Ich habe folgendes Problem.

Ich möchte eine Registerpage auf meinen Linux Server zum laufen bringen.
Ich nutze dafür den Webserver Apache2.

Leider klappt die Acc Erstellung nicht da angebelich keine verbindung zur DB aufgebaut werden kann.

Nun hab ich mal eine Testphp hoch geladen mit dem
Ergebnis: Connected successfully

Also kann die Verbindung zum Host aufgebaut werden. Hab die selben Daten benutzt wie in der config. von Registerpage.

Wenn ich auf Acc erstellen klicke kommt die Meldung: Could not connect to host

Ich hoffe es sind ausreichend Informationen und mir kann jemand helfen vielen dank im Voraus.

MfG Devisions



devisions is offline  
Old   #2
 
elite*gold: 0
Join Date: Mar 2014
Posts: 89
Received Thanks: 13
Config richtig eingestellt? Localhost?


Sunrisew0w is offline  
Old   #3
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
***, wie gesagt: Mit der Testseite kann ich ja conecten nur mit register page leider net und ich habe schon einige ausprobiert immer das selbe problem.
Also:
<?php
$servername = "localhost";
$username = "root";
$password = "meinpw";

// Create connection
$conn = mysqli_connect($servername, $username, $password);

// Check connection
if (!$conn) {
die("Connection failed: " . mysqli_connect_error());
}
echo "Connected successfully";
?>

sagt verbunden.

<?php
// Database settings
define('DB_HOST', 'localhost');
define('DB_USER', 'root');
define('DB_PASS', 'mein pw');
define('DB_NAME', 'auth');

// Soap settings
define('SOAP_IP', '127.0.0.1');
define('SOAP_PORT', '7878');
define('SOAP_USER', 'admins');
define('SOAP_PASS', 'admins');

// Misc settings
define('CHECK_FOR_DUPLICATE_EMAIL', true);
define('SITE_TITLE', "Account Registration Page");
define('META_DESCRIPTION', "Devision Wow");
define('META_KEYWORDS', "Jeutie, Blizzlike, Repack, registration, account, emulation");
define('META_ROBOTS', "INDEX,NOFOLLOW");
define('REALMLIST', "85.214.207.162");
?>
sagt nicht verbunden
devisions is offline  
Old   #4
 
elite*gold: 140
Join Date: Aug 2009
Posts: 200
Received Thanks: 32
Wenn es ne öffentliche Seite ist dann musst du deine richtige IP anlegen und den Port freischalten, wenn es ne Seite ist die bei dir auf den Pc läuft dann sollte es eig gehen.


thekiller1 is offline  
Old   #5
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
Ist ne öffentliche. Also statt localhost die ip? Oder wie muss ich das angehen?
devisions is offline  
Old   #6
 
elite*gold: 140
Join Date: Aug 2009
Posts: 200
Received Thanks: 32
Genau, sobald du so ne Seite veröffentlichst, kann er ja schlecht zu 127.0.0.1 verbinden da die Seite ja nicht über deinen Pc sonder von nen Server aus läuft.
Such deine Ip Adresse raus und übernimm die. Den Port musst du dann auch noch freigeben.
thekiller1 is offline  
Old   #7
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
Database connection failed: Can't connect to MySQL server on '85.214.207.162' (111)
Ich hab über port freigabe nun schon einiges gelesen und versucht, aber so richtig hat es bisher nicht funktioniert. Hättest da vlt. noch nen Tipp für mich?
devisions is offline  
Old   #8
 
elite*gold: 140
Join Date: Aug 2009
Posts: 200
Received Thanks: 32
Schon etwas länger her aber soweit ich mich entsinne, gehst du auf deine Firewall dann auf Erweiterte Einstellungen, Neue Regel hinzufügen.
Dann Port anklicken und den Port namen eingeben, in deinen Fall war das glaub ich 7878. Musst mal probieren aber es sollte genügend Threads geben, die das erklären wie das geht.
thekiller1 is offline  
Old   #9
 
elite*gold: 7
Join Date: Jun 2011
Posts: 1,799
Received Thanks: 700
Du musst einen seperaten User anlegen und den MySQL Server für externe Zugriffe konfigurieren. Der User muss korrekt spezifiziert werden, ansonsten kannst du dirch trotz korrekter Konfiguration des MySQL-Servers nicht verbinden ->
Zypr is offline  
Old   #10
 
elite*gold: 140
Join Date: Aug 2009
Posts: 200
Received Thanks: 32
Quote:
Originally Posted by .interp View Post
Du musst einen seperaten User anlegen und den MySQL Server für externe Zugriffe konfigurieren. Der User muss korrekt spezifiziert werden, ansonsten kannst du dirch trotz korrekter Konfiguration des MySQL-Servers nicht verbinden ->
Er hat doch bereits seinen "User" angelegt, er benutzt den Admin dazu.
<?php
// Database settings
define('DB_HOST', 'localhost');
define('DB_USER', 'root');
define('DB_PASS', 'mein pw');
define('DB_NAME', 'auth');

// Soap settings
define('SOAP_IP', '127.0.0.1');
define('SOAP_PORT', '7878');
define('SOAP_USER', 'admins');
define('SOAP_PASS', 'admins');

Oder sehe ich das falsch?
thekiller1 is offline  
Old   #11
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
ich nutze prinzipiell root als user ja
devisions is offline  
Old   #12
 
elite*gold: 7
Join Date: Jun 2011
Posts: 1,799
Received Thanks: 700
Quote:
Originally Posted by thekiller1 View Post
Er hat doch bereits seinen "User" angelegt, er benutzt den Admin dazu.
<?php
// Database settings
define('DB_HOST', 'localhost');
define('DB_USER', 'root');
define('DB_PASS', 'mein pw');
define('DB_NAME', 'auth');

// Soap settings
define('SOAP_IP', '127.0.0.1');
define('SOAP_PORT', '7878');
define('SOAP_USER', 'admins');
define('SOAP_PASS', 'admins');

Oder sehe ich das falsch?
Ja, du siehst das falsch. Wenn man von extern zugreifen möchte, muss ein spezifizierter Benutzer erstellt werden. Wenn man also von einem Server mit der IP 123.123.123.123 und dem Host hostname.de connecten möchte, dann muss der entsprechende Benutzer erstellt werden:

Code:
CREATE USER 'beispieluser'@'123.123.123.123' IDENTIFIED BY 'test';

oder

CREATE USER 'beispieluser'@'hostname.de' IDENTIFIED BY 'test';
Der root Benutzer ist standardmäßig nur an den localhost und an den hostname des Servers gebunden, auf dem der MySQL-Server installiert worden ist.

Für externen Zugriff muss die my.cnf konfiguriert und der entsprechende Benutzer erstellt werden, sonst wird das nichts.


Quote:
Originally Posted by devisions View Post
ich nutze prinzipiell root als user ja
Du solltest damit aufhören, zumindest was MySQL angeht.
Zypr is offline  
Thanks
1 User
Old   #13
 
elite*gold: 0
Join Date: Mar 2015
Posts: 6
Received Thanks: 0
ah ok das is nen punkt der mir definitiv weiter hilft danke


devisions is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Keine Verbindung zum Server möglich
Hello there, klingt natürlich nach voll dem Anfängerproblem, ist es irgendwie auch. Unser Router ging gestern drauf, haben heute 'ne neuere...
5 Replies - Metin2 PServer - Discussions / Questions
Keine Verbindung zum server möglich
Yoar, neues Problem: Wenn ich mich jetzt einlogge verzögert sich der login extrem, es steht ewig dran "Du wirst mit dem Server verbunden.." und...
0 Replies - Metin2 PServer - Discussions / Questions
[B.net] keine verbindung möglich
hi leute... wollte eben WoW starten... nix passiert - 1 minute später kommt dann "der launcher kann die patch-infomation nicht abrufen" ich...
1 Replies - WoW Main - Discussions / Questions
Wolfteam : Keine Verbindung Möglich?
Hallo leute hab mir heut ma wolftteam gedownloadet, beim start seht da: Eine verbindung mit den Spielservern ist nicht möglich. Bitte versuche es...
2 Replies - Wolfteam
Homepage keine Verbindung möglich!!
Hey, ich habe jetzt ein Problem mit meiner Hamachi Homepage..ich hab sie soweit sogut fertig gestellt und ICH kann auch drauf connecten..nur leider...
1 Replies - Metin2 PServer - Discussions / Questions



All times are GMT +2. The time now is 02:58.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.