Register for your free account! | Forgot your password?

You last visited: Today at 01:06

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Release] The new XYZ 2 | 3.3.5

Closed Thread
 
Old   #121

 
elite*gold: 1
Join Date: Feb 2009
Posts: 6,356
Received Thanks: 7,937
Quote:
Originally Posted by theredvex View Post
16K bei mir
und bei meiner freundin Kabel.
Hm, dann verstehe ich nicht, wieso du so schnell Disconnects bekommst. Wobei, was hast du durchschnittlich für eine Framerate (ingame STRG+R drücken)?

Quote:
Originally Posted by mrkoolguy View Post
If only this was English >.< seriously what language is this site?!
There is an english translation on the bottom of the mainpost



Ende! is offline  
Thanks
1 User
Old   #122
 
elite*gold: 0
Join Date: Aug 2009
Posts: 22
Received Thanks: 9
Thanks for the update Ende! actually i havnt errors now in win7 x64


dalflaon is offline  
Old   #123
 
elite*gold: 97
Join Date: Jun 2007
Posts: 2,246
Received Thanks: 4,850
Quote:
Originally Posted by Ende! View Post
Hm, dann verstehe ich nicht, wieso du so schnell Disconnects bekommst. Wobei, was hast du durchschnittlich für eine Framerate (ingame STRG+R drücken)?
Welche Funktion verwendest du denn zum Versenden der Pakete? SendMovementPacket oder die normale SendPacket Funktion?

Bin gerade zu faul zum Nachschauen wie du es gelöst hast.

Der Server erwartet zumindest immer genau die richtigen Movementflags, ein einfaches 0x1 und ein 0x0 als Stop Flag wird nicht reichen, wenn er z.B. Levitieren aktiv hat, die Levitieren Flags müssten immer mitgesendet werden.

Ansonsten ist Teleportation durch Wasser natürlich recht gefährlich.
Cencil is offline  
Thanks
1 User
Old   #124

 
elite*gold: 1
Join Date: Feb 2009
Posts: 6,356
Received Thanks: 7,937
Quote:
Originally Posted by Cencil View Post
Welche Funktion verwendest du denn zum Versenden der Pakete? SendMovementPacket oder die normale SendPacket Funktion?

Bin gerade zu faul zum Nachschauen wie du es gelöst hast.

Der Server erwartet zumindest immer genau die richtigen Movementflags, ein einfaches 0x1 und ein 0x0 als Stop Flag wird nicht reichen, wenn er z.B. Levitieren aktiv hat, die Levitieren Flags müssten immer mitgesendet werden.

Ansonsten ist Teleportation durch Wasser natürlich recht gefährlich.
Ich benutze (atm noch) SendMovementPacket. Die Position wird mit jedem MSG_MOVE_HEARTBEAT um genau 0.137 Einheiten verschoben, sodass das Movement Flag noch nicht nötig ist. Allerdings kommen so relativ viele Pakete zusammen. Sobald ich herausgefunden habe, warum meine CDataStore Klasse bei jeder Verwendung eine Access Violation hervorruft, werde ich mal auf die Verwendung von SendPacket umsteigen, damit ich selbst das Movement Flag setzen kann


Ende! is offline  
Thanks
1 User
Old   #125
 
elite*gold: 97
Join Date: Jun 2007
Posts: 2,246
Received Thanks: 4,850
Quote:
Originally Posted by Ende! View Post
Ich benutze (atm noch) SendMovementPacket. Die Position wird mit jedem MSG_MOVE_HEARTBEAT um genau 0.137 Einheiten verschoben, sodass das Movement Flag noch nicht nötig ist. Allerdings kommen so relativ viele Pakete zusammen. Sobald ich herausgefunden habe, warum meine CDataStore Klasse bei jeder Verwendung eine Access Violation hervorruft, werde ich mal auf die Verwendung von SendPacket umsteigen, damit ich selbst das Movement Flag setzen kann
Ah dachte teleportierst ein wenig weiter pro Paket, kann es ja leider unter XP nicht testen MSG_MOVE_HEARTBEAT wird allerdings nur alle 500 ms vom Server erwartet.
Cencil is offline  
Old   #126

 
elite*gold: 1
Join Date: Feb 2009
Posts: 6,356
Received Thanks: 7,937
Quote:
Originally Posted by Cencil View Post
Ah dachte teleportierst ein wenig weiter pro Paket, kann es ja leider unter XP nicht testen MSG_MOVE_HEARTBEAT wird allerdings nur alle 500 ms vom Server erwartet.
Das scheint ihn aber relativ wenig zu stören :>
Ende! is offline  
Old   #127
 
elite*gold: 0
Join Date: Jul 2010
Posts: 7
Received Thanks: 0
Hallo,
habe heute euer Forum entdeckt und bin auf dieses interessant wirkende Tool gestoßen.
Habe den Thread auch schon mehrfach gelesen, doch die Antwort auf meine Frage leider noch nicht entdeckt.
Bei mir schließt sich das Fenster auch sofort wieder, und in WOW erscheint nichts.
System: Win7 x64
DirectX: 10
vcredist_x64 installiert
Wenn ich WoW schließe und dann das Prog starte, dann wartet er auf WOW dann verschwindet das Fenster.

Könnt Ihr mir einen Tipp geben. wäre sehr nett!

Nun noch einen schönen Samstag
empe3master is offline  
Old   #128

 
elite*gold: 1
Join Date: Feb 2009
Posts: 6,356
Received Thanks: 7,937
Quote:
Originally Posted by empe3master View Post
Hallo,
habe heute euer Forum entdeckt und bin auf dieses interessant wirkende Tool gestoßen.
Habe den Thread auch schon mehrfach gelesen, doch die Antwort auf meine Frage leider noch nicht entdeckt.
Bei mir schließt sich das Fenster auch sofort wieder, und in WOW erscheint nichts.
System: Win7 x64
DirectX: 10
vcredist_x64 installiert
Wenn ich WoW schließe und dann das Prog starte, dann wartet er auf WOW dann verschwindet das Fenster.

Könnt Ihr mir einen Tipp geben. wäre sehr nett!

Nun noch einen schönen Samstag
Lad dir einfach mal DirectX neu herrunter, das hat bei vielen Leuten geholfen
Ende! is offline  
Thanks
1 User
Old   #129
 
elite*gold: 185
Join Date: May 2008
Posts: 3,646
Received Thanks: 603
Hast du noch vor iwelche features einzubauen?
epiTR is offline  
Old   #130

 
elite*gold: 1
Join Date: Feb 2009
Posts: 6,356
Received Thanks: 7,937
Quote:
Originally Posted by dasr2142 View Post
Hast du noch vor iwelche features einzubauen?
Ich bin für jeden Vorschlag offen, was würdest du denn gerne noch haben?
Ende! is offline  
Thanks
2 Users
Old   #131
 
elite*gold: 0
Join Date: Jan 2010
Posts: 29
Received Thanks: 1
Moinsen mal ne Frage,
was wäre wenn ich mit XYZ mir bluthibiskus erfarme und dabei keine bosse Töte.
Wäre das Safe ? :P
Oharu is offline  
Old   #132
 
elite*gold: 0
Join Date: Jul 2010
Posts: 7
Received Thanks: 0
Genau!
Vielen Dank, DirectX neu eingespielt und es funktioniert! Danke !
empe3master is offline  
Old   #133
 
elite*gold: 0
Join Date: Jul 2009
Posts: 55
Received Thanks: 8
hab jetzt auf die schnelle nichts gefunden, aber ist es normal das man sich nur so langsam "portet"?
und wenn ichs schneller stell und dann porte krieg ich nen dc
Icyy is offline  
Old   #134
 
elite*gold: 1
Join Date: Sep 2009
Posts: 107
Received Thanks: 47
kanns auch ned =(
TFlash is offline  
Old   #135
 
elite*gold: 14
Join Date: Apr 2010
Posts: 489
Received Thanks: 188
Quote:
Originally Posted by Ende! View Post
Ich bin für jeden Vorschlag offen, was würdest du denn gerne noch haben?
click to port click to port click to port !


Fake. is offline  
Closed Thread

Tags
3.3.5a, tnxyz, xyz



« Previous Thread | Next Thread »



All times are GMT +1. The time now is 01:06.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.