Register for your free account! | Forgot your password?

Go Back   elitepvpers > Star Wars: The Old Republic > SWTOR Hacks, Bots, Cheats & Exploits
You last visited: Today at 13:00

  • Please register to post and access all features, it's quick, easy and FREE!

 

[Beta] UntzBot (Space Missions Bot, recorder+player)

Reply
 
Old   #631
 
elite*gold: 0
Join Date: Jul 2011
Posts: 22
Received Thanks: 0
I have a not so oustanding record of 54-34 on republic drexel, mostly because of failed event sync. So i sort of confirm about the loading times problem, it still works sometimes. A small suggestion to improve event sync: multiple events at start (also verify by reading the timer above that you found it at about the right time, sometimes it will think it found an event way later in the mission, and then proceeds to fail it) and resynchs later during the mission (mostly during small breaks in it).



Ganondorf7 is offline  
Old   #632
 
elite*gold: 0
Join Date: Mar 2012
Posts: 3
Received Thanks: 0
a nice addition to the crew skills bot would be to allow selecting a primary and secondary skill so that if there are only say 3-4 missions but your sending out 5 guys, it goes to the secondary mission to do a skill there. Also, now that the robot can gain affection, and you can buy a sensor unit to give him boosts to the specific crew skills you have, it might be smart to select the bottom guy instead of scrolling down and selecting the guy above the bottom when you select 5 members. This would also solve the problem of selecting 5 crew members when you only have 5. I did this before getting the 6th on a char, and it wouldnt send out the 5th guy probably because of the mechanic listed above.

Nice work philz, keep it up.

##### thephilz #####

any chance you could respond to this? especially the part about sending out 5 crew members when you only have 5


CFraychineaud is offline  
Old   #633
 
elite*gold: 0
Join Date: Jan 2010
Posts: 5
Received Thanks: 0
my timer sync on the lvl 40 mission worked 106 out of 3 very nice !
nicedreamsbt is offline  
Old   #634
 
elite*gold: 0
Join Date: Mar 2012
Posts: 8
Received Thanks: 0
Hey Philz, im not sure if this is just isolated to my laptop (not the greatest performance) but after going 47-26 last night (always run clouds, its the best credit-per-second) I decided to check out the log.

I'm on timer sync at it was starting anywhere between 33750ms - 3580ms after worldmap. Anything between 33750 - 34040 was a WIN, anything higher than 34040 was a LOSS. Curious if it may be possible to include a MIN and MAX value in the bot (under no circumstances start BEFORE X-afterworldmap and not AFTER x-afterworldmap...the X being the MS value and if it were to reach the AFTER ms value the bot would just start without a delay)

Or maybe you could shine some light on why my MS would vary so much


EDIT: or perhaps just setting an auto correct delay...for every 100MS difference in start time from recorded start the delay would respectably adjust itself up or down?
Thanks!


mindgame18 is offline  
Old   #635
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
Quote:
Originally Posted by mindgame18 View Post
Hey Philz, im not sure if this is just isolated to my laptop (not the greatest performance) but after going 47-26 last night (always run clouds, its the best credit-per-second) I decided to check out the log.

I'm on timer sync at it was starting anywhere between 33750ms - 3580ms after worldmap. Anything between 33750 - 34040 was a WIN, anything higher than 34040 was a LOSS. Curious if it may be possible to include a MIN and MAX value in the bot (under no circumstances start BEFORE X-afterworldmap and not AFTER x-afterworldmap...the X being the MS value and if it were to reach the AFTER ms value the bot would just start without a delay)

Or maybe you could shine some light on why my MS would vary so much


EDIT: or perhaps just setting an auto correct delay...for every 100MS difference in start time from recorded start the delay would respectably adjust itself up or down?
Thanks!
the whole point of the log was for this very purpose, however it is not very 'clear' what the fail/pass conditions are

for example, here is one of my latest logs:

SUN 15/04/2012 09:16:35 -- Event Sync started 15179 ms after galaxy map.
SUN 15/04/2012 09:19:26 -- BAIL - Death Screen Found - Bails:2

SUN 15/04/2012 10:02:15 -- Event Sync started 15116 ms after galaxy map.
SUN 15/04/2012 10:05:42 -- WIN -> 64/1

SUN 15/04/2012 11:51:25 -- Event Sync started 15070 ms after galaxy map.
SUN 15/04/2012 11:54:12 -- BAIL - Death Screen Found - Bails:3

SUN 15/04/2012 11:47:12 -- Event Sync started 15195 ms after galaxy map.
SUN 15/04/2012 11:50:40 -- WIN -> 89/1

as you can see here,

15070 = fail
15116 = win
15179 = fail
15195 = win

so its not 100% accurate. at this point in time, the log is just there for .. well, being a log, really, and seeing how the bot went over time or something (it doesnt really have a use, i just thought it was nifty)
thephilz is offline  
Old   #636
 
elite*gold: 0
Join Date: Mar 2012
Posts: 8
Received Thanks: 0
could be different issues then. Mine seems pretty linear. I've watched the bot and all the missions that started after the threshold(it seems) the cursor was just lagging slightly behind...enough to fail.

my log doesn't have any over my 34040 that was a win
mindgame18 is offline  
Old   #637
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
Quote:
Originally Posted by mindgame18 View Post
could be different issues then. Mine seems pretty linear. I've watched the bot and all the missions that started after the threshold(it seems) the cursor was just lagging slightly behind...enough to fail.

my log doesn't have any over my 34040 that was a win
a dodgy workaround, but try moving the delay just by -100
being slightly early is always the better option

by default, on this **** computer, i have all missions set to 1800, even though i record ON THIS COMPUTER at 2000 (all default missions included in downloads use the files from this computer). i really dont know why that is, but that just is. however, when using THE SAME FILES on my brothers better computer, i can keep the delay there at 2000 and it works perfect.

/shrug

i am currently in the process of making event files for all missions (except maybe the minefield, but ill see), and will include them in the next update (or as a temporary download until the next update is available)
thephilz is offline  
Old   #638
 
elite*gold: 0
Join Date: Mar 2010
Posts: 240
Received Thanks: 10
Looking fo all the republic missions...
Iggy808 is offline  
Old   #639
 
elite*gold: 0
Join Date: Feb 2012
Posts: 7
Received Thanks: 0
After some tweaking I got mine to work for v5.0.

My only issue is crew skill. Somehow when it wants to click on finished missions on top right, it clicked the top bar instead and made my window full screen. I am not sure if it is mine only because I know with 125% dpi my topbar is much bigger.

Here are some tips:
  1. Debugger is broke for me. I don't use it
  2. Go to your normal resolution, mine is 1920x1080. Default interface. Open Editor. Move the mini map all the way to the right
  3. Set resolution to 800x600 and gfx = very low.
  4. Launch Untzbotz5
  5. Press Q for window to resize
  6. Make sure you are using the update Default UI with mini-map moved all the way to the right. You cannot move the minimap in 800x600 resolution. Do it in step 2.
  7. Re-record missions if you have to
  8. Some missions like Ezran28 have changed time. So for timer sync, you need to print screen a new one

Any funny bug I experienced.

Empire here. Missions that I run with my Warrior is different than BH, Inq or IA. Somehow my warrior space mission do not like those recorded with the other 3 classes. Those 3 recorded works for all of them.

I have to record separate timing for warrior. Anyone having similar issues?

Proton torpedos are kinda broke especially for Clouds44 missions. Remove them from your ship if you are recording Clouds44. Missiles wont fire if the proton reticule is over the shield generators.
egoadk is offline  
Old   #640
 
elite*gold: 0
Join Date: Apr 2012
Posts: 10
Received Thanks: 1
I ran the Jabiim mission flawlessly nearly 100 times. I had to close the bot to reboot my PC and when I fired it up again to continue Jabiim runs it will not run the script. The bot runs and mission loads, but it never identifies the event image (I assume). Any tweaks that can be made on my end? Or maybe new event images that I can inject? So I don't have to keep making recordings over and over?
cartoonchikn is offline  
Old   #641
 
elite*gold: 0
Join Date: Mar 2012
Posts: 8
Received Thanks: 0
IDK what's going on .... can't really use this anymore. It's as if the recording itself and lagging behind.

56/48 last night. Was running pretty solid 90+/1-2 before patch.
mindgame18 is offline  
Old   #642
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
Quote:
Originally Posted by mindgame18 View Post
IDK what's going on .... can't really use this anymore. It's as if the recording itself and lagging behind.

56/48 last night. Was running pretty solid 90+/1-2 before patch.
its mainly 1.2's fault

long story short : the loading time for each mission has been increased (or, just takes longer to load in general)

what this means is that during the intro sequences, things still are 'loading' (like the backgrounds, ships suddenly appearing out of nowhere, rocks appearing etc) which throws off sync by a tiny bit, which is enough to cause the mission to fail, if unlucky

to fix this, im going ahead and changing all event/timer syncs to be LATER into the mission, which means everything should be 'loaded' already and thus cause no 'loading lag' and hopefully makes it better

timer sync is more useful right now, if you can get it to work, but higher end computers are fine with event sync, if they can load everything fast enough

here is all the republic missions resynced and re-recorded, not using any ship mods, but dont expect the higher level missions to be perfect as i sort of had to rush through (seriously i spent like 5 hours doing this, i got REALLY bored) the last few, but you can easily use the new sync to re-record if you need to

im working on empire event sync now, then will re-do timer sync as well
Attached Files
File Type: zip Republic50.zip (308.6 KB, 38 views)
thephilz is offline  
Old   #643
 
elite*gold: 0
Join Date: Sep 2010
Posts: 142
Received Thanks: 134
hoooly **** my stupid webserver for version checking is down, AGAIN

at the moment the current version is still 5.0

.. yeah, in the next update im going to change the webserver, this is getting ridiculous, sorry about this guys

ill make a new update probably wednesday that SHOULD include imperial missions, and maybe something extra, if i have time
thephilz is offline  
Old   #644
 
elite*gold: 0
Join Date: Feb 2012
Posts: 83
Received Thanks: 3
THX
Plumsi is offline  
Old   #645
 
elite*gold: 0
Join Date: Mar 2012
Posts: 8
Received Thanks: 0
Unfortunately (for me I guess) I already assumed these issues and was using timer sync that started WAY late (to be specific, 3:01 in clouds. It loads up around 3:28). I assumed it was all still loading. Even started that late didn't help. Sometimes it seems the cursor goes in areas I wouldn't even be near lol.


mindgame18 is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Beta player gesucht!!!
Hey, ich suche ein paar beta spieler für meinen minecraft root server 1.1 soweit steht schon ein großteil an gebäuden jedoch suche ich noch 4 beta...
1 Replies - Minecraft Server Advertising
Minecraft 1.7.3 Beta: Not enough space
Hallo! Also, ich habe Minecraft Beta 1.7.3, und benutze den Mod ,,Millionaire´´. In dem Mod bauen ja andere was für dich. Auf dem Schild steht was...
2 Replies - elite*gold Trading
Do The TP Missions And get 2000 TP/Missions
Free File Hosting & Video Downloads, Free File Sharing, Online Friends Network - Ziddu OK. i know all of you is understand using fiddler2.. no...
6 Replies - Facebook



All times are GMT +2. The time now is 13:00.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.