Register for your free account! | Forgot your password?

Go Back   elitepvpers > Popular Games > Silkroad Online > SRO Private Server > SRO PServer Guides & Releases
You last visited: Today at 22:10

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement


[Tutorial]Silkroad Online C# Emulator Project From Lyzerk

Discussion on [Tutorial]Silkroad Online C# Emulator Project From Lyzerk within the SRO PServer Guides & Releases forum part of the SRO Private Server category.

Closed Thread
 
Old 01/14/2010, 16:53   #526
 
elite*gold: 0
Join Date: Apr 2009
Posts: 1
Received Thanks: 0
Quote:
Originally Posted by spozel View Post
Hey i have this Error when i start the Login-Server. I use Windows 7 as u can see.



Having the same problem here with W7 x64 machine. Framework 2.0 and 3.5 are both installed. Even tried the comp. mode with Vista and XP and run as admin.

Out of ideas. Little hint would be nice.
Devilfromroof is offline  
Old 01/14/2010, 19:46   #527
 
elite*gold: 0
Join Date: Apr 2008
Posts: 378
Received Thanks: 32
i get an C9 error pls help and when i just start the Login server its show me The user is already connected pls help me
stas123456 is offline  
Old 01/14/2010, 19:56   #528
 
elite*gold: 0
Join Date: Jun 2007
Posts: 111
Received Thanks: 22
where to find the newest ver of this emu? any1 can tell me?
ranggadaikuasa is offline  
Old 01/14/2010, 22:36   #529
 
elite*gold: 0
Join Date: May 2008
Posts: 201
Received Thanks: 73
Nothing. He only develop it non public. He will sell it when he finished it. Only 10000 dollars.
GoneUp is offline  
Old 01/15/2010, 18:28   #530
 
elite*gold: 0
Join Date: Mar 2009
Posts: 443
Received Thanks: 597
Quote:
Originally Posted by cheater94x View Post
Nothing. He only develop it non public. He will sell it when he finished it. Only 10000 dollars.
...bullshit. lyzerk stopped working on it
Shadowz75 is offline  
Old 01/15/2010, 21:07   #531
 
elite*gold: 20
Join Date: Aug 2007
Posts: 1,709
Received Thanks: 1,609
Quote:
Originally Posted by Shadowz75 View Post
...bullshit. lyzerk stopped working on it
No he didn't He stoped working on the public one.. Well cuz of the leeched source He's still working on an emulator
Windrius is offline  
Old 01/16/2010, 00:56   #532
 
elite*gold: 0
Join Date: Mar 2009
Posts: 443
Received Thanks: 597
Quote:
Originally Posted by Windrius View Post
No he didn't He stoped working on the public one.. Well cuz of the leeched source He's still working on an emulator
still working since summer 2009? nice progress
Shadowz75 is offline  
Old 01/16/2010, 08:08   #533
 
elite*gold: 20
Join Date: Aug 2007
Posts: 1,709
Received Thanks: 1,609
Quote:
Originally Posted by Shadowz75 View Post
still working since summer 2009? nice progress
He has quite good progress
Windrius is offline  
Old 01/16/2010, 13:54   #534
 
elite*gold: 0
Join Date: Jul 2009
Posts: 29
Received Thanks: 1
Unhappy

Quote:
Originally Posted by DoubleDTheGreat View Post
Since many many people are complaining about how they can't make it work, i actually had a hard time figuring out as well, but let me clear this mess up.

First of all,

Credits for the Emulator to Lyzerk

I have nothing to do with the emulator, i did in NO way contribute to the work for this emulator, so give the credits to Lyzerk.

Let's start

First of all before i start my own Tutorial, i'll pass the link for Video Tutorial made by Lyzerk

So please be KIND and give thanks to Lyzerk as well (The first post on the thread)

Click the following link to open the youtube tutorial video!


Step 1 (Downloading)
First of all, this is what you need:


Silkroad Legend 3 + v1.176 Client (thanks to silkbotter for the links)

MySql 5.1 (Click on " No thanks, just take me to the downloads!" once you click the link) -
.Net Connector (Select MySql.Data.Rar file) -
Navicat -
.Net framework 2.0 - Click!
Emulator -
Media Patcher -
Launcher (Select Silkroad.rar to download, unrar to Silkroad folder)
Once you downloaded the following stuff, install it following the step 2

Step 2 (Installing)

- Edut your hosts file

Open your hosts file found in C:\WINDOWS\system32\drivers\etc
And add this at the end





- Install MySql 5.1
Select Typical installation, install, once you installed, mark the server instance configuration wizard and click Finish, now you are at the Server Config wizard, use Detailed Configuration, Developer machine, Multifunctional Database, (DSS)/OLAP, Leave Marked 'Enable TCP/ip Networking' With default port, leave Strict Mode Marked as well, Use Standard Character Set, Leave ''Install as WIndows Service'' mark marked along with Launch the MySql server Automatically, now UNMARK 'Modify Security Settings' and click Next then Execute

- Install MySql Connector Net
Nothing much to talk about this one, just choose Typical and install it.

- Install Navicat
Nothing much to talk about this one either

Step 3 (Configuring)

The hardest step actually, just follow my steps and u'll be aight.

- Open Navicat
- Click on Connection

Fill in the following


In case you get Access Denied to connect to LocalHost, try to start MySql Command Line Client, and see if it asks you for password, if it does that means you previously entered a password, and in that case u'll have to add a password to the Picture Above.
This is how to reach the Command Line, use Start!


Once you clicked ok, you should see the following picture

**IMAGE REMOVED DUE TO IMAGE HOSTING SERVICE IMAGE LINK BREAKDOWN**

Right Click localhost, and select Open Connection just like on the picture

**EDITED PICTURE, HOSTING PICTURE PROVIDER MESSED UP**

Now Once you opened it, Right Click localhost again and select ''New Database..''

Fill in the following stuff in the window that pops out



Then Right Click emulator and click Open Database (Just like on the picture above)



Now Right Click on emulator again and choose ''Execute Batch File...'' (Just like on the picture above)



And try to find the emulator.sql in your Database folder from the emulator you previously Downloaded.

Once you found it and selected it, press start and wait for the progress till it fills to the end (Should take around 5mins depending on pc specs)

Now once it's completed, just press the Close button and proceed to Navicat again.
Left Click on Emulator, and On the right u'll see 'serverlar' table, Double Click It.
Now a window is going to pop out, and now do the following thing.
Press the + You see on the top left window of the opened table.
**IMG REMOVED DUE TO IMAGE HOSTING SERVICE BREAKDOWN**

Now simply edit the settings to the settings you see on the following picture.


If you didn't download the MediaPatcher, do it now by clicking on this link

Now Download the Media Patcher and put it in your silkroad folder.
Once you downloaded it, write down the path to your silkroad Media.pk2 in the first line you see, just like i did in the picture above, and write down the same ip's just as i did on the picture



Now Click Patch and do the final step.
Proceed to your Extracted Emulator Folder, and make sure the following .ini files have these ip's in it

Game Server server.ini



Login Server server.ini



Now Start the GameServer.exe from your Emulator server, then LoginServer.exe
And using the launcher you've left in your silkroad folder, double click it and it shall start.

Note: Navicat needs to be open whole time!


Default Username is: lyzerk
Default Password is: test


Press thanks if this tutorial helped you, i'll keep the thread updated every day.

Features & Ingame Commands
[Login Server]
- Delete Character

[On Game]
- Movement
- MultiPlayer (Works but crashes a lot)
- Chat
- Emote,Light,Char State(Walk,run,sit etc..)

[Skills Buffs and Attacks]
- Open Skill
- Up Mastery
- Normal Attack
- Skills
- Imbue (Some of the imbues working)

[Monsters]
- Spawn Monster
-Uniques.
- Attack to Player
- Monster Death..

[Items]
- You can use potions
- Male Female Restrictions
- Level Restriction
- Fixed Glavie & Shield Bug
- Inventory Item Moving, Equipping & Unequipping
- Working Blues (Must be added through DB)

[Ingame GM Console]
To open an Ingame Console, once you log ingame, press Shift + Alt as much times as needed until you switch you keyboard language to US (Unitated States), Or UK (English).
Once you switch, press Shift + ~ (The button left from 1) till the Console pops out.

[Working Gm Commands]
"/LOADMONSTER MOB_OA_ONG 4" To spawn a Giant Ong.
"/MAKEITEM ITEM_CH_SWORD_09_C 9" to make it 9d + 9 sword
"/MOBKILL 1" Selected Monster to kill
"~" Notice (E.g: ~Test)

Have Problems? Read this

access denied for user 'root'@'localhost'


This mostly happens if a firewall is blocking the Navicat from connecting to your Localhost (127.0.0.1), try turning off the firewall, if it still doesn't work, try the following.
Open MySql Command Line Center, if it prompts you for a password, try to use the one you've set when you had the previous version of MySql installed.
This is how to reach command line, use the Start button!

Incase you did use the password, just add the password to the Connection tab, and leave the username ''Root''.
In that case u'll have to change .ini files in the LoginServer & GameServer Folders.

Send/Don't Send when starting Login/Game server.exe


That mostly happens if you don't have an connection to the Localhost established using Navicat, so basically make sure it's established or if you are using Vista, Righ click the file, Run As: Administrator.
Another reason why this COULD be happening is .Net Framework version 2.0, if you don't have it, install it then try again.

Getting <Hata> Errors?


Hata errors are related to wrong ports/ip's, so make sure your server table is identical as mine, along with your game and login server, server.ini files



===============================

HI i have 1 problem



PLSSS HELP ME!!
csdi is offline  
Old 01/16/2010, 14:10   #535
 
elite*gold: 0
Join Date: Sep 2009
Posts: 516
Received Thanks: 434
Quote:
Originally Posted by csdi View Post
===============================

HI i have 1 problem



PLSSS HELP ME!!
You must edit the Server id to "0", and the ip to 127.0.0.1
CraYu is offline  
Thanks
1 User
Old 01/16/2010, 14:37   #536
 
elite*gold: 0
Join Date: Jul 2009
Posts: 29
Received Thanks: 1
I do not know what you mean

You have skype??

For help me??
csdi is offline  
Old 01/16/2010, 14:59   #537
 
elite*gold: 0
Join Date: Sep 2009
Posts: 516
Received Thanks: 434
Quote:
Originally Posted by csdi View Post
I do not know what you mean

You have skype??

For help me??
Ok first you open "Navicat"
then you go to the database "emulator"
Open the table "serverlar"
you find id and change it to 0
it looks something like that
CraYu is offline  
Thanks
1 User
Old 01/16/2010, 15:19   #538
 
elite*gold: 0
Join Date: Jul 2009
Posts: 29
Received Thanks: 1
any settings but I just had to id 1 is not a

csdi is offline  
Old 01/16/2010, 15:51   #539
 
elite*gold: 0
Join Date: Jul 2009
Posts: 29
Received Thanks: 1
I did like you said but still I do not get the server and image ... what I gotta do to my work???


csdi is offline  
Old 01/16/2010, 17:21   #540
 
elite*gold: 0
Join Date: Jul 2009
Posts: 29
Received Thanks: 1
PLSSS WHO HELP ME?? ( =(

csdi is offline  
Closed Thread

Tags
silkroad, silkroad emulator, silkroad hack




All times are GMT +2. The time now is 22:10.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2021 elitepvpers All Rights Reserved.