Register for your free account! | Forgot your password?

You last visited: Today at 23:47

  • Please register to post and access all features, it's quick, easy and FREE!


Chatbox lamps

Closed Thread
 
Old   #1
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Exclamation Chatbox lamps

i have really weird problem that when i press on #Party the @GuiLD's lamp turn on and when press on @GuiLD the #Party's lamp turn on, how can i fix that so when i press #party the #party's lamp turn on and same for @GuiLD, because its really bad&weird problem,

Thanks in advanced.



alydandy is offline  
Old 02/22/2018, 20:07   #2
 
elite*gold: 0
Join Date: Jul 2009
Posts: 1,788
Received Thanks: 655
He actually has a valid point.
There is no known solution to this little visual bug, neither via resinfo data nor 2dt manipulation.

Example:


I had it once "fixed", but cannot remember if it was while having a different executable or regular media-file mixing and matching. One or another has messed up this thing. I was not paying any attention to this for years, since it never bothered me nor my players.

As far as I am concerned about the usual "mystery" of silkroad ****-ups, this might be a hardcoded issue. For example, the skill window has its design ratio and co also hardcoded, same for its accessible tab-amount and many more.


Little Update:
If locking down the chat window, disabling its fade-away via the button right next to the "All Chat", "Lock Chat window/Auto hide" and clicking at Party / Guild, the lamps will be shown correctly, as far as your pointer (mouse) is still hovering above the ID:1 render (chat window complexity).
Moving the mouse somewhere else will render the wrong chat-lamp indicator, once again.

So, definitely a wrong coded **** by Joymax inside the client itself, not fixable via easy file editing.


blapanda is offline  
Thanks
3 Users
Old 02/23/2018, 03:56   #3
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by blapanda View Post
He actually has a valid point.
There is no known solution to this little visual bug, neither via resinfo data nor 2dt manipulation.

Example:


I had it once "fixed", but cannot remember if it was while having a different executable or regular media-file mixing and matching. One or another has messed up this thing. I was not paying any attention to this for years, since it never bothered me nor my players.

As far as I am concerned about the usual "mystery" of silkroad ****-ups, this might be a hardcoded issue. For example, the skill window has its design ratio and co also hardcoded, same for its accessible tab-amount and many more.


Little Update:
If locking down the chat window, disabling its fade-away via the button right next to the "All Chat", "Lock Chat window/Auto hide" and clicking at Party / Guild, the lamps will be shown correctly, as far as your pointer (mouse) is still hovering above the ID:1 render (chat window complexity).
Moving the mouse somewhere else will render the wrong chat-lamp indicator, once again.

So, definitely a wrong coded **** by Joymax inside the client itself, not fixable via easy file editing.
that's exactly my problem ,
so should i keep the topic opened and wait for answer or should i just disable all the lamps and close the topic ?
alydandy is offline  
Old 02/23/2018, 13:43   #4
 
elite*gold: 0
Join Date: Apr 2008
Posts: 458
Received Thanks: 585
Actually, its not that hard to do ... Kappa



(Yes, all of this stuff is done in IDA, but you can do it in OllyDBG or x64dbg aswell. Cheat Engine might come in handy.)

TL;DR; x64dbg Patch File is appended.

When messing with the /frame-command in the interface, i recognized something odd. (This is not the frame command, its my own window. Its easier to capture.)


You cant really see the red box, but you can see the values in the window change. The active "lamp" is a recognized object, while the inactive lamp is not changed. The lead me to the conclusion that inactive lamps must be hidden/invisible.
From earlier days of debugging, i know that all CIF* Objects have a "IsVisible" Attribute.
My GUI told me the address of the active lamp (0x17412200).

I then set up a breakpoint on the "SetVisibility"-Function that would only trigger if its related to the lamp. (ECX == Address of Interface)




The breakpoint hit and the stack took me to a function of my interest:



Here we have the location of evil. A switch is "selecting" the correct lamp to show. I figured out all the lamps in the comments. We know the Party Chat and the Guild Chat Lamp are flipped, so the easiest fix at this point is to simply change the offsets 0x47C and 0x480. So that either the opposite lamp is turned on.





Both offsets should then look like this


Since Silkroads code is a huge mess, there may be other locations where this visibility is set :/
Tell me when you find a combination where its still wrong.
Attached Files
File Type: txt chat_lamp_fix.1337.txt (53 Bytes, 45 views)


florian0 is online now  
Thanks
15 Users
Old 02/23/2018, 16:20   #5
 
elite*gold: 0
Join Date: Jul 2009
Posts: 1,788
Received Thanks: 655
Quote:
Originally Posted by florian0 View Post
Tell me when you find a combination where its still wrong.
Megamax + Silkroad Source Files.
Fix this! This is the definition of ineffectivity!
blapanda is offline  
Old 02/23/2018, 20:23   #6
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by florian0 View Post
...
its working man u are a legend, now i have another popular problem that we all have it on our server iam talking about newbie once, this is the problem when a player try to use ADV there's no instruction in the warning box like this


but in other servers i see its working like this

i tried to copy the lines from textisystem but i faild, i tried manythings but i keep fail, so can u please tell me what should i copy exactly or what should i edit or you can just do it for me, sorry iam newbie in this scene and i offered this problem in alot of forums but seems like people newbies like me
so here is my textisystem
and the working one here its


Thanks in advanced
alydandy is offline  
Old 02/24/2018, 01:32   #7
 
elite*gold: 0
Join Date: Jun 2008
Posts: 464
Received Thanks: 128
textui............................................ ...................... again, try search before ask... this problem is caused by mismatch of language flag in sro_client, and textuisystem. You get this "bug" when you using old mixed textui and also using vsro sro_client with "english patch"..
janicka is offline  
Old 02/24/2018, 03:26   #8
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by janicka View Post
textui............................................ ...................... again, try search before ask... this problem is caused by mismatch of language flag in sro_client, and textuisystem. You get this "bug" when you using old mixed textui and also using vsro sro_client with "english patch"..
again you damnn, Sir please tell me a usefull answer that may help me or just dont spam comon, u have comments in all my topics with same kind of comment iam not asking why i do have the problem iam asking for a solution so commonnnnn! please

Please tell me what should i do if you knew in the first place
alydandy is offline  
Old 02/24/2018, 09:45   #9
 
elite*gold: 0
Join Date: Jul 2009
Posts: 1,788
Received Thanks: 655
Quote:
Originally Posted by alydandy View Post
again you damnn, Sir please tell me a usefull answer that may help me or just dont spam comon, u have comments in all my topics with same kind of comment iam not asking why i do have the problem iam asking for a solution so commonnnnn! please

Please tell me what should i do if you knew in the first place
Here is an example fixing your mess up or anyone else's wrong editing.

Make sure, that you have the correct tab.
The first 7 tabs are for different languages (marked in blue). You have to have your skill names, item names, skill tab names, and so on on the 8th tab, which is usually a standard on edited clients. If you miss a tab and have nothing being saved there, that will lead your client to display nothing, not a single letter or figure.

So, ensure that you have a correct indexing.

blapanda is offline  
Thanks
1 User
Old 02/24/2018, 10:17   #10
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by blapanda View Post
Here is an example fixing your mess up or anyone else's wrong editing.

Make sure, that you have the correct tab.
The first 7 tabs are for different languages (marked in blue). You have to have your skill names, item names, skill tab names, and so on on the 8th tab, which is usually a standard on edited clients. If you miss a tab and have nothing being saved there, that will lead your client to display nothing, not a single letter or figure.

So, ensure that you have a correct indexing.

SORRY BUT IAM LOST, iam trying to fix the message that pop up when i try to ues adv on item like i explained with those 2 images, do u speak about that or something else ? because i really can't understand, excuseme iam newbie on this scene, can u please explain more, like what should i do exactly to fix this and if u can do it, can u please do ? i have uploaded my textuisystem already ...
alydandy is offline  
Old 02/24/2018, 11:21   #11
 
elite*gold: 1
Join Date: Nov 2011
Posts: 2,524
Received Thanks: 1,342
He was talking about the spaces between the the name and the code, which I explained to you in another thread. Anyhow I attached your textuisystem below, check it out now
Attached Files
File Type: rar SHOULD WORK.rar (148.4 KB, 17 views)
Snow* is offline  
Thanks
1 User
Old 02/24/2018, 19:54   #12
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by Snow* View Post
He was talking about the spaces between the the name and the code, which I explained to you in another thread. Anyhow I attached your textuisystem below, check it out now
hell yeah you are here <3 u just made my day man, nah its not working , i tried all the types Armor-weapon-accessory-shield the instruction text dosn't exist still , can you please try again? , and yes u did explain to me once before with the invitation party thing, but what can i say, iam just newbie and iam learning i start that scene around 30 days ago, so comon iam a begginer, Thanks again mate for everything and best wishes in all ur dreams, iam waiting for ur replay..
alydandy is offline  
Old 02/25/2018, 09:20   #13
 
elite*gold: 0
Join Date: Jul 2009
Posts: 1,788
Received Thanks: 655
Quote:
Originally Posted by alydandy View Post
hell yeah you are here <3 u just made my day man, nah its not working , i tried all the types Armor-weapon-accessory-shield the instruction text dosn't exist still , can you please try again? , and yes u did explain to me once before with the invitation party thing, but what can i say, iam just newbie and iam learning i start that scene around 30 days ago, so comon iam a begginer, Thanks again mate for everything and best wishes in all ur dreams, iam waiting for ur replay..
You actually need some basic skills, like some regular text editing skills, for instance in excel. If you want to advance your game... You will clearly fail while struggling with the most easiest things what everyone should be capable of fixing, without being that heavily handicapped like you are.

Even the simple "no text shown" issue should be solved on one's own, since it just requires you to reorganize the text... As simple as it sounds, it is that simple and you still require the help of others.

So, do yourself a favor, and that is not to offend you: get some learning lessons about the most simple and easy things that the internet offers. Start with "how to use text editors". It will help you significantly.
blapanda is offline  
Thanks
1 User
Old 02/25/2018, 11:21   #14
 
elite*gold: 0
Join Date: Feb 2016
Posts: 458
Received Thanks: 11
Quote:
Originally Posted by blapanda View Post
You actually need some basic skills, like some regular text editing skills, for instance in excel. If you want to advance your game... You will clearly fail while struggling with the most easiest things what everyone should be capable of fixing, without being that heavily handicapped like you are.

Even the simple "no text shown" issue should be solved on one's own, since it just requires you to reorganize the text... As simple as it sounds, it is that simple and you still require the help of others.

So, do yourself a favor, and that is not to offend you: get some learning lessons about the most simple and easy things that the internet offers. Start with "how to use text editors". It will help you significantly.
first of all i want to ask you for ur way to help me i really appreciate it, but trust me i tried to fix it, beside iam kinda good in pc stuff in even editing stuff i did some edited to Skills aswell and i made some new GodBless Wings, so common iam not dat bad, every topic that i upload , i upload it after i try everything with it, you guys are kinda my last hope to fix the problem so when you say that , you are like giving me no hope to fix it ,because i did my moves, and not working...i am kinda good in icons, but iam not good at all in texts thing, so i already helped alot of people with edit icons,skills,etc stuff but i still need a help...anyway i will close the topic in this next 24 hours if i dont get a answer and i will keep it as no text then , since no1 want to help me, beside remmber ur early replay about its possible to change lamps then some one showup and fix it for all of us in just 2 seconds so common, try to help me, or just leave me alone man...i have already my sadness

fixedddddddd damnnnnnnnn iam proooo xD
Thanks to all of you guys i mean it <3 speciality thanks to my friend blapanda that almost in all my topics thanks man best wishes in ur life <3, and special thanks to Snow You are legend man, so i fixed it throw editing the line of UIIT_STT_SPECIAL_ENCHANT
Thanks guys <3
alydandy is offline  
Old 02/25/2018, 15:02   #15
CheeseBurger !!


 
elite*gold: 1751
Join Date: Oct 2012
Posts: 7,915
Received Thanks: 3,046
#Closed


Spidy. is offline  
Closed Thread



« Sro_Client.exe Error | Any Help? Mbot Error [9] »

Similar Threads
Street Lamps
12/05/2010 - EO PServer Hosting - 4 Replies
Hey guys i found these street lamps on the game and thr rlly starting tpo piss me off casue i cant find them anywere in the database... IM using revo anyone know?
[ALZ GUIDE] PURPLE LAMPS
09/25/2010 - Cabal Guides & Templates - 6 Replies
Hi all, i am new here and want share my guide how to make alz with purple lamps, this is not hack, just trick. I will talk about CabalOnline Europe. Ok, all new users get premium account for 1 week and ofc 1 purple lamp per week (every thursday,...
EPvp Chatbox
11/29/2008 - Flyff Main - Discussions / Questions - 3 Replies
Also ich hatte ne chatbox gemacht wo alle pvpers reinkönnen usw^^ Elitepvpers chat group - elitepvpers.com Chatbox ^^ Keine Beleidugungen uns pornolinks etc =) Der chat ist neu also Bitte link weitersenden etc^^
Cabal Rider: Auto Training and Stop Training in the Chatbox.
06/17/2008 - Cabal Hacks, Bots, Cheats, Exploits & Macros - 8 Replies
Every time I press Home and End, it says Auto Training and Stop Training. I'm kinda worried because it shows in the chat box. Am I the only one who can read it or others can?
Hm Farben in der chatbox aendern ?!
08/07/2005 - Lineage 2 - 0 Replies
Soooooo ich hab mir letztens ein l2 pvp movie angeguckt und der jenige der das movie aufgenommen hat, hats irgendwie fertig gebracht die chatfarben in c2 zu ändern so das die dmg die er abkriegt zB. rot angezeigt wird. Mich intressiert welche...



All times are GMT +2. The time now is 23:47.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.