Register for your free account! | Forgot your password?

You last visited: Today at 13:18

  • Please register to post and access all features, it's quick, easy and FREE!

 

Agbot "OUT OF STACK SPACE"

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Feb 2008
Posts: 8
Received Thanks: 0
Agbot "OUT OF STACK SPACE"

i have a problem, after like 1-10 min into the game about 20 errors come up saying "runtime error: out of stack space" and then it closes it self. i followed the official and unofficial guide so i dont think i did anything wrong. Anyone have any ideas?



creamyblack is offline  
Old   #2
 
elite*gold: 0
Join Date: Feb 2007
Posts: 2,012
Received Thanks: 705
hmmm never heard of it.
Stack is a Special Kind of Memory for procedures & functions etc. Its a Area of your normal Memory.
How much RAM & virtuell RAM have you?

What Revbot Version u used?

Normally its an error that occours through wrong codin & programmin, so that the program at least needs more Stack Memory than you can give him.


SpriGgy is offline  
Old   #3
 
elite*gold: 0
Join Date: Feb 2008
Posts: 8
Received Thanks: 0
i use the newest version, 1.5 i think it is.
my ram is 504m, kinda weird isnt it suppose to be 512m
i am not sure abt my virtual memory.
thx for ur reply, urs is the only actual useful information i've got up till now.
creamyblack is offline  
Old   #4
 
elite*gold: 0
Join Date: Jan 2008
Posts: 222
Received Thanks: 142
i have had a error like this too if you open t bot much errors appear **** dont know how i make it ok. download silkroad folder and agbot again maybe try another version


xxfukerxx is offline  
Old   #5
 
elite*gold: 0
Join Date: Feb 2007
Posts: 2,012
Received Thanks: 705
Quote:
Originally Posted by creamyblack View Post
i use the newest version, 1.5 i think it is.
my ram is 504m, kinda weird isnt it suppose to be 512m
i am not sure abt my virtual memory.
thx for ur reply, urs is the only actual useful information i've got up till now.
Yeah normaly.
Were you read the 504 MB?
I detect 1023,*** on me.
But still better than HDD, there you never can use the GB you really bought xD
Didnt tested Version 1.5 till now, cause im stalling and used 1.4.8.2
Maybe theres a Bug in the new Version, that comes from the new loopback feature, like Loops that dont come to the right break-off conditions.

@xxfukerxx sind wir jetzt schon beim Turbobot^^
SpriGgy is offline  
Old   #6
 
elite*gold: 0
Join Date: Feb 2008
Posts: 8
Received Thanks: 0
i read it in My Computer's properties
i have the same problem in evey version (i've tried 3 of them i think, working 4 others but not me)
maybe there is sumthing rong wif my RAM.
creamyblack is offline  
Old   #7
 
elite*gold: 0
Join Date: May 2006
Posts: 4
Received Thanks: 1
Stack errors are memory errors, silkroad with 512Mb of memory is totally not enough, sro averages 300 to 400 Mb on its own. also the reason you only show 504Mb of memory is that you probably have an integrated video card therefore it is using a dedicated amount of memory from your system.
ADVICE: buy more memory, it's real cheap now, 20 to 30 dollars for a 1Gb chip, also get a real video card for your system integrated not only uses your system memory it also uses your processor clock cycles therefore slowing everything else down while rendering video. As far as how to do this check your comp manufacturers website, they are all usually pretty good about posting instructions on how to do these simple upgrades
Supersurfr is offline  
Old   #8
 
elite*gold: 0
Join Date: Apr 2006
Posts: 124
Received Thanks: 0
guess cant bot SRO on computers like this, am i right?
=/
Gnaf is offline  
Old   #9
 
elite*gold: 0
Join Date: Feb 2007
Posts: 2,012
Received Thanks: 705
Quote:
Originally Posted by Supersurfr View Post
Stack errors are memory errors, silkroad with 512Mb of memory is totally not enough, sro averages 300 to 400 Mb on its own. also the reason you only show 504Mb of memory is that you probably have an integrated video card therefore it is using a dedicated amount of memory from your system.
ADVICE: buy more memory, it's real cheap now, 20 to 30 dollars for a 1Gb chip, also get a real video card for your system integrated not only uses your system memory it also uses your processor clock cycles therefore slowing everything else down while rendering video. As far as how to do this check your comp manufacturers website, they are all usually pretty good about posting instructions on how to do these simple upgrades
That reason for the 504 MB cant be true. If you had a integrated Videocard that uses only 8MB, SRO would never start lol^^
But 512 MB are really few to Bot in SRO. I have 1GB, and sometimes its a little few ^^ But my Videocard is shared Memory^^


SpriGgy is offline  
Reply



« Previous Thread | Next Thread »



All times are GMT +1. The time now is 13:18.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.