Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Shaiya > Shaiya Private Server > Shaiya PServer Development
You last visited: Today at 19:27

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



Shaiya Private Server - Instructions - English

Discussion on Shaiya Private Server - Instructions - English within the Shaiya PServer Development forum part of the Shaiya Private Server category.

Closed Thread
 
Old 01/26/2010, 11:11   #376
 
shinru2004's Avatar
 
elite*gold: 260
Join Date: Oct 2009
Posts: 258
Received Thanks: 266
Lol, im using that exact version of SQL Server! I got 1 question if someone can answer it. i have the full EP 4 server running but i want to know how to edit the portals to get them working
shinru2004 is offline  
Old 01/29/2010, 23:36   #377
 
elite*gold: 0
Join Date: Jan 2010
Posts: 19
Received Thanks: 1
OK, well everything SEEMS to be set up right, but for some reason I can not get the game to connect to the server.

1 - I followed the instructions in this topic to set up my server.
2 - I used the files/instructions to convert it to an EP4 server.
3 - Opened SMSE to verify the server was connected and all the databases were included.
4 - Opened server patch config and started all services, all are running steady with the green arrows.
5 - Downloaded and installed the official US EP4 client.
6 - Replaced the original game.exe with the one from to remove the gameguard error I was getting.
7 - Opened that new game.exe in hex editor and replaced the original IP (72.55.177.194) with (127.0.0.1) that the server is configured to use.

Now, the server is up and running, databases are added and running, and the game is configured to look to the correct IP, but every time I try to start the game I get the "check notice board" error as if the server was down. I've gone though this maybe 5 or 6 times from start to finish, but this just keeps happening. I have a feeling I've overlooked something incredibly simple, which is usually the case when I'm running into problems with this kind of thing. Anyone got any insight as to what's going wrong?

Here are the pics of everything as it is currently set up:







HiFiSi is offline  
Old 01/30/2010, 00:04   #378
 
ProfNerwosol's Avatar
 
elite*gold: 0
Join Date: Oct 2009
Posts: 449
Received Thanks: 644
After Hex value 31 in changed game.exe there is '2E' four times which is a dot. Change it to 00. It should solve the problem.
ProfNerwosol is offline  
Old 01/31/2010, 09:58   #379
 
elite*gold: 0
Join Date: Jan 2010
Posts: 19
Received Thanks: 1
Quote:
Originally Posted by ProfNerwosol View Post
After Hex value 31 in changed game.exe there is '2E' four times which is a dot. Change it to 00. It should solve the problem.
goddammit I knew I did something dumb. Like forgetting that dots not being the same as actual blank spaces in hex... Thanks a ton man, it's running now.

EDIT: Now and getting character load error after log in where you would normally select your faction

Did some searching but can only find solutions dealing with downloading modified game.exe file from euroshaiya site, which isn't up at the moment.

Could this have something to do with having to log into the game using "admin, admin123" where trying to log in with the "Shaiya, shaiya123" login gives me an account does not exist message?

I'm gonna try installing everything the same on my laptop except for updating to the EP4 databases to see if that's what's causing the problem.

Nope. Installed cleanly on another server and didn't update server files/database to EP4 and still got the character load error.

I'll go see if I can find an EP3 version of the game and see if that works.

I'll just keep on editing since nobody's posted...

I got an EP3 server up and running perfectly with an EP3 client, and even an EP4 client (only the EP4 content would not work, like skills, higher kill cap, etc.) No problems there as that would be expected from running an EP4 client on a server that is for EP3.

Now that I know I can get that far, I just need to get it running fully as EP4. I replaced the database and various files as per ProfNerwosol's instructions, only problem I am seeing with this is that the game service won't stay on. All other services (session, userlog, login01, dbagent, and gamelog stay on)...

I saw Virus post earlier that the EP4 server directory needs to be installed on C:\ rather than on D:\ like it is with EP3. ()... Is this true? Seems like none of the other services would be running if it were looking for everything to be on the C drive.
HiFiSi is offline  
Old 01/31/2010, 11:25   #380
 
ProfNerwosol's Avatar
 
elite*gold: 0
Join Date: Oct 2009
Posts: 449
Received Thanks: 644


This post will help you with Game switching from online to paused.

Quote:
I saw Virus post earlier that the EP4 server directory needs to be installed on C:\ rather than on D:\ like it is with EP3. (LINK)... Is this true? Seems like none of the other services would be running if it were looking for everything to be on the C drive.
No, it doesn't matter where you place Database's. You attach them manually so the path is preserved. SQL server needs to know where they are, game connects via IP so it doesn't care .
ProfNerwosol is offline  
Old 01/31/2010, 11:42   #381
 
elite*gold: 0
Join Date: Jan 2010
Posts: 19
Received Thanks: 1
Quote:
Originally Posted by ProfNerwosol View Post


This post will help you with Game switching from online to paused.
Yeah I saw that post while trying to find a solution, but I had already installed all th new map files... the map file I got from the first post is in the correct place and this is still happening. If you look at the last post in that thread you linked to you can see the ps_game log output... says DB table load error, Call save all failed dbagent disconnected, etc.
HiFiSi is offline  
Old 01/31/2010, 11:56   #382
 
ProfNerwosol's Avatar
 
elite*gold: 0
Join Date: Oct 2009
Posts: 449
Received Thanks: 644
Quote:
Originally Posted by HiFiSi View Post
Yeah I saw that post while trying to find a solution, but I had already installed all th new map files... the map file I got from the first post is in the correct place and this is still happening. If you look at the last post in that thread you linked to you can see the ps_game log output... says DB table load error, Call save all failed dbagent disconnected, etc.
I'm with you. Here's the solution:

ProfNerwosol is offline  
Old 02/01/2010, 00:13   #383
 
elite*gold: 0
Join Date: Dec 2009
Posts: 15
Received Thanks: 11
By the start of the Server_bat always this announcement....pls help

Karabush is offline  
Old 02/01/2010, 15:05   #384
 
elite*gold: 0
Join Date: Apr 2009
Posts: 20
Received Thanks: 1
Yeah i've found that on ********...
Quote:
hi

GO TO

SQL Database - PS_GameData - CHAR - design table and change Maketime in varchar


xd you have the same problem I've had but I am a good programmer

CHANGE MY SCRYPT


go to USP_SAVE_CHAR_ITEM_ADD_E



/****** Object: Stored Procedure dbo.usp_Save_Char_Item_Add_E Script Date: 2008-6-7 18:31:57 ******/

/****** Object: Stored Procedure dbo.usp_Save_Char_Item_Add_E Script Date: 2008/3/15 下午 05:25:52 ******/



/****** 偃羹: 盪濰 煎衛盪 dbo.usp_Save_Char_Item_Add_E 蝶觼董 陳瞼: 2006-04-11 螃 10:57:16 ******/


CREATE Proc usp_Save_Char_Item_Add_E

@CharID int,
@ItemUID bigint,
@Bag tinyint,
@Slot tinyint,
@ItemID int,
@Type tinyint,
@TypeID tinyint,
@Quality int,
@Gem1 tinyint,
@Gem2 tinyint,
@Gem3 tinyint,
@Gem4 tinyint,
@Gem5 tinyint,
@Gem6 tinyint,
@Craftname varchar(20) = '',
@Count tinyint,
@Maketime varchar(20)='01/01/1999',
@Maketype char(1)

AS

--SET NOCOUNT ON

IF(@Quality >= 5000)
BEGIN
SET @Quality=0
END

INSERT INTO CharItems
(CharID, bag, slot, ItemID, Type, TypeID, ItemUID, quality, gem1, gem2, gem3, gem4,
gem5, gem6, craftname, [count], maketime, maketype)
VALUES(@CharID, @Bag, @Slot, @ItemID, @Type, @TypeID, @ItemUID, @Quality, @Gem1, @Gem2, @Gem3, @Gem4,
@Gem5, @Gem6, @Craftname, @Count, @Maketime, @Maketype)

IF(@@ERROR = 0)
BEGIN
RETURN 1
END
ELSE
BEGIN
RETURN -1
END

--SET NOCOUNT OFF
GO




and

go to usp_Read_Char_Items_Detail_R


CHANGE MY SCRYPT




/****** Object: Stored Procedure dbo.usp_Read_Char_Items_Detail_R Script Date: 2008-6-7 18:31:57 ******/

/****** Object: Stored Procedure dbo.usp_Read_Char_Items_Detail_R Script Date: 2008/3/15 下午 05:25:51 ******/




CREATE Proc usp_Read_Char_Items_Detail_R

@CharID int

AS

/******SET NOCOUNT ON******/

SELECT ItemID, Type, TypeID, ItemUID, Bag, Slot, Quality,
Gem1, Gem2, Gem3, Gem4, Gem5, Gem6, Craftname, [Count], Maketype ,
'2009' AS MakeTime_YYYY,
'01' AS MakeTime_MM,
'01' AS MakeTime_DD,
'00' AS MakeTime_HH,
'00' AS MakeTime_MI,
'00' AS MakeTime_SS


FROM CharItems

WHERE CharID = @CharID AND Del = 0

/******SET NOCOUNT OFF******/
GO


and restarts all the service and good luck

I've spend 4 days but I've successfully with these changes it is sufficient to look for or just the error ^ ^
And you can create characters now
But i'm noob and i don't understand... i just understood that "CHAR" Table is "dbo.CharItems" in PS_GameData, i chandes the column maketime from datetime to varchar(50) first, tried and still same prob, the in varchar (MAX) but nothing...
Btw downloading now sql standard from ur link...
Thanks guys i try now and will see ^^
Edit :
Quote:
By the start of the Server_bat always this announcement....pls help
I fixed that doin this:
1- MANUALLY attached ProfNerwosol's DBs on sql server 2005
2- od D:\SHAIYA_SERVER\SERVER\batch i edited the svc register with my directory: (mine was C:\server1\SHAIYA_SERVER......) The one i used to make subst d drive and in services window manually started shaiya_server and shaiya_serverf.... Now they start also with ProfNerwosol's batch files...
XFiloX is offline  
Old 02/01/2010, 15:52   #385
 
ProfNerwosol's Avatar
 
elite*gold: 0
Join Date: Oct 2009
Posts: 449
Received Thanks: 644
I see that ZeroSignals tutorial is a pain. It's becoming my pain as well >_> ... and it's getting on my nerves ... since instead of playing with the server people have to spend time making it start .......... and I look forward to something more challenging than fixing DB connection ...

Thank you for the input XFiloX. I will consider updating my tutorial and files to include setting up the server from scratch.
ProfNerwosol is offline  
Old 02/07/2010, 17:24   #386
 
elite*gold: 0
Join Date: Jan 2009
Posts: 6
Received Thanks: 0
Please i need video tutorial i cant create (I have Windows Sp2)
cokevl is offline  
Old 02/10/2010, 20:29   #387
 
elite*gold: 0
Join Date: Feb 2010
Posts: 5
Received Thanks: 1
i got every thing working i just cant figure out how to log in to shaiya now that i have made the server
salvaire is offline  
Old 02/11/2010, 00:30   #388
 
elite*gold: 0
Join Date: May 2008
Posts: 5
Received Thanks: 0
I have all running, all with green arrow...
but when I start exe it keep telling me "Cannot connect to login server! check server. please check notice board.
Ip on game.exe is right. It seems game.exe cant find server... no block on firewall
GANJA_HM is offline  
Old 02/16/2010, 01:52   #389
 
elite*gold: 0
Join Date: Jun 2009
Posts: 66
Received Thanks: 5
Run "PSM_Server\PSM_ServiceMgr.exe".

I have be toying around with this project for a lil bit but, for some reason I'm getting stuck at this point. When I try to Start the PSM_ServiceMgr.exe I get this Error or warning whatever it maybe. I would copy paste and translate but, I cant highlight it to Copy x.x

Anyone know how I could fix this issue? Thank in advance

Progrip909 is offline  
Old 02/16/2010, 04:48   #390
 
elite*gold: 0
Join Date: Feb 2010
Posts: 2
Received Thanks: 0
Hi there first i would like to say a big "thank you" to Zerosignal for taking the time to enlighten us and to the others who are contributing ,

I seem to have struck a bit of a snag nooblishly speaking .. with regard to
the game.exe file which is part of thee "us client" i am trying to edit it using
HxD and when i replace the ip address 72.55.177.194 with 127.0.0.1
i save the file and try to execute it and it comes up as an invalid win32 app..im doing something wrong ..here are the original instructions

Quote:
Originally Posted by Zerosignal
SETUP US CLIENT FOR SERVER:
Open up the game.exe client in a hex editor, use find and enter "72.55.177.194". When it's found change it to your Login Server IP Address. Make sure all bytes are preserved (insert over), fill with null bytes. I recommend using HxD (free) or Hex Workshop.
Create shortcut with arguments added to end of Target "start game".
The part im unclear on is the "Make sure all bytes are preserved (insert over) , fill with null bytes" ..i tried doing this but i kept getting it wrong can anyone elaborate on how this is achieved if possible Please ?
Pydrodraxian is offline  
Closed Thread




All times are GMT +2. The time now is 19:27.


Powered by vBulletin®
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2024 elitepvpers All Rights Reserved.