Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Shaiya > Shaiya Private Server > Shaiya PServer Development
You last visited: Today at 20:40

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



Shaiya Private Server - Instructions - English

Discussion on Shaiya Private Server - Instructions - English within the Shaiya PServer Development forum part of the Shaiya Private Server category.

Closed Thread
 
Old 12/07/2009, 12:23   #346
 
elite*gold: 0
Join Date: Mar 2009
Posts: 2
Received Thanks: 0
Hey ZS thanks for the great guide got it all set up and running.

One question.... where do i setup other user accounts?

nvm i got it duh..was to many hours setting up looked over the obvious thanks again for the guide
helmets is offline  
Old 12/12/2009, 00:23   #347
 
elite*gold: 0
Join Date: Dec 2009
Posts: 3
Received Thanks: 0
Come thus far to only find a big fat wall.

Ok, i won't ask the world of you.
I picked this all up yesterday, got my WinServ2k3 out and installed, my MSQL 05 enterprise running. Comp name is HOMESERV, SQL instance is SQLSERV.

I've come across several problems, such as the services starting (except session) and then stopping, which i fixed by replacing the 127.0.0.1 in all config files i could find mentioning DB to HOMESERV\SQLSERV...that got it to connect.

I had to modify the batch installation files, as the original ones didnt work for me, simply because i changed the instance name during installation without thinking about it...took me a while but then i changed all batches connecting to the db. Following is what the command in shaiya_db_restore.bat was changed to...
Code:
osql -S HOMESERV\SQLSERV -E -i temp.sql
After that, it worked great on imports. (note: ALL the .bat's using osql in the first place have to be changed to this for this method to work fully.)

Anyways, i finally get the server up and running, run the version checking and nprotect mods, so its up and working fine. I go to log in with my hex'd client (to change all the ip's to my 127 and remove the email/smtp server, funny thing...when i edit it, it comes up with an OSK? anyone else see that or is that just somethin funky i did? it still works...either way) to my server, it logs me in goes thru server and force choices. I get to the toon screen and i make a new toon (well its already there now so i just select one of them and go). This is the part where i can't seem to solve the problem myself...it goes to the loading screen (like when you are loading the map...) but then almost immediately pops up this box saying "game data load error!!!". Ive run searches on google and on epvp, but the only thread that came up on here mentioned redownloading the us shaiya client and then the euroshaiya patches...which im not dealing with euroshaiya. I did notice something similar on a forum (RGZN i believe) that mentioned it, and a quick fix was to copy a clean ep3 data.saf and data.sah to the 'D:\SHAIYA_SERVER\SERVER\ShaiyaServerPatch\Server\ GameMain\PS_Game' folder. I did, i tried both ep3 (using an installer dated feb 10, 09...from what i understand that was pre-ep4 so i figured it would work.) and fully updated ep4 files, to no avail. The same thing happens whether i use an EP3 or EP4 hex'd game.exe when both are hex'd the same...(not sure the difference?)

I searched for *.log in my 'SERVER' folder, and this is out of the only file that was modified at the time i tried it, in the "D:\SHAIYA_SERVER\SERVER\PSM_Client\Bin\Log\PS_GAM E__system.log__20091211_132703.log" file.

There was only the one line at the specific time, the previous lines were almost 20minutes prior.


Code:
2009-12-11 14:46:18 discon client: (  7, 10054) T=000:00:00:000, RC=4,RCS=0, RB=46,RBS=1, SC=20,SCS=0, SB=430,SBS=9
Not sure if that line is any help whatsoever, it means nothing to me...i cant even guess what it means.

Any ideas or maybe links to some post i mightve missed?
(need more info? just let me know what u need.)
deviousxevious is offline  
Old 12/13/2009, 13:12   #348
 
elite*gold: 0
Join Date: Sep 2009
Posts: 3
Received Thanks: 0
what should i do after i restarted cpu??
there is no file called : PSM_Server\PSM_ServiceMgr.exe
only : PSM_Server\PSMServer_ServiceMgr.exe
the other is : PSM_Client\PSM_ServiceMgr.exe
i need to know which one to use
help me pls
Better if u can email me as i need ask some questions(windows live messenger)
email:

im just wondering if this is correct place to put the Server file


and what is scmanager??


Im Stuck at this step :

help pls D=
kelsimkel is offline  
Old 12/14/2009, 10:48   #349
 
elite*gold: 0
Join Date: Jun 2009
Posts: 20
Received Thanks: 1
I'm stuck at the place where everything goes back to || again.... here are my logs:

PS_dbagent:
Code:
2009-12-14 17:33:43 PS_DBAGENT__system log start (DBAgent01)

2009-12-14 17:34:04 DB gamedata connect error

2009-12-14 17:34:04 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-14 17:34:04 DBKillCountSave db alloc failed

2009-12-14 17:34:04 SAVE kill count ERROR

2009-12-14 17:34:04 CKeepObeliskMgr::DBSave db alloc failed

2009-12-14 17:34:04 SAVE g_KeepObeliskMgr ERROR

2009-12-14 17:34:04 GuildMgrSave::DBSave db alloc failed

2009-12-14 17:34:04 SAVE g_GuildMgrSave ERROR

2009-12-14 17:34:04 PS_DBAGENT__system log end (DBAgent01)


2009-12-14 17:34:04 3 1 SService::ServiceCtrlDispatcher(): service shutdown
ps_game:
Code:
2009-12-14 17:33:11 PS_GAME__system log start (Game01)

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/sorp1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/croco1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/croco2

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Troll1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Spink1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/GoldenPig

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Sorp3

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/SorpNamed1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/SorpNamed2

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Sorp2

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/CrocoNamed1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/CrocoNamed2

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/CrocoNamed3

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/OrcNamed1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/OrcNamed2

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/OrcNamed3

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/TrollNamed1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/HellTouthNamed1

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Deinos

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Parridalis

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Alcarian

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/ZinAlcaria

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Belizabeth

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/Kirhiross

2009-12-14 17:33:11 Loaded Behavior In Factory : data/ai/CrypticOne

2009-12-14 17:33:32 DB gamedef connect error

2009-12-14 17:33:32 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-14 17:33:32 Call save all waiting...

2009-12-14 17:33:32 Call save all failed dbagent disconnected(user count = 0)...

2009-12-14 17:33:32 server shutdown Connection INFO : T=000:00:00:000, NumC=0,CMin=0,CMax=0,CAvg=0.00, CAva=0,CReq=0,CCnt=0,DCCnt=0, CTimeT=000:00:00:000,CTimeAvg=000:00:00:000, RBT=0,RBS=0,RBSC=0,SBT=0,SBS=0,SBSC=0

2009-12-14 17:33:32 Save MobID=2418570

2009-12-14 17:33:32 PS_GAME__system log end (Game01)

2009-12-14 17:33:32 3 1 SService::ServiceCtrlDispatcher(): service shutdown
ps_gamelog:
Code:
2009-12-14 10:41:19 PS_GAMELOG__system log start (GameLog01)

2009-12-14 10:41:40 DB gamelog connect error

2009-12-14 10:41:40 init db error

2009-12-14 10:41:40 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-14 10:41:40 PS_GAMELOG__system log end (GameLog01)

2009-12-14 10:41:40 3 1 SService::ServiceCtrlDispatcher(): service shutdown
ps_login:
Code:
2009-12-06 19:29:33 PS_LOGIN__system log start (Login01)

2009-12-06 19:29:54 DB userdata connect error, id=sa, pass=

2009-12-06 19:29:54 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-06 19:29:54 PS_LOGIN__system log end (Login01)

2009-12-06 19:29:54 3 1 SService::ServiceCtrlDispatcher(): service shutdown
ps_session:
Code:
009-12-06 19:38:18 PS_SESSION__system log start (Session)

2009-12-06 19:38:39 userlog connect failed

2009-12-06 19:38:39 initserver() failed

2009-12-06 19:38:39 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-06 19:38:39 PS_SESSION__system log end (Session)

2009-12-06 19:38:39 3 1 SService::ServiceCtrlDispatcher(): service shutdown
ps_userlog:
Code:
2009-12-12 14:23:47 PS_USERLOG__system log start (UserLog)

2009-12-12 14:24:08 DB userlog connect error, Server=192.168.1.7, DBName=PS_UserData, User=sa, Pass=

2009-12-12 14:24:08 3 1 SService::ServiceCtrlDispatcher(): m_pService->Init()

2009-12-12 14:24:08 PS_USERLOG__system log end (UserLog)

2009-12-12 14:24:08 3 1 SService::ServiceCtrlDispatcher(): service shutdown
I'm pretty sure i did something wrong, i'll try to figure it out...And some advice/help would be great
N4ZB34T is offline  
Old 12/17/2009, 22:46   #350
 
elite*gold: 0
Join Date: Jan 2009
Posts: 6
Received Thanks: 0
Can't make new Char

Hey all, sry to be an technical n00b but I just can't get any further. I finally got all set up and working.

My problem is that everytime i try to make a new Char it says "name already in use" I don't know where the problem is so pls help me.

My DBs are those:

PS_Billing
PS_GameData
PS_GameDefs
PS_GameLog
PS_UserData
PS_GMTool

Thanks in advance and if ZS reads this: sry to bother you but as time goes by i realized i can only HERE get real support.
Puffreis is offline  
Old 12/18/2009, 01:13   #351
 
(Virus)'s Avatar
 
elite*gold: 0
Join Date: Dec 2009
Posts: 71
Received Thanks: 22
Quote:
Originally Posted by Puffreis View Post
Hey all, sry to be an technical n00b but I just can't get any further. I finally got all set up and working.

My problem is that everytime i try to make a new Char it says "name already in use" I don't know where the problem is so pls help me.

My DBs are those:

PS_Billing
PS_GameData
PS_GameDefs
PS_GameLog
PS_UserData
PS_GMTool

Thanks in advance and if ZS reads this: sry to bother you but as time goes by i realized i can only HERE get real support.
Read this forum again you will see the answer.
(Virus) is offline  
Old 12/20/2009, 12:43   #352
 
elite*gold: 0
Join Date: Aug 2009
Posts: 26
Received Thanks: 5
I have same problem "name already in use" and i cant find answer in this thread... someone suggest to do something but nothing works...
baldracca is offline  
Old 12/21/2009, 23:24   #353
 
elite*gold: 0
Join Date: Jun 2009
Posts: 8
Received Thanks: 0
Ok question for you everytime i start up all service server, they go back to being paused can you help me out with that plz
UNeo is offline  
Old 12/22/2009, 15:14   #354
 
elite*gold: 0
Join Date: Jan 2009
Posts: 6
Received Thanks: 0
forgot

Quote:
Originally Posted by (Virus) View Post
Read this forum again you will see the answer.
I'm using SQL Server 2008 Enterprise and got it working for now can someone show me (screenshots) the solution for the "name already in use" problem?

my problem is I'm german and so I'm having dificulties gettin' all this right.

I heard of databases called PS_UserLog or PS_statistics whats up with these they aren't created by the bat and they seem pretty important.

as always thx in advance for ur patience and help.
greets Puffreis

[EDIT]

SORRY!! i overread a solution xD don't mind my stupidnes i'll try it when i get home.

@baldracca
you have to reinstall all DBs and whole SQL Data cause there r some problems if u installed DBs twice.

as always merci, thx, danke, harigato, etc. in advance.
greets Puffreis
Puffreis is offline  
Old 12/23/2009, 12:30   #355
 
elite*gold: 0
Join Date: Aug 2009
Posts: 26
Received Thanks: 5
I reistalled DB... i formatted all... reistalled OS (vista and xp) I tried every possible solution but problem remains. I tried to install it on a clean OS (windows xp and vista updated, SQL 2008, and shaiya server... nothing else).

I know there is a problem with DB but what kind of problem? If i can login means DB works... really i cant understand what is my problem...

I found only a solution in this thread "change datetime with varchar" problem remains.......... boh..... weird enigma
baldracca is offline  
Old 12/23/2009, 20:54   #356
 
elite*gold: 0
Join Date: Jan 2009
Posts: 6
Received Thanks: 0
Quote:
Originally Posted by baldracca View Post
I reistalled DB... i formatted all... reistalled OS (vista and xp) I tried every possible solution but problem remains. I tried to install it on a clean OS (windows xp and vista updated, SQL 2008, and shaiya server... nothing else).

I know there is a problem with DB but what kind of problem? If i can login means DB works... really i cant understand what is my problem...

I found only a solution in this thread "change datetime with varchar" problem remains.......... boh..... weird enigma
i reinstalled my SQL 2008 and now nothing goes anymore the configs r messed up i think and the replace with varchar didnt help at all.

I'm losing hope. ah well..
greets Puffreis
Puffreis is offline  
Old 12/24/2009, 11:27   #357
 
elite*gold: 0
Join Date: Aug 2009
Posts: 26
Received Thanks: 5
Did u config TCP/IP and Named Pipes? If yes.. try to reistall again but if u can try to reinstall OS too... sometimes delete and resinstall SQL could give some problem, if u reinstall ALL should be better... gl
baldracca is offline  
Old 12/24/2009, 12:05   #358
 
elite*gold: 0
Join Date: Nov 2008
Posts: 1
Received Thanks: 0
can i have help by skype i want to try to make a shaiya private server so contact me:john.eriksson9
madusa44 is offline  
Old 12/25/2009, 06:44   #359
 
elite*gold: 0
Join Date: Oct 2009
Posts: 57
Received Thanks: 5
why no one can't make video until now? if any one made video this will be great
12boom is offline  
Thanks
1 User
Old 12/27/2009, 19:37   #360
 
elite*gold: 0
Join Date: Jan 2009
Posts: 6
Received Thanks: 0
-.- I'm gettin a real headache now!

I use M$ SQL2008

I got it working except for the login (the name already in use bug).

and now cause someone recommended reinstalling to solve the prob NOTHING goes anymore. I can get all installed: AgentClient and AgentServer but if I try to run the other servers like ps_game it runs 1 sec then stops and if i try amanually in service_mgr i get a wierd message surely telling me about a mistake or something like that.

It's obvious that the servers can't connect to the DBs but y?

I installed the Databases correctly, made Shaiya user and Shaiya123 pass for mixed auth mode but when i try to run the servers they will stop! I don't get it!
I changed the IPs to local (127.0.0.1) and named the Server everywhere Game.

Here r my Config files from D:\SHAIYA_SERVER\SERVER\PSM_Client\Bin\Config
maybe someone who got his server running can help me and look over them.

ps_dbAgent.ini:

Quote:
[SERVER]
ServerName=DBAgent01
ServerPort=
MaxConnection=
[DB]
GameData=127.0.0.1, PS_GameData, Shaiya, 5DF59870228E618AD213434D5607805F4B12780FB64F364914 7635F3FCE26CE5A5F9984F1C30D7CB26E18F4BE33CE12A7736 E92E39500F711DAB9FC6A01D863F416B0B719C23511BED7529 93915E02BF5DB6B859A35AAEC93E87F8E217D6220F4F5043AC B5BE5BD5760D2B3B5B309AEA27258E17BF71A82CF4E221992A 813686
[LOGFILE]
Replace=0
Append=1
[MONITOR]
Enable=0
Port=50000
ps_game.ini

Quote:
[SERVER]
ServerName=Game01
ServerPort=
MaxConnection=10
[CONNECTION]
Session=127.0.0.1
UserLog=127.0.0.1
DBAgent=127.0.0.1
GameLog=127.0.0.1
[DB]
GameDef=127.0.0.1, PS_GameDefs, Shaiya, 6C8DB9E6855CDB4C67CDDAA53E2F9E24E096AE76F1178383C3 1C5AD7E1A819B2AB5323A2BFBC34153590D10370F3EC6DE1A4 B0EE1F473B7887045A04AD7AFA276F91D36D85DA282826FC7B 78A5A174EE0A3C2AD5E3A022E4F4BAAF2B077C9430EC698710 5493948106A51108C2435E58F045A0C806B4A248F03D0A2D77 800A91
GameData=127.0.0.1, PS_GameData, Shaiya, BF7D69A385D01E5DE337ED047256087C7E740061C7283316F6 1E7ABC2C53985D1E40C72C788DC81A42A141DF49DA648825EF 7B4069BD7CAB7C86AD7CCC434BAD05399C31BFD3686A1B11D2 AEF062628CF9D612C59CACF7B6FF245BB24E65E78DF33718C5 4E7D2463D2201172FFF07E41C8292F308B990EC931A7E0FB20 3EC5B6
[GAMEINFO]
GameName=Game
GamePublicIP=127.0.0.1
GameVersion=0x08022100
GameLogDBID=1
[LOGFILE]
Replace=0
Append=1
[MONITOR]
Enable=0
Port=50000
ps_gamLog.ini

Quote:
[SERVER]
ServerName=GameLog01
ServerPort=
MaxConnection=
[DB]
DBCount=1
DBGame01=127.0.0.1, PS_GameLog, Shaiya, 1A3FDDCF30829F3A71792BE5B1E304A69785B9CD328F7733D1 44D4C97869E3203C52C01A9FD1E2241817799E66E7455449B2 0663531CAC9DA89163BB3ABED90A7E5F7F689EE163EBD5880D 205EBA3107A65101F94BEC8539AE0ECB4E4AE76385261CC222 1167913BA34880B19AD0263577C9F7E8CEFBC27A1894ABB91D 9F06A3
DBChat01=127.0.0.1, PS_GameLog, Shaiya, 06D7585AC02E89711B74480F6FDCEE80826836655AEC3530F5 914DB2ED2E23D0C5325FA6EFDFA5FBB37933FC2C30E05A67DE 4F722D0AAA45ED523528F1F9B99E069EC10A4780223919EF02 48B41F10DBDD5915A1E72DC7BEFC03064B6A1EB28BDC7767DE DE80E2C49EDF27F331598B63341C3A6E1D0950E37B94C81AB0 F629B5
[LOGFILE]
Replace=0
Append=1
[MONITOR]
Enable=0
Port=50001
ps_login.ini:

Quote:
[SERVER]
ServerName=Login01
ServerPort=
MaxConnection=10
[CONNECTION]
Session=127.0.0.1
UserLog=127.0.0.1
[DB]
UserData=127.0.0.1, PS_UserData, Shaiya, CF4DF9120680DD8A3DF05E1504F7366994F844D8590D6AE522 2D841D4D572F6408DD836DCDF05E357F5A55CE24955F3C0EAE 136E4CFAB0141C6D9499623526304D5223C5C9F88F1630ACC3 44420F252FC01FC1BC2C7C673F01BBA1C404B8B7B5B1CBE486 72CC0B48DDB6D9AF0626B9D25C63EDD893B96A88EDC5420B84 C5F1B2
[GAMESERVERS]
// Game01 = name, Mapping ServerID, Mapping DB ID(use prev server id)
GameServerCount=1
Game01=Game, 1

[LOGFILE]
Replace=0
Append=1
[MONITOR]
Enable=0
Port=50000
ps_session.ini:

Quote:
[SERVER]
ServerName=Session
ServerPort=
MaxConnection=

[CONNECTION]
UserLog=127.0.0.1

[GAMESERVERS]
GameServerCount=1
Game01=Game

[LOGFILE]
Replace=0
Append=1

[MONITOR]
Enable=0
Port=50000
ps_userlog:

Quote:
[SERVER]
ServerName=UserLog
ServerPort=
MaxConnection=
[DB]
UserLog=127.0.0.1, PS_UserData, Shaiya, 7427BE8A8A278E266ACBF05DF33B823012CC3A1F129615165E 1C26FAE7CE50C127D1041F0795BDAE71956EDCD6044EB5BA27 2ED083DAAC1F9BAD221379229037242AADACE62A520AC68DDD F84B36E718C2D2F2EF655440E5DBA039AA6D4455797EBAD2DF 93819D82108FC6314F9A2C23585BDAF558F0140AE4B1814A31 19745B
[LOGFILE]
Replace=0
Append=1
[MONITOR]
Enable=0
Port=50001
as always thx in advance for your help ^^
greez Puffreis
Puffreis is offline  
Closed Thread




All times are GMT +2. The time now is 20:40.


Powered by vBulletin®
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2024 elitepvpers All Rights Reserved.