Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Rappelz > Rappelz Private Server
You last visited: Today at 15:40

  • Please register to post and access all features, it's quick, easy and FREE!

 

[How To] Create a Rappelz Private Server | Rappelz Privatserver erstellen

Reply
 
Old   #241
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,004
Received Thanks: 958
1 update character permission to 100

2. change some lines in your game server opt to your LAN address that is running the server, and open up ports in that computers advanced firewall settings...

S io.auth.ip:127.0.0.1
S io.ip_address:127.0.0.1
S io.port:4504

Change the addresses on those lines to your LAN IP.



ThunderNikk is offline  
Thanks
1 User
Old   #242
 
elite*gold: 0
Join Date: Sep 2014
Posts: 55
Received Thanks: 5
what if I want to make the server public, how big is the diff?


joaobitu2 is offline  
Old   #243
 
elite*gold: 0
Join Date: Apr 2012
Posts: 91
Received Thanks: 7
Thks for your tuto but I still having issues
swtib91 is offline  
Old   #244
 
elite*gold: 0
Join Date: Sep 2014
Posts: 7
Received Thanks: 0
How do i add a second world?
I got my first up and running..
I got my GM Power set up
how would one add a second or 3rd server?

Also: Can you run 2 different world s with two different epics?.. I have 8.1 (up) got files for 7.4
.. how if you Please


Thank you all for the Help. I am not a Dev or a Tech. I am but a GM in training. But I want to do my best, so I am learning as much as I can. I figure If I set up a home Server.. And mess it up there, I will not harming the game for others or the team. So when they take me off this trial part I will be good at the games understanding for the players and team I am working with


ErosMonk is offline  
Old   #245
 
elite*gold: 0
Join Date: Sep 2014
Posts: 55
Received Thanks: 5
please add to the original topic how to make it online. No one plays single player rappelz :s
joaobitu2 is offline  
Old   #246
 
elite*gold: 0
Join Date: Sep 2014
Posts: 2
Received Thanks: 0
Hello everyone. I finally got my private server up and running but I still have a few questions.

1. How will I get other people to join my private server? What will my friends have to have to join my private server?

2. Ive looked at other threads on how to use the GM commands but I just cant seem to get min to work. I type them in the Game Server but nothing happens.

And my permission is set to 100
hwars19 is offline  
Old   #247
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,004
Received Thanks: 958
Change some of the lines to your gameserver.opt to point to your external IP and some other fancy router or firewall stuff...

These lines specifically...

S io.auth.ip:127.0.0.1
S io.ip_address:127.0.0.1
S io.port:4504

The rest will still work with local host setting but these point out which ports are the true IO for the authentication and game server. The IO port here is for the game server and that will be the router or firewall stuff. The IO auth port is in the authserver.opt and that will be needed for the firewall stuff as well as the .bat launcher or configured launcher.

Your friends will need a configured launcher or .bat file that points their client to your external IP and your IO auth port.

You use most of the GM commands that are written with // or / in the in game chat window.

You use GM commands written with # in the game server console.
ThunderNikk is offline  
Old   #248
 
elite*gold: 0
Join Date: Sep 2014
Posts: 3
Received Thanks: 0
Quote:
Originally Posted by ChaoSnipe View Post
Hey guys, first time doing this in a while, did everything as it was explained, all working perfectly, up until actually login in, the game closes and gives me the error
"Cannot connect to server"

Captain herlock + the auth server are both running and doing what they should be been trying for the past hour to figure it out but, I just cant seem to xD
I'm having this exact same issue. Any help would be appreciated!

AutherServer.opt

area of gameserver.opt

launcher

IPs and Ports all line up from what I can tell and even though there is no outbound/inbound connections going on i opened ports 4504 and 8841 in and out.

any ideas? It seems to me that it's authenticating, but it then doesn't find the actual game server.

yes I've also entered the commands into the game server
command.log
lebobo is offline  
Old   #249
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,004
Received Thanks: 958
The two commands to open the game servers are entered into the auth console.
ThunderNikk is offline  
Old   #250
 
elite*gold: 0
Join Date: Sep 2014
Posts: 3
Received Thanks: 0
Quote:
Originally Posted by thndr View Post
The two commands to open the game servers are entered into the auth console.
Thank you thndr.

I had confused the 2 servers for those commands. However, entering the commands into the Auth Server has produced the same results for me.

Is there supposed to be a confirmation when entering "start service"?
lebobo is offline  
Old   #251
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,004
Received Thanks: 958
"start service" should be

start_service

You will see some text lines appear in the auth console after this command.

and then

set game.open_external 1

You will not see anything appear in the auth console after this command.
ThunderNikk is offline  
Old   #252
 
elite*gold: 0
Join Date: Sep 2014
Posts: 3
Received Thanks: 0
wow geeze thank you again!
lebobo is offline  
Old   #253
 
elite*gold: 0
Join Date: Sep 2014
Posts: 2
Received Thanks: 0
Thanks thndr. Any idea how to edit the in-game content? like adding merchants that sells tamed pets or potions and upgrading materials? and editing the taming rate, and staging rate? thx
hwars19 is offline  
Old   #254
 
elite*gold: 0
Join Date: Oct 2014
Posts: 9
Received Thanks: 0
HHHHEEEEELLLPP PLLLZZZZ

You must register and activate your account in order to view images.

I don't know what to do ... help me plz this is what it spawn when i start rappelz private server
RestMore is offline  
Old   #255
Moderator
 
elite*gold: 1
Join Date: Dec 2012
Posts: 3,004
Received Thanks: 958
Looks like your server is running fine.

You are having a client error. Shut down as many other running processes as you can in task manager that run under your log in id, and see if maybe you have a program conflict.

Other than that it would be helpful to know a little bit more about your client and where you got it from, what server files you are running. and if you can run a retail client on that computer without the same thing happening.

BTW the failed on the server launch you have there is normal when you have not started the upload server and you only need to upload server for guild icon uploading. You can play without upload running. That's why I said your server is running just fine.


ThunderNikk is offline  
Thanks
1 User
Reply



« Previous Thread | Next Thread »



All times are GMT +2. The time now is 15:40.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.