Register for your free account! | Forgot your password?

Go Back   elitepvpers > Metin2 > Metin2 PServer - Discussions / Questions
You last visited: Today at 00:42

  • Please register to post and access all features, it's quick, easy and FREE!

[HELP]0 0x08069e83 in ?? () Segmentation fault

Old   #1
elite*gold: 0
Join Date: Mar 2010
Posts: 25
Received Thanks: 8
[HELP]0 0x08069e83 in ?? () Segmentation fault

I run a root server with 2089 gamefile unstripped version. Game cores crashes often declaring segmentation fault, but no entry in syserr - syslog.
When I try to debug the .core, with gdb, this is the output:

GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd".
(gdb) core game.core
Core was generated by `game'.
Program terminated with signal 11, Segmentation fault.
#0  0x08069e83 in ?? ()
It's weird that the function is not recognized and it is displayed as "?? ()".
I tried to find this address in gamefile, but there is nothing. The longer address is 02df27e0. Does anyone know what could be causing that?

FSXraptor is offline  
Old 12/07/2011, 13:37   #2
elite*gold: 0
Join Date: Mar 2010
Posts: 25
Received Thanks: 8
This is the output of

# gdb game
(gdb) run
(gdb) backtrace
#0  0x285ff2f7 in __error () from /lib/
#1  0x285fece9 in __error () from /lib/
#2  0x2883210c in ?? ()
#3  0x0000000f in ?? ()
#4  0x285f3fac in sem_wait () from /lib/
#5  0x08336a3e in CSemaphore::Wait ()
#6  0x08335c9b in CAsyncSQL::ChildLoop ()
#7  0x0833650e in AsyncSQLThread ()
#8  0x285f473f in pthread_getprio () from /lib/
#9  0x00000000 in ?? ()


# Solved
# Close request

FSXraptor is offline  
1 User

« game_2089 einfügen??? | [.Kay331 v6.1] Einloggproblem »

Similar Threads
Segmentation fault(core dumped)
10/15/2011 - Metin2 PServer - Discussions / Questions - 1 Replies
Mein Problem ist folgendes: da ich die Jagdquests auf meinem Server entfernen wollte, habe ich die beiden levelup dateien aus dem hongkong\quest ordner gelöscht und auch aus der liste hongkong.list als ich dann gemacht hab kam nichts wie sonst immer von den Quests sondern das ganze Fenster wurde mit "Segmentation fault (core dumped)" zugespammt. die sufu hat mir dazu keine Lösung bieten können, die funktioniert hätte. Ich weiß nicht, ob das damit was zu tun hat, aber als...
Segmentation fault in ubuntu
06/09/2011 - Metin2 PServer - Discussions / Questions - 2 Replies
Welcome! I have a VPS,and the VPS's Operation System Ubuntu. When i copy the metin2 server file and server mysql to SSH,i write:"./". And it's write: "No such file or directory" Image: After i write: "cd auth" "./auth"
Segmentation fault (core dumped)
05/14/2011 - Metin2 PServer - Discussions / Questions - 3 Replies
Segmentation fault (core dumped) Segmentation fault (core dumped) Segmentation fault (core dumped) ???????????????????? :rtfm: Metin2 :(
VPC - segmentation fault
01/07/2011 - Metin2 PServer - Discussions / Questions - 22 Replies
Hi, wenn ich die dateiausführen möchte in Virtual pc damit meine funktioniert, dann kommt imma eine fehler meldung: segmentation fault und das ganz oft Da manche schon gesagt haben das das an der Honkonglist liegt, habe ich die mal hier reinkopiert.
Segmentation fault (core dumped)
09/10/2010 - Metin2 PServer - Discussions / Questions - 10 Replies
Habe heute einen Root eingerichtet. Das erstemal starten ging einwandfrei. Nun habe ich vorhin reboot gemacht und es kam: connection refused beim starten. Dann habe ich: cd /home/game/db ./db

All times are GMT +1. The time now is 00:42.

Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.