Register for your free account! | Forgot your password?

You last visited: Today at 22:09

  • Please register to post and access all features, it's quick, easy and FREE!

 

League of Legends Sandbox

Reply
 
Old   #181
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Quote:
Originally Posted by ismailman123 View Post
Open "common.h" and find "PKT_S2C_Emotion = 0x41, //3 UPDATED",then change it to "PKT_S2C_Emotion = 0x42, //3 UPDATED".
Every emotion should work then
Bugsplat



KazuyaX93 is offline  
Old   #182
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by KazuyaX93 View Post
Bugsplat
Let me upload the source then,I only have the .spawn and the .model commands ,though.


ismailman123 is offline  
Old   #183
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Quote:
Originally Posted by ismailman123 View Post
Let me upload the source then,I only have the .spawn and the .model commands ,though.
it would be great
KazuyaX93 is offline  
Old   #184
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by KazuyaX93 View Post
it would be great
, working emotes,spawn and models. Name is set to "Riot MrPixel" (yolo <3) and on Anivia as champion.


ismailman123 is offline  
Thanks
1 User
Old   #185
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Quote:
Originally Posted by ismailman123 View Post
, working emotes,spawn and models. Name is set to "Riot MrPixel" (yolo <3) and on Anivia as champion.
Thanks, it works now!

Quote:
Originally Posted by ismailman123 View Post
, working emotes,spawn and models. Name is set to "Riot MrPixel" (yolo <3) and on Anivia as champion.
btw, could you get ".model" and ".spawn" to work? When I use them, nothing happens. :/
KazuyaX93 is offline  
Old   #186
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by KazuyaX93 View Post
Thanks, it works now!



btw, could you get ".model" and ".spawn" to work? When I use them, nothing happens. :/
Uhm,yeah sure i'm on it.

EDIT: Got the .spawn command to work,only the .model left
ismailman123 is offline  
Old   #187
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Quote:
Originally Posted by ismailman123 View Post
Uhm,yeah sure i'm on it.

EDIT: Got the .spawn command to work,only the .model left
great We have to get the chat to work again, too
KazuyaX93 is offline  
Old   #188
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by KazuyaX93 View Post
great We have to get the chat to work again, too
Yeah already got the chat to work + the .spawn command. Trying to get the .model to work tho,somewhy it doesn't work.
ismailman123 is offline  
Old   #189
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Quote:
Originally Posted by ismailman123 View Post
Yeah already got the chat to work + the .spawn command. Trying to get the .model to work tho,somewhy it doesn't work.
Could you tell me what you've done to get .spawn und chat to work?
KazuyaX93 is offline  
Old   #190
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by KazuyaX93 View Post
Could you tell me what you've done to get .spawn und chat to work?
Modified the values in the "common.h":

1) PKT_ChatBoxMessage ; changed it's value to 0x68 ,so the chat box works.
2) PKT_S2C_LevelPropSpawn ; changed it's value to 0xD0 ,so the .spawn command can actually spawn something.
ismailman123 is offline  
Old   #191
 
elite*gold: 0
Join Date: Jun 2014
Posts: 68
Received Thanks: 6
Can you please explain to me how you got those values? Did you use a program like wireshark or WPE pro to catch them?
noobasaurus is offline  
Old   #192
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by noobasaurus View Post
Can you please explain to me how you got those values? Did you use a program like wireshark or WPE pro to catch them?
Actually,since it's a new patch it was just the hex value + 1(sometimes it could be +2 or even +3,quite rare) ,for example if it was 0x69(105) it'd be 0x6A(106).
ismailman123 is offline  
Old   #193
 
elite*gold: 0
Join Date: Jun 2014
Posts: 68
Received Thanks: 6
Ah I see. In one of them it was -1, so did you just experiment with them until it worked?
noobasaurus is offline  
Old   #194
 
elite*gold: 68
Join Date: Nov 2007
Posts: 680
Received Thanks: 127
Chat and spawn works now. Now we need .model again and all is great
KazuyaX93 is offline  
Old   #195
 
elite*gold: 0
Join Date: May 2010
Posts: 149
Received Thanks: 16
Quote:
Originally Posted by noobasaurus View Post
Ah I see. In one of them it was -1, so did you just experiment with them until it worked?
No,it was easier. In the "gamed.exe" when you,for example,talked in chat in-game you'd see a message saying the packet has a unknown value,then it'd show the value in hexadecimal and the decimal in parenthesis. You just have to change the value of the correct packet to the right hex number

Quote:
Originally Posted by KazuyaX93 View Post
Chat and spawn works now. Now we need .model again and all is great
Oh yeah the model,I got it,forgot about it ^^.
Open "common.h" and set "PKT_S2C_UpdateModel" to "0x97" (remember to put the coma at the end).
Then open "packets.h",find "updateModel" and rewrite "header.cmd = (PacketCmd)0x97;"


ismailman123 is offline  
Thanks
1 User
Reply



« Previous Thread | Next Thread »



All times are GMT +2. The time now is 22:09.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.