Register for your free account! | Forgot your password?

Go Back   elitepvpers > MMORPGs > Guild Wars > GW Exploits, Hacks, Bots, Tools & Macros
You last visited: Today at 03:04

  • Please register to post and access all features, it's quick, easy and FREE!


OK to ask for exploit/Scripting help here...

Discussion on OK to ask for exploit/Scripting help here... within the GW Exploits, Hacks, Bots, Tools & Macros forum part of the Guild Wars category.

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
Cool OK to ask for exploit/Scripting help here...

I started a thread back in the day like this else where and it went pretty well, so trying again here...

I will start off the convo with this:

Working on an exploit/script etc.. and I get this error because I closed my first gui and I am trying to run another one... Can someone explain why this happened and maybe suggest a work around?

...always eager to learn a thing or two!
Attached Images
File Type: png LabelLoadFinishedReturn.PNG (2.1 KB, 344 views)



phat34 is offline  
Old 05/12/2018, 08:49   #2
 
elite*gold: 0
Join Date: Feb 2016
Posts: 96
Received Thanks: 16
(edit: watch out with multiple client hacks)
Unsure, but most likely not caused by UI. Anyway I'll save you a Saturday, hopefully.

[Quick]
If lower function is almost similar (structure and construction) to that in your API...

Code:
Func ModifyMemory()
	$mASMSize = 0
	$mASMCodeOffset = 0
	$mASMString = ''
	CreateData()
	CreateMain()
	CreateTargetLog()
	CreateSkillLog()
	CreateSkillCancelLog()
	CreateSkillCompleteLog()
	CreateChatRev()
	CreateChatLog()
	CreateTraderHook()
	CreateDialogHook()
	CreateKREISCHRec()
	CreateLoadFinished()
	CreateStringLog()
	CreateStringFilter1()
	CreateStringFilter2()
	CreateRenderingMod()
	CreateCommands()
	$mMemory = MemoryRead(MemoryRead($mBase), 'ptr')
	Switch $mMemory
		Case 0
			$mMemory = DllCall($mKernelHandle, 'ptr', 'VirtualAllocEx', 'handle', $mGWProcHandle, 'ptr', 0, 'ulong_ptr', $mASMSize, 'dword', 0x1000, 'dword', 64)
			$mMemory = $mMemory[0]
			MemoryWrite(MemoryRead($mBase), $mMemory)
			CompleteASMCode()
			WriteBinary($mASMString, $mMemory + $mASMCodeOffset)
			WriteBinary('83F8009090', GetValue('ClickToMoveFix'))
			MemoryWrite(GetValue('QueuePtr'), GetValue('QueueBase'))
			MemoryWrite(GetValue('SkillLogPtr'), GetValue('SkillLogBase'))
			MemoryWrite(GetValue('ChatRevAdr'), GetValue('ChatRevBase'))
			MemoryWrite(GetValue('ChatLogPtr'), GetValue('ChatLogBase'))
			MemoryWrite(GetValue('StringLogPtr'), GetValue('StringLogBase'))
		Case Else
			CompleteASMCode()
	EndSwitch
	WriteDetour('MainStart', 'MainProc')
	WriteDetour('TargetLogStart', 'TargetLogProc')
	WriteDetour('TraderHookStart', 'TraderHookProc')
	WriteDetour('DialogStart', 'DialogHookProc')
	WriteDetour('DialogRec', 'DialogRecProc')
	WriteDetour('LoadFinishedStart', 'LoadFinishedProc')
	WriteDetour('RenderingMod', 'RenderingModProc')
	WriteDetour('StringLogStart', 'StringLogProc')
	WriteDetour('StringFilter1Start', 'StringFilter1Proc')
	WriteDetour('StringFilter2Start', 'StringFilter2Proc')
EndFunc

[Dirty]
Continue changing...

Code:
Func GetLabelInfo($aLab)
	Local Const $lVal = GetValue($aLab)
	If $lVal <> -1 Then Return $lVal
	Exit MsgBox(0x10, 'Error', 'Label "' & $aLab & '" tries faq.')
EndFunc
to...

Code:
Func GetLabelInfo($aLab)
	Local Const $lVal = GetValue($aLab)
	Return $lVal
EndFunc
... for now.

CHEERS


Walles/TEŽ/In_Zombiac is offline  
Old 05/12/2018, 20:19   #3
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
Great... so we are actually crashing into a open thread by doing this...?

What would be the clean way>??

and what are the repercussions of doing it the quick/easy way since my main goal is stability?
phat34 is offline  
Old 05/13/2018, 22:18   #4
 
elite*gold: 0
Join Date: May 2014
Posts: 238
Received Thanks: 273


DerMoench14 is offline  
Thanks
1 User
Old 05/13/2018, 23:22   #5
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
Cool FAST Method not recomended...

Going to read that thread... thanks DerMoench14... and thanks for the original quick method, but I have had not desired results so far with the quick-dirty fix, such as: Smart Cast getting knock out on a bot restart and secondary included auto-it files no longer working.
phat34 is offline  
Old 05/14/2018, 18:37   #6
 
elite*gold: 0
Join Date: Mar 2018
Posts: 5
Received Thanks: 1
Walles, why don't you say nothing instead of giving the single worst "solution" ?
If it tell you that there is an error, it's not by removing the message box that the error will be fix.
MrBigBones is offline  
Old 05/15/2018, 00:09   #7
 
elite*gold: 0
Join Date: Jun 2013
Posts: 39
Received Thanks: 25
its walles tho
4D1 is offline  
Old 05/15/2018, 01:36   #8
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
ok... issue # 2

I have a party spread out in the underworld that all die in different parts of a map...or maps (sub zone wise only). I find the GetPartyDead() via Getisdead($mAgentID) becomes in-effective - - as a remedy I have tried many solutions, but to no avail... Only know , improper solution is timer after so many iterations of the getpartydead() loop.
Have tried accessing agent directly doing geteffect() method as well as %hp * maxhp method as well... both without any merit.
phat34 is offline  
Old 05/15/2018, 15:32   #9
 
elite*gold: 0
Join Date: Nov 2015
Posts: 8
Received Thanks: 1
deleted
sushitech is offline  
Old 05/15/2018, 16:15   #10
 
elite*gold: 0
Join Date: Jan 2013
Posts: 40
Received Thanks: 22
Hey sushitech, I can't help but i have the same problem with a bot I have, the moveto func doesn't even work properly in disabled rendering mode.
It just stops on half way or it doesn't walk to the spot it should.
I add the file, maybe it is the same problem with your bot.

E: I know that it isn't updated
Attached Files
File Type: zip tenguranger.zip (35.5 KB, 12 views)
zoidberg1337 is offline  
Old 05/17/2018, 04:18   #11
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
Sushitech and zoidberg ---- try implementing this fix... It made my bot work more like a bot, and cleaned up the ("getting lost") and ("non responsive") issues quite a bit... it also fixed rendering...



well, for issue #2, I have a partial fix with the returntooutpost() function but still not 100% ideal...

I would like to keep track of my party which distance is far from me better if possible... perhaps the memory location where the red health bars are read from.

Issue #3 --- After a successful or failed run and back at the outpost... with my Initialize(ProcessExists("gw.exe"), True, True, True) = False command towards the beginning of my script... therefore making string logs and the event system accessible. So on my first run, my bot has no problem finding the merchant and xunial chance. However, on future iterations, the script can not find the merchant or xunial...? What gives... any hints would be appreciated.?
phat34 is offline  
Old 05/18/2018, 14:51   #12
 
elite*gold: 0
Join Date: Nov 2015
Posts: 8
Received Thanks: 1
deleted
sushitech is offline  
Old 05/18/2018, 19:52   #13
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
Actually using event system to locate them and go to them (sorta like holding down alternate and matching the text "Merchant"), then using dllstruct get data to get x.y then move to them.... some of the prior issues were caused by the headers being changed...so after checking my bots today I will update here if there are still things causing me trouble.

Seems like the header change hit me gradually as it ran up to the full change of headers... most likely because I was running the un-updated .exe file... which was somewhat affected by some server side changes but not 100% on how it works.
phat34 is offline  
Old 05/19/2018, 03:16   #14
 
elite*gold: 0
Join Date: Jan 2016
Posts: 63
Received Thanks: 5
meh update messed up the ferry bot i was given.
I mystogan I is offline  
Old 06/15/2018, 04:43   #15
 
elite*gold: 0
Join Date: Sep 2014
Posts: 182
Received Thanks: 46
* bump *


phat34 is offline  
Reply



« Nicholas The Traveller - Farm Thread | Pre Farmer »

Similar Threads
Hello guys, i got hacked and gm didnt help me :( so i ask for help here
12/22/2009 - Kal Online - 25 Replies
Hello guys, i got hacked 7 days ago, i sent a c/s to gms connected my id card, they told me twrite back after 7 days... GM Reply Hello. This is Kalonline. We checked over your report and blocked hackers.
HELP! I need help scripting
02/06/2007 - Conquer Online 2 - 1 Replies
OK, I want to know how u ppl do it&#33; I what program do u use to make them? cause i wanna help but i dun know how... somone plz reply&#33;
L2Walker, scripting questions/help
12/13/2006 - Lineage 2 - 0 Replies
Hey, just asking a few questions hope you don&#39;t mind ^_^ I&#39;m looking to make a script so when I cast magic on something, the walker bot will cast, say Wind Strike, on the same thing, at the same time. I&#39;ve looked through the options in walker and have it setup now, but it doesn&#39;t cast at the same time, but when I&#39;ve finished casting. If this isn&#39;t possible, last time I checked Walker scripts could not pickup what was said in chat, is this still the case? Thanks. ^_^ Note: If you...
I need help scripting
09/05/2006 - General Coding - 0 Replies
Ok I am tired of leeching I am ready to try my hand at scripting but I dont know where to start and I was wondering if someone could help me get started or tell me a website that can help me learn so I can make my own hacks and contribute to the epvp community that we all love :D



All times are GMT +2. The time now is 03:04.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

BTC: 3KeUpz52VCbhmLwuwydqxu6U1xsgbT8YT5
ETH: 0xc6ec801B7563A4376751F33b0573308aDa611E05

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2019 elitepvpers All Rights Reserved.