Register for your free account! | Forgot your password?


Go Back   elitepvpers > MMORPGs > Guild Wars > GW Bots
You last visited: Today at 07:03

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



OK to ask for exploit/Scripting help here...

Discussion on OK to ask for exploit/Scripting help here... within the GW Bots forum part of the Guild Wars category.

Reply
 
Old 03/06/2019, 20:40   #61

 
elite*gold: 0
Join Date: Nov 2017
Posts: 179
Received Thanks: 130
RiflemanX
thank you for our help now my heros use skills the raptor bot have help me me
NiliyaFlamme is offline  
Old 03/08/2019, 03:32   #62
 
elite*gold: 0
Join Date: Aug 2016
Posts: 3
Received Thanks: 0
I have a problem since the last update when I want the character to deposit money or take it in the chest Xunlai this one doesn't do anything.

I use the classic functions of GWA2 (version: 3.7.11)

WithdrawGold ()
DepositGold ()

Quote:
;~ Description: Deposit gold into storage.
Func DepositGold($aAmount = 0)
Local $lAmount
Local $lStorage = GetGoldStorage()
Local $lCharacter = GetGoldCharacter()

If $aAmount > 0 And $lCharacter >= $aAmount Then
$lAmount = $aAmount
Else
$lAmount = $lCharacter
EndIf

If $lStorage + $lAmount > 1000000 Then $lAmount = 1000000 - $lStorage

ChangeGold($lCharacter - $lAmount, $lStorage + $lAmount)
EndFunc ;==>DepositGold

;~ Description: Withdraw gold from storage.
Func WithdrawGold($aAmount = 0)
Local $lAmount
Local $lStorage = GetGoldStorage()
Local $lCharacter = GetGoldCharacter()

If $aAmount > 0 And $lStorage >= $aAmount Then
$lAmount = $aAmount
Else
$lAmount = $lStorage
EndIf

If $lCharacter + $lAmount > 100000 Then $lAmount = 100000 - $lCharacter

ChangeGold($lCharacter + $lAmount, $lStorage - $lAmount)
EndFunc ;==>WithdrawGold

;~ Description: Internal use for moving gold.
Func ChangeGold($aCharacter, $aStorage)
Return SendPacket(0xC, $ChangeGoldHeader, $aCharacter, $aStorage)
EndFunc ;==>ChangeGold

ChangeGoldHeader = 0x81
Lander92 is offline  
Old 03/08/2019, 08:42   #63
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by Lander92 View Post
I have a problem since the last update when I want the character to deposit money or take it in the chest Xunlai this one doesn't do anything.

I use the classic functions of GWA2 (version: 3.7.11)

WithdrawGold ()
DepositGold ()
Please look through the past pages. This issue has already been addressed and the correction that you need to make has already been posted.
RiflemanX is offline  
Thanks
1 User
Old 03/08/2019, 14:04   #64
 
elite*gold: 0
Join Date: Aug 2016
Posts: 3
Received Thanks: 0
Quote:
Originally Posted by RiflemanX View Post
Please look through the past pages. This issue has already been addressed and the correction that you need to make has already been posted.
Sorry I haven't seen this answer

Quote:
Originally Posted by Borega View Post
Look at the functions: Getgoldcharacter(), DepositGold(), DonateFaction() and be sure to update your headers using the updatescript.

Suddenly seeing this answer a problem is presented.

This one talks about an update script, I thought about the Guild Wars Botting API Patcher 1.6. But I think it is out of date compared to the last update.

I compared the $ HEADER that are present in my GWA2 and in the GWA2_Headers, they are exactly the same values, it's just the names that change.

PS : Here is my header for move golds
Global Const $ChangeGoldHeader = 0x81

and the present header in gwa2_headers
Global Const $HEADER_GOLD_MOVE = 0x81 ;Moves Gold (from chest to inventory, and otherway around IIRC)
Lander92 is offline  
Old 03/08/2019, 17:28   #65
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by Lander92 View Post
Sorry I haven't seen this answer




Suddenly seeing this answer a problem is presented.

This one talks about an update script, I thought about the Guild Wars Botting API Patcher 1.6. But I think it is out of date compared to the last update.

I compared the $ HEADER that are present in my GWA2 and in the GWA2_Headers, they are exactly the same values, it's just the names that change.

Test your newly updated scripts by checking to make sure they count items in your inventory accurately.

PS : Here is my header for move golds
Global Const $ChangeGoldHeader = 0x81

and the present header in gwa2_headers
Global Const $HEADER_GOLD_MOVE = 0x81 ;Moves Gold (from chest to inventory, and otherway around IIRC)
0x81 is correct for the header. As for the other updates, check these two functions in your GWA2 and ensure they are updated:

Code:
;~ Description: Returns amount of gold in storage.
 Func GetGoldStorage()     
Local $lOffset[5] = [0, 0x18, 0x40, 0xF8, 0x94]                   
 ; from 80     Local $lReturn = MemoryReadPtr($mBasePointer, $lOffset)     
Return $lReturn[1] 
EndFunc   ;==>GetGoldStorage  

;~ Description: Returns amount of gold being carried.
 Func GetGoldCharacter()  
  Local $lOffset[5] = [0, 0x18, 0x40, 0xF8, 0x90]  
; from 7C     Local $lReturn = MemoryReadPtr($mBasePointer, $lOffset)
Return $lReturn[1] 
EndFunc   ;==>GetGoldCharacter
Also, find this line for your $ItemStruct and make sure it is updated with this one:
[
Code:
Local $lItemStruct = DllStructCreate('long id;long agentId;ptr bagequipped;ptr bag;ptr modstruct;long modstructsize;ptr customized;long modelfileid;byte type;byte unknown1;short extraId;short value;byte unknown2[2];long interaction;long modelId;ptr modString;ptr namestring2;ptr namestring;ptr singleitemname;byte itemowner;byte unknown3[9];byte ismaterialsalvageable;byte unknown4;short quantity;byte equipped;byte profession;byte slot')
If you are working with a script that counts anything you may have noticed that it is not counting correctly. Updating as listed above will help fix this problem along with a few other things.
RiflemanX is offline  
Old 03/14/2019, 09:08   #66
 
elite*gold: 0
Join Date: Apr 2008
Posts: 14
Received Thanks: 1
Open chest using Canthan Key

NVM got it
noobsuy is offline  
Old 03/15/2019, 14:02   #67
 
elite*gold: 0
Join Date: Aug 2014
Posts: 17
Received Thanks: 0
hello i will want to know how coded to stop my bot after the first loop please?
diguano is offline  
Old 03/16/2019, 15:32   #68
 
elite*gold: 0
Join Date: Apr 2008
Posts: 14
Received Thanks: 1
Lately Ive been running into a lot of GW crashes and I cant pinpoint where its at really. It happens with the easiest bot that ports to a town, leaves it and runs a few seconds using the MoveTo function of GWA2. All headers are updated as well as the latest GWA2.

Guild Wars error log states: (2) Client pathing data out of sync with server. You may observe your character 'warping' during movement.
(2) Sequence queue congestion.

I cant really pinpoint whats going wrong even with logging certain functions. I assume it has to do with getting body blocked but im not sure.

Any help?
noobsuy is offline  
Old 03/16/2019, 18:26   #69
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by noobsuy View Post
Lately Ive been running into a lot of GW crashes and I cant pinpoint where its at really. It happens with the easiest bot that ports to a town, leaves it and runs a few seconds using the MoveTo function of GWA2. All headers are updated as well as the latest GWA2.

Guild Wars error log states: (2) Client pathing data out of sync with server. You may observe your character 'warping' during movement.
(2) Sequence queue congestion.

I cant really pinpoint whats going wrong even with logging certain functions. I assume it has to do with getting body blocked but im not sure.

Any help?
Do all your scripts crash like this? What specific script is this that you refer too? More info = more help.
RiflemanX is offline  
Old 03/16/2019, 19:05   #70
 
elite*gold: 0
Join Date: Aug 2014
Posts: 17
Received Thanks: 0
hello i will want to know how coded to stop my bot after the first run please? cordialy
diguano is offline  
Old 03/16/2019, 19:53   #71
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by diguano View Post
hello i will want to know how coded to stop my bot after the first run please? cordialy

Code:
Exit
RiflemanX is offline  
Old 03/16/2019, 21:28   #72
 
elite*gold: 0
Join Date: Apr 2008
Posts: 14
Received Thanks: 1
Ive reduced the script as much as I could and it still crashes very randomly, sometimes after 4 iterations, sometimes after 20 or 40. I dont have this issue with every bot. But I noticed my fiber bot (which I did not change for a couple of weeks, started crashing too after about 3 hours).

This little script however already crashes after 3-7 min.

See attachment
Attached Files
File Type: zip Crashing.zip (47.4 KB, 3 views)
noobsuy is offline  
Old 03/16/2019, 22:36   #73
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by noobsuy View Post
Ive reduced the script as much as I could and it still crashes very randomly, sometimes after 4 iterations, sometimes after 20 or 40. I dont have this issue with every bot. But I noticed my fiber bot (which I did not change for a couple of weeks, started crashing too after about 3 hours).

This little script however already crashes after 3-7 min.

See attachment
What is this? It looks like its suppose to be Pogmei Chest runner but everything is missing from the main combat loop. Your loop looks like it just goes outside, runs to a certain spot, then casts IAU and then goes back to town. I don't understand.

Code:
Func CombatLoop()
	If Not $RenderingEnabled Then ClearMemory()
	Out($numChestsFound & " chests found")
	Local $openedChestIDs[5]
	Local $openedChestIndex = 0
	Out("RunTo1")
	RunTo(-12290, 976)
	Out("use iau")
	UseSkill($IAU)
	
	If GetIsDead(-2) Then
		Out("Failed")
		$FailCount += 1
		GUICtrlSetData($FailsLabel, $FailCount)
		MapDT()
		Sleep(1000)
		Return False
	Else
		$RunCount += 1
		GUICtrlSetData($RunsLabel, $RunCount)
		MapDT()
		Sleep(1000)
		Return True
	EndIf
EndFunc
Well, whatever your trying to do, experiment with changing out your gwa2 with another script that is running well and see if that helps. I do not see any errors in your base script.
RiflemanX is offline  
Old 03/17/2019, 08:23   #74
 
elite*gold: 0
Join Date: Apr 2008
Posts: 14
Received Thanks: 1
Yep, that is my whole point. I made a pongmei chest runner myself and I was planning to make different chest runners as well. The point of THIS script is to just provide a script that still crashes on my pc while being stripped of everything else. i.e to narrow down the problem...

I can't see anything wrong with it either, but it crashes which is why I have no clue wtf is going on.

Edit: I already tried different GWA2 files, from your bots and others.
noobsuy is offline  
Old 03/17/2019, 12:29   #75
 
elite*gold: 0
Join Date: Feb 2014
Posts: 180
Received Thanks: 337
Quote:
Originally Posted by noobsuy View Post
Yep, that is my whole point. I made a pongmei chest runner myself and I was planning to make different chest runners as well. The point of THIS script is to just provide a script that still crashes on my pc while being stripped of everything else. i.e to narrow down the problem...

I can't see anything wrong with it either, but it crashes which is why I have no clue wtf is going on.

Edit: I already tried different GWA2 files, from your bots and others.
Compile the script into a .exe and run as admin. It could be possible that your anti-virus kills the process on a random security sweep.
RiflemanX is offline  
Reply


Similar Threads Similar Threads
Hello guys, i got hacked and gm didnt help me :( so i ask for help here
12/22/2009 - Kal Online - 25 Replies
Hello guys, i got hacked 7 days ago, i sent a c/s to gms connected my id card, they told me twrite back after 7 days... GM Reply Hello. This is Kalonline. We checked over your report and blocked hackers.
HELP! I need help scripting
02/06/2007 - Conquer Online 2 - 1 Replies
OK, I want to know how u ppl do it! I what program do u use to make them? cause i wanna help but i dun know how... somone plz reply!
L2Walker, scripting questions/help
12/13/2006 - Lineage 2 - 0 Replies
Hey, just asking a few questions hope you don't mind ^_^ I'm looking to make a script so when I cast magic on something, the walker bot will cast, say Wind Strike, on the same thing, at the same time. I've looked through the options in walker and have it setup now, but it doesn't cast at the same time, but when I've finished casting. If this isn't possible, last time I checked Walker scripts could not pickup what was said in chat, is this still the case? Thanks. ^_^ Note: If you...
I need help scripting
09/05/2006 - General Coding - 0 Replies
Ok I am tired of leeching I am ready to try my hand at scripting but I dont know where to start and I was wondering if someone could help me get started or tell me a website that can help me learn so I can make my own hacks and contribute to the epvp community that we all love :D



All times are GMT +2. The time now is 07:03.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2021 elitepvpers All Rights Reserved.