Register for your free account! | Forgot your password?

You last visited: Today at 12:55

  • Please register to post and access all features, it's quick, easy and FREE!

 

Hero Online Hellfire Bot

Reply
 
Old   #136
 
elite*gold: 0
Join Date: May 2009
Posts: 1,047
Received Thanks: 468
i have been runing the bot for 4h and had no problems the thing i want to the bot is to be able to leave the window to do some other stuff but still the bot is 10/10, Good bye Aid system hahaha



ax5 is offline  
Old   #137
 
elite*gold: 0
Join Date: Jun 2011
Posts: 53
Received Thanks: 1
Quote:
Originally Posted by ax5 View Post
i have been runing the bot for 4h and had no problems the thing i want to the bot is to be able to leave the window to do some other stuff but still the bot is 10/10, Good bye Aid system hahaha
I have a virtual machine running with the bot and that works out perfectly fine for me. That's a valid option for me to have it running on the side. The performance is a little poor though, but if you don't have to interact with the game to npc anything or such it works pretty well.


willi1602 is offline  
Old   #138
 
elite*gold: 0
Join Date: Aug 2015
Posts: 5
Received Thanks: 0
for some reson the bot notworking anymore when i run the bot and it make hero go black
huynhhaimap0 is offline  
Old   #139
 
elite*gold: 0
Join Date: Jun 2008
Posts: 428
Received Thanks: 289
Quote:
Originally Posted by willi1602 View Post
I have a virtual machine running with the bot and that works out perfectly fine for me. That's a valid option for me to have it running on the side. The performance is a little poor though, but if you don't have to interact with the game to npc anything or such it works pretty well.
Yeah, I tried working it so the bot wouldn't flicker so bad but it's a timeshare issue with Windows and vms. Windows wants to hog the cpu time. I'm running 4 vms concurrent. Netgame restructured everything so it has been "fun" recoding the bot. I'm working as fast as I can, tho.

MANY THANKS for you guys sending me bug reports via Skype!! It has helped a lot with the screenshots to narrow down the problems with the Hunting Aid bug/glitch. I am testing a workaround that seems to handle the bug. Will send it out as soon as I'm finished testing.


karraksc is offline  
Thanks
1 User
Old   #140
 
elite*gold: 0
Join Date: Jul 2015
Posts: 4
Received Thanks: 0
thanks one more time for your work bot is running better then any time
Chami93 is offline  
Old   #141
 
elite*gold: 0
Join Date: Jun 2011
Posts: 53
Received Thanks: 1
Quote:
Originally Posted by karraksc View Post
Yeah, I tried working it so the bot wouldn't flicker so bad but it's a timeshare issue with Windows and vms. Windows wants to hog the cpu time. I'm running 4 vms concurrent. Netgame restructured everything so it has been "fun" recoding the bot. I'm working as fast as I can, tho.

MANY THANKS for you guys sending me bug reports via Skype!! It has helped a lot with the screenshots to narrow down the problems with the Hunting Aid bug/glitch. I am testing a workaround that seems to handle the bug. Will send it out as soon as I'm finished testing.
I am not getting any flickering in my VMs, I just get massive fps drops (which is due to the VM, not due to the bot). However, I appreciate the awesome work on it! Just curious, can automatic NPCing be implemented for certain areas, like SV?
willi1602 is offline  
Old   #142
 
elite*gold: 0
Join Date: Aug 2011
Posts: 2
Received Thanks: 0
HI MEN NICE JOB
------------------
Help me plz karraksc

forget the password bank(LATCH)

Do you think that information should be stored in some file of the game?

help plz :c

postscript:
I can not verify my account by mail is erased because it is very old 2006 xD
djhakek is offline  
Old   #143
 
elite*gold: 0
Join Date: Jun 2008
Posts: 428
Received Thanks: 289
Quote:
Originally Posted by Chami93 View Post
thanks one more time for your work bot is running better then any time
When I added in code to deal with time-sharing in a vm, the bot started working smoother under windows (to the point the skilling is as fast/smooth as the in-game hunting aid or better) I'm not sure if the flicker is just in the VMware 11 driver or just what is causing it here. A friend who was testing vms in virtual box had the menus go completely invisible in Virtualbox.

I am almost ready to send out another update, to fix the issues with the bot locking when the char revives, a work-around to the Hunting Aid glitch, and several fixes to stuff I skipped over in the rush to get hellfire out for the release. I am working on finishing things up, got to kill my char a few more times to test out the revive routines.

Quote:
Originally Posted by djhakek View Post
HI MEN NICE JOB
------------------
Help me plz karraksc

forget the password bank(LATCH)

Do you think that information should be stored in some file of the game?

help plz :c

postscript:
I can not verify my account by mail is erased because it is very old 2006 xD
If you still remember what it was, log into the account you currently have and send a 1:1 to Kuro explaining you can't reset your password because you no longer have access to that email. I had to do that to one of my old accounts after I changed ISPs and couldn't get to my mail account there.

As for the password latch, I don't think you should worry about that, unless you just put a password on it. It is not stored on your system, only on the Netgame servers. If it for an account created before Hero Plus came out, you wouldn't be able to recover it, since they wiped ALL the items in ALL the accounts. Items, chars, everything.

Quote:
Originally Posted by willi1602 View Post
I am not getting any flickering in my VMs, I just get massive fps drops (which is due to the VM, not due to the bot). However, I appreciate the awesome work on it! Just curious, can automatic NPCing be implemented for certain areas, like SV?
Which vm app are you running? I'm running VMware 11, and a friend of mine is using Virtualbox.
karraksc is offline  
Thanks
1 User
Old   #144
 
elite*gold: 0
Join Date: Oct 2007
Posts: 764
Received Thanks: 67
karraksc hi i wanted to say that the bot sometimes just stands still and does nothing he just uses healing potions.
Can it be that the Bot causes Dc or is it on my system'?
What resultation can you recommed? full or window screen ?
Are you running windows 7 light version on your vms?
sry lots of questions
tigerfire is offline  
Old   #145
 
elite*gold: 0
Join Date: Jun 2011
Posts: 53
Received Thanks: 1
Quote:
Originally Posted by karraksc View Post
Which vm app are you running? I'm running VMware 11, and a friend of mine is using Virtualbox.
This one:
You must register and activate your account in order to view images.

Quote:
Originally Posted by tigerfire View Post
karraksc hi i wanted to say that the bot sometimes just stands still and does nothing he just uses healing potions.
Can it be that the Bot causes Dc or is it on my system'?
What resultation can you recommed? full or window screen ?
Are you running windows 7 light version on your vms?
sry lots of questions
Maybe I can help a bit here.
Are your skills set? If I turn on Hellfire in the loading screen, the profile for the character isn't loaded afterwards, so the skills are not set. That's why it will just stand there hitting pots. Also, is it activated? Do you see the usual labels for example "bot routines started / stopped"? Or do you just see something like "popup" in that window? If Hellfire crashes, I experienced weird labels and the bot would not work at all anymore until I restart hero (seems to be game client dependant).

Resolution does not seem to matter from my point of view, I tried 1024x800, 1440x900, 1680x1050 and 1920x1080 and the bot seems to work fine at any resolution (window mode), so I can only recommend that.

I personally use Windows 7 Professional X64 for the bot, I think I tried Windows 10 and (oh, what a surprise) it didn't work at all. Haven't tried with Win8 yet.



Another thing at the developer: have you used hunting aid with a monk yet? Do you know that it cancels like every second skill and attempt to recast? Hellfire does the same, does it use the hunting aid routines? Do you think you could fix something about that?
willi1602 is offline  
Old   #146
 
elite*gold: 0
Join Date: Jun 2008
Posts: 428
Received Thanks: 289
Quote:
Originally Posted by tigerfire View Post
karraksc hi i wanted to say that the bot sometimes just stands still and does nothing he just uses healing potions.
Can it be that the Bot causes Dc or is it on my system'?
What resultation can you recommed? full or window screen ?
Are you running windows 7 light version on your vms?
sry lots of questions
If the window is no focused, you will see the char just swinging and using pots, but not using skills. Also, check to see if the light next to the word ACTIONS is lit or not. If the light is red, but the bot is running, you ran into the hunting aid glitch. Stop the bot and then click on that light when it turns green. This will reset the hunting aid so you can use it again.

I am using XP in my vms, TinyXP rev 11. Small footprint so my vm drive is only 5 gig with Hero installed. I then made 3 clones of it to run.

Quote:
Originally Posted by willi1602 View Post
This one:
You must register and activate your account in order to view images.



Maybe I can help a bit here.
Are your skills set? If I turn on Hellfire in the loading screen, the profile for the character isn't loaded afterwards, so the skills are not set. That's why it will just stand there hitting pots. Also, is it activated? Do you see the usual labels for example "bot routines started / stopped"? Or do you just see something like "popup" in that window? If Hellfire crashes, I experienced weird labels and the bot would not work at all anymore until I restart hero (seems to be game client dependant).

Resolution does not seem to matter from my point of view, I tried 1024x800, 1440x900, 1680x1050 and 1920x1080 and the bot seems to work fine at any resolution (window mode), so I can only recommend that.

I personally use Windows 7 Professional X64 for the bot, I think I tried Windows 10 and (oh, what a surprise) it didn't work at all. Haven't tried with Win8 yet.



Another thing at the developer: have you used hunting aid with a monk yet? Do you know that it cancels like every second skill and attempt to recast? Hellfire does the same, does it use the hunting aid routines? Do you think you could fix something about that?
Once the bot loads up, if you don't see your skills in the list, try clicking on NORMAL. When you click on any item in that list, it also refreshes the list from the game memory.

8^D Took me a while, almost 7 months to get the quirks worked out of the floating overlay for hellfire so it would work with about any resolution.

With vms, the best settings are 1024x768 windowed, with the graphics settings down as low as possible. Actually you could run it in 800x600, by modding the screen size in TDH_Launcher.ini, and it would still run. I'm still working on finding the best setups for vms, so I'll be adding more things specific to them as I go along.

I've got a monk that I am running right now, to test things out with. The issue there is the long charge times for the skills. If it delays more than 1.5-2 seconds, it skips to the next usable skill. I haven't found a way to reliably identify when a buff skill runs out yet, so I haven't added that yet. Once I can find that, then I can make the monk def buff constant, as well as the 2nd job skills (Def, str/dex,int, dodge, etc) like I had in the old hellfire.
karraksc is offline  
Old   #147
 
elite*gold: 0
Join Date: Oct 2007
Posts: 764
Received Thanks: 67
anyone knows at which parameter they give out vetaran rewards?
i could only get it with 2 accounts i even opened it with a vm etc.
Its hard to bot without it xD
tigerfire is offline  
Old   #148
 
elite*gold: 0
Join Date: Jun 2008
Posts: 428
Received Thanks: 289
Quote:
Originally Posted by tigerfire View Post
anyone knows at which parameter they give out vetaran rewards?
i could only get it with 2 accounts i even opened it with a vm etc.
Its hard to bot without it xD
You only get one per account
karraksc is offline  
Thanks
1 User
Old   #149
 
elite*gold: 0
Join Date: Oct 2007
Posts: 764
Received Thanks: 67
yeha i know but i tryed it with 7 diffrent accounts they say im not eligeble to get that reward.
tigerfire is offline  
Old   #150
 
elite*gold: 0
Join Date: Jun 2008
Posts: 428
Received Thanks: 289
Quote:
Originally Posted by tigerfire View Post
yeha i know but i tryed it with 7 diffrent accounts they say im not eligeble to get that reward.
I've got 17 so far, haven't had a problem. All of them had divines


karraksc is offline  
Thanks
1 User
Reply

Tags
hellfire, hero online, mjsbots



« Previous Thread | Next Thread »



All times are GMT +1. The time now is 12:55.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.