Register for your free account! | Forgot your password?

Go Back   elitepvpers > General Gaming > General Gaming Discussion
You last visited: Today at 20:34

  • Please register to post and access all features, it's quick, easy and FREE!

 

Autoit not working with Requiem

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Dec 2008
Posts: 2
Received Thanks: 0
Autoit not working with Requiem

I know Hack shield is removed since the speed hack works fine but i don't know why auto it doesn't send keys or moves the mouse once the window is active.

Any one know what i should do?
I already tried deleting the HS folders that Jatacid mention and did a full check , still nothing.

If anyone knows a way around this or a program that does work tell me.



antiarriorx is offline  
Old   #2
 
elite*gold: 0
Join Date: Dec 2008
Posts: 2
Received Thanks: 0
you can del this.... i didn't look into direct input XD ....srry....ehmm , but i would like to know where i can get a list of hex values. There are a few on the forums, but is there a table that i could look at?


antiarriorx is offline  
Old   #3
 
elite*gold: 0
Join Date: Oct 2009
Posts: 1
Received Thanks: 0
Did you get it to work????
blahblahhaha is offline  
Old   #4
 
elite*gold: 0
Join Date: Feb 2007
Posts: 18
Received Thanks: 0
Quote:
Originally Posted by antiarriorx View Post
I know Hack shield is removed since the speed hack works fine but i don't know why auto it doesn't send keys or moves the mouse once the window is active.

Any one know what i should do?
I already tried deleting the HS folders that Jatacid mention and did a full check , still nothing.

If anyone knows a way around this or a program that does work tell me.
I also would like to know that...
I mean Jatacid made it work, so there´s GOTTA be a way.


Yezir is offline  
Old   #5
 
elite*gold: 0
Join Date: Nov 2008
Posts: 336
Received Thanks: 315
I havent tried recently but it still works for me. Are you using ControlSend( ? Because ControlSend will not work - only Send( to an active window will work

Add:
Post a sample of your code ^_^ I can take a look
Jatacid is offline  
Old   #6
 
elite*gold: 0
Join Date: Feb 2007
Posts: 18
Received Thanks: 0
Quote:
Originally Posted by Jatacid View Post
I havent tried recently but it still works for me. Are you using ControlSend( ? Because ControlSend will not work - only Send( to an active window will work

Add:
Post a sample of your code ^_^ I can take a look
PHP Code:

HotKeySet 
("{ESC}""_exit")
HotKeySet ("{F12}""_pause")

Sleep(5000) ; Time to select Requiem window by myself!


 While 
1  
 Send 
("1")  
 
Sleep(1000)  
 
Send ("2"
 
Sleep (5000
 
 
WEnd  

Func _exit
()
    Exit
EndFunc

Func _pause
()
    while 
1
    Sleep
(9999999)
WEnd
EndFunc 
Doesnt work at all.
1 is the button for selecting a target
2 is the button to attack
Yezir is offline  
Old   #7
 
elite*gold: 0
Join Date: Nov 2008
Posts: 336
Received Thanks: 315
Code:
HotKeySet ("{ESC}", "_exit") 
HotKeySet ("{F12}", "_pause") 

WinActivate("Requiem") ;Selects& Activates Requiem window for you ;)

 While 1   
Send("{1 down}")
Sleep(80)
send("{1 up}")
 Sleep(1000)   
Send("{2 down}")
Sleep(80)
send("{2 up}")
Sleep (5000)    
 WEnd

Func _exit() 
    Exit 
EndFunc 

Func _pause() 
    while 1 
    Sleep(9999999) 
WEnd 
EndFunc

Try that.
I think the problem was autoit wasnt pressing the keys down long enough for the game to register.
By sending the keypress DOWN, and then UP after a brief pause, it fixes that.

Otherwise you can also look into

Opt("SendKeyDownDelay",xxxx)
and
Opt("SendKeyDelay, xxxx)
in the help file. That way you dont have to write as many lines of code
Jatacid is offline  
Thanks
1 User
Old   #8
 
elite*gold: 0
Join Date: Feb 2007
Posts: 18
Received Thanks: 0
Quote:
Originally Posted by Jatacid View Post
Code:
HotKeySet ("{ESC}", "_exit") 
HotKeySet ("{F12}", "_pause") 

WinActivate("Requiem") ;Selects& Activates Requiem window for you ;)

 While 1   
Send("{1 down}")
Sleep(80)
send("{1 up}")
 Sleep(1000)   
Send("{2 down}")
Sleep(80)
send("{2 up}")
Sleep (5000)    
 WEnd

Func _exit() 
    Exit 
EndFunc 

Func _pause() 
    while 1 
    Sleep(9999999) 
WEnd 
EndFunc

Try that.
I think the problem was autoit wasnt pressing the keys down long enough for the game to register.
By sending the keypress DOWN, and then UP after a brief pause, it fixes that.

Otherwise you can also look into

Opt("SendKeyDownDelay",xxxx)
and
Opt("SendKeyDelay, xxxx)
in the help file. That way you dont have to write as many lines of code
Unfortunately doesn´t work...thank you for trying.
I even tried more Sleep time, in Word he writes down 1212...but ingame nothing happens
Maybe because i use Vista and need something with adminrights in the script?
I dunno...


Yezir is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Autoit Skript für Requiem
Hallo allerseits, ich versuche schon seit ca. 1 Woche täglich ein Bot für Requiem mit Autoit zu schreiben... Ein ganz simplen der lediglich die...
20 Replies - AutoIt
Updated Requiem Bot 1.09 and 1.03 + Working Tutorial
Hey guys I have been getting some messages about the requiem bot but since I don't play it no more I have had to re-update myself so please take a...
26 Replies - General Gaming Discussion



All times are GMT +1. The time now is 20:34.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.