Register for your free account! | Forgot your password?

Go Back   elitepvpers > News & More > Gaming News > Gaming News - EN
You last visited: Today at 05:47

  • Please register to post and access all features, it's quick, easy and FREE!

Advertisement



WoW - NVIDIA drivers issue

Discussion on WoW - NVIDIA drivers issue within the Gaming News - EN forum part of the Gaming News category.

Reply
 
Old   #1
 
elite*gold: 1531
Join Date: Jun 2008
Posts: 13,084
Received Thanks: 2,935
WoW - NVIDIA drivers issue

If you own a NVIDIA graphics card you should read the following bluepost from Datth:

"We're getting reports where users are getting intermittent low FPS after installing these drivers. It seems that it is related to the fan control included in these drivers not working correctly and is causing the video card to overheat on 3D applications. This will affect Warcraft 3, World of Warcraft and StarCraft 2 Beta. Please uninstall the drivers and revert back to the older ones."

Windows XP: NVIDIA DRIVERS 196.21 WHQL
Windows XP 64-bit: NVIDIA DRIVERS 196.21 WHQL
Windows Vista/7 32-bit: NVIDIA DRIVERS 196.21 WHQL
Windows Vista/7 64-bit: NVIDIA DRIVERS 196.21 WHQL

More information can be found on threads such as these:

- Major with new drivers with my- 9800gt not oc - NVIDIA Forums
- Problem with 196.75 driver - NVIDIA Forums"
- World of Warcraft - English (NA) Forums -> Recent In-Game Fixes - March 2010 - 3/4

As you can see, deleting the current drivers and switching to an older version is currently the best solution. If you seem to have familiar problems please report in this thread.
Attached Thumbnails
WoW - NVIDIA drivers issue-news_wownvidia.jpg  
Lucyy is offline  
Thanks
2 Users
Old 03/05/2010, 15:55   #2
 
elite*gold: 0
Join Date: Oct 2008
Posts: 53
Received Thanks: 106
Looks like the drivers only broke the automatic fan control of my graphics card. If you force your fan speed to 100% it will also work with the very latest drivers.
Ahiru is offline  
Thanks
1 User
Old 03/05/2010, 18:30   #3
 
elite*gold: 246
Join Date: Jan 2008
Posts: 1,712
Received Thanks: 895
Just for clarification, because it wasn't been stated explicitly, all references to "latest" or "current" drivers refer to the 196.75 version. References to "older" drivers are the 196.21 drivers, which the OP posted links for.

Nvidia has also removed the 196.75 drivers from their download pages as a precaution.
King_Arthur is offline  
Old 03/06/2010, 23:44   #4
 
elite*gold: 0
Join Date: Oct 2007
Posts: 88
Received Thanks: 3
Quote:
Originally Posted by King_Arthur View Post
Just for clarification, because it wasn't been stated explicitly, all references to "latest" or "current" drivers refer to the 196.75 version. References to "older" drivers are the 196.21 drivers, which the OP posted links for.

Nvidia has also removed the 196.75 drivers from their download pages as a precaution.
This isnt bothering the 175.19 updated drivers!
lustdemon is offline  
Reply

Tags
wow


Similar Threads Similar Threads
CabalRider+mouse drivers
09/07/2010 - Cabal Online - 0 Replies
Hello there, few days ago i had no problems using CabalRider.. then, when i was back from work and try launch bot after few min after i login i got GG detetection, is there posibility GG detection shows up because of my Oscar mouse editor+ Cabal rider, pls share some info about it Sry for bad english
WoW - NVIDIA drivers = böse !
03/10/2010 - Gaming News - DE - 6 Replies
Falls ihr eine NVIDIA Grafikkarte besitzt dann solltet ihr auf jedenfall folgenen BluePost von Datth lesen: "We're getting reports where users are getting intermittent low FPS after installing these drivers. It seems that it is related to the fan control included in these drivers not working correctly and is causing the video card to overheat on 3D applications. This will affect Warcraft 3, World of Warcraft and StarCraft 2 Beta. Please uninstall the drivers and revert back to the older...
Problems with ecsro and graphic drivers
02/11/2009 - SRO Private Server - 4 Replies
Hi all, a friend of mine is having some problems logging in ecsro. The first time, pressing start button, it said "failed to execute silkroad (errore code)" but I told him how to solve the problem. Second time he pressed start button and when he logged into the server it crashed with the "???" problem (interrogation points problem). I told him to download and install last graphic drivers and he did. But now when he press start button the whole pc restarts and he cannot starts ecsro or...
the sro drivers
02/25/2008 - Silkroad Online - 7 Replies
do u need the GeForce and ATi drivers and when i try to download them it says i dont have the right software plz help me
Drivers where found?
02/06/2008 - RO Guides & Templates - 0 Replies
Im trying to foud where is de Driver,and maybe if is possible load the Driver and don´t get the Disconection when use Delay 0 in the Filters Look the pic: ImageShack - Hosting :: driveraz5.jpg



All times are GMT +1. The time now is 05:47.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

BTC: 33E6kMtxYa7dApCFzrS3Jb7U3NrVvo8nsK
ETH: 0xc6ec801B7563A4376751F33b0573308aDa611E05

Support | Contact Us | FAQ | Advertising | Privacy Policy | Terms of Service | Abuse
Copyright ©2020 elitepvpers All Rights Reserved.