Register for your free account! | Forgot your password?

You last visited: Today at 04:00

  • Please register to post and access all features, it's quick, easy and FREE!


2Probleme ( Boxen) (Red Chip)

Closed Thread
 
Old   #1
 
elite*gold: 0
Join Date: Dec 2011
Posts: 66
Received Thanks: 13
2Probleme ( Boxen) (Red Chip)

Hallo ePvpers,

Ich habe folgendes problem, und zwar habe ich mir eben 2 Neue Sets erstellt ( einzelne parts) und nun wollte ich eine box erstellen wo jeweils das gesamte set raus kommt.

nun zu meinen problem, Ich habe die Box in PropPackItem erstellt, in der propItem.txt eingetragen mit Beschreibung in der DefineItem und in der Dyna ordnungsgemäß eingetragen, habe die 4 Set parts eingetragen.

PackItem II_SYS_SYS_SCR_BXMKNT150SET 0
{
II_ARM_M_LORDK_HELMETH 0 1
II_ARM_M_LORDK_SUITH 0 1
II_ARM_M_LORDK_GAUNTLETH 0 1
II_ARM_M_LORDK_BOOTSH 0 1
}

Nun gehe ich ingame erstelle mir dir Box und habe sie im inventar . aber sie lässt sich nicht öffnen.

zu meinem Zweiten Problem, Ich würde gerne Rüstung im Red Chip händler einfügen.
Habe das Part im Shop eingetragen
AddVenderitem4(2, II_WEA_SWO_SHSWOBLA);

der Eintrag aus der Spec:
= = ARMOR_SET = = = 1550 = = 0 0 0 0 0 0 =

Nun gehe ich Ingame und das Item befindet sich nicht im Shop


Bedanke mich im vorraus für die Hilfe.

MFG Monnyman



Monnyman is offline  
Old 11/30/2015, 19:07   #2

 
elite*gold: 270
Join Date: Oct 2008
Posts: 2,238
Received Thanks: 378
Zu deim ersten problem........

Quote:
Source:Project.h

Code:

#define MAX_PACKITEM 512

In

Code:

#define MAX_PACKITEM 1024


™Dryad is offline  
Thanks
1 User
Old 11/30/2015, 21:07   #3
 
elite*gold: 0
Join Date: Oct 2012
Posts: 947
Received Thanks: 153
2nd problem

Take an look on how the Nox Set for level 120 Blade has been set.
Code:
MaFL_Waforu
{
SetVenderType(1);
AddVenderItem2(0, II_SYS_SYS_SCR_BXMBLA120SET);
}
So unless you changed it in the source to let it use AddVenderitem4 it wont work.

Mover.cpp
Code:
if(pCharacter->m_nVenderType == 1) // ĨÀ¸·Î °Å·¡ÇÏ´Â venderÀÏ °æ¿ì
				{
					if(pCharacter->m_venderItemAry2[i].GetSize())
					{
						fShop	= TRUE;
						m_ShopInventory[i]->Clear();		// m_packÀ» ´Ù ¾ø¾Ø´Ù.
						for( int j = 0; j < pCharacter->m_venderItemAry2[i].GetSize(); j++ )
						{
							pVendor	= (LPVENDOR_ITEM)pCharacter->m_venderItemAry2[i].GetAt(j);
							CItemElem itemElem;
							itemElem.m_dwItemId	= pVendor->m_dwItemId;
							itemElem.m_nItemNum	= (short)( prj.GetItemProp( pVendor->m_dwItemId )->dwPackMax );
							itemElem.m_nHitPoint = prj.GetItemProp( pVendor->m_dwItemId )->dwEndurance;
							if( (int)itemElem.GetChipCost() < 1 )
								Error( "chip cost < 1 : npc = %s, item = %d", pCharacter->m_szKey, pVendor->m_dwItemId );
							else
								m_ShopInventory[i]->Add( &itemElem );
						}
					}
				}
raventh1984 is offline  
Thanks
1 User
Old 11/30/2015, 21:11   #4
 
elite*gold: 0
Join Date: Dec 2011
Posts: 66
Received Thanks: 13
Thanks , beide Probleme behoben
Monnyman is offline  
Closed Thread



« Whitescreen | [HELP] res Coverter »

Similar Threads
Warrock 2Probleme [Help!]
04/09/2012 - WarRock - 5 Replies
Hallo, ich habe seit einigen wochen 2probleme, die ich schonmal hier in Forum gepostet hab und zwar : Gamersfirst Hompage funktioniert nicht ich habe alles schon versucht z.B. Ccleaner + Chronik löschen + Cookies löschen + Browser wechsel und alles hat nicht gebracht -.- Ingame Clan Avatare werden nicht angezeigt die Clan Avatare werden bei mir micht mehr angezeigt habe " Checkfiles " geklickt + Neu Installiert und und und....
2Probleme pls Help
03/10/2012 - Metin2 PServer - Discussions / Questions - 0 Replies
Hallo ich habe 2 Probleme und eine Frage : Problem eins : ich habe ka wie ich diese mobs hier >>Hier Klikkään<< einfügenen kann (serverside) pls nur querys verstehe das mit dem manuellen einfügen und raussuchen usw. nicht <.< Für Querys wäre ich sehr sehr dankbar :D Und Problem 2 : Wenn ich auf meinen samuraimt2 serverfiles connecten will kommt da immer wenn ich imgame bin : Falsche Version bitte patche neu wie kann ich das beheben ? habe schon 3 2012er clients getesten , 2 clienten...
2Probleme
10/17/2011 - Metin2 PServer - Discussions / Questions - 7 Replies
Hey Leute, Ich habe 1Problem und das wäre,- Ich komm nicht mehr in Navicat rein... Früher wo ich das gestartet habe, kam am Anfang immer ,,Trail´´ und ,,Registration´´ zur Auswahl. Mit Trail kam ich dann immer in Navicat doch jetzt ist Trail grau-nicht mehr Anklickbar.Heißt das ich mich Anscheint Regestrienen muss. Frage-kostet das was? Denn da steht irgentwie PermiumSoft. Kostet das was? Habe Navicat MySQL.Hilfe wäre nett. Mein 2. Problem ist, meine Loadscreen´s. Ich wollte die...
2Probleme mit Minecraft
05/26/2011 - Minecraft - 8 Replies
Hallo, seitem ich mir vor 10minuten 1.6Geupdatet habe funktioniert To Many Items nicht mehr bzw wenn ich ModLoad + TMI wieder normal reinziehe Meta-Inf odner loesche und spiel starte bekomme ich einen Black Screen, funktionieren die Mods nichtmehr bei 1.6? Und gibt es einen Neueren Modloader + TMI für 1.6? Ps. Ich suche noch Plugins, weil ich keinen Plugin odner habe.
Metin2 2Probleme
02/16/2011 - Metin2 PServer - Discussions / Questions - 4 Replies
Hallo erstmal, Ich habe mir jetzt einen Server gemacht aber habe 2Probleme 1. Problem.) Wenn ich in game einloggen will kommt "Du wirst mit dem Server verbunden" dan geht es nicht mehr weiter. Habe aber Portmap an , Virtual PC es steht 8mal timed out da , bin auch in Hamachi , in "mc" steht auf meine Hamachi-IP drinnen 2. Problem.) Ich kann mich nicht mit NaviCat connecten!!! Habe aber alles an (virtual PC PortMap mit 3306 Port an Hamachi an ) aber es geht einfach ned . Es kommt...



All times are GMT +1. The time now is 04:00.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.