Register for your free account! | Forgot your password?

Go Back   elitepvpers > Conquer Online 2 > CO2 PServer - Discussions / Questions
You last visited: Today at 22:53

  • Please register to post and access all features, it's quick, easy and FREE!


[HELP]CoEmu 2 content not working?

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Oct 2008
Posts: 430
Received Thanks: 176
[HELP]CoEmu 2 content not working?

I really didn't want to have to ask, but I seem to have no other choice.

So here's the deal, I've been leeching some content from a few members here to add onto the source to help make any work I'm going to have to do easier. Everything compiled properly, no issues, but when I load the game and play, none of the added material works. Is it possible I'm doing something wrong? If so, can anyone provide me some insight as to what it may be.

Edit: On a side note, is anyone having problems with bridges on maps? Just curious, guessing something needs to be changed with Dmaps, but that's something I've never worked with. Find out more about it at a later point in time.



Incariuz is offline  
Old 06/09/2009, 16:26   #2
 
elite*gold: 20
Join Date: Jun 2006
Posts: 3,293
Received Thanks: 919
Kinshi posted a fix for the DMAP thing.
Go to Structs/DmapData.cs and search for:
Code:
public bool CheckLoc(ushort x, ushort y)
replace that bool with:
Code:
public bool CheckLoc(ushort x, ushort y)
			{
				try{
					if(Tiles[x,y] == 1)
					{
						return true;
					}
                    else if (Tiles[x, y] == 0) // Bridges, Floating Rocks, etc -Stuff by Kinshi88
                    {
                        return true;
                    }
					else
					{
						return false;
					}
				}
				catch
				{
					return false;
				}
			}
		}


Kiyono is offline  
Thanks
1 User
Old 06/09/2009, 17:16   #3
 
elite*gold: 20
Join Date: Apr 2008
Posts: 2,281
Received Thanks: 908
Quote:
Originally Posted by Kiyono View Post
Kinshi posted a fix for the DMAP thing.
Nah, that's the wrong way to do it, 1 = can walk, 0 = can't.
You have to load Scenes to fix bridges and stuff.
=D
kinshi88 is offline  
Thanks
1 User
Old 06/09/2009, 18:20   #4
 
elite*gold: 0
Join Date: Oct 2008
Posts: 430
Received Thanks: 176
Well the Dmapping isn't my major concern (thanks though, I will look into that), I just don't get why nothing is working. I've worked with other sources, established my own coding (not always fantastic, but it worked). Now when I add something into this, build it, and play, it acts like it hasn't been added in the source. I just don't get it. Not even NPC's that I've added are working, the ones others have released (not my own, wanna see basic structures for them before I start). I highly doubt I've screwed up and put them in the wrong place, lol.


Incariuz is offline  
Old 06/09/2009, 18:50   #5
 
elite*gold: 20
Join Date: Jun 2006
Posts: 3,293
Received Thanks: 919
Quote:
Originally Posted by kinshi88 View Post
Nah, that's the wrong way to do it, 1 = can walk, 0 = can't.
You have to load Scenes to fix bridges and stuff.
=D
Well you posted it in the first place lol
Kiyono is offline  
Old 06/09/2009, 20:44   #6
 
elite*gold: 20
Join Date: Apr 2008
Posts: 2,281
Received Thanks: 908
Quote:
Originally Posted by Kiyono View Post
Well you posted it in the first place lol
But I also corrected myself on the first post =P
kinshi88 is offline  
Old 06/09/2009, 21:38   #7
 
elite*gold: 20
Join Date: Jun 2006
Posts: 3,293
Received Thanks: 919
Quote:
Originally Posted by kinshi88 View Post
But I also corrected myself on the first post =P
True ^^ but the bridges and stuff don't matter to me cause I'm not gonna host a server anyway.
Kiyono is offline  
Old 06/11/2009, 17:53   #8
 
elite*gold: 0
Join Date: Oct 2008
Posts: 430
Received Thanks: 176
Well I tried deleteing the source, then setting it up again. Tried adding one thing at a time once it was running, but still the same issue. When I add a feature, the source builds, no problems. However, I run the servers, login, and whatever I added doesn't work. Doesn't matter whether it's an NPC, or loading for an extra Dmap, just nothing seems to want to take effect.

If anyone has any idea's, or would like to view the issue through teamviewer, it would be greatly appreciated.
Incariuz is offline  
Old 06/11/2009, 18:04   #9
 
elite*gold: 20
Join Date: Jun 2006
Posts: 3,293
Received Thanks: 919
So not even debug works?
Kiyono is offline  
Thanks
1 User
Old 06/11/2009, 18:18   #10
 
elite*gold: 0
Join Date: Oct 2008
Posts: 430
Received Thanks: 176
debug works, I can get on the game, no problem there, but for example, this is just a small example.

I go to Structs/Map.cs

change

Code:
            Promotion = 1004,
            Arena = 1005,
            Stables = 1006,
            MapleForest = 1011,
            //WonderLand = 1013,
            DragonPool = 1014,
to

Code:
            Promotion = 1004,
            Arena = 1005,
            Stables = 1006,
            newbie = 1010,
            MapleForest = 1011,
            //WonderLand = 1013,
            DragonPool = 1014,
Build/Compile the source, then go into

CoEmu v2\CoEmu v2 GameServer\bin\Debug

and run CoEmu v2 GameServer

but the Dmap for BirthVillage still won't load.

Same deal if I add an NPC into the source, build/compile, run the game, go to the NPC ingame, it'll tell me it hasn't been coded, even though it has, and it compiled with no issues what so ever.

I just don't understand it, I worked a lot on LOTF, I've created a lot of custom coding in it to make different features work, from skills of all 3 kinds, NPC's, etc... So the idea of copying and pasting other peoples releases on here, or creating basic NPC's shouldn't be giving me issues like this, regardless of the fact that I'm not a pro, I still know the basics to making things work.

Edit: Could it be that I'm not debugging directly from Visual Studio? I don't get why that would cause an issue, but is it possible? If so, how do I get it to switch from the login server to the game server for debugging in visual studio?

Edit2: Ha, that was exactly the problem, I had to debug it directly from Visual Studio, wow, I feel like an idiot. But hey, atleast I have it figured out now. Thanks for offering some help Kiyono.


Incariuz is offline  
Reply


Similar Threads
CoEmu full ninja skills working + NPC!!
11/20/2009 - CO2 PServer - Discussions / Questions - 57 Replies
Author: Not me only copy pasted here. So this source has full ninja skills works all ,and the NPC's. Try it. Link: Mirror 1 Don't forget to press THANS button.
[REQUEST]CoEMU-Soure + Working DB
07/12/2008 - CO2 Main - Discussions / Questions - 12 Replies
Hello guys i need a CoEMU source + db to bring my MySQL skillz up xD If CoEMU isnt possible Any MySQL based Source Or only a DB thx in advance (not the selector shit xD)
bad[WoW]Content
04/22/2006 - WoW Main - Discussions / Questions - 1 Replies
Also, ich hab vor das Ding zu holn, wenn wer den Link haben will soll einfach mitzahlen, einfach mal ICQ (203-241-482) adden, sollte es Probleme geben, wird Geld zurück überwießen.



All times are GMT +1. The time now is 22:53.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2018 elitepvpers All Rights Reserved.