Register for your free account! | Forgot your password?

You last visited: Today at 13:15

  • Please register to post and access all features, it's quick, easy and FREE!

 

[5017]Auth Response Problem

Reply
 
Old   #1
 
elite*gold: 0
Join Date: Dec 2011
Posts: 1,537
Received Thanks: 782
[5017]Auth Response Problem

When I send the auth response packet then the client is disconnecting.
What could be the prolem causing it?

My packet structure is:
DataType Data Offset (fixed value)
Code:
uint16 Size 0 (32)
uint16 Type 2 (0x41f)
uint32 LoginUID 4
uint32 LoginKey 8
string IP 12
uint32 Port 28
Test:
Code:
            PacketStructures.AuthResponsePacket resp = new PacketStructures.AuthResponsePacket();
            resp.LoginUID = 1000000;
            resp.LoginKey = Enums.AuthResponseKey.LOGIN_SUCCESS;
            resp.IP = "5.222.56.63";
            resp.Port = 5816;
            Client.Send(resp);
I am encrypting the packet and the crypto cannot be wrong as I can decrypt the packets and my crypto is taken straight out from my 4267 source.

Code:
        public void Send(ConquerOnline.Network.ConquerPacket Packet)
        {
            Packet.Encrypt(this.Crypto);
            networkClient.Send(Packet);
        }
I've also tried with other cryptographers, including the one in LOTF and it did not work either.

And as you can see my gameserver is setup to that IP and port as well.
Code:
            Server server = new Server("5.222.56.63", 5816);
            server.BeginServer();
            server.AcceptConnections();
Tho it never connects...

So I'm pretty lost at what the problem is.

Any help is appreciated.



I don't have a username is offline  
Old   #2
 
elite*gold: 0
Join Date: May 2008
Posts: 1,769
Received Thanks: 1,137
Maybe I'm remembering a newer patch, but didn't port come before IP after 50XX?


Zeroxelli is offline  
Old   #3
 
elite*gold: 0
Join Date: Dec 2011
Posts: 1,537
Received Thanks: 782
Quote:
Originally Posted by Zeroxelli View Post
Maybe I'm remembering a newer patch, but didn't port come before IP after 50XX?
Nope. The structure is correct, checked it up in other sources and even back in 4267 the port was still after.
I don't have a username is offline  
Old   #4
 
elite*gold: 0
Join Date: May 2008
Posts: 1,769
Received Thanks: 1,137
Strange.. and the token is correct?


Zeroxelli is offline  
Old   #5
 
elite*gold: 0
Join Date: Dec 2011
Posts: 1,537
Received Thanks: 782
Quote:
Originally Posted by Zeroxelli View Post
Strange.. and the token is correct?
It can be any value, so yes.


I don't have a username is offline  
Reply



« Previous Thread | Next Thread »

Similar Threads
Auth Response
As far as I know, from patch 5375 - 5509, Auth Response is the same, however I use Hellmouths 5355. I've compared it to Leo's source, but it...
1 Replies - CO2 PServer - Discussions / Questions
packets after auth response
After sending edited authrespond paacket to the client, client still send 80 bytes packet to auth ? and after that client connects to to IP from...
17 Replies - CO2 Programming
Selling Runescape Both Auth Codes Only 5$ each for ANY auth regular price is 10$-30$
Any auth code is 5$ send me a Pm or leave a post to tell me which ones you would like http://img260.imageshack.us/img260/2675/runescapeauths.png
5 Replies - Runescape Trading
Decrypting Auth response?
I can't seem to decrypt the auth response packet correctly but I can decrypty/encrypt every other packet from auth or game.. Am I supposed to...
8 Replies - CO2 Main - Discussions / Questions
Response Time Exceeded problem
Ok i entered ip correctly and disabled all firewall. So i go log in and whem im loged in i go chose char then select server then ok then black...
6 Replies - Dekaron Private Server



All times are GMT +1. The time now is 13:15.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy | Abuse
Copyright ©2017 elitepvpers All Rights Reserved.