FreeBSD 11 Root Installiation

02/25/2017 15:47 Du.ke#1
Hallo Liebe Com,

Ich versuche schon seit ein paar stunden FreeBSD 11 auf meinem Root Installiert zu bekommen leider mit wenig erfolg.

FreeBSD soll mir automatisch meine Festplatte (da ich kein Profi bin) mit MBR Partitionieren nach dem ich weiter gehen und er versuchen möchte zu Mounten tritt ein fehler auf (mount error / kann nicht partitioniert werden)

Bitte helft mir


thx
02/25/2017 17:02 Đurek_v3#2
Quote:
Originally Posted by Du.ke View Post
Hallo Liebe Com,

Ich versuche schon seit ein paar stunden FreeBSD 11 auf meinem Root Installiert zu bekommen leider mit wenig erfolg.

FreeBSD soll mir automatisch meine Festplatte (da ich kein Profi bin) mit MBR Partitionieren nach dem ich weiter gehen und er versuchen möchte zu Mounten tritt ein fehler auf (mount error / kann nicht partitioniert werden)

Bitte helft mir


thx
Wie wäre es mit mehr Informationen? Was für ein Hoster?
Warum MBR? GPT sollte auf aktuellen Maschinen am besten funktionieren.
02/25/2017 17:05 Du.ke#3
GPT habe ich bereits versucht. Selbe fehler.
Unlimited Hoster

Ist ein KVM Six core und 10 gb server

ich versuche mal bilder hier zur verfügung zu stellen

FreeBSD 10.3 lässt sich hingegen installieren jedoch bekomme ich danach einen boot error

Bild bei Freebsd 10.3

[Only registered and activated users can see links. Click Here To Register...]
02/25/2017 20:20 Đurek_v3#4
Quote:
Originally Posted by Du.ke View Post
[Only registered and activated users can see links. Click Here To Register...]


Sieht, für mich, nach einem Partitionsfehler aus.

Da ich aber nicht weiß, wie dein Anbieter Systeminstallationen händelt kann ich nicht sagen, ob nachfolgendes nicht noch mehr Schaden anrichtet, oder überhaupt funktioniert.


Starte die Installation erneut, wähle bei der Partitionierung manual aus und wipe/formatiere alle Partitionen. Danach entweder fortführen und die Partitionierung selber erledigen, oder !nachdem die Formatierung durchgeführt wurde! die Installation erneut starten.
Ich weiß allerdings jetzt aus dem Kopf nicht, ob die Formatierung sich durchführen lässt ohne die Installation fortzusetzen.
Das wäre jedenfalls mein Lösungsansatz.
02/25/2017 23:21 Du.ke#5
ich habe etwas gefunden was ich gerade einmal teste allerdings unter 10.3.

und zwar die partitionen so an zu legen:

64KB freebsd-boot
8GB freebsd-swap none
20GB freebsd-ufs /
Rest freebsd-zfs

die installation läuft noch und ich hoffe es funktioniert dann.

Besteht die möglichkeit 10.3 zu updaten auf 11?

------------------------------------------- Edit

Okay es hat funktioniert ich hoffe alles weitere klappt.

Kann mir jemand sagen ob das ganze updaten kann ?

------------------------------------- Edit

Wenn ich jetzt via putty zugriff auf den server haben möchte (mit root) verweigert er mir den zugang.

in ubuntu konnte man das ganze mit PermitRootLogin YES regeln wie ist es bei bsd ?
02/26/2017 00:54 Rainer Wahnsinn#6
Hi,

funktioniert genau so in FreeBSD;
Code:
/etc/ssh/sshd_config
Anschließend mit service sshd restart den Dienst neustarten.

Grüße
02/26/2017 16:30 Du.ke#7
okay hat geklappt.

letztes problem nach der installation von mysql kann ich mich weder über putty noch über navicat zu mysql verbinden.

ich bin mit root angemelden auf putty.

dieser fehler kommt

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
02/26/2017 16:43 Ascaria2Bercol#8
Quote:
Originally Posted by Du.ke View Post
Besteht die möglichkeit 10.3 zu updaten auf 11?
Die Möglichkeit besteht, jedoch wird das nicht vollkommen Problemlos ablaufen. Kannst es ja probieren und die Fehler dann selber beheben die auftreten.
folgendes machen:

freebsd-update fetch install
dannach
freebsd-update upgrade -r 11.0-RELEASE

sobald das installiert ist (was meist nie fehlerlos funktioniert und man einiges selber noch beheben muss)

gibst du noch das ein:
freebsd-update install

dann neustart: shutdown -r now

und schauen ob die version 11.0 installiert ist:
freebsd-version -k
02/26/2017 16:49 Du.ke#9
okay dann lasse ich das mit dem updaten.

weis jemand was zum thema mysql ?

bekomme jetzt diesen error

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
02/27/2017 22:31 #dynastie#10
Quote:
Originally Posted by Du.ke View Post
okay dann lasse ich das mit dem updaten.

weis jemand was zum thema mysql ?

bekomme jetzt diesen error

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
Das ist kein "Error". Lediglich die Mitteilung, dass dein verwendetes Passwort für den MySQL-Root-User falsch ist.

service mysql-server stop
service mysql-server onestart
mysqladmin -u root password hierdeinneuespw

Danach sollte es funktionieren (intern).
02/28/2017 23:04 Du.ke#11
komisch ist jetzt nur das ich durch einen crash neu installieren musste und eswieder nicht funktioniert?

obwohl ich es genauso mache wie ich oben sagte
03/01/2017 06:26 Ideal-Cloud#12
Bei Unlimied Host ist es normal das du mehrfach neuinstallieren musst bis es neu laufen tut
03/01/2017 10:38 Du.ke#13
Aber wieso das ?

-------------------
Edit
______________

Unlimited Host ist für mich mehr als inkompetent es kann nicht sein das derartige Probleme auftreten und einem dann beim Support nicht einmal geholfen wird!
Die wollen lieber einen Telefonisch voll quatschen.

Und wenn man dieses Verneint antworten die nicht mehr.

Ich bekomme meistens auch keine Verbindung zu meinem Server da war die Antwort darauf das dieser sich in der Installation befinde?

Kann aber nicht sein hatte diesen einen Tag zuvor installiert!

Ist zum ****** ausreisen.

Ich habe nun ein letztens mal den Support Kontaktiert wenn die jetzt nicht eine lösung bringen drehe ich vollkommen frei.

Ich bezahle in grunde genommen für nichts.