Serverstart ERROR 1045 (28000)

05/13/2015 17:03 °Ace°#1
Guten Tag Epvp,

anscheinend habe ich ein Fehler, sobald ich mein Server starte und mich ingame einlogge bzw die mysql_query Funktion ausgeführt wird kommt folgendes raus:

PHP Code:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) 
Ich habe natürlich SuFu benutzt und habe einige Beiträge durchgelesen und die Möglichkeiten ausprobiert wie:

PHP Code:
c148# mysql -uroot -hlocalhost
mysql>GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' {enter}
mysql>IDENTIFIED BY 'password' WITH GRANT OPTION; {enter}
mysql>FLUSH PRIVILEGES; {enter}
mysql>quit {enter}
c148# 
Vielleicht kann einer weiterhelfen ?
05/13/2015 17:10 .Shōgun#2
(using password: NO)

You didn't enter the password in the CONFIG (or in db conf.txt)
05/13/2015 20:12 °Ace°#3
Quote:
Originally Posted by .Shōgun View Post
(using password: NO)

You didn't enter the password in the CONFIG (or in db conf.txt)
Where exactly comes out my password?

PHP Code:
SYSERR: May 13 20:29:31 :: ChildLoop: AsyncSQL: query failed: Query execution was interrupted (query: SELECT id,login,vnum,count,socket0,socket1,socket2,mall,why FROM item_award WHERE taken_time IS NULL errno: 1317)
SYSERR: May 13 20:29:41 :: ChildLoop: MySQL connection was reconnected. querying locale set
SYSERR
: May 13 20:29:44 :: hupsig: SIGHUP, SIGINT, SIGTERM signal has been received. shutting down.
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Query execution was interrupted (query: UPDATE player SET job = 0, voice = 0, dir = 0, x = 969616, y = 278640, z = 0, map_index = 41, exit_x = 969616, exit_y = 278640, exit_map_index = 41, hp = 6017, mp = 2339, stamina = 820, random_hp = 4257, random_sp = 2079, playtime = 598, level = 100, level_step = 0, st = 6, ht = 4, dx = 3, iq = 3, gold = 90718997, exp = 30, stat_point = 267, skill_point = 99, sub_skill_point = 91, stat_reset_count = 0, ip = '95.91.225.244', part_main = 41005, part_hair = 0, last_play = NOW(), skill_group = 0, alignment = 2079, horse_level = 11, horse_riding = 0, horse_hp = 12, horse_hp_droptime = 1431628269, horse_stamina = 30, horse_skill_point = 0, skill_level = '\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Lost connection to MySQL server during query (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000001, 59354, 1, 0, 1, 41006, 1432051857, 0, 0) errno: 2013)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: query failed: Can'
t connect to local MySQL server through socket '/tmp/mysql.sock' (2) (query: REPLACE INTO item (id, owner_id, window, pos, count, vnum, socket0, socket1, socket2) VALUES(130000002, 59354, 1, 1, 1, 41005, 1432051861, 0, 0) errno: 2002)
SYSERR: May 13 20:29:44 :: ChildLoop: AsyncSQL: retrying
SYSERR
: May 13 20:29:44 :: pid_deinit: 
End of pid

SYSERR
: May 13 20:31:20 :: pid_init: 
Start of pid: 720

SYSERR
: May 13 20:31:20 :: Start: TABLE_POSTFIX not configured use default
SYSERR: May 13 20:31:21 :: Load:  DirectQuery failed(SELECT login FROM block_exception)
SYSERR: May 13 20:31:27 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:29 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:34 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:39 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:42 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:47 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:52 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:31:57 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:32:02 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost)
SYSERR: May 13 20:32:07 :: __GetHostInfo: __GetHostInfo() ==> DirectQuery failed(SELECT mIP FROM gmhost) 
05/14/2015 07:25 Shimao#4
reinstall mysql and unpack the mysql.tar.gz
05/14/2015 12:24 .yorliK#5
Zusatzinfo:
Zuerst kam der Error beim benutzen der mysql_query Funktion, er hat schon in einigen Threads gesehen das er in den Configs das mysql Passwort für einen Account in der mysql -> user Tabelle angeben muss. Die Frage ist wo in der Config?

additional info:
First time, the error occurs when using the mysql_query function, in some threads they said he must add a MySQL password in the configs of an account in the mysql -> user table. The question is where he have to put the password in the configs?
05/14/2015 13:57 Azμre#6
Die Config Datei befindet sich in jedem Core und im Ordner vom Database-Cache.

Verzeichnisse die bei standard Files oft verwendet werden: /usr/home/game/channel1/CONFIG
/usr/home/game/g1/db/conf.txt

Da ist scheinbar kein Passwort eingetragen.
05/14/2015 14:12 °Ace°#7
Quote:
Originally Posted by Leyrox View Post
Die Config Datei befindet sich in jedem Core und im Ordner vom Database-Cache.

Verzeichnisse die bei standard Files oft verwendet werden: /usr/home/game/channel1/CONFIG
/usr/home/game/g1/db/conf.txt

Da ist scheinbar kein Passwort eingetragen.
Danke für die Antwort, die Frage ist wieder rum wo genau wird den das Passwort eingetragen ?!
05/14/2015 14:22 .Shōgun#8
In CONFIG (all of them)

Code:
COMMON_SQL: 127.0.0.1 root PASSWORD common
LOG_SQL: 127.0.0.1 root PASSWORD log
PLAYER_SQL: 127.0.0.1 root PASSWORD player
Additionally, in CONFIG (auth)

Code:
ACCOUNT_SQL: 127.0.0.1 root PASSWORD account
In conf.txt (db core)

Code:
SQL_ACCOUNT = "127.0.0.1 account root PASSWORD 0"
SQL_COMMON = "127.0.0.1 common root PASSWORD 0"
SQL_HOTBACKUP = "127.0.0.1 hotbackup root PASSWORD 0"
SQL_PLAYER = "127.0.0.1 player root PASSWORD 0"
05/14/2015 17:39 °Ace°#9
Quote:
Originally Posted by .Shōgun View Post
In CONFIG (all of them)

Code:
COMMON_SQL: 127.0.0.1 root PASSWORD common
LOG_SQL: 127.0.0.1 root PASSWORD log
PLAYER_SQL: 127.0.0.1 root PASSWORD player
Additionally, in CONFIG (auth)

Code:
ACCOUNT_SQL: 127.0.0.1 root PASSWORD account
In conf.txt (db core)

Code:
SQL_ACCOUNT = "127.0.0.1 account root PASSWORD 0"
SQL_COMMON = "127.0.0.1 common root PASSWORD 0"
SQL_HOTBACKUP = "127.0.0.1 hotbackup root PASSWORD 0"
SQL_PLAYER = "127.0.0.1 player root PASSWORD 0"
And what is with DB_ADDR: localhost ?
I got it debugged, but does not work

Syserr:

PHP Code:
SYSERR: May 14 18:04:13 :: Start: TABLE_POSTFIX not configured use default
SYSERR: May 14 18:04:14 :: Load:  DirectQuery failed(SELECT login FROM block_exception)
SYSERR: May 14 18:04:59 :: __GetAdminInfo: __GetAdminInfo() ==> DirectQuery failed(SELECT mID,mAccount,mName,mContactIP,mServerIP,mAuthority FROM gmlist WHERE mServerIP='ALL' or mServerIP='MEINE IP STEHT HIER') 
05/14/2015 18:19 .Shōgun#10
What does not work? Those errors are normal and harmless
05/14/2015 18:33 °Ace°#11
Quote:
Originally Posted by .Shōgun View Post
What does not work? Those errors are normal and harmless
I have in the config which entered what you mean, but it still does not work?

PHP Code:
 mysql: ambiguous option '--e=SELECT money from player.ah_money WHERE player_id = 59360;' (enable_cleartext_plugin, execute)
mysql: ambiguous option '--e=SELECT * from player.ah_item WHERE player_id != 59360 ORDER BY auction_id DESC LIMIT 100;' (enable_cleartext_plugin, execute) 
05/14/2015 20:48 Nick#12
Quote:
Originally Posted by °Ace° View Post
I have in the config which entered what you mean, but it still does not work?

PHP Code:
 mysql: ambiguous option '--e=SELECT money from player.ah_money WHERE player_id = 59360;' (enable_cleartext_plugin, execute)
mysql: ambiguous option '--e=SELECT * from player.ah_item WHERE player_id != 59360 ORDER BY auction_id DESC LIMIT 100;' (enable_cleartext_plugin, execute) 
Code:
--e
durch

Code:
-e
ersetzen, da scheinbar eine MySQL-Version >5.1 in Verwendung ist.

lg
05/14/2015 20:50 °Ace°#13
Quote:
Originally Posted by .JayZoN View Post
Code:
--e
durch

Code:
-e
ersetzen, da scheinbar eine MySQL-Version >5.1 in Verwendung ist.

lg
Mein Mysql hab ich nach den TuT installiert:
[Only registered and activated users can see links. Click Here To Register...]

Die Frage ist, in welcher Datei änder ich die --e zu -e, in welcher questlib ?
05/14/2015 21:40 Nick#14
/fixed

Mehrere Erweiterungen (Extensions) waren in Verwendung, wo u.a. auch die mysql_query() - Funktion enthalten war, allerdings in veralteter Form. Künftig also sichergehen, ob die Funktion auch dementsprechend aktuell ist, im Idealfall sollte die Funktion auch nur einmal enthalten sein - da hierbei mehrere Extensions mit der besagten Funktion inkludiert waren, ging auch die Übersicht flöten. (closerequested)

lg