SMC -CANNOT start smnet:9 what?
DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456;DATABASE=SRO_VT_ACCOUNT
query=DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=SRO_VT_SHARD_INIT;UID=sa;PWD=123456;DATABASE=SRO_VT_SHARD_INIT
query_log=DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=Log_DB;UID=sa;PWD=123456;DATABASE=Log_DB
Quote:
please post what do i put on config.cfg and the files in custom certification ^^
thanks
and config.cfg give me mint ;)Quote:
For People who can't opening Certification Server
Open
CustomCertificationServer Folder
then (bin) folder
then open 1 - decompile.bat
when finish press enter to exit it then u will find ini folder appear to u
open ini folder
then we must edit :
srGlobalService.ini
&PHP Code:DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456;DATABASE=SRO_VT_ACCOUNT
srNodeType.ini
Edit
wip=
nip=
Replace the old ip with ur machine ip like 192.168.0.1 etc ..
Last
srShard.ini
name=Ur Server Name
PHP Code:query=DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=SRO_VT_SHARD_INIT;UID=sa;PWD=123456;DATABASE=SRO_VT_SHARD_INIT
capacity=2300PHP Code:query_log=DRIVER={SQL Server};SERVER=Your MachineName\SQLEXPRESS;DSN=Log_DB;UID=sa;PWD=123456;DATABASE=Log_DB
DSN= (better to right database name)
now we save out work then open
2 - compile.bat
when finish press enter to exit
then open
3 - CustomCertificationServer.bat
it works fine and it's the CertificationServer
not the CustomCertificationServer.exe one [Only registered and activated users can see links. Click Here To Register...]
Hope i help [Only registered and activated users can see links. Click Here To Register...]
Fixing SMC_IndependentQuote:
SMC -CANNOT start smnet:9 what?
So we have a good Step and we are working to solve that :)Quote:
Common {
debug_option_debugger_present {
DEBUG_OPTION_ASSERT_SHOW_MESSAGEBOX_OKCANCEL,
DEBUG_OPTION_ASSERT_ADVANCE_BREAK,
DEBUG_OPTION_ASSERT_CANCEL_EXIT
}
debug_option_stand_alone {
DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
}
netengine_debug_option_debugger_present {
DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
}
netengine_debug_option_stand_alone {
DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
}
}
////////////////////////////////////////////////////////////////////////////////////////////
GlobalManager {
// Certification "127.0.0.1", 32001
Certification "127.0.0.1", 32001
LoginFailureTolerance 3 // 최대 로그인 패스워드 오류 허용치
IBUVFailureTolerance 3 // 최대 이미지 인증 오류 허용치
LoginFailureBlockTimeMin 10 // 블럭 시간(분) - 로그인 패스워드 오류
IBUVFailureBlockTimeMin 10 // 블럭 시간(분) - 이미지 인증 오류
AutomatedPunisher "AutomatedPunisher" // 블럭 주체 이름 (기존 블럭은 gm 명)
LoginPunishmentGuide "Blocked for 10 minutes due to incorrect password entered 3 times" // 패스워드 오류에 대한 블럭 가이드
LoginPunishmentDescription "Blocked for 10 minutes due to incorrect password entered 3 times" // 패스워드 오류에 대한 블럭 설명
IBUVPunishmentGuide "Blocked for 10 minutes due to incorrect code entered 3 times" // 이미지 인증 오류에 대한 블럭 가이드
IBUVPunishmentDescription "Blocked for 10 minutes due to incorrect code entered 3 times" // 이미지 인증 오류에 대한 블럭 설명
}
GatewayServer {
LastFullVersion_SR_Client 130
Certification "127.0.0.1", 32000
IBUVQueueReserveCount 20000 // IBUV를 위해 미리 생성해 놓을 이미지 갯수
IBUVQueuePrepareRatio 0.05 // 아이들 타임에 이미지 생성할 비율
IBUVFailureIPTolerance 0 // 한 IP당 IBUV 실패를 허용할 최대 오류 허용치, 0이면 블럭 안하겠다는 거지.
// 추가된 넘이다!!!!!
//////////////////////////////////////////////////////////
IBUVStringSize 6 // 한글 캐릭터셋 사용 시 3, 알파벳 캐릭터 셋만 사용하는 경우 6 으로 세팅한다.
IBUVCharacterSet "ABCDEFGHLMNQRTabdehimn2345678"
//////////////////////////////////////////////////////////
}
DownloadServer {
Certification "127.0.0.1", 32000
}
FarmManager {
Certification "127.0.0.1", 32000
}
AgentServer {
Certification "127.0.0.1", 32004
}
MachineManager {
Certification "127.0.0.1", 32000
}
SR_GameServer {
Certification "127.0.0.1", 32004
ExpRatio 100
ExpRatioParty 100
DropItemRatio 0,1
DropGoldAmountCoef 0,1
//WINTER_EVENT_2009 EVENT_ON // 2009년 겨울 이벤트
//EUBUSINESS_EVENT EVENT_ON
//GOLDEN_PIG_FEBRUARY_EVENT EVENT_ON
//THANKS_GIVING_EVENT EVENT_ON
//LIBERATION_EVENT EVENT_ON
LOCALE LOCALE_VIETNAM // for Helper mark
//#ifdef OPEN_MARKET_SYSTEM
SET_FEE_RATE "0,5,5,5"
SELL_FEE_RATE "0,10,10,10"
//#endif OPEN_MARKET_SYSTEM
}
SR_ShardManager {
Certification "127.0.0.1", 32004
BILLING_SERVER_URL "http://127.0.0.1:8080/"
CREST_FTP_URL "ftp://id:pass@127.0.0.1/"
ExtraExpRatio 0.1
ChristmasEvent2007 0
//SERVER_EVENT_SYSTEM ON
LOCALE LOCALE_VIETNAM
FlagEvent 0
FlagEvent 1
HourForMeterRateLevelFirst 22
HourForMeterRateLevelSecond 23
BattleArenaRandom 1
BattleArenaParty 1
BattleArenaGuild 1
BattleArenaJob 1
ArenaMatchOccupy 1
ArenaMatchFlag 1
ArenaMatchPoint 1
}
now download iis manager 6 and edit the files and ftp of ur machine ;)Quote:
k i got iss working but its a picture but when i go to [Only registered and activated users can see links. Click Here To Register...]
it works fine but 127.0.0.1 is a picture
Quote:
i Forgot
SK_gamebang_ip problem
PHP Code:SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
CREATE TABLE [dbo].[SK_gamebang_ip](
[nID] [smallint] NOT NULL,
[ip] [int] NOT NULL,
[capacity] [smallint] NOT NULL
) ON [PRIMARY]
GO
[ip] [varchar] NOT NULL
let me try to make db named _ExistsServiceOffRentItem and see if error gone or ..Quote:
also SR_ShardManager.exe billing dead issue isn't about server.cfg.PHP Code:[ip] [varchar] NOT NULL
it's about the db... stored procedure called "_ExistsServiceOffRentItem" was deleted.
now, looking at globalmanager module, i saw
Query Error!!! Query Result : -1, Query : exec _AddCurrentUserCount 64, 0, '2011-9-13 3:57:6' - Error converting data type varchar to datetime..
which table and field has to change?