[Guide] Most of vsro files problem solved here

09/14/2011 02:04 bibi_fr#346
Quote:
Originally Posted by bibi_fr View Post
Hello,

First Thanx for your works and time spend for us !

Im getting a certification error !

After try a lots of time and read the post i post for getting help

Ip Set at mine
port set a your
DB Set and checked a lot of time

Certification succeful but always a same prob

Check pics :)

[Only registered and activated users can see links. Click Here To Register...]

Thanx for help :)

After a mp help i checked my Window Firewall and he's disable
After that i don't have any firewall on this pc !

Need a little help xD
09/14/2011 02:07 Dr.Abdelfattah#347
Quote:
Originally Posted by bibi_fr View Post
After a mp help i checked my Window Firewall and he's disable
After that i don't have any firewall on this pc !

Need a little help xD
GlobalManager port 32001 not 32000 ..
change it and it will works fine ;)
09/14/2011 02:14 cardoso125874#348
where i creat account for login?
09/14/2011 02:15 formatme#349
can some 1 tell me how to edit the ip from bloody?
09/14/2011 02:16 akira_lee#350
[Only registered and activated users can see links. Click Here To Register...]
....sever online but when login get C8...
09/14/2011 02:19 6_lucifer_6#351
i get this when i open cert..

[Only registered and activated users can see links. Click Here To Register...]
09/14/2011 02:21 Dr.Abdelfattah#352
Quote:
Originally Posted by akira_lee View Post
[Only registered and activated users can see links. Click Here To Register...]
....sever online but when login get C8...
Quote:
Originally Posted by Dumfiesta [Only registered and activated users can see links. Click Here To Register...]
Got my server working. Here's a few tips:
  • Change operation_type in your cert files to 22, or your client will crash
  • Also, change the shard id from 64 to 99 in srShard.ini and srNodeData.ini
  • To log on as a GM, you need to add your client IP (as an integer, LE) to _PrivilegedIP
  • Remember to fix the IPs and connection string in your billing scripts, or you'll get DC'd

This is all assuming you've got your servers to initialize properly.
-----------------------------------------------------------------------------------------
maybe help and don't forget to open sro from other machine (not machine u host vsro on it) ...


Quote:
Originally Posted by 6_lucifer_6 View Post
i get this when i open cert..

[Only registered and activated users can see links. Click Here To Register...]
check ur IP u enter in ini configs ;)

Quote:
Originally Posted by 6_lucifer_6 View Post
i get this when i open cert..

[Only registered and activated users can see links. Click Here To Register...]
check ur IP u enter in ini configs ;)
09/14/2011 02:27 Ninja1337#353
That's what i got when i run everything Sr_gameworld and SR_manager are not working [Only registered and activated users can see links. Click Here To Register...]
09/14/2011 02:33 bibi_fr#354
Quote:
Originally Posted by abdelfattah View Post
GlobalManager port 32001 not 32000 ..
change it and it will works fine ;)
Port is already on 32001 lol

You see only the gatewayserver port xD

Server.cgf
Code:
Common {
	debug_option_debugger_present	{
			DEBUG_OPTION_ASSERT_SHOW_MESSAGEBOX_OKCANCEL,
			DEBUG_OPTION_ASSERT_ADVANCE_BREAK,
			DEBUG_OPTION_ASSERT_CANCEL_EXIT
	}
	
	debug_option_stand_alone	{			
			DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
			DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
	}

	netengine_debug_option_debugger_present	{
			DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
			DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
	}

	netengine_debug_option_stand_alone	{
			DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
			DEBUG_OPTION_ASSERT_WRITE_MINIDUMP 
	}

}

////////////////////////////////////////////////////////////////////////////////////////////
GlobalManager {
//	Certification "192.168.1.10", 32001
	Certification "192.168.1.10", 32001
	
	LoginFailureTolerance		3				// 최대 로그인 패스워드 오류 허용치
	IBUVFailureTolerance		3				// 최대 이미지 인증 오류 허용치
	LoginFailureBlockTimeMin	10				// 블럭 시간(분) - 로그인 패스워드 오류 
	IBUVFailureBlockTimeMin		10				// 블럭 시간(분) - 이미지 인증 오류 
	AutomatedPunisher		"AutomatedPunisher"		// 블럭 주체 이름 (기존 블럭은 gm 명)
	LoginPunishmentGuide		"Blocked for 10 minutes due to incorrect password entered 3 times"	// 패스워드 오류에 대한 블럭 가이드
	LoginPunishmentDescription	"Blocked for 10 minutes due to incorrect password entered 3 times"	// 패스워드 오류에 대한 블럭 설명
	IBUVPunishmentGuide		"Blocked for 10 minutes due to incorrect code entered 3 times"		// 이미지 인증 오류에 대한 블럭 가이드
	IBUVPunishmentDescription	"Blocked for 10 minutes due to incorrect code entered 3 times"		// 이미지 인증 오류에 대한 블럭 설명

}

GatewayServer {
	LastFullVersion_SR_Client 130
	Certification "192.168.1.10", 32000
	IBUVQueueReserveCount		20000	// IBUV를 위해 미리 생성해 놓을 이미지 갯수	
	IBUVQueuePrepareRatio		0.05	// 아이들 타임에 이미지 생성할 비율
	IBUVFailureIPTolerance		0	// 한 IP당 IBUV 실패를 허용할 최대 오류 허용치, 0이면 블럭 안하겠다는 거지.

	// 추가된 넘이다!!!!!
	//////////////////////////////////////////////////////////
	IBUVStringSize			6 	// 한글 캐릭터셋 사용 시 3, 알파벳 캐릭터 셋만 사용하는 경우 6 으로 세팅한다.
	IBUVCharacterSet		"ABCDEFGHLMNQRTabdehimn2345678"
	//////////////////////////////////////////////////////////
}

DownloadServer {
        Certification "192.168.1.10", 32000
}
FarmManager {
	Certification "192.168.1.10", 32000
}

AgentServer {
	Certification "192.168.1.10", 32004
}

MachineManager {
	Certification "192.168.1.10", 32000
}

SR_GameServer {
	Certification "192.168.1.10", 32004

	ExpRatio             100
        ExpRatioParty        100
      
	DropItemRatio       0,1
        DropGoldAmountCoef   0,1	
        //WINTER_EVENT_2009		EVENT_ON	// 2009년 겨울 이벤트
	//EUBUSINESS_EVENT		EVENT_ON
        //GOLDEN_PIG_FEBRUARY_EVENT	EVENT_ON
	//THANKS_GIVING_EVENT		EVENT_ON
	//LIBERATION_EVENT		EVENT_ON
	LOCALE LOCALE_VIETNAM	// for Helper mark 
       
         //#ifdef OPEN_MARKET_SYSTEM
        SET_FEE_RATE            "0,5,5,5"
        SELL_FEE_RATE           "0,10,10,10"
         //#endif OPEN_MARKET_SYSTEM
}

SR_ShardManager {
	Certification "192.168.1.10", 32004
	BILLING_SERVER_URL "http://192.168.1.10:8080/"
	CREST_FTP_URL "ftp://crest:crest@localhost/"
        ExtraExpRatio		0.1
        ChristmasEvent2007 0
	//SERVER_EVENT_SYSTEM             ON
       LOCALE LOCALE_VIETNAM
       FlagEvent 			0
       FlagEvent                        1
       HourForMeterRateLevelFirst	22
       HourForMeterRateLevelSecond	23

	BattleArenaRandom 1
	BattleArenaParty 1
	BattleArenaGuild 1
	BattleArenaJob 1
	ArenaMatchOccupy 1
	ArenaMatchFlag 1
	ArenaMatchPoint 1
}
srGlobalService.ini
Code:
[global]
count=1
[entry0]
operation_type=17
name=SRO_GameOn_Official
query=DRIVER={SQL Server};SERVER=FABIEN-PC\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456;DATABASE=SRO_VT_ACCOUNT
global_manager_node_id=697
srNodeType.ini
Code:
[global]
count=8
[entry0]
id=335
operation_type=17
name=GMGS
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=0
[entry1]
id=336
operation_type=17
name=DN1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=701
[entry2]
id=338
operation_type=17
name=GWS1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=699
[entry3]
id=339
operation_type=17
name=FMGS1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=0
[entry4]
id=340
operation_type=17
name=SDMGS1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=706
[entry5]
id=341
operation_type=17
name=SD1AGS1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=708
[entry6]
id=344
operation_type=17
name=SD1GAS1
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=714
[entry7]
id=133
operation_type=0
name=Certification Manager
wip=192.168.1.10
nip=192.168.1.10
machine_manager_node_id=0
srShard.ini
Code:
[global]
count=1
[entry0]
id=64
global_operation_id=20
operation_type=17
name=KOUGA
query=DRIVER={SQL Server};SERVER=FABIEN-PC\SQLEXPRESS;DSN=SRO_VT_SHARD;UID=sa;PWD=123456;DATABASE=SRO_VT_SHARD
query_log=DRIVER={SQL Server};SERVER=SRO_VT_SHARD;DSN=Log_DB;UID=sa;PWD=123456;DATABASE=Log_DB
capacity=2300
shard_manager_node_id=705
u1=240
u2=208
u3=17
u4=1
u5=0
u6=0
u7=0
09/14/2011 02:34 Dr.Abdelfattah#355
Some Usefull things after setup ur server ;)

Copied from [Only registered and activated users can see links. Click Here To Register...] not my write ..

Use this query to clean out old data from VT_ACCOUNT tables.

PHP Code:
USE [SRO_VT_ACCOUNT]
GO
TRUNCATE TABLE 
[dbo].[TB_User]
TRUNCATE TABLE [dbo].[TB_User_Bak]
TRUNCATE TABLE [dbo].[SK_CharRenameLog]
TRUNCATE TABLE [dbo].[_Punishment]
TRUNCATE TABLE [dbo].[_ServiceManagerLog]
TRUNCATE TABLE [dbo].[Test_HN]
TRUNCATE TABLE [dbo].[_BlockedUser]
TRUNCATE TABLE [dbo].[_CasGMChatLog]
TRUNCATE TABLE [dbo].[_Notice]
TRUNCATE TABLE [dbo].[_SMCLog]
TRUNCATE TABLE [dbo].[QuaySoEpoint]
TRUNCATE TABLE [dbo].[SK_ITEM_GuardLog]
TRUNCATE TABLE [dbo].[SK_ItemSaleLog]
TRUNCATE TABLE [dbo].[SK_PackageItemSaleLog]
TRUNCATE TABLE [dbo].[SK_PK_UpdateLog]
TRUNCATE TABLE [dbo].[SK_ResetSkillLog]
TRUNCATE TABLE [dbo].[SK_Silk]
TRUNCATE TABLE [dbo].[SK_SilkBuyList]
TRUNCATE TABLE [dbo].[SK_SilkGoods]
TRUNCATE TABLE [dbo].[SK_SubtractSilk_VAS]
TRUNCATE TABLE [dbo].[SR_ShardCharNames]
TRUNCATE TABLE [dbo].[TB_Net2e]
TRUNCATE TABLE [dbo].[TB_Net2e_Bak]
TRUNCATE TABLE [dbo].[tb_paygate_trans] 
If you need to create your own GM account:

PHP Code:
1. You need a md5 hasher. (can google it)
2. Go to TB_Users table
3. Fill the form like this
:

    
JID: Fills automatically
    StrUserID
: Username
    password
: password
    status
: can leave blank
    GMRank
: Set this to 1 (Server Dev) 2 (content administrator) 3 (content user) 4 (content marketer) 5 (content monitor) 6 (Content GM) 7 (content GM Leader)
    
sec_primary - set it to 1 (3 is normal user)
    
sec_content - set it to 1 (3 is normal user)


4. You can fill in the other neccesary fields like email, adress so on, but they're not really neccesary. 
This will clean up Log database instantly.

PHP Code:
USE [SRO_VT_LOG]
GO
TRUNCATE TABLE 
[dbo].[_LogCashItem]
TRUNCATE TABLE [dbo].[_LogEventChar]
TRUNCATE TABLE [dbo].[_LogEventItem]
TRUNCATE TABLE [dbo].[_LogEventSiegeFortress]
TRUNCATE TABLE [dbo].[_LogSchedule]
TRUNCATE TABLE [dbo].[_LogServerEvent] 
Use this to prune all old character data from shard.

PHP Code:
//..basically you need to delete these manually. 
09/14/2011 02:38 formatme#356
im getting this error

[Only registered and activated users can see links. Click Here To Register...]
what ip and port do i use for the client? 192.168.x.x or 127.0.0.1
and what port
09/14/2011 02:38 Tazdingo7#357
Please help :

I have this error :
[Only registered and activated users can see links. Click Here To Register...]

You know why ?

I do all the steps until this point when i try to open the CustomCertificationServer Batch File

Another question , what ports i need to open ?

Thanks

I like your efforts abdelfattah to help the community. Thanks to you too [Only registered and activated users can see links. Click Here To Register...]
09/14/2011 02:41 nansif2#358
i just want know why in login screen my client crash... (before login)
09/14/2011 02:56 formatme#359
Official IP Detected, Official IP Pass the 'In Service' Check
how do u get pass that? im using 127
09/14/2011 03:00 mokadidi#360
i need help whit SR_ShardManager if some one want to help whit teamviewver