[Guide] Most of vsro files problem solved here

09/24/2011 17:51 roko36#1726
Quote:
Originally Posted by tancau1 View Post
I have this error ! I have read 100 pages, i did all kind of thinks, i make the certification again server. cfg again...

In the Global Manager wont connect to DB !
My Error :[Only registered and activated users can see links. Click Here To Register...]
My configuration :

srGlobalService :
Code:
[global]
count=1
[entry0]
operation_type=17
name=SRO_GameOn_Official
query=DRIVER={SQL Server};ADMIN-PC\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456;DATABASE=SRO_VT_ACCOUNT
global_manager_node_id=697
srNodeType:
Code:
[global]
count=8
[entry0]
id=335
operation_type=17
name=GMGS
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=0
[entry1]
id=336
operation_type=17
name=DN1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=701
[entry2]
id=338
operation_type=17
name=GWS1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=699
[entry3]
id=339
operation_type=17
name=FMGS1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=0
[entry4]
id=340
operation_type=17
name=SDMGS1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=706
[entry5]
id=341
operation_type=17
name=SD1AGS1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=708
[entry6]
id=344
operation_type=17
name=SD1GAS1
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=714
[entry7]
id=133
operation_type=0
name=Certification Manager
wip=5.29.28.68
nip=5.29.28.68
machine_manager_node_id=0
srShard:
Code:
[global]
count=1
[entry0]
id=64
global_operation_id=20
operation_type=17
name=KOUGA
query=DRIVER={SQL Server};SERVER=ADMIN-PC\SQLEXPRESS;DSN=SRO_VT_SHARD_INIT;UID=sa;PWD=123456;DATABASE=SRO_VT_SHARD_INIT
query_log=DRIVER={SQL Server};ADMIN-PC\SQLEXPRESS;DSN=Log_DB;UID=sa;PWD=123456;DATABASE=Log_DB
capacity=2300
shard_manager_node_id=705
u1=240
u2=208
u3=17
u4=1
u5=0
u6=0
u7=0
Server.cfg :
Code:
Common {
    debug_option_debugger_present    {
            DEBUG_OPTION_ASSERT_SHOW_MESSAGEBOX_OKCANCEL,
            DEBUG_OPTION_ASSERT_ADVANCE_BREAK,
            DEBUG_OPTION_ASSERT_CANCEL_EXIT
    }
    
    debug_option_stand_alone    {            
            DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
            DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
    }

    netengine_debug_option_debugger_present    {
            DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
            DEBUG_OPTION_ASSERT_WRITE_MINIDUMP
    }

    netengine_debug_option_stand_alone    {
            DEBUG_OPTION_ASSERT_DONOT_SHOW_MESSAGEBOX ,
            DEBUG_OPTION_ASSERT_WRITE_MINIDUMP 
    }

}

////////////////////////////////////////////////////////////////////////////////////////////
GlobalManager {
//    Certification "5.29.28.68", 32001
    Certification "5.29.28.68", 32001
    
    LoginFailureTolerance        3                // 최대 로그인 패스워드 오류 허용치
    IBUVFailureTolerance        3                // 최대 이미지 인증 오류 허용치
    LoginFailureBlockTimeMin    10                // 블럭 시간(분) - 로그인 패스워드 오류 
    IBUVFailureBlockTimeMin        10                // 블럭 시간(분) - 이미지 인증 오류 
    AutomatedPunisher        "AutomatedPunisher"        // 블럭 주체 이름 (기존 블럭은 gm 명)
    LoginPunishmentGuide        "Blocked for 10 minutes due to incorrect   password entered 3 times"    // 패스워드 오류에 대한 블럭 가이드
    LoginPunishmentDescription    "Blocked for 10 minutes due to   incorrect password entered 3 times"    // 패스워드 오류에 대한 블럭  설명
    IBUVPunishmentGuide        "Blocked for 10 minutes due to incorrect   code entered 3 times"        // 이미지 인증 오류에 대한 블럭 가이드
    IBUVPunishmentDescription    "Blocked for 10 minutes due to   incorrect code entered 3 times"        // 이미지 인증 오류에 대한 블럭   설명

}

GatewayServer {
    LastFullVersion_SR_Client 130
    Certification "5.29.28.68", 32000
    IBUVQueueReserveCount        20000    // IBUV를 위해 미리 생성해 놓을 이미지 갯수    
    IBUVQueuePrepareRatio        0.05    // 아이들 타임에 이미지 생성할 비율
    IBUVFailureIPTolerance        0    // 한 IP당 IBUV 실패를 허용할 최대 오류 허용치, 0이면 블럭 안하겠다는 거지.

    // 추가된 넘이다!!!!!
    //////////////////////////////////////////////////////////
    IBUVStringSize            6     // 한글 캐릭터셋 사용 시 3, 알파벳 캐릭터 셋만 사용하는 경우 6 으로 세팅한다.
    IBUVCharacterSet        "ABCDEFGHLMNQRTabdehimn2345678"
    //////////////////////////////////////////////////////////
}

DownloadServer {
        Certification "5.29.28.68", 32000
}
FarmManager {
    Certification "5.29.28.68", 32000
}

AgentServer {
    Certification "5.29.28.68", 32004
}

MachineManager {
    Certification "5.29.28.68", 32000
}

SR_GameServer {
    Certification "5.29.28.68", 32004

    ExpRatio             100
        ExpRatioParty        100
      
    DropItemRatio       0,1
        DropGoldAmountCoef   0,1    
        //WINTER_EVENT_2009        EVENT_ON    // 2009년 겨울 이벤트
    //EUBUSINESS_EVENT        EVENT_ON
        //GOLDEN_PIG_FEBRUARY_EVENT    EVENT_ON
    //THANKS_GIVING_EVENT        EVENT_ON
    //LIBERATION_EVENT        EVENT_ON
    LOCALE LOCALE_VIETNAM    // for Helper mark 
       
         //#ifdef OPEN_MARKET_SYSTEM
        SET_FEE_RATE            "0,5,5,5"
        SELL_FEE_RATE           "0,10,10,10"
         //#endif OPEN_MARKET_SYSTEM
}

SR_ShardManager {
    Certification "5.29.28.68", 32004
    BILLING_SERVER_URL "http://5.29.28.68:8080/"
    CREST_FTP_URL "ftp://sergyu:123456@5.29.28.68/"
        ExtraExpRatio        0.1
        ChristmasEvent2007 0
    //SERVER_EVENT_SYSTEM             ON
       LOCALE LOCALE_VIETNAM
       FlagEvent             0
       FlagEvent                        1
       HourForMeterRateLevelFirst    22
       HourForMeterRateLevelSecond    23

    BattleArenaRandom 1
    BattleArenaParty 1
    BattleArenaGuild 1
    BattleArenaJob 1
    ArenaMatchOccupy 1
    ArenaMatchFlag 1
    ArenaMatchPoint 1
}

Can anyone help me ?

Thanks !

use this code and test

[global]
count=1
[entry0]
operation_type=17
name=SRO_GameOn_Official
query=DRIVER={SQL Server};SERVER=ADMIN-PC\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456 ;DATABASE=SRO_VT_ACCOUNT
global_manager_node_id=697
09/24/2011 19:29 --->BeQuiet<----#1727
How to fix C9 Error at Login?
09/24/2011 21:29 Do0mSwEb#1728
Hey..
I have little Problems with my server anyone can help me via Team Viewer?
09/24/2011 21:32 Trapezun#1729
Yok Arkadaşım bugu bulup ayrılanlardan olmicam ben işte buda bu foruma olan borcumdur.. Serveri burdaki arkadaşlar sayesinde kurdum her zamans �yledim toplamda 4 post attım zaten neden az 梧nk� ben formu okumaya başladığımda zaten item bugundaydı herkes 3 post sizi yakalayana kadar ge�ti son noktayıda ben koyuyorum inş zaten problemde sadece bir noktadan kaynaklanıyomuş meğerse

anlatıma ge�elim problemli olan prosed�r�n ismini veriyorum _STRG_DEL_ITEM_NoTX buraya nerden ulaşırız derseniz

SRO_VT_SHARD_INIT/Programmability/stored procedures/_STRG_DEL_ITEM_NoTX yol bu

Prosed�r�n i�ine girdiğimizde (Sağ tık Modify yaparak )

aşağıdaki bloğu resimde bulun ve mavi ile g�stediğim yere dikkat edin

if (@DelFromPC_Inv = 1)
select @ItemToDel = ItemID FROM _Inventory WHERE CharID = @CharID AND Slot = @Slot
else if ( @DelFromPC_Inv = 2 )
select @itemToDel = ItemID FROM _InventoryForLinkedStorage WHERE LinkedItemID = @CharID AND Slot = @Slot
else
select @ItemToDel = ItemID FROM _InvCOS WHERE COSID = @CharID AND Slot = @Slot
Resmi Orjinal Boyutunda G�r�nt�lemek İ�in Buraya Tıklayın 1024x819px.


diğer @ItemToDel değişkenlerinden farklı olarak bu k淮�k i kullanılmış aslında edit�rde zaten uyarı vermiş altında hatalı yazım olduğuna dair kırmızı �izgi var yapacağımız iş bu @itemToDel değişkeni @ItemToDel arkadaşlar yaklaşık 1 saatte yaptım ben sql bilgim olmadığı i�in belki �ok kolay bi yolu da vardır bi �oğunuz biliyodurda belki ben size mantığını verdim benim yapma şeklim ş�yle oldu

1 _STRG_DEL_ITEM_NoTX proced�rn� tamamen sildim
2 SRO_VT_SHARD_INIT mause sağ tuş a basarak New Query �ıkan edit�re aşağıdaki kodları yapışıtın ve exucute yapın herkese kolay gelsin umarım faydamız olmuştur. Teşekk�re gerek yok ama oldu ve ya olmadı die bilgi verirseniz sevinirim...


USE [SRO_VT_SHARD_INIT]
GO
/****** Object: StoredProcedure [dbo].[_STRG_DEL_ITEM_NoTX] Script Date: 09/24/2011 16:29:12 ******/
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO





CREATE PROCEDURE [dbo].[_STRG_DEL_ITEM_NoTX]
@DelFromPC_Inv AS TINYINT,
@CharID AS BIGINT, -- 매직 큐브 추가로 인해 확장
@Slot AS TINYINT

as
declare @Rvalue int
declare @ItemToDel bigint

if (@DelFromPC_Inv = 1)
select @ItemToDel = ItemID FROM _Inventory WHERE CharID = @CharID AND Slot = @Slot
else if ( @DelFromPC_Inv = 2 )
select @itemToDel = ItemID FROM _InventoryForLinkedStorage WHERE LinkedItemID = @CharID AND Slot = @Slot
else
select @ItemToDel = ItemID FROM _InvCOS WHERE COSID = @CharID AND Slot = @Slot

if (@ItemToDel IS NULL or @ItemToDel = 0)
return -1

----------------------------------------
-- 졸라 이 아래쪽 순전히 펫 소환아이템 때문에
-- 들어간 코드이다. �&#208;명 overhead이긴 하지만
-- _STRG_DEL_ITEM 의 신뢰도와 게임�*버 코드 복잡도
-- 증가를 유발하지 않기 위해 어쩔 수 없는 판단이었다. T_T
----------------------------------------
declare @BoundCOS int
declare @RefItemID int
select @RefItemID = RefItemID, @BoundCOS = Data from _Items where ID64 = @ItemToDel
if (@@ROWCOUNT = 0)
return -2

----------------------------------------
-- 혹시 이눔 PET 소환아이템인가?
----------------------------------------
declare @TypeID1 tinyint
declare @TypeID2 tinyint
declare @TypeID3 tinyint
select @TypeID1 = TypeID1, @TypeID2 = TypeID2, @TypeID3 = TypeID3 from _RefObjCommon where ID = @RefItemID
if (@TypeID1 = 3 and @TypeID2 = 2 and @TypeID3 = 1 )
begin
----------------------------------------
-- 엮여있는 PET 이 있으면 그넘 삭제
----------------------------------------
if (@BoundCOS <> 0)
begin
exec @Rvalue = _DeleteCharCOS_NoTX @BoundCOS
if (@Rvalue < 0)
return @Rvalue
end
end

----------------------------------------
-- 혹시 이눔 LinkedStorage아이템인가?
----------------------------------------
else if( @TypeID1 = 3 and @TypeID2 = 2 and @TypeID3 = 3 )
begin
----------------------------------------
-- 엮여있는 Storage 있으면 그넘 삭제
----------------------------------------
if (@BoundCOS <> 0)
begin
IF( NOT EXISTS( select LinkedItemID from _InventoryForLinkedStorage where LinkedItemID = @ItemToDel ) )
BEGIN return -1000 END
IF( EXISTS( select top 1 ItemID from _InventoryForLinkedStorage where LinkedItemID = @ItemToDel and ItemID <> 0 and ItemID IS NOT NULL ) )
BEGIN
update _ItemPool Set InUse = 0 from _ItemPool as IP join _InventoryForLinkedStorage as IFLS on IP.ItemID = IFLS.ItemID
where IFLS.LinkedItemID = @ItemToDel AND IFLS.ItemID <> 0
END
DELETE FROM _InventoryForLinkedStorage where LinkedItemID = @ItemToDel
IF( @@ERROR <> 0 )
BEGIN return -2 END
end
end


----------------------------------------------------------
-- 슬롯 비우기
----------------------------------------------------------
if (@DelFromPC_Inv = 1 )
update _Inventory SET ItemID = 0 WHERE CharID = @CharID AND Slot = @Slot
else if (@DelFromPC_Inv = 2 )
update _InventoryForLinkedStorage SET ItemID = 0 WHERE LinkedItemID = @CharID AND Slot = @Slot
else
update _InvCOS SET ItemID = 0 WHERE COSID = @CharID AND Slot = @Slot

if (@@error <> 0 OR @@rowcount = 0)
return -3

----------------------------------------------------------
-- 삭제 대상 아이템에 �*인 임대 정보 삭제
----------------------------------------------------------
if exists (select 1 from _RentItemInfo with (nolock) where nItemDBID = @ItemToDel)
begin
delete from _RentItemInfo where nItemDBID = @ItemToDel
if (@@ERROR <> 0 OR @@ROWCOUNT = 0)
begin
rollback transaction
return -6
end
end

----------------------------------------------------------
-- 해당 아이템 삭제
----------------------------------------------------------
exec @Rvalue = _STRG_FREE_ITEM_NoTX @ItemToDel
if (@Rvalue < 0)
return -4

return 1

item bug fixxxx yeahhhh :D
09/24/2011 21:35 tancau1#1730
Quote:
Originally Posted by roko36 View Post
use this code and test

[global]
count=1
[entry0]
operation_type=17
name=SRO_GameOn_Official
query=DRIVER={SQL Server};SERVER=ADMIN-PC\SQLEXPRESS;DSN=SRO_VT_ACCOUNT;UID=sa;PWD=123456 ;DATABASE=SRO_VT_ACCOUNT
global_manager_node_id=697
Not working :(
09/24/2011 23:58 erivando123#1731
plis post 1 video all configurate plis

i have big problem plis help me
[Only registered and activated users can see links. Click Here To Register...]

Uploaded with [Only registered and activated users can see links. Click Here To Register...]I was on the same video because I have this so?
09/25/2011 00:33 balphag0re#1732
shardlog:
PHP Code:
    Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!
    
Schedule Manager : g_pServerBodyOfMyself is NULL !!

    
Not found RefServerEvent[30001]. Check service and date value. progress next data
    Not found RefServerEvent
[30002]. Check service and date value. progress next data
    Not found RefServerEvent
[30003]. Check service and date value. progress next data
    Not found RefServerEvent
[30004]. Check service and date value. progress next data
]    SR_ShardManager is initialized successfully 
gameserverlog
PHP Code:
    server cord established : 3 (5.71.217.165:15883)
    
Invalid Region!![ID:1][ObjName128:??????]
    
Invalid Region!![ID:2][ObjName128:??? ?]
    
Invalid Region!![ID:3][ObjName128:??? ??]
    
Invalid Region!![ID:4][ObjName128:????]
    
Invalid Region!![ID:5][ObjName128:??????? ?]
    
Invalid Region!![ID:6][ObjName128:?????]
    
Invalid Region!![ID:7][ObjName128:????]
...
    
Invalid Region!![ID:32][ObjName128:??2? (2???)]
    
Invalid Region!![ID:33][ObjName128:??3? (3???)]
    
Invalid Region!![ID:38][ObjName128:??4? (????)]
    
Invalid Region!![ID:39][ObjName128:?????? (?)]
    
Invalid Region!![ID:40][ObjName128:?????? (?)]
    
Invalid Region!![ID:41][ObjName128:????]
    
Invalid Region!![ID:42][ObjName128:????]
    
At initialize Server, Loading Siege data :: CurrentTax = 1194694954
    At initialize Server
, Loading Siege data :: CurrentTax = 0
    At initialize Server
, Loading Siege data :: CurrentTax = 1102110 
gameserver closes instantly
i disabled all regions except china in database
anyone can help me please?
09/25/2011 00:41 Maximus9229#1733
Guys is there any chacne to increase the magic pop rate?
09/25/2011 00:41 Trapezun#1734
SQL Error State:42000, Native Error Code: AFC, ODBC Error: [Microsoft][ODBC SQL Server Driver][SQL Server]Could not find stored procedure '_STRG_ALLOC_ITEM_NoTX'. PLS HELP NEW CHARD OPEN EROR SHARD SQL Error State:42000, Native Error Code: AFC, ODBC Error: [Microsoft][ODBC SQL Server Driver][SQL Server]Could not find stored procedure '_STRG_ALLOC_ITEM_NoTX'. CODE PLS HELP
09/25/2011 01:40 milliyet#1735
gm cant login help me!!

I can login in normal player,but I made sec_primary and sec_content 1 or 2 cant login
09/25/2011 03:02 lukz0r#1736
Can someone help me out? I'm getting this error:

I've searched tirelessly for a solution but had no luck.

can anyone help me on fixing this?
09/25/2011 03:40 wei280193746#1737
服务器现在已经正常运行,但是客户端在选择服务器的时候,提示:维护 ! 这是什么问题?
09/25/2011 04:26 menagamil95#1738
help plz why get error[Only registered and activated users can see links. Click Here To Register...]
09/25/2011 05:32 nansif2#1739
any know how to active Fortress/CTF?
09/25/2011 10:03 --->BeQuiet<----#1740
how to fix C9 at login?