Register for your free account! | Forgot your password?

You last visited: Today at 20:26

  • Please register to post and access all features, it's quick, easy and FREE!

 

question??

Reply
 
Old   #1
 
elite*gold: 0
Join Date: May 2008
Posts: 70
Received Thanks: 81
question??

i have a WOW client in 1.2.1 patch do i need it update it to 2.0.1 patch to install TBC??
after it how can i update it to 2.4.3 patch?



chaos091 is offline  
Old   #2
 
elite*gold: 20
Join Date: Dec 2006
Posts: 839
Received Thanks: 91
Just get TBC and install it. This will update your installation to 2.0. After that you will have to download the current patch.

You can do this either by using the integrated downloader or simply download 2.4.3 full patch from the web. Here is a list of patch mirrors:


Assass1n is offline  
Thanks
1 User
Reply



« Previous Thread | Next Thread »

Similar Threads
[QUESTION]How do i bypass Xtrap for any private server?[QUESTION]
Exactly what the title says. I keep on getting an xTrap error when i try and load ANY private server that uses XTrap and it's driving me...
3 Replies - Cabal Main - Discussions / Questions
[QUESTION]How do i bypass Xtrap for any private server?[QUESTION]
Exactly what the title says. I keep on getting an xTrap error when i try and load ANY private server that uses XTrap and it's driving me...
2 Replies - Cabal PServer - Discussions / Questions



All times are GMT +1. The time now is 20:26.


Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2016 elitepvpers All Rights Reserved.