Register for your free account! | Forgot your password?

You last visited: Today at 03:48

  • Please register to post and access all features, it's quick, easy and FREE!

 

Hero Online Hellfire Bot

Reply
 
Old   #91
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
Hey everything works fantastically its just when press start all it does is normal attack (I have my skills 1-6 hp 7 mp 8) I have them ticked in the bot (I don't have normal attack ticked) and all it does is normal attack



gofik123 is offline  
Old   #92
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
Hey everything works fantastically its just when press start all it does is normal attack (I have my skills 1-6 hp 7 mp 8) I have them ticked in the bot (I don't have normal attack ticked) and all it does is normal attack
Try going into the CHARS folder and deleting the existing config files, then restart the bot (the bot will generate new ones) Most likely, if you look in the existing skills file (text file) it has the Names section but not the Skills section.


karraksc is offline  
Thanks
1 User
Old   #93
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
Ok i deleted all the existing files in the CHARS folder. Now when i started the bot no skills popped up or anything the bot crashed with this error (Exception EAccessViolation in module Hellfire3.exe at 01180D5. Access Violation at address 00518D5 in module 'Hellfire3.exe'. Read of Address 0000008)

edit /nevermind reloaded bot etc but problem still remains the same =\

edit #2/ I looked in the existing skills file in notepad its just this
gofik123 is offline  
Old   #94
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
Ok i deleted all the existing files in the CHARS folder. Now when i started the bot no skills popped up or anything the bot crashed with this error (Exception EAccessViolation in module Hellfire3.exe at 01180D5. Access Violation at address 00518D5 in module 'Hellfire3.exe'. Read of Address 0000008)

edit /nevermind reloaded bot etc but problem still remains the same =\

edit #2/ I looked in the existing skills file in notepad its just this
The bot should recreate the INI and SKILLS files using the current chars name.

Thats all there is supposed to be in that file. The bot loads it when it first starts and updates the file once every 5 minutes and again on exit. The settings are worked on in memory only. Saving them entry by entry takes 1.3 seconds, and reading them back in takes as long, where saving/reading them all at once only takes 12 ms (1/100 as long)

As for the error, look in EHANDLERLOG.LOG and tell me what caused the error? If it was an index out of bounds error, it was because the SKILLS file wasn't found and the skills list couldn't be loaded.


karraksc is offline  
Thanks
1 User
Old   #95
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
I got your 3-30 version and everything works much better but i still can't use skills i am wondering if anyone else is facing this problem
gofik123 is offline  
Old   #96
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
I got your 3-30 version and everything works much better but i still can't use skills i am wondering if anyone else is facing this problem
when you run the bot, try leaving the Normal unchecked. I don't know why yet but when that was checked it only used the normal (A) attack and ignored the rest. When I unchecked it, the bot started using the other skills.
karraksc is offline  
Thanks
1 User
Old   #97
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
Normal is unticked. I tried re-adding skills down at the bar no luck =\ ummm in hunting boxes that are ticked is Attack, Loot, Buff, use pet, training

I got an EHANDLERLOG!

gofik123 is offline  
Old   #98
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
Normal is unticked. I tried re-adding skills down at the bar no luck =\ ummm in hunting boxes that are ticked is Attack, Loot, Buff, use pet, training

I got an EHANDLERLOG!
Ok, just ran into that one myself, with a low-level (17) char. Will see what I can find and get this fixed.
karraksc is offline  
Thanks
2 Users
Old   #99
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
Excellent thanks
gofik123 is offline  
Old   #100
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
Excellent thanks
Here's an odd one for you guys. The bot routines for Hunt and War are identical except for the one switch that turns the Hunting Aid on/off. When running on War, the bot works normally with no errors but when I switch to Hunt with the same settings it throws an exception whenever I run it. Puzzling 8^D

Oh, btw, the code for the War settings is the original bot code before I started adding in the Hunting Aid settings.
karraksc is offline  
Thanks
1 User
Old   #101
 
elite*gold: 0
Join Date: Nov 2007
Posts: 148
Received Thanks: 4
I swapped the bot to war mode and all it doesn't do is loot and run LOTS but ah well better than nothing for now
gofik123 is offline  
Old   #102
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by gofik123 View Post
I swapped the bot to war mode and all it doesn't do is loot and run LOTS but ah well better than nothing for now
Look on the SKILLS page and make sure the TARGET and LOOT are checked as well. As for LOTS, I was running into an issue where it only picked paid LOTS, so I disabled it until I could look into it. Am going thru code as fast as I can.
karraksc is offline  
Thanks
1 User
Old   #103
 
elite*gold: 0
Join Date: Apr 2011
Posts: 5
Received Thanks: 0
Just checking in, to see how things are going.
xianjhuo is offline  
Old   #104
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
I think I have solved the problem with the Hunting Aid, so I expect to release an update later today (Monday)

Posted the update for download.
karraksc is offline  
Thanks
2 Users
Old   #105
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Sorry for the server hiccup. GoDaddy just informed me they are shutting down the server my site has been on for the last 5 years. I am moving everything over to a new server so it all should be back up soon.


karraksc is offline  
Thanks
1 User
Reply

Tags
hellfire, hero online, mjsbots



« Previous Thread | Next Thread »



All times are GMT +1. The time now is 03:48.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2017 elitepvpers All Rights Reserved.