Register for your free account! | Forgot your password?

You last visited: Today at 00:01

  • Please register to post and access all features, it's quick, easy and FREE!

 

Hero Online Hellfire Bot

Reply
 
Old   #241
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by aron.nemet View Post
any1 maybe succeded to gather at least? its seems its not working either, i cannot set it to target the plants
That is a Divine Job skill. Unfortunately I have not had time to get a char up to Divine yet as I am still working on trying to figure out why the bot works fine on some systems but does not load skills on others. I am working as fast as I can.

The code for the bot is over 110k+ lines long (139 printed pages, single-spaced/doubleside printed), and very easy to make changes in one section that affects others unexpectedly, as seen with version 5. I have not had time to fully test out all the code sections I changed to add buffs and tavern features yet since I've been trying to get a working release out. Somewhere, in making the changes to add in buffs, a quirk worked in that is affecting the loading of skills on some systems. That issue has priority over any other on my list of things to fix/work on.

Quote:
Originally Posted by cancels View Post
the bot is not working so attacks on knock to use the magic does not work !!!!
I am aware of this issue and am working as fast as I can to solve it. Because of this, I have not had time to finish updating the website manual or finish recording tutorials on using the bot features. As soon as I can solve the skill loading/buff issues, I will get back to updating the manual and the video tutorials.

I have 2 completed:
1. Initial Startup/features.
2. Pet Usage/Hunting Aid Attack Range Limiting
3. Buffs/Skills usage
4. Divine Job Skills (Mining/Gathering/Caligraphy/Fishing) and I will explain why the targetting for them is seperate and different from normal mob targetting.

These videos will be available on my site, , as soon as I finish updating the manual there.



karraksc is offline  
Thanks
2 Users
Old   #242
 
elite*gold: 0
Join Date: Jul 2015
Posts: 9
Received Thanks: 0
waiting forward to the new version since version 6 ever served me. hopefully soon and functional please.


exsodias1 is offline  
Old   #243
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by exsodias1 View Post
waiting forward to the new version since version 6 ever served me. hopefully soon and functional please.
I haven't figured out why it loads fine on some but not on others, so I'm rewriting it. I have had to pull out the old skill display routines and am writing a new section for it. The original code was written 8 years ago and somehow the changes to allow for recent buffs is causing it to be quirky.
karraksc is offline  
Thanks
1 User
Old   #244
 
elite*gold: 0
Join Date: Feb 2010
Posts: 76
Received Thanks: 18
For everyone that have problem with the UI of the bot(Not showing up), there is a simple solution. When you run the bot, simply open Task Manager(CTRL+ALT+DEL), find hero plus on the tab and minimize it. When you Maximize hero back, the bot UI should load =)


lycce is offline  
Thanks
1 User
Old   #245
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by lycce View Post
For everyone that have problem with the UI of the bot(Not showing up), there is a simple solution. When you run the bot, simply open Task Manager(CTRL+ALT+DEL), find hero plus on the tab and minimize it. When you Maximize hero back, the bot UI should load =)
Neat little trick, Lycce!! 8^D I tried it by minimizing the game and the bot pulled right up. I like it and it's now coded into the bot!!

Two things left to lock down and I should have an update ready.
karraksc is offline  
Thanks
1 User
Old   #246
 
elite*gold: 0
Join Date: Nov 2011
Posts: 1
Received Thanks: 0
why it will not works on mine...only one skill is usable..
shuijinz is offline  
Old   #247
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by shuijinz View Post
why it will not works on mine...only one skill is usable..
There is a quirk in the skill detection routine that I am working on fixing. Should be ready to send out a release soon.
karraksc is offline  
Thanks
1 User
Old   #248
 
elite*gold: 0
Join Date: Oct 2015
Posts: 1
Received Thanks: 0
Bot works only on windows 8. Why not works on Windows 7?
korteneca is offline  
Old   #249
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by korteneca View Post
Bot works only on windows 8. Why not works on Windows 7?
Running Hero on different versions of Windows give different ID markers, something I was not aware of when I released version 6a. I am working on fixing that now, along with a few other things. I am testing out the new changes this morning.
karraksc is offline  
Thanks
1 User
Old   #250
 
elite*gold: 0
Join Date: Jul 2015
Posts: 10
Received Thanks: 0
GM will make maintenance tomorrow please release new version thanks
TheLittleThing is offline  
Old   #251
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by TheLittleThing View Post
GM will make maintenance tomorrow please release new version thanks
I just sent out copies to be tested on a few systems known to have problems with skills in the last release. If they test out okay, I will post the release here. As for how it will work with XTrap, that I will have to wait and see about.
karraksc is offline  
Thanks
1 User
Old   #252
 
elite*gold: 0
Join Date: Aug 2010
Posts: 6
Received Thanks: 0
the x -trap leaves not open the bot.
joseluiz4321 is offline  
Old   #253
 
elite*gold: 0
Join Date: Jun 2008
Posts: 427
Received Thanks: 288
Quote:
Originally Posted by joseluiz4321 View Post
the x -trap leaves not open the bot.
XTrap is locking the game memory and not letting the bot read it. I am working on a way around that.
karraksc is offline  
Thanks
1 User
Old   #254
 
elite*gold: 0
Join Date: Aug 2010
Posts: 6
Received Thanks: 0
Ok. Thank you for help
joseluiz4321 is offline  
Old   #255
 
elite*gold: 0
Join Date: Feb 2010
Posts: 76
Received Thanks: 18
karraksc, do you know any way for disabling that xtrap, it used to be really easy with process manager, but it looks like it became good anti-cheat. The problem is that the xtrap runs now later then usually, and it wont let me suspend it. Ive tried couple of ways, and they work, but the game crushes in few mins... If you do, please let me know. I have good macro-based bot that I can share, if you can't fix yours =)


lycce is offline  
Reply

Tags
hellfire, hero online, mjsbots



« Previous Thread | Next Thread »



All times are GMT +1. The time now is 00:01.


Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.

Support | Contact Us | FAQ | Advertising | Privacy Policy
Copyright ©2016 elitepvpers All Rights Reserved.