Not a member yet? Register for your free account!


Go Back   elitepvpers > Other Online Games > Browsergames
You last visited: Today at 20:43

  • Did you know? elitepvpers has its own image host, epvpimg.com.

 

[Release] KryoBot FOE - Forge Of Empires Bot

This is a discussion on [Release] KryoBot FOE - Forge Of Empires Bot within the Browsergames forum part of the Other Online Games category; KryoBot FOE Forge Of Empires Bot This bot is a side product of my current project. Therefore I wont say ...

Reply
 
Thread Tools
Old 07-28-2013, 18:24   #1
(p_-)
 
Join Date: Jan 2013
Posts: 29
Received Thanks: 15
Post [Release] KryoBot FOE - Forge Of Empires Bot


KryoBot FOE
Forge Of Empires Bot

This bot is a side product of my current project. Therefore I wont say much about it. It's made for the game "Forge Of Empire". Some things wont work properly because the bot isn't finished yet. But it still works well.

KryoBot is a pixelsearch & image recognition bot. This means it needs the mouse to operate and
you can't do anything on your computer as long as it runs.

Features:
• Pickup gold
• Pickup supplies
• Starts production
• Train units (0.0.4)

Bugs:
none - yet

Requirements:
[Only registered and activated users can see links. ][Only registered and activated users can see links. ]
•AutoItX.dll ([Only registered and activated users can see links. ])
•Fiddler2 ([Only registered and activated users can see links. ])
•Latest modified game .swf

Tutorial part 1
1. Open Fiddler2
2. GoTo AutoResponder
3. Enable Automatic Responses
4. Tick Unmatched requests passthrough
5. Add Rule:
Code:
First gap:      regex:http://cdn.*.forgeofempires.com/assets/city/gui/citymap_icons/citymap_icons.swf
Second gap:    <PATH TO YOUR citymap-icons.swf>
6. Save

Tutorial part 2
1. Start Firefox
2. Clear BrowserCache
3. Log into Forge of Empire
4. Settings -> Disable Fog
5. Zoom out
6. Start Bot and switch to your browser
To close the Bot press the key "x"

Download Bot:
Alpha 0.0.5: [Only registered and activated users can see links. ]
Alpha 0.0.5: obsolete (03.09.2013 - 27.11.2013) (expired)
Alpha 0.0.4: obsolete (26.08.2013 - 03.09.2013)[Only registered and activated users can see links. ] Alpha 0.0.3: obsolete (28.07.2013 - 26.08.2013)

Download SWF:
FOE 1.14: [Only registered and activated users can see links. ]

Virustotal:
The executable of my bot is to large for Virustotal. sorry..

Screenshots:
[You must register and activate your account in order to view images. ]
[You must register and activate your account in order to view images. ] [You must register and activate your account in order to view images. ]

~RGrand

Last edited by RGrand; 11-27-2013 at 18:12.
RGrand is offline  
Thanks
9 Users
astrodog (08-08-2013), BiberXXL (01-05-2014), Captnitro (09-20-2013), Cheesenonion (09-24-2013), HerbaKing (10-13-2013), JeFFiNhU (10-30-2013), kaiserorn (10-23-2013), mblaster (10-22-2013), SniperFi (11-22-2013)
 
Old 08-04-2013, 03:41   #2
Junior Member
 
Join Date: Oct 2012
Posts: 15
Received Thanks: 0
Think im not smart enough to do this install....tried to run the register_64bit batch file, but its trying to find it in an e:dropbox folder, and then it just closes.

are you making a version that loads everything?
MAJ Madden is offline  
Old 08-05-2013, 05:38   #3
Junior Member
 
Join Date: Sep 2012
Posts: 6
Received Thanks: 1
appear to have problem registering dll, it registers but gets exception. module was loaded but the call to dllregisterserver failed with code 0x80070005
also when starting application get
"exception in thread main com.jacob.com.comfailexception
from progid
at java.lang.void.<unknown><unknown source>
at java.lang.void.<unknown><unknown source>
at java.lang.void.<unknown><unknown source>
at java.lang.void.<unknown><unknown source>
I do see the trap working in fiddler.
astrodog is offline  
Thanks
1 User
anonimo79 (10-25-2013)
Old 08-05-2013, 13:31   #4
(p_-)
 
Join Date: Jan 2013
Posts: 29
Received Thanks: 15
Post re

@MAJ Madden:
try to copy the AutoIt folder to desktop before executing.
Yes there will be a self installing version some day.

@astrodog:
Cause:
This behavior may occur if you try to register a DLL by using Regsrv32 while
you are logged on using an account that does not have administrative
credentials, such as an account that is a member of the standard users group.
An account that does not have administrative credentials cannot write to the
registry or change files in the System32 folder.

-------
The easiest solution for both of you is to install AutoIt (Google: AutoIt)

~RGrand
RGrand is offline  
Old 08-06-2013, 06:19   #5
Junior Member
 
Join Date: Sep 2012
Posts: 6
Received Thanks: 1
Thanks for the help
Got the dll registered and I got farther. Here is where I am know:

_ __ ____ _
| |/ / | _ \ | |
| ' / _ __ _ _ ___ | |_) | ___ | |_
| < | '__| | | |/ _ \| _ < / _ \| __|
| . \| | | |_| | (_) | |_) | (_) | |_
|_|\_\_| \__, |\___/|____/ \___/ \__|
__/ |
|___/

[KryoBot Engine]: KryoBot Engine by RGrand @ elitepvpers.com
[KryoBot Engine]: KryoBot Engine Version 0.0.3 Alpha
[KryoBot Engine]: Customized for Forge Of Empire
[KryoBot - Forge Of Empire]: Bot ChangeState::Started
[KryoBot - Forge Of Empire]: BotFunction Collect | ...
Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: C
:\Users\xxxxx\AppData\Local\Temp\javacpp1682580608 85349\jniopencv_core.dll
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)

The directory for the javacpp168258060885349\jniopencv_core.dll is empty.
astrodog is offline  
Old 08-06-2013, 12:47   #6
(p_-)
 
Join Date: Jan 2013
Posts: 29
Received Thanks: 15
Post re

Install both runtime components of Microsoft C++ 2010:
[Only registered and activated users can see links. ][Only registered and activated users can see links. ]
~RGrand

Last edited by RGrand; 08-06-2013 at 13:51.
RGrand is offline  
Old 08-06-2013, 20:42   #7
Junior Member
 
Join Date: Jan 2013
Posts: 3
Received Thanks: 0
Hello, I did all the configurations of the mouse arrow is on the left at the top and not do anything else. what could it be?

Last edited by moisesmetal; 08-06-2013 at 20:57.
moisesmetal is offline  
Old 08-06-2013, 21:15   #8
(p_-)
 
Join Date: Jan 2013
Posts: 29
Received Thanks: 15
Post re

Make sure hat the game looks like this:

[You must register and activate your account in order to view images. ]

If not:
•Make sure that Fiddler2 is running properly
•Clear BrowserCache (while game is not running)
•Restart Forge of Empires

~RGrand
RGrand is offline  
Old 08-06-2013, 23:21   #9
Junior Member
 
Join Date: Jan 2013
Posts: 3
Received Thanks: 0
Now is giving this error: Failed to load startup/startup
Attached Images
File Type: jpg Sem título.jpg (16.8 KB, 166 views)
moisesmetal is offline  
Old 08-07-2013, 00:22   #10
(p_-)
 
Join Date: Jan 2013
Posts: 29
Received Thanks: 15
Post re

Make sure that the second gap in the rule is referring to an existing file

~RGrand
RGrand is offline  
Reply

 

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
REQUEST: Forge of Empire Hack fafaPETER Browsergames 2 09-11-2013 15:44
TOP!!!! Forge of Empire Accounts zu verkaufen gaaralol Browsergames Trading 0 07-06-2013 17:16
TOP!!!! Forge of Empire Accounts zu verkaufen gaaralol Browsergames Trading 0 07-06-2013 00:43
[WTS] Forge Of Empire Acc [Exclusive] bizzy// Browsergames Trading 1 05-14-2013 11:03
[B] Forge of Empire Account [S] e*gold Dumbledore. Browsergames Trading 0 12-21-2012 16:27



All times are GMT +2. The time now is 20:43.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.